11:59:55 <kornerr> #startmeeting
11:59:56 <MeetBot> Meeting started Sun Aug  7 11:59:55 2011 UTC.  The chair is kornerr. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:59:56 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:02 <kornerr> oh. already.
12:00:11 <kornerr> #topic introductions
12:00:19 <kornerr> everyone, introduce yourselves.
12:00:28 <kornerr> I'm Michael Kapelko, this meeting organizer. I participate in open source development, and currently develop 3D Mahjong solitaire (http://opengamestudio.org). This is my second Debian games meeting.
12:00:29 <kornerr> Kamping Keiser has to be on a show, so he'll be missing, apologies.
12:01:29 <guus> I'm Guus Sliepen, maintainer of blobwars, blobandconquer (both also upstream), crawl and omega-rpg. I also did the Dutch voice of the blue fish in fillets-ng.
12:01:51 <Clint> i'm Clint Adams, and I can't be here right now
12:01:56 <kornerr> lol
12:02:17 <SynrG> ben armstrong, not currently maintaining any games within the team. some interest children's games, being a parent of 5 kids and former leader of debian-jr project. currently a debian-live team member and working on a live-games image
12:02:20 <magnate> I'm Chris Carr, a member of the Angband devteam (http://rephial.org - v3.3.0 just released)
12:02:50 <kornerr> SynrG: give them mahjong :P
12:03:03 <ansgar> I'm Ansgar and maintain a few games (mostly looking after simutrans, less time for others).
12:04:22 <kornerr> 5 more minutes to introduce yourself
12:04:41 <kornerr> everyone else reads agenda items: http://wiki.debian.org/Games/Meetings/2011-08-07
12:05:05 <kornerr> shevek seems absent
12:05:13 <kornerr> pabs too, yet.
12:05:52 <kornerr> Rhonda: come here
12:06:29 <lindi-> I'm Timo Lindfors. I don't have a specific interest in games but I liked Triplane Turmoil a lot in 1997. More recently I met the original authors and managed to convince them that we can release it as free software if we can port it. It's now in unstable as 'triplane'
12:06:52 <SynrG> kornerr: my eldest likes mahjong, but she's 21 ... hence 'former' debian-jr team leader (my youngest is now 9, the others are 13, 17, and 19)
12:06:55 <jandd> I'm Jan Dittberner DD maintaining spring and springlobby as well as some non-game packages
12:06:56 <kornerr> no Fuddl as well.
12:07:30 <kornerr> SynrG: you're quite a parent!
12:07:35 <kornerr> grats to you :D
12:07:42 * kornerr is not a parent yet
12:07:56 <SynrG> all of them grown up on debian, too :)
12:07:57 <jandd> my kids are 4, 2 and 0 years old
12:08:05 <kornerr> hehe :)
12:08:11 <kornerr> debian-parents-meeting
12:08:44 <kornerr> ok. looks like time is almost up. moving on
12:09:43 <kornerr> #topic action items from last meeting: http://meetbot.debian.net/debian-games/2011/debian-games.2011-06-26-09.57.html  (scroll to the bottom)
12:09:57 <kornerr> ok. guus.
12:10:06 <kornerr> guus to talk about full-screen behaviour on games@lists.freedesktop.org
12:10:07 <kornerr> guus talk about documentation browser (either in-game or out-of-game) on games@lists.freedesktop.org
12:10:17 <guus> I had some discussion on the fdo mailing lists. Mostly about the full-screen behavior.
12:10:54 <guus> I have just put the results on the Games/Upstream page on the fdo wiki. (http://www.freedesktop.org/wiki/Games/Upstream)
12:11:29 <guus> Anyway, the results were not too different from what we discussed here last time.
12:11:44 <kornerr> which is not FS by default, yeah?
12:11:51 <guus> Yes.
12:12:17 <guus> But also, hotkeys and integration with the window manager.
12:12:59 <guus> For the documentation browser, the answer was: just use xdg-open.
12:13:00 <lindi-> should these be linked from http://wiki.debian.org/Games/Policy?
12:13:07 <kornerr> #info results of guus FS behaviour work here: http://www.freedesktop.org/wiki/Games/Upstream
12:13:26 <guus> However, xdg-open on one of my machines didn't give very good results.
12:13:35 <guus> It tried to open a manpage with notepad.exe, and a PDF with the Gimp.
12:13:56 <kornerr> I have experienced xdg-open open URL and not terminate itself on some distros.
12:14:17 <lindi-> guus: that PDF with GIMP is a known bug. it happens if XDG_DATA_DIRS is not set afaik
12:14:22 <kornerr> until firefox with that open url has been closed. that made my app hang
12:14:45 <guus> Maybe I should file some bug reports or check if they have already been filed?
12:14:53 <guus> It makes xdg-open less than useful.
12:14:57 <lindi-> guus:   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=522998
12:15:30 <kornerr> guus: what about documentation browser?
12:15:35 <kornerr> ah. wait.
12:15:38 <kornerr> blind me. lol
12:15:40 <kornerr> you told .
12:15:58 <kornerr> ok. xdg-open, everybody happy when it will open correctly.
12:16:00 <kornerr> me included.
12:16:12 <kornerr> now SynrG.
12:16:17 <kornerr> Fuddl to get SynrG to create a repo for the blends configs and add a link to the wiki page about it
12:16:20 <SynrG> hm, wiki page link still needed. place to put http://anonscm.debian.org/gitweb/?p=pkg-games/live-games-image.git;a=summary ?
12:17:19 <SynrG> /Games/Development? somewhere else?
12:17:47 <kornerr> /Games/Blend may be if it's a blend?
12:17:56 <kornerr> or what is its official name?
12:18:09 <kornerr> Games/Image...
12:18:14 <SynrG> live-games-image. at this point i don't know what it is :)
12:18:51 <SynrG> it's a live image containing a selection of games that should fit on a DVD
12:19:09 <SynrG> we decide what to actually do with it later :)
12:19:22 <kornerr> hm
12:19:51 <kornerr> #info Rhonda absent
12:19:53 <SynrG> Games/Live if you like
12:20:06 <kornerr> #action (from last time) Rhonda to write a wiki page about presenting games (Games/Present)
12:20:19 <kornerr> games live sounds like something microsoft, but sounds nice and descriptive to me
12:20:20 <SynrG> but linked from where, just Development for now?
12:20:50 <kornerr> yeah, for now
12:21:01 <SynrG> will do that immediately after conclusion of the meeting.
12:21:08 <kornerr> ok
12:21:09 <SynrG> so we don't need to carry that forward for next one
12:21:14 <kornerr> yeah.
12:21:28 <kornerr> #info pabs is absent, may come a bit later
12:21:39 <kornerr> #action (from last time) pabs to investigate lintian warnings about deprecated FHS games paths
12:21:40 <kornerr> pabs to start a discussion on the list about extending debtags, documenting the discussion on the wiki and talking to the debtags maintainers about adding the new tags
12:21:55 <kornerr> those warnings. I had them too. and just placed my launch-script into /usr/games.
12:22:01 <kornerr> may be not perfect.
12:22:10 <kornerr> if FHS change /usr/games policy
12:22:41 <kornerr> all the rest done.
12:23:16 <kornerr> #topic Giving all DDs commit access? There are alioth issues with this but when those are fixed, should we do it?
12:23:35 <kornerr> not sure what that is :)
12:23:48 <kornerr> and why it is
12:24:00 <lindi-> I understood it was already very easy to get commit access
12:24:02 <ansgar> Somebody want to change file permissions on our repositories to allow all DDs to commit.
12:24:04 <q66> uh
12:24:14 <q66> kornerr, lol, i didn't realize irc.debian.org was equal to OFTC
12:24:17 <q66> on which I already was
12:24:28 <kornerr> lol
12:24:28 <ansgar> pkg-perl uses it so lazy people don't have to request membership (if they are not very active anyway)
12:24:53 * ansgar does not mind either way.
12:24:58 <guus> It would lower the barrier even further. Is there a drawback to giving all DDs commit access?
12:25:20 <kornerr> I thought becoming DD isn't very easy, so all of them should be 'good' people :)
12:25:31 <ansgar> I don't think so. They can already upload all packages anyway ;)
12:25:49 <guus> Well, it was easier in my time, but now it is quite hard ;)
12:25:52 <SynrG> do DDs actually perceive lack of access as a barrier?
12:26:17 <SynrG> joining the team is quite trivial
12:26:28 <kornerr> but that doesn't make anyone DD, right?
12:28:12 <SynrG> hm? not sure what you mean. guus said opening access to all DDs to commit lowers the barrier. but that's obviously only for DDs, and they shouldn't find it hard to join the team.
12:28:27 <SynrG> do we want to give DDs an excuse to avoid the very easy step of joining the team?
12:28:42 <SynrG> it's not like team membership is a big burden.
12:28:56 <kornerr> I think you're right.
12:29:13 <kornerr> this way games team at least will be informed, I guess
12:29:24 <lindi-> would that increase the damage an accidental rm -fr / as DD would do? ;)
12:30:37 <kornerr> I think it's nice to know if anyone does smth on your realm.
12:30:44 <kornerr> even being Linus Torvalds :)
12:31:06 <kornerr> so we say no? :)
12:31:11 <SynrG> what were we trying to accomplish by the suggestion, try to encourage more DDs to participate?
12:31:24 * kornerr doesn't know
12:31:28 <ansgar> Who suggested it anyway?
12:31:39 <SynrG> if you haven't won their minds, i'm not sure what this technical measure accomplishes.
12:31:53 <Clint> there's also a group limit on alioth and not having to join another one helps not max that out
12:32:08 <SynrG> or to put it another way, does anyone know if any DD has not contributed merely because they didn't have access by default?
12:32:18 <kornerr> yeah
12:32:23 <SynrG> Clint: ah. good point
12:32:28 <SynrG> are we close to that limit?
12:32:34 <kornerr> nothing in the logs about who suggested it.
12:32:54 <lindi-> how about we close that with MOREINFO and move on?
12:33:15 <kornerr> you mean dashmoreinfo for later?
12:33:35 <lindi-> possibly, I don't know meetbot very well
12:33:40 * kornerr hasn't read complete meetbot manual
12:33:45 <kornerr> ok. just make it an action then.
12:34:42 <kornerr> #action nobody present can tell anything about the issue, apart from Clint who said that "there's also a group limit on alioth and not having to join another one helps not max that out", but SynrG's point to which I agree: "does anyone know if any DD has not contributed merely because they didn't have access by default?"
12:34:59 <kornerr> #moreinfo we need more info to decide, or pabs or kamping kaiser to be here.
12:35:03 <kornerr> may be it worked.
12:35:38 <kornerr> #topic Do a session on #debian-meeting? This would be about training, answering questions and more.
12:35:54 <kornerr> that one is unclear to me as well. what are we going to train for?
12:35:59 <kornerr> the DDs to commit? :D
12:36:21 <lindi-> my only guess is training for new contributors
12:36:52 <kornerr> ah. training how easy it is to add your game to debian?
12:36:58 <kornerr> and give you POPularity?
12:37:32 <lindi-> I'm just guessing here but it might be an interesting idea. I'd be willing to spend an hour on IRC for that :)
12:37:35 <SynrG> how much of our membership comes from people who are already the upstream of a game?
12:37:50 <magnate> So would I. In my experience it is not so easy to add your game to Debian, only to debian-mentors!
12:37:56 <kornerr> well. yeah.
12:38:05 <SynrG> and if so, that's a measure of commitment to writing free software to begin with, and so not merely a vanity thing to join us.
12:38:14 <kornerr> but it mostly boils down to reading Debian policy and maintainer guide I think.
12:38:27 <kornerr> we want to make it simpler than reading those docs?
12:39:02 <SynrG> so the meeting would be mostly social/indoctrination, not technical?
12:39:16 <lindi-> SynrG: yep
12:39:20 <kornerr> I'm an upstream and for the latest realease could make a binary deb package, but not source one, it took me about 2-3 weeks :P
12:39:29 <kornerr> *did make
12:40:00 * kornerr would like technical one
12:40:02 <lindi-> maybe we could target people who already claim to have read the policy and created packages to mentors?
12:40:18 <SynrG> if we want to expand the membership and hold a meeting about that, it's going to attract some people with wrong motives. but we have a process for weeding those out, so we shouldn't worry.
12:40:19 <lindi-> but might need some polishing to get a sponsor?
12:40:34 <SynrG> just put on a meeting that we think is most likely to help get people started and see who comes.
12:41:01 <lindi-> should we have this session on the same day as the next debian games meeting?
12:41:10 <kornerr> not sure.
12:41:22 <kornerr> unless we want to spend 2+ hours :P
12:41:23 <SynrG> i don't think so. mid-month, space it out by two weeks
12:41:33 <kornerr> yeah, in between, that would be good
12:41:38 <SynrG> this is already a big chunk of my day which is otherwise spent with family
12:41:46 * kornerr doesn't get it will be about though. what are those social things?
12:42:10 <SynrG> talk to debian-women who have recently had a series of successful meetings to expand membership
12:42:25 <SynrG> get some ideas from them. i think the concerns are similar.
12:42:32 <kornerr> who wants to talk to debian-women? :P
12:42:37 <SynrG> i will
12:42:46 <kornerr> ok. so action for you? :)
12:42:49 <SynrG> yep
12:43:35 <kornerr> #action SynrG to talk to debian-women who have recently had a series of successful meetings to expand membership. looks like the meeting would be mostly social/indoctrination, not technical
12:43:52 <kornerr> ok.
12:44:04 <kornerr> #topic Pleft is an Open Source alternative to Doodle, albeit missing the local timezone option
12:44:23 <kornerr> http://www.pleft.com/
12:44:30 <kornerr> there's a video in the upper right corner
12:44:43 <ansgar> #link http://www.pleft.com/
12:44:52 <kornerr> thanks
12:45:13 <kornerr> is this critical if web source be open source?
12:45:17 <kornerr> I wondered.
12:45:49 <lindi-> how is this related to debian-games?
12:45:50 <SynrG> i recently used doodle with our LUG partly because we had used it here for meeting organization. it drew fire from members who hated the Javascript requirement. how is pleft with respect to Javascript?
12:46:02 <SynrG> lindi-: we use doodle to choose meeting times
12:46:04 <kornerr> lol
12:46:07 <SynrG> and topics
12:46:09 <kornerr> I think JS is here too.
12:46:16 <kornerr> it reacts to mouse clicks
12:46:29 <SynrG> but does it have a non-JS mode of operation?
12:46:30 <kornerr> who is without JS nowadays?
12:46:33 <kornerr> oh.
12:46:44 * SynrG shrugs ... die-hard gui haters :p
12:46:50 <lindi-> I think non-free is bad but free software JS should be ok
12:48:08 <lindi-> SynrG: if you try to make the gui haters comfortable you easily make gui people uncomfortable :)
12:48:14 * kornerr doesn't like UTC-only
12:48:25 <kornerr> may be it'll come later
12:48:44 <kornerr> I think it doesn't not non-JS
12:49:19 <kornerr> it looks lighter than doodle, but without local time it's hard to do all calculations, at least for me
12:49:21 <SynrG> doodle is working on non-JS, targetted at mobile users i think
12:49:36 <SynrG> the current mobile interface still requires it tho
12:49:41 <guus> You can also run your own instance of Pleft, instead of handing all your private data to Google.
12:49:54 <kornerr> *doodle
12:50:02 <SynrG> the beauty of pleft is if someone cares about non-JS, it could be added, being open source
12:50:04 <kornerr> well. will debian run pleft?
12:50:17 <kornerr> and will this anyone add non-JS? :)
12:50:30 <guus> Debian has its own pastebin as well...
12:51:00 <kornerr> btw. I can't see where the sources are
12:51:11 <guus> http://code.google.com/p/pleft/
12:51:16 <kornerr> oh
12:51:17 <SynrG> http://code.google.com/p/pleft/wiki/Source?tm=4
12:51:29 <kornerr> so someone else could add non-UTC support as well.
12:51:36 <kornerr> may be it's too early to move there?
12:51:53 <kornerr> unless some one takes time to enhance and run it on debian.net/org/whatever
12:52:33 <SynrG> it may be a chicken and egg thing. until someone takes the initiative to use it, there's not much incentive to fix our perceived problems with it.
12:52:44 <kornerr> ok.
12:52:57 <kornerr> we may try to suggest the next organizer to use pleft
12:53:05 <kornerr> and everyone will participate, and tell how it was
12:53:18 <SynrG> sounds good to me.
12:54:46 <kornerr> #action next debian games meeting organizer should try to appoint a meeting with Pleft and let everyone choose time in there. on the next meeting we will all share our experience and decide if we are ready to move, or it's too early, or everybody hates Pleft
12:55:15 <kornerr> #topic Use XZ compression for data packages (and maybe others?) [ansgar]
12:55:41 <kornerr> I agree to xz. I use 7z as a stand-alone archive for my game
12:55:49 <kornerr> xz is 7z afaik
12:55:58 <kornerr> xz,7z,lzma. iirc
12:56:01 <kornerr> all the same.
12:56:09 <kornerr> correct me if I'm wrong :D
12:57:07 <guus> I think the only problem with xz is that at the highest compression levels, the decompressor can use huge amounts of memory.
12:57:08 <kornerr> LZMA Utils are legacy data compression software with high compression ratio. LZMA Utils are no longer developed, although critical bugs may be fixed as long as fixing them doesn't require huge changes to the code.
12:57:08 <kornerr> Users of LZMA Utils should move to XZ Utils. XZ Utils support the legacy .lzma format used by LZMA Utils, and can also emulate the command line tools of LZMA Utils. This should make transition from LZMA Utils to XZ Utils relatively easy.
12:57:13 <kornerr> from http://tukaani.org/lzma/
12:57:53 <kornerr> do we have very big archives so that the amount of memory can be near, say, 100M?
12:58:02 <kornerr> if it's less, not sure if there's any issue
12:58:10 <lindi-> 100 MB would indeed be a problem on openmoko
12:58:44 <ansgar> For the default comression level, it needs ~10 MB when decompressing.
12:59:17 <ansgar> And even the highest even only needs 65 MB.  Of course, compression is a different beast (48 MB for default, 674 MB for highest level).
12:59:18 <kornerr> does't sound much nowadays
12:59:35 <kornerr> 674?
12:59:44 <ansgar> No, it is certanly acceptable.
13:00:01 <kornerr> you said 65 or 674 for highest? :)
13:00:26 <ansgar> kornerr: For decompression 65 MB.
13:00:44 <kornerr> ah. compression takes 674M?
13:00:49 <kornerr> of memory O_o
13:00:49 <ansgar> And 94 (default) -- 674 MB during compression.
13:00:56 <kornerr> wow
13:01:03 <lindi-> 674 sounds like a lot
13:01:18 <ansgar> Yes, we probably only want to use the default level.
13:01:27 <kornerr> do we care for compression?
13:01:38 <ansgar> It makes quite a difference.
13:01:43 <lindi-> kornerr: I do build arm packages on real hardware
13:01:43 <kornerr> is anybody going to develop anything on openmoko? or archive in there?
13:01:49 <kornerr> oh
13:02:08 <kornerr> so xz is fine at default level?
13:02:12 <kornerr> is it of any use then? :D
13:02:21 <ansgar> For example, simutrans-pak64 shrunk from 40 MB to 20 MB (or similar, don't have the package around right now).
13:02:28 * guus runs Debian on his Freerunner, so it would be awkward if I couldn't install packages on it due to memory problems :)
13:02:49 <lindi-> is the memory consumption independent of the size of the file?
13:02:54 <guus> No
13:03:13 <ansgar> lindi-: It will no get more, only less for small files.
13:03:23 <lindi-> right
13:03:49 <lindi-> Indeed trying to compress as  2.8 MB file with "xz -9" fails with " Cannot allocate memory"
13:03:52 <lindi-> on openmoko
13:03:55 <kornerr> freerunner has 128M
13:04:00 <kornerr> eek.
13:04:01 <ansgar> It's quite easy to use XZ instead of gzip. Just use dh_builddeb -- -Zxz, optionally set a non-default compression level with -z9
13:04:02 <lindi-> only -6 works
13:04:35 <kornerr> if it's not max, I am not sure xz wins then.
13:04:50 <ansgar> dak already has support for it, but there is a lintian tag which will result in the package being rejected. Will be changed in the next lintian release, cf. #632556
13:04:55 <guus> So, somebody should do some benchmarks?
13:05:08 <kornerr> who wants?
13:05:13 <kornerr> or has hardware :D
13:05:13 <ansgar> There were some already. xz wins.
13:05:20 <guus> Link?
13:05:39 <ansgar> I don't have a link right now, has been quite  awhile ago.
13:05:42 <lindi-> ansgar: wins with -9?
13:05:49 <ansgar> lindi-: No, even with the default level.
13:05:58 <kornerr> hm.
13:06:14 <ansgar> I can build simutrans-pak64 with it. Wait a moment.
13:06:26 <lindi-> -6 seems to be the default indeed
13:07:20 <guus> Related to compressing packages, I recently ran advpng (from the advancecomp package) on all PNG files in blobwars, which resulted in 7% reduction of file size, which amounted to 150 kB.
13:07:43 <kornerr> and the overall package size is?
13:07:43 <guus> So this will improve disk usage and maybe load times after installation.
13:07:54 <ansgar> 3.2M (gzip) vs. 2.5M (xz, default level).
13:08:12 <kornerr> does default run on arm?
13:08:16 <lindi-> kornerr: yes
13:08:20 <guus> kornerr: 63 MB, largely due to soundtrack in .ogg format.
13:08:25 <lindi-> kornerr: on openmoko with 128 MB of RAM, that is
13:08:32 <kornerr> I see
13:08:48 <kornerr> guus: those soundtracks, always taking tens of megabytes..
13:08:51 <guus> :)
13:08:52 <ansgar> kornerr: As long as it has ~10 MB free RAM. Or ~100 MB during build.
13:09:11 <kornerr> hm.
13:09:16 <kornerr> so we choose xz default?
13:09:21 <kornerr> or more tests ?
13:09:24 <lindi-> I guess you can try xz -6 if it really helps over bzip2. It's easy to go back
13:09:27 <guus> And for crawl, Adam Borowski (aka kilobyte) added calls to advpng in debian/rules.
13:09:37 <kornerr> yeah. btw. how about bzip2? :)
13:09:40 <ansgar> lindi-: You cannot use bzip2.
13:09:50 <ansgar> Hmm, or can you?
13:09:58 <lindi-> why not?
13:10:19 <ansgar> Ah, you can. I should have remembered what I saw when patching lintian ;)
13:10:24 <kornerr> ansgar: try to compress your app with bzip2
13:10:53 <guus> There are also recompression utilities for gif and PDF as far as I know.
13:10:54 * kornerr doesn't know how much memory bzip2/gzip take to compress/decompress
13:11:08 <lindi-> how about you do all these compression experiments only on packages that are large (> 20 MB)?
13:11:46 <ansgar> bzip2 gives 3.2 MB (also default settings)
13:12:01 <kornerr> and your unpacked size is?
13:12:31 <ansgar> Installed-Size: 12104
13:12:51 <kornerr> 4-6 times. not bad.
13:13:00 <kornerr> so...
13:13:09 <kornerr> experiments?
13:13:18 <ansgar> simutrans does not store images very well packed ;)
13:13:35 <kornerr> may be take the largest package on arm and try it with xz default?
13:13:44 <ansgar> I would switch to xz where it gives significant saving.
13:13:45 <kornerr> instead of whatever is now
13:13:46 <lindi-> kornerr: what's the largest package?
13:13:55 <kornerr> largest in compressed size.
13:14:02 <kornerr> if there's such a package :)
13:14:15 <lindi-> I'm afraid my openmoko lacks the storage space for that
13:14:16 <kornerr> see how it behaves on arm. if it doesn't die then it's ok. I guess
13:14:17 <ansgar> kornerr: Why? arm buildds should have enough RAM.
13:14:37 <lindi-> ansgar: indeed
13:14:46 <lindi-> ansgar: it's not the buildds that have the problem
13:15:16 <kornerr> btw. are we discussing something about debian in a whole? not just game packages?
13:15:31 <lindi-> I was assuming games only here
13:15:50 <ansgar> lindi-: For installation it takes a lot less RAM. As I said, for the default compression level only 10 MB RAM are needed. And I believe this was already discussed on debian-devel at some point (when XZ for binaries was proposed).
13:16:07 <kornerr> was it done there?
13:16:09 <kornerr> xz
13:16:19 <ansgar> kornerr: done?
13:16:22 <kornerr> agreed.smth
13:16:34 <lindi-> ansgar: yes decompression takes 10 MB
13:16:59 <lindi-> but again, I guess you can go ahead with default xz. we can always undo
13:17:02 <ansgar> kornerr: Some people agreed they wanted xz for (at least some) packages ;)
13:17:23 <kornerr> I would like it too, definitely. if it's not a requirement, but a choise , why not
13:17:45 <kornerr> if it won't work on arm, it will be re-done, as lindi- said.
13:17:49 <kornerr> if I got it correct
13:18:09 <ansgar> #agree We want to switch to using XZ for most (all?) game packages.
13:18:20 <ansgar> (Can I use this command?)
13:18:25 <kornerr> don't know
13:18:30 <kornerr> #agree We want to switch to using XZ for most (all?) game packages.
13:18:35 * kornerr tried just in case
13:18:48 <kornerr> ok. the last one probably answered already
13:18:57 <kornerr> #topic How to package a game if it depends on unstable/unreleased versions of non-standard libraries? Currently OGS Mahjong depends on unstable branch of OGRE and the latest CEGUI release. The problem is that CEGUI must be specifically compiled for OGRE to work with it. [kornerr]
13:19:03 <ansgar> #info #632556 needs to be fixed in squeeze-backports first
13:19:07 <ansgar> Ah, too late.
13:19:12 <kornerr> wait. sec.
13:19:17 <kornerr> I can change back right?
13:19:24 <kornerr> #topic Use XZ compression for data packages (and maybe others?) [ansgar]
13:19:28 <ansgar> #info #632556 needs to be fixed in squeeze-backports first
13:19:31 <kornerr> :)
13:19:42 <kornerr> #topic How to package a game if it depends on unstable/unreleased versions of non-standard libraries?
13:19:51 <kornerr> I guess the answer is to wait?
13:20:07 <kornerr> unless dev becomes stable and you can finally get into stable yourself
13:20:15 <kornerr> yep?
13:20:21 <kornerr> unless->until
13:20:36 <kornerr> non-std being ogre and cegui.
13:21:01 <kornerr> before that, one should provide own packages manually. I see it as this
13:21:34 <kornerr> anyone to suggest anything? :)
13:21:37 <ansgar> kornerr: Upload unstable versions to experimental?
13:21:50 <lindi-> I can suggest one to not embed the library
13:22:06 <kornerr> ansgar: can we release unstable?
13:22:17 <kornerr> I mean there are people who mentor ogre, cegui, and I want newer.
13:22:34 <kornerr> that won't work, I guess, I can't force them to release unstable?
13:22:55 <kornerr> or can I.
13:23:04 <ansgar> kornerr: Well, you should talk to them. Or ask them if they are fine with you preparing an experimental upload.
13:23:12 <SynrG> i suppose anything at all can go into git, regardless of whether the game is in a releasable state yet or not?
13:23:23 <kornerr> you mean Live?
13:23:27 <SynrG> i doubt if such packages are suitable even for experimental
13:23:42 <SynrG> (unless you're talking about also putting the unreleased deps in experimental too)
13:24:10 <kornerr> well. it would be good for my game to be in live, so if anything can go, I agree :P
13:24:13 <ansgar> SynrG: That was my idea. Though it might mean fun with sonames...
13:24:33 <SynrG> btw, 'live' is not just one thing. many live images are possible
13:24:40 <kornerr> many. hm.
13:24:40 <SynrG> if you want to make one with experimental stuff, go for it.
13:24:55 <kornerr> stable and unstable games.
13:25:15 <lindi-> I hope you are all aware of the nice web interface that lets you create your own live images
13:25:22 * kornerr not
13:25:32 <lindi-> http://live-build.debian.net/cgi-bin/live-build
13:25:47 <SynrG> lindi-: i don't recall if that allows you to put arbitrary debs from other sources in it. i think not.
13:26:04 <SynrG> i suggest in that case you build images yourself locally, not via the web interface.
13:26:10 <lindi-> SynrG: I guess for security reasons it doesn't let you add more sources yes
13:26:27 <SynrG> anyway, the point is, using live-build is easy, and i can help
13:26:33 <lindi-> but it does let you use both stable and unstable
13:26:42 <kornerr> ok.
13:27:08 <lindi-> at least for bug reporting it would be nice to get people test the game on the same live image as the develoepr
13:27:11 <kornerr> # action one should contact dependency devs and talk to them
13:27:18 <kornerr> #action one should contact dependency devs and talk to them
13:27:41 <kornerr> I guess we're done? :)
13:27:46 * SynrG nods
13:27:49 <kornerr> ah no
13:27:55 <kornerr> ah. yes for the item.
13:28:06 <SynrG> p.s. http://wiki.debian.org/Games/Live
13:28:13 <kornerr> yay.
13:28:17 <SynrG> did it during the boring (to me) xz discussion
13:28:25 <kornerr> lol.
13:28:26 <SynrG> ;)
13:28:33 * ansgar has to leave.
13:28:34 <ansgar> Bye.
13:28:36 <kornerr> bye
13:28:47 <kornerr> #action SynrG: http://wiki.debian.org/Games/Live
13:28:51 <lindi-> SynrG: what's the policy on adding packages to that list? ;)
13:28:55 <kornerr> so that it is in the logs
13:29:02 <kornerr> #topic next meeting
13:29:10 <kornerr> who wants to organize next meeting?
13:29:34 * kornerr has thought that he should have used #info tag instead of #action above.
13:30:11 <SynrG> lindi-: i guess if it doesn't push it over 4G, sure (current image is targetted at 4G and is amd64)
13:30:31 <SynrG> lindi-: i can discuss w. you more after the mtg
13:30:48 <lindi-> SynrG: sure.
13:30:57 <kornerr> can we not decide on this one?
13:31:04 <kornerr> or leave it undecided?
13:31:18 <kornerr> or just assign to pabs/Kamping Kaiser?
13:33:52 <kornerr> ok. leave it to them then.
13:33:53 <SynrG> kornerr: hm, what is the action for me on /Games/Live? (maintenance of that page is now ongoing from now on, so not sure what in particular we're looking for :)
13:34:06 <kornerr> ahm.
13:34:08 <kornerr> sec.
13:35:05 <kornerr> #action nobody volonteered to organize the next meeting. leave the decision to pabs, Kamping_Kaiser
13:35:14 <kornerr> *volunteered
13:35:18 <kornerr> #endmeeting