09:57:11 <arand> #startmeeting
09:57:11 <MeetBot> Meeting started Sun Jun 26 09:57:11 2011 UTC.  The chair is arand. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:57:11 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:57:26 <Kamping_Kaiser> there was also discussion on the fhs and deb-games lists about the fhs
09:57:33 <Kamping_Kaiser> s/fhs/fhs-discuss
09:57:37 <Kamping_Kaiser> wow, perfect timing
09:57:42 * Kamping_Kaiser appears for meeting \o/
09:57:48 <arand> #topic Introductions
09:58:46 * Kamping_Kaiser is karl goetz, and helps maintain freeciv
09:58:59 <pabs> I'm Paul Wise, packaging chromium-bsu, mancala, warzone2100 and some of Jason Rohrer's games. interested in growing the team, processes and stuff like that
09:59:17 * guus is Guus Sliepen, and maintains blobwars, blobandconquer, omega-rpg and crawl
09:59:35 <arand> So, to kick things off, hello, I'm arand, got in't pkg-games via the cube-verse and is now packaging a couple of games, recently Lugaru
09:59:49 <marcello^> I am Emmanuel Kasper and I co maintain the Mame arcade emulator
09:59:50 * arand Is too slow in writing :)
10:00:11 * udienz is Mahyuddin Susanto, i'm packaging gmult
10:00:11 <pabs> berarma: hi, welcome to the meeting, please introduce yourself :)
10:00:42 <berarma> hi, I'm just a casual gamer interested in games and Debian
10:00:44 <berarma> :)
10:00:45 * kornerr is Michael Kapelko. new here. wants to have his OGS Mahjong in Debian
10:00:46 <Kamping_Kaiser> (i may drop out at random points, for some reason we have microdisconnects)
10:00:56 * ansgar maintains simutrans and some smaller games (which I neglect...).
10:01:33 <pabs> berarma: whats yr favourite game?
10:01:34 <ThibG> I'm Thibaut Girka, have been using Debian for a while, and while I'm not in the team, I'm really interested in games (playing a lot, and currently writing one) and free software in general.
10:03:14 <gdm> hi, i'm another casual observer who has come along to see how things work.. i know pabs, too
10:03:38 * pabs waves at gdm across the room
10:04:01 <Rhonda> I'm Gerfried Fuchs, but please use Rhonda. I'm propably best known for looking after wesnoth these days.
10:04:17 <arand> pdewacht_: Welcome, meeting time, please introduce yourself :)
10:04:30 <berarma> I have no static faves, I like changing, ah, my name is Bernat
10:06:23 <arand> I guess time for next topic.
10:06:36 <arand> I was trying to figure out if I should number these
10:07:02 <arand> #topic From last meeting: http://wiki.debian.org/Games/Meetings/2011-05-29
10:07:14 <Kamping_Kaiser> bad timing from the netsplit:/
10:07:22 <arand> Yeah :/
10:07:33 <arand> First off, the actions
10:08:08 <arand> #info http://meetbot.debian.net/debian-games/2011/debian-games.2011-05-29-11.03.html
10:08:46 <arand> Is shevek around?
10:09:43 <pabs> I completed writing up usertags on the wiki: http://wiki.debian.org/Games/Policy
10:10:01 <Kamping_Kaiser> iirc they emailed thelist after the last meeting (i dont have the item handy), don't know if they've made the meeting though
10:10:02 <pabs> DebConf11 hasn't started yet so I didn't yet do my lightning talks :)
10:11:35 <pabs> and I think I helped magnate with his wiki page a little
10:11:45 <arand> Excellent! :)
10:11:46 * magnate is here
10:11:57 <magnate> (but only partially - two children underfoot)
10:12:08 <Rhonda> The mentioning of numbers in the actions is confusing.
10:12:16 <magnate> Sorry to miss the intros
10:12:47 <pabs> magnate created the wiki page he was going to: http://wiki.debian.org/Games/IntoDebian
10:13:00 <Rhonda> The topic about the short video idea of mine will come later, right?
10:13:22 <pabs> yep
10:13:33 <pabs> arand organised the meeting :)
10:13:58 <arand> Rhonda: Yeah, I think the "From last, itme got a little messy"
10:14:03 <pabs> Zhenech didn't yet give his debconf talk, since debconf didn't start yet :)
10:14:08 <magnate> My wiki page is incomplete because my dev machine died - sorry
10:14:15 <magnate> I will complete it when I've rebuilt the box
10:14:26 <magnate> I also didn't edit other pages yet
10:14:39 <arand> Good to hear things are progressing though
10:14:42 <kornerr> what are FTBFSes in the Game/Policy?
10:14:59 <pabs> kornerr: "Fails To Build From Source"
10:15:04 <kornerr> ah
10:15:20 <pabs> kornerr: other terms in http://wiki.debian.org/Glossary
10:15:40 <pabs> I guess thats all the actions from the last meeting
10:15:50 <kornerr> can I ask questions now about Games/Policy?
10:16:12 <pabs> I would suggest waiting till later in the meeting
10:16:22 <kornerr> ok
10:16:54 <arand> Yep that's it for the actions I guess, I won't put down another follow-up item with shevek, I think
10:17:43 <arand> (This got mushed up into one item) I intended also to revisit some items from last meet
10:18:26 <arand> #topic Alioth migration - did everyone and everything survive it?
10:18:37 <pabs> #info PET1 is back up
10:18:50 <pabs> #link http://pkg-games.alioth.debian.org/cgi-bin/PET/qareport.cgi
10:19:01 <pabs> I think that is all for alioth
10:19:11 <ansgar> Does it use cron now?
10:19:26 <arand> I was wondering about the link to DEP-5
10:19:29 * pabs has no idea, didn't put it back up
10:19:52 <pabs> ansgar: did it use cron before?
10:20:12 <pabs> (IIRC all cron jobs were lost when alioth was split into two machines)
10:20:19 <ansgar> No, it had commit hooks before.  But now repository and PET1 live on different hosts → pkg-perl had to switch to cron.
10:20:32 <ansgar> If there is no cron job for pet, it will just display outdated data.
10:20:39 <pabs> ok, I guess it still needs work then
10:21:05 <pabs> #info PET1 needs a cron job setup, currently displaying old data
10:21:24 <Kamping_Kaiser> arand: http://dep.debian.net/deps/dep5 is there, dont' know about the 'static' links for it though
10:21:39 <Kamping_Kaiser> s/static/Format
10:22:19 <arand> It should have a static link to a revision of the DEP5, of which there are none atm, afaik.
10:23:10 <Kamping_Kaiser> yup. but with it open as a bug in policy, soon that'll be moved again anyway won't it?
10:23:28 <arand> Ah, no, there's http://anonscm.debian.org/viewvc/dep/web/deps/dep5.mdwn?revision=174&view=markup rather, but I'm not sure if this is the one to use
10:24:33 <arand> I guess that it's not really related to pkg-games specifically, though, so maybe leave that item?
10:25:24 <Kamping_Kaiser> i'd say so
10:25:27 <arand> #topic documentation regarding packaging
10:25:45 <arand> This was covered in the "From last meeting" topic, right?
10:25:58 <Kamping_Kaiser> yup
10:26:15 <Kamping_Kaiser> then its Rhonda s gig afterthis
10:26:48 <arand> #info This was covered in the "From last meeting" topic
10:27:02 <arand> #topic Screencasting/game presentations
10:27:09 <pabs> Rhonda: yr up!
10:27:34 <arand> #info, the Debconf presentations was covered in the "From last meeting" topic
10:28:07 <pabs> we did?
10:28:40 * pabs thinks not, only thing about that was <Rhonda> The topic about the short video idea of mine will come later, right?
10:29:47 <pabs> hmm, Rhonda seems AFK, I guess we move on
10:30:24 <arand> I though this was the talks, and since DebConf hasn't been yet..
10:31:17 <pabs> well, and also the screencasts / youtube videos idea. and for the debconf stuff we could have got some format/etc ideas
10:31:32 * pabs not sure what to do in his lightning talk
10:31:45 <kornerr> what is lightning talk?
10:32:14 <arand> Ok, I guess keep these items under this topic as well?
10:32:29 <pabs> kornerr: 5 minute short talk at a conference
10:32:47 <Rhonda> Ah, around now.
10:32:58 <Rhonda> Sorry, young one got a bit more demanding.
10:34:07 <Rhonda> I unfortunately didn't had so much time to investigate further, but I looked at recordmydesktop and byzanz, both seem to be able to produce something usable, though might be tricky with certain setups and get video and audio out of sync easily if not configured properly
10:34:37 <Rhonda> I am still looking for other suggestions to give a try though, and hope to be able to find a bit more time soon
10:35:11 <ThibG> there was a opengl-specific things with really good results, but I think it's dead now
10:35:12 <pabs> did you manage to work out the audio recording stuff?
10:35:15 <Rhonda> … and all this shouldn't hold anyone else back from giving it a try themself. Maybe you think differently than me, have other sound setup, who knows.
10:35:46 <arand> AS mentioned earlier, I'm trying to package glc which is a "fraps-like" tool for openGL, but currently upstream is a but unresponsive
10:35:47 <Rhonda> pabs: For recordmydesktop I did set the recording framerate to 2, which got video and audio in sync (for me).
10:35:56 <Rhonda> I'm though not sure whether that is the best option.
10:36:33 <kornerr> recordmydesktop couldn't record audio for me when I was using Slackware. may be my on-board audio sucks
10:36:47 <Rhonda> Also, I'd like to have the sounds produced by the desktop recorded directly, not through the feedback-loop to the speaker.
10:37:27 <arand> I think you need to do some routing magic with pulseaudio for that..
10:38:08 <arand> Or pavucontrol, rather, but I'm not sure if it works with recordmydesktop
10:39:03 <ThibG> alsa can do that, no need for pulseaudio
10:39:18 <arand> So, shall we put this down as an action for next time?
10:39:40 <arand> ThibG: Ah, right, any good guides for it?
10:40:07 <pabs> #info recordmydesktop & byzanz were tried, can get some sync issues if not configured properly (recording framerate 2)
10:41:19 <ThibG> arand, just select Mix as the recording source instead of Mic
10:41:26 <pabs> #info audio output can be recorded using alsa
10:41:29 <pabs> #link http://www.earth.li/~noodles/blog/2009/02/recording-application-sound-ou.html
10:41:54 <pabs> #info or select Mix as the recording source instead of Mic
10:42:42 <arand> #info glc is another a/v recording option, packaging is ongoing, waiting for upstream
10:44:20 <pabs> Rhonda: and about the lightning talks, did you have any suggestions for format etc?
10:44:42 <kornerr> are there any videos of debconfs?
10:45:01 <pabs> kornerr: video.debian.net
10:45:14 <pabs> and live streaming during the event
10:45:26 <kornerr> wow
10:45:43 <pabs> yep, DebConf video team are awesome :)
10:46:12 <kornerr> oh man
10:46:15 <kornerr> there are lots of files
10:46:18 <Rhonda> pabs: Well, potentially in a way that would work for a screencast too
10:48:33 * Rhonda . o O ( sorry, kid getting demanding again )
10:48:59 <pabs> Rhonda: ok, do you think you could do a wiki page (say Games/Present) about the talks and screencasts?
10:49:16 <arand> Is the idea to have game fotage running in the background whilst overlaying the talk? (regarding both talks and screencasts I guess :)
10:49:27 * pabs thinks so
10:49:38 * pabs nominates Rhonda to do the wiki page and suggests moving on
10:50:59 <Rhonda> Put me into that action, yes
10:51:10 <arand> #action Rhonda to write a wiki page about presenting games (Games/Present)
10:51:29 <Rhonda> arand: During the screencasts, obviously, explaining what's going on and such
10:52:14 <arand> Rhonda: Right, there's either that or actually playing the game whilst talking.
10:52:55 <arand> Anyhow, is this topic done we think? pabs mentioned something else abou video?
10:53:38 <pabs> I think we are done, that was just providing some info to kornerr
10:53:45 <kornerr> :)
10:54:20 <arand> Ok, phew, I should've split that up better :)
10:54:25 <arand> #topic LiveCDs/Blends with a ready-to-play set of games
10:54:41 <pabs> #link http://wiki.debian.org/Games/Blends
10:55:14 <Rhonda> Ah, interesting topic!
10:55:17 * pabs forgets who was interested in the blends
10:55:21 <pabs> SynrG?
10:55:24 <Rhonda> I tried with grml-live for a while :)
10:55:43 <Rhonda> SynrG is at least involved with debian-live
10:55:45 <Kamping_Kaiser> pabs: you were taliking about d-live with him, don't know if he was with blends too
10:55:54 <christoph> I guess Fuddl had something there?
10:56:03 * kornerr wants his game in the blends
10:56:04 <kornerr> :P
10:56:27 <Rhonda> We will have a hard time to put tremulous into there :)
10:56:32 <Rhonda> … or even warzone
10:56:35 <Rhonda> For CD though
10:56:56 <pabs> how about a Debian games Blu-Ray disk :)
10:57:01 <kornerr> lol
10:57:24 * kornerr thinks DVD is enough
10:57:32 <kornerr> are tremulous and warzone big?
10:57:48 <pabs> part of the blends idea was also to add blends for game devs/producers
10:58:31 <pabs> ThibG, kornerr: what software are you using for making your games?
10:59:02 <kornerr> pabs: http://code.google.com/p/ogstudio/wiki/Redonation
10:59:05 <kornerr> quite a lot
10:59:38 <ThibG> inkscape, a lot
10:59:51 * pabs adds a link to that from the wiki page
11:00:21 <ThibG> otherwise, it's the runtime deps
11:00:25 <ThibG> (python, pygame, etc.)
11:02:52 <pabs> added to the wiki
11:02:55 <Fuddl> I sent my live DVD configuration to SynrG who played around with it
11:03:13 <pabs> #info Fuddl sent his live DVD configuration to SynrG who played around with it
11:03:38 <pabs> Fuddl: hmm, perhaps we should put it in SVN?
11:04:34 <Fuddl> pabs: it turned out that my configuration was quite broken and I think I used the live helper tools not the-way-god-intended. better ask SynrG, I think he fixed it
11:04:52 <Fuddl> pabs: and I vote for git over SVN ;)
11:05:02 <pabs> Fuddl: sure :)
11:05:39 <pabs> Fuddl: can you poke SynrG to create a repo and add it?
11:05:48 <pabs> (and add a link on the wiki page)
11:05:51 <kornerr> svn is good for keeping binary data
11:05:52 <Fuddl> pabs: ok, I'll do so
11:05:59 <kornerr> which can't be diff'ed
11:06:32 <pabs> #action Fuddl to get SynrG to create a repo for the blends configs and add a link to the wiki page about it
11:06:47 <kornerr> what's the wiki page url?
11:06:58 <pabs> <pabs> #link http://wiki.debian.org/Games/Blends
11:09:06 <arand> Do we consider this topic covered?
11:09:31 <pabs> I think so
11:09:44 <pabs> we can start a thread on the list if not
11:10:05 <arand> #topic FHS regarding /usr/games et. al.
11:10:13 * Kamping_Kaiser better wake up for this bit
11:10:18 <arand> #link http://lists.freedesktop.org/archives/games/2011-May/000369.html
11:10:26 <kornerr> finally
11:10:27 <arand> #link https://lists.linux-foundation.org/pipermail/fhs-discuss/2011-May/000002.html
11:11:18 <arand> So there was a lengthy discussion regarding this, with no proper end decision, so I was wondering if we have a common opinion in this?
11:11:27 <ThibG> I am quite strongly against /usr/share/games
11:11:38 <Fuddl> hehe, I don't have a strong opinion about this ;)
11:11:45 * christoph doesn't care either
11:11:48 <kornerr> I vote for /usr/bin, /usr/share and may be /var/games
11:11:54 * pabs doesn't mind either way, but thinks consistency is a good idea
11:11:57 <ThibG> it's quite useless, and inconsistant
11:12:00 <pabs> kornerr: why /var/games?
11:12:03 <Kamping_Kaiser> #link http://bugs.linux-foundation.org/show_bug.cgi?id=766
11:12:06 <arand> I personally am neutral as well.
11:12:08 <Kamping_Kaiser> is the relevant bug report
11:12:29 <kornerr> to keep /var cleaner :)
11:12:35 <ThibG> it's particulary harmful when you consider XDG Basedir
11:12:36 <kornerr> but I'm fine with just /var.
11:12:47 <pabs> /var/lib
11:13:04 <arand> Fedora, and many other distros don't use /usr/games and /share/games as far as I've understood thing?
11:13:13 <pabs> yep
11:13:18 <ThibG> if you're using both /usr/share/games and XDG, you should use games/mygame everywhere
11:13:32 <ThibG> including ~/.config/games/mygame
11:13:41 <kornerr> yeah. /var/lib is nice since everyone else is there like mplayer  and things
11:13:44 <ThibG> and I don't know of *any* game doing that
11:14:02 <pabs> I guess the course of action should be to see what the final layout is listed by the FHS folks, then write some lintian warings about the deprecated paths
11:14:19 <kornerr> I use ~/.OGStudio because I don't only keep config, but also saves in there
11:14:26 <pabs> #action pabs to investigate lintian warnings about deprecated FHS games paths
11:14:31 <ThibG> and the FHS is really light on the whole "games" thing
11:14:54 <ThibG> the only thing is a path, without description, and the "optional" mention, AFAIK
11:14:55 <Kamping_Kaiser> fwiw, the next FHS will only be able to make the games stuff optional and 'to be deprecated', ti'll need the release after to actually remove the dirs
11:15:30 <Kamping_Kaiser> ThibG: no, it has wordage for all games paths
11:15:40 <pabs> Kamping_Kaiser: to be deprecated or deprecated?
11:16:10 <Kamping_Kaiser> pabs: marked optional, and 'will be removed in a future version'
11:16:25 <Kamping_Kaiser> pabs: so people have time to stop using it
11:16:37 <pabs> #info the next FHS will make games-specific paths deprecated and removed in a future version
11:16:51 <Kamping_Kaiser> frankly, fhs 3 feels more like fhs 2.4, but thats not something that needs a meeting item *g*
11:16:52 <arand> Kamping_Kaiser: But is there any indication atm that this is likely to happen?
11:16:59 <Kamping_Kaiser> arand: what is likely?
11:17:27 <pabs> that the deprecation will happen. and when will this be?
11:17:28 <arand> I got the impression that whether or not this would happen was not decided yet?
11:17:50 <ThibG> kornerr, I think game saves should go in config-specific dirs, but it's another debate
11:18:15 <kornerr> we decided to make it easier for a gamer to find everything in one place
11:18:20 <Kamping_Kaiser> at this stage its likely, but its not been discussed for the last month (so when its disucssed again it might change)
11:19:03 <Kamping_Kaiser> seems to me everyone but vorlon has no strong objections to the games stuff going away, but i don't know if there is going to be a renewwed bsd interest either
11:19:03 <kornerr> everything meaning user specific content
11:19:13 <kornerr> not binaries.
11:20:28 <arand> I don't think we seem to have a common opinion in the games team about this, (with seemingly the majority being neutral)
11:20:34 <kornerr> we will also keep downloadable content in ~/.OGStudio.
11:20:41 <kornerr> looks like the only viable option for any app
11:21:37 <Fuddl> is the ~/.mygamestuff vs. ~/.config/mygamestuff covered by the current topic?
11:21:38 <berarma> I don't understand why games are treated differently than any other package
11:21:47 <pabs> Fuddl: not really
11:21:56 <Fuddl> pabs: k, then I'll shut up ;)
11:22:04 <pabs> Fuddl: FHS doesn't specify what goes into ~/
11:22:07 <arand> Not intended when I wrote the agenda, no
11:22:20 <ThibG> Fuddl, it'd be ~/.config/games/mygamestuff vs ~/.config/mygamestuff, with regards to the topic :)
11:22:41 <kornerr> :)
11:22:55 <Fuddl> heh ;)
11:23:46 <arand> Anyhow, I guess the people interested could re-ignite the discussion on FHS-ml et. al.
11:24:26 <arand> And as the games team we just keep aware that things may need changing if the change is made
11:25:11 <arand> (Since it doesn't seem to be the case that the games team can give a majority opinion on it)
11:25:24 <arand> Sounds ok?
11:25:59 <pabs> yup
11:27:17 <arand> #info currently the majority opinion of the debian games team is neutral
11:27:44 <arand> nest topic
11:27:51 <arand> *next
11:27:59 <arand> #topic Fullscreen/windowed games, policy?
11:28:43 <pabs> I prefer windowed by default, with a config option for full-screen
11:28:50 <kornerr> too
11:29:01 * kornerr has that in his game
11:29:03 <ThibG> I prefer windowed, but I don't think it's the real problem
11:29:10 <arand> I agree there
11:29:11 <ThibG> the real problem being grabbed input
11:29:31 * guus would like every game to use the same hotkey to switch. Or maybe one of a small list of common hotkeys, like ctrl-enter, F11, F.
11:29:31 <kornerr> wow
11:29:34 <arand> That is windowed by default, with option
11:29:36 <kornerr> netsplliiiiit
11:29:38 <pabs> #link http://lists.debian.org/debian-devel-games/2011/05/msg00134.html
11:30:01 * kornerr had F11 before.
11:30:06 <kornerr> may be F11 then only?
11:30:09 <kornerr> looks universal
11:30:10 <guus> Or maybe have them react properly to the window manager.
11:31:00 <pabs> indeed, reacting to WM hints/events is the way to go
11:31:25 <kornerr> what kind of reacting to hints?
11:31:32 <ThibG> I find SDL quite broken for fullscreen stuff :(
11:31:34 <kornerr> can wm say 'no' to fullscreen apps? :)
11:31:44 <kornerr> say->hint
11:32:15 <arand> Many games don't respond to alt-tab, or media volume keys whilst fullscreened
11:32:15 <guus> Another problem of SDL is selecting the right video mode, or presenting a list of them.
11:32:20 <pabs> kornerr: if user presses the wm full-screen key
11:32:33 <kornerr> is there such a button?
11:32:43 <ThibG> arand, yeah, and that sucks
11:32:50 <pabs> kornerr: in GNOME it is F11 IIRC
11:32:53 * guus has Alt-F11 bound to "force fullscreen" in xfwm.
11:33:03 <ThibG> (although it's a way to ensure it'll work for almost any game on any wm)
11:33:17 <pabs> guus: SDL has functions for that, but IIRC they only deal with one screen
11:33:17 <kornerr> jeez
11:33:17 <kornerr> netjoin
11:33:24 <kornerr> yeah. SDL is known for one-screen thing
11:33:31 <kornerr> 1.3 promised to deal with that iirc
11:33:42 <guus> pabs: yes, but if you have a 1920x1200 or bigger screen, you have a gazillion possible modes it will return.
11:33:53 <Kamping_Kaiser> ah, we're back
11:34:06 * kornerr only knows that Opera uses F11 for fullscreen
11:34:09 <guus> pabs: it would be nice to filter them on aspect ratio and even divisions, perhaps.
11:34:18 <Fuddl> I'm for windowed by default
11:34:23 <kornerr> we all
11:34:44 <ThibG> The problem is that since SDL has been grabbing and overriding everything for so long, games may expect this behavior
11:34:50 <ThibG> (I'm talking about the alt-tab thing)
11:35:07 <arand> How much of this could/should be done in packaging, and how?
11:35:34 <kornerr> one can switch from OGS Mahjong on Alt-Tab, but if it's in 640x480 FS, you switch to 640x480 desktop
11:35:48 <pabs> Kamping_Kaiser: netsplit-conversation: http://paste.debian.net/121049/
11:36:12 <Kamping_Kaiser> pabs: thanks
11:36:49 <guus> Hm, maybe this is something for freedesktop.org to standardize?
11:37:05 <pabs> arand: probably none, I think patches (forwarded upstream) is the only way
11:37:29 <christoph> and/or bug reports
11:37:50 <pabs> guus: agreed, could you bring it up on the games list
11:37:59 <guus> Ok.
11:38:20 <arand> We could put it down on the upstream recommendations wiki?
11:38:45 <guus> URL?
11:38:47 <pabs> #action guus to talk about full-screen behaviour on games@lists.freedesktop.org
11:39:10 <pabs> guus: http://www.freedesktop.org/wiki/Games/Upstream
11:39:27 <guus> Anything else I might bring up at the same time? Standardised hotkeys for load/save/inventory/whatever? Other issues?
11:39:56 <pabs> perhaps that P2P high scores protocol idea?
11:40:27 <guus> I missed that
11:41:10 <pabs> guus: http://lists.debian.org/868574.84653.qm@web180606.mail.sp1.yahoo.com
11:41:25 <arand> pabs: oh, I was thinking debian-games had a wiki similar, but of course that would be the best place for it.
11:41:50 <pabs> guus: also the next agenda topic probably needs bringing up there too
11:42:43 <arand> Should I put down an agreement that we want windowed by default (with a fullscreen option)
11:42:56 * pabs thinks so
11:42:58 <guus> pabs: ok
11:43:43 <kornerr> or config window at the first start
11:43:48 <kornerr> some Windows games do that
11:44:33 <pabs> ok, I need to go. no ideas about the rest of the agenda items but I volunteer to start a discussion on the list about extending debtags, documenting the discussion on the wiki and talking to the debtags maintainers about adding the new tags
11:44:38 <guus> mandatory command-line options to force windowed or full-screen would help too.
11:45:29 <arand> #agreed we prefer games to start windowed by default (with fullscreen option)
11:45:44 <SynrG> morning
11:45:51 <Fuddl> hi SynrG
11:46:11 <SynrG> it's early for me. missed the discussion above :/
11:46:35 <arand> SynrG: Welcome, we're currently finishing off point 4
11:47:22 <arand> So do we have more things on this topic?
11:48:33 <Fuddl> not from me, agreed to windowed by default ;)
11:48:33 <arand> #info Work with upstream on this (bugs, patches, etc.)
11:50:07 <arand> #topic How to make sure that users of a graphical desktop environment find the manual (...) of a game? (...)
11:50:32 <kornerr> that's some nice topic
11:50:42 <SynrG> certainly in-game help is the gold standard?
11:51:02 * pabs notes that there is no doc-base like freedesktop standard
11:51:13 <kornerr> doc-base?
11:51:18 <Fuddl> does manual mean the manual how to play the game or something like the manpage or READMEs in /usr/share/doc/PACKAGE?
11:51:21 * pabs notes that doc-base is next to useless on desktops
11:51:22 <arand> I think this topic was lindi-'s
11:51:38 <kornerr> doc-base is /usr/doc?
11:51:57 <arand> For triplane which has limited ingame documentation capabilities
11:52:18 <pabs> kornerr: http://packages.debian.org/sid/doc-base
11:52:20 * pabs off
11:52:36 <kornerr> oh
11:52:48 <kornerr> like man pages I guess then
11:53:18 <SynrG> well, then goplay? that's the next closest thing we have to a game index
11:53:21 <arand> #info Full topic: How to make sure that users of a graphical desktop environment find the manual (think PDF with images, not a man page that you view from a terminal emulator) of a game? In SDL programs it is often not easy to integrate this to the in-game menu system.
11:54:03 <Fuddl> does the standard for .desktop files offer something?
11:54:06 <SynrG> or is that a misfit because it is aimed at stuff not yet installed?
11:54:10 <arand> ^ This is what was given, the specific case for triplane is that it's basically a DOS-ish game with a manual in PDF format
11:54:33 <Kamping_Kaiser> freeciv gtk has in game help through civilopedia, i dont' have the sdl version installed to test with
11:55:14 <SynrG> goplay could include a URL to any doc for the game ...
11:56:14 <kornerr> any link for goplay?
11:56:17 <Kamping_Kaiser> (i just checked, freeciv calls it 'freeciv help browser')
11:56:38 <SynrG> otherwise, people are expected (as with any other package, not game-specific) to be able to find doc under /usr/share/<package>/doc
11:57:12 <SynrG> apt-cache show goplay
11:58:13 <berarma> alternatives that I can think of: 1- in-game. 2- from a desktop entry in the menus. 2- from the package manager. 3- help integrated in the desktop manager help
12:00:08 <Kamping_Kaiser> berarma: does 1 include 'game launches pdf viewer' or just 'game includes native help browsing'
12:00:20 <Kamping_Kaiser> s/pdf/html or other format
12:00:27 <arand> I think additional desktop entries is not a good idea.. (it sounds as though it should break some policy)
12:00:34 <kornerr> native one
12:00:37 <kornerr> surely
12:00:54 <berarma> native browsing but launching viewer would work too
12:00:59 * kornerr doesn't use html, uses hard coded layout
12:01:18 * ThibG doesn't use help muhahaha
12:01:25 <Fuddl> how is that handled on windows or mac?
12:01:30 <ThibG> (or any sort of user doc)
12:01:57 <berarma> xdg-open should open any help file
12:02:18 <kornerr> ThibG: hard core developer :P
12:02:52 * kornerr doesn't play Windows board games, can't say anything of help files
12:03:07 <kornerr> I can't remember anything of the sort for Mass Effect, Dragon Age, Witcher, etc
12:03:18 <kornerr> only some PDF installed into Start menu may be
12:03:21 <ThibG> kornerr, well, the controls are pretty easy to pick up, and there is a tutorial (with absolutely no wording in it huhuhu)
12:03:26 * kornerr recalls that one PDF from Morrowind
12:03:35 <berarma> Fuddl: AFAIR games create a menu subfolder with links to help
12:03:46 <kornerr> ThibG: yeah. that's good then when no help needed.
12:03:47 <berarma> that's for windows
12:04:00 <pdewacht_> many windows games just put the documentation on the website
12:04:10 <pdewacht_> since you need to go the website anyway to get the game
12:04:38 <Fuddl> how about doing it the same way? create a sub directory for each game and add menu entries to start the game, read a PDF, etc.?
12:05:29 <kornerr> then one would need to make both in-game and out-game docs :)
12:05:42 <ThibG> Fuddl, I think it's overkill, but I have no strong opinion against it
12:05:43 <arand> I would disagree to creating desktop entries just for help items
12:06:26 <Kamping_Kaiser> disagreei disagree too
12:06:45 <kornerr> I think it's not very unix way
12:06:46 <arand> Another alternative is to have a launcher dialogue.
12:07:15 <arand> But I think that's a bit ugly to.
12:07:30 <kornerr> launcher for games?
12:07:32 <berarma> I think the package manager is a better place
12:07:50 <kornerr> launcher for a game, i.e., for it's other options?
12:08:04 <Kamping_Kaiser> wonder if there is a/seeral help browsers that could be split into libraries for use by upstreams?
12:08:21 <Kamping_Kaiser> 'we suggest builing with libgtk-help-browser and help magically works'
12:08:37 * kornerr doesn't think anything of the sort exists
12:08:51 <kornerr> I think html is the best option with xdg-utils
12:08:52 <arand> kornerr: a window with "start game" "read help" basically (many does pre-launch options etc. this way)
12:09:07 <kornerr> arand: yeah. launcher could help, but it's not very suitable for small games
12:09:21 <Kamping_Kaiser> a launcher means you have to relaunch the game to get help while in the game
12:09:28 <Kamping_Kaiser> which isn't an improvement
12:09:31 <arand> kornerr: It is an annoyance in the long run, indeed
12:09:46 <kornerr> big games have launchers like Dragon Age
12:09:58 <kornerr> wasn't annoying, but I didn't press anything other than Play :P
12:10:28 <Kamping_Kaiser> brb
12:10:31 <berarma> would it be possible to run a keyboard utility while the game is running that would catch some key combination and launch a command?
12:11:03 <arand> berarma: I don't quite follow documentation-in-pkg-manager? Like a link in software-centre?
12:11:55 <berarma> yes, that's it, maybe because that's the first and only place to find info about the game for desktop users
12:12:00 <kornerr> I guess smth like game, and game-doc packages
12:12:03 <Fuddl> berarma: I think that's hard to do. a lot of games use different methods to grad keyboard input, bypassing the window manager and stuff
12:12:17 <kornerr> much like gimp and gimp-help/doc iirc
12:12:34 <kornerr> but still, packager is not the place to launch help
12:12:50 <kornerr> I would love some central help repository
12:13:21 <berarma> kornerr, that'd be good not only for games :)
12:13:32 <kornerr> I recall there is/was some KDE help center
12:13:42 <kornerr> it used to display man pages as well
12:13:54 <kornerr> wait. KDE has some sort of central help browser
12:13:57 <berarma> gnome has also a help center meant as a central place for desktop users, ala Windows
12:13:59 <kornerr> all KDE apps display help in there
12:14:06 <berarma> but it's underused
12:14:58 <Fuddl> will users think of System → Help? that's too trivial and obvious ;)
12:15:26 <ThibG> I think the KDE/Gnome help things are interesting, some sort of "upgraded" man pages
12:15:32 <ThibG> but it has to be standardized
12:15:36 <kornerr> yeah.
12:15:39 <arand> This also seems to be much of an "upstream recommendations" thing.
12:15:40 <ThibG> I'm not writing a gnome game, nor a KDE game
12:15:47 <kornerr> me too
12:16:08 <Fuddl> which will be A LOT of work to make every game upstream use a standard to document their game...
12:16:28 <ThibG> sure
12:17:11 <berarma> F1 is a standard key for help
12:17:35 <Kamping_Kaiser> not in games
12:17:38 <berarma> would it be possible to recommend upstream the use of this key to trigger an external command for help?
12:17:53 <kornerr> hm
12:17:54 <berarma> yes, I know, there might be problems
12:17:59 <kornerr> F1 sounds good
12:18:18 <arand> I know Frets on Fire uses F1 for one of the frets :)
12:18:25 <Fuddl> lol
12:18:38 <arand> But I agree, it would be a good recommendation
12:18:40 <berarma> I know too, lol
12:18:44 <kornerr> xfce4-terminal spawns default web browser and displays help in there
12:18:47 <kornerr> upon F1
12:18:48 <ThibG> makes me think of the 3DS, they have an interesting way of displaying documentation
12:19:04 <kornerr> so I think xdg-open HTML is the way to go for F1
12:19:19 <Kamping_Kaiser> frankly, this is starting to sound like a freedesktop thing
12:19:40 <ThibG> of course, Debian isn't a console system, and the UI would be very different, but at least they have a common way of displaying help
12:19:42 <Fuddl> what has to happen when a user presses F1 in a full screen game that grabs mouse and keybar input? switch to window mode, restore the desktop resolution, release input devices and then start the external command for the help browser?
12:19:47 <ThibG> Kamping_Kaiser, I fully agree with this
12:20:39 <kornerr> in case there's no in-game help, I guess yes
12:20:54 <Kamping_Kaiser> arand: i suggest this is done (by someone?) as a freedesktop thing, optinally discussed with (say) debian and fedora first
12:21:00 <pdewacht_> does anybody know if "xdg-open man:ls" to get a man-page will work in any desktop environment?
12:21:06 <pdewacht_> (it works here in gnome)
12:21:11 <kornerr> I guess upon alt-tab it should restore resolution and minimise itself, iirc that's what windows games do
12:21:22 * guus will add it to his task
12:22:03 <Kamping_Kaiser> guus: thanks :)
12:22:18 <arand> guus: Thankyou :)
12:22:20 <Kamping_Kaiser> arand: will you handle the bot, or shall i ? :)
12:22:50 <arand> I'm trying to figure out how to formulate it, fire away.
12:23:03 <guus> #action guus talk about documentation browser (either in-game or out-of-game) on games@lists.freedesktop.org
12:23:42 <arand> Excellent, next topic?
12:23:55 <Kamping_Kaiser> that'l do :) (i notice no one took any sort of info items during the convo, so we'll have to rely on full logs)
12:23:58 <kornerr> xdg-open man:ls does not work here with XFCE4
12:24:24 <arand> #topic Debtag for "this is a multiplayer game", "this is a single-player game", "this is a multiplayer game with AI"?
12:24:30 <Kamping_Kaiser> arand: please, my bed is feeling lonely
12:25:56 <arand> I don't know much about this topic, who's is it?
12:26:41 <Kamping_Kaiser> #link http://debtags.alioth.debian.org/
12:26:51 <Kamping_Kaiser> thatsthe place to enter debtags
12:26:58 <Kamping_Kaiser> (no idea about teh topic overall though)
12:27:15 <arand> #action pabs to start a discussion on the list about extending debtags, documenting the discussion on the wiki and talking to the debtags maintainers about adding the new tags
12:28:00 <Fuddl> the debtag thingy always confuses me, but I'm totally for marking games as single and multiplayer games! on LAN parties it's really annoying if one can't filter all the single player games :/
12:28:13 <arand> #info This was mentioned by pabs under the window/fullscreen topic
12:28:36 * kornerr thinks that goplay is nice
12:29:01 <Kamping_Kaiser> wish debtagswere in controlfiles :/
12:29:04 * berarma thinks it was mentioned in blends
12:29:33 <arand> Yeah, on the blends wiki
12:30:16 <arand> #link http://wiki.debian.org/Games/Blends
12:31:54 <arand> Hmm, anything more on this topic, maybe let it be re-introduced next meeting?
12:32:21 <Kamping_Kaiser> +1 for postpoing, or discussing on the list
12:33:04 <arand> #info postponing this to mailing list/next meeting
12:33:24 <arand> #topic Add "/srv/home/groups/pet/PET2/pkg-games/pet-git-helper update ${PACKAGE}.git" to hooks/post-receive in /git/pkg-games/setup-repository?
12:33:38 <arand> (Last topic on the agenda)
12:33:57 <arand> Is the topic-ee around?
12:34:06 <Kamping_Kaiser> i suspect this is affected by teh alioth split, and will need the same fix as pet1 - a cron job
12:34:27 <Kamping_Kaiser> (btw, lst topic item needs to be finding a pesron to run the next meeting)
12:34:32 <Fuddl> uhm... what is PET?
12:34:45 <kornerr> :)
12:34:51 <arand> Kamping_Kaiser: Ah, right, of course :)
12:35:26 <guus> Talking about alioth, I'm trying to move my games packages to it, but it seems my ssh keys are not being recognized (I cannot log in to git.debian.org for example). Maybe this has to do with the migration?
12:35:37 <Kamping_Kaiser> Fuddl: its one of these. http://pkg-games.alioth.debian.org/cgi-bin/PET/pet.cgi
12:36:07 <Fuddl> guus: write access is done via vasks.debian.net and you have to add your ssh key on alioth
12:36:08 <Kamping_Kaiser> guus: you should save that for after hte meeting (hoepfully almost done...)
12:36:31 <guus> k
12:37:43 <arand> #info Kamping_Kaiser suspects this is affected by teh alioth split, and will need the same fix as pet1 - a cron job
12:37:47 <arand> I guess
12:38:24 <arand> #topic Next meeting
12:38:57 <arand> So we need a volonteer to organise next meeting.
12:39:07 <Kamping_Kaiser> ideally someone who hasn't done one yet :)
12:39:20 <arand> Any takers? suggestions ? ;)
12:39:36 <Kamping_Kaiser> its not a lot ofwork, and you've got up to two months to get it sorted
12:40:38 <kornerr> what is required?
12:41:03 <arand> http://wiki.debian.org/Games/Meetings/ Has most of the info
12:41:53 <arand> Create the agenda from template, (everyone adds items), and run the meetbot
12:42:24 <Kamping_Kaiser> and set up a poll to work out the dates
12:42:25 <arand> also create a poll for the meeting timeslot, and announce it
12:42:46 <Kamping_Kaiser> kornerr: its been documented on the wiki, and you can always ask on teh list or here for help if you get stuck (we've had a couple of organisers now)
12:43:36 <kornerr> I should some items? :)
12:43:39 <kornerr> *add
12:44:22 <Kamping_Kaiser> kornerr: it'll probably take 30 min of your time to organise spread over a month, + some time for the meeting itself.
12:44:32 <Kamping_Kaiser> kornerr: so say you'll do it, we can end the meeting and i an go to bed :p
12:44:37 <Kamping_Kaiser> (no preasure ;))
12:44:40 <kornerr> :D
12:44:45 <kornerr> ok. I'll do it :D
12:44:51 <Kamping_Kaiser> :D
12:44:54 <arand> kornerr: Cool
12:45:19 <Kamping_Kaiser> #action kornerr will organise the next meeting
12:45:28 <Kamping_Kaiser> #info previous organisers are availble to help if required
12:45:39 <Kamping_Kaiser> arand: i think we're done?
12:45:54 <arand> #info make sure to take the dates of debconf into account when setting the date
12:46:03 <arand> Indeed, I think so to
12:46:04 <Kamping_Kaiser> goodthought
12:46:37 <kornerr> I think August 10 would be about time
12:46:59 <kornerr> i.e. 8 to 14 then
12:47:35 <arand> No objections there :)
12:47:38 <arand> Anyhow
12:47:43 <arand> #endmeeting