11:03:44 <Kamping_Kaiser> #startmeeting
11:03:44 <MeetBot> Meeting started Sun May 29 11:03:44 2011 UTC.  The chair is Kamping_Kaiser. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:03:44 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:03:56 <Kamping_Kaiser> #chair pabs
11:03:56 <MeetBot> Current chairs: Kamping_Kaiser pabs
11:04:01 <Kamping_Kaiser> incase you need it
11:04:18 <Kamping_Kaiser> #topic introductions
11:04:34 <Kamping_Kaiser> everyone who made it along, please speak up :)
11:04:40 <CIA-9> 03smcv 07openarena-085-data * r32b0604 10openarena-data/debian/ (changelog control):
11:04:40 <CIA-9> Merge branch 'master' into openarena-085-data
11:04:40 <CIA-9> Conflicts:
11:04:40 <CIA-9> debian/control
11:04:41 <CIA-9> 03smcv 07openarena-maps * r2f55078 10openarena-data/debian/ (changelog control):
11:04:41 <CIA-9> Merge branch 'master' into openarena-maps
11:04:41 <CIA-9> Conflicts:
11:04:43 <CIA-9> debian/control
11:04:45 <CIA-9> 03smcv 07openarena-players * r4d7f48e 10openarena-data/debian/ (changelog control):
11:04:45 <CIA-9> Merge branch 'master' into openarena-players
11:04:48 <CIA-9> Conflicts:
11:04:48 <CIA-9> debian/control
11:04:49 <CIA-9> 03smcv 07openarena-players * r1eabc7b 10openarena-data/debian/changelog: prepare upload (increment date)
11:04:49 <CIA-9> 03smcv 07openarena-players-mature * r7e0e940 10openarena-data/debian/ (changelog control):
11:04:51 <CIA-9> Merge branch 'master' into openarena-players-mature
11:04:51 <CIA-9> Conflicts:
11:04:54 <CIA-9> debian/control
11:04:54 <CIA-9> 03smcv 07openarena-textures * r531b5c5 10openarena-data/debian/ (changelog control):
11:04:55 * pabs grins
11:04:56 <CIA-9> Merge branch 'master' into openarena-textures
11:04:56 <CIA-9> Conflicts:
11:04:57 <CIA-9> debian/control
11:04:57 <CIA-9> 03smcv 07openarena-misc * ra7e649b 10openarena-data/debian/ (changelog control):
11:05:00 <CIA-9> Merge branch 'master' into openarena-misc
11:05:01 <CIA-9> Conflicts:
11:05:01 <CIA-9> debian/control
11:05:02 <Kamping_Kaiser> optionally say if you are new and what your interest is
11:05:06 <Kamping_Kaiser> wow, what timing
11:05:27 <christoph> heh
11:06:05 <pabs> I'm Paul Wise aka pabs. been involved with the team for a few years. my fav game in Debian is warzone2100. I also packaged some of Jason Rohrer's art games
11:06:39 <pabs> for the future I mainly intend to help with existing games in Debian and reviewing packages needing sponsorship
11:07:02 <pabs> <done>
11:07:09 <Kamping_Kaiser> i'm karl goetz, mostly Kamping_Kaiser on irc. my main interest is freeciv, but i dream of being generally useful ;)
11:07:36 <magnate> I'm Chris Carr aka magnate. I'm new to the team. I'm a member of the angband devteam (http://trac.rephial.org). I am not a DD, and lost touch with my previous mentor/sponsor. So I'm interested in how someone who now has no access to the Debian archive gets new games packages added to it.
11:08:11 <magnate> (There are *lots* of good roguelike games not yet packaged for Debian/Ubuntu.)
11:08:12 <christoph> I'm Christoph Egger aka. christoph -- I was a lot more active here previously but still care for some games like supertuxkart
11:08:41 <vlegout> I'm Vincent Legout and I'm mostly interested in chess and board games
11:08:59 <BigMc> I'm Tobias Hansen and packaged sludge.
11:09:39 <arand> I'm kind of new around here, got in via the cube universe.
11:09:52 <ThibG> I'm Thibaut Girka aka. ThibG, I'm not really involved with the team, but I like to idle here. I'm also working on some top-secret free software game projects muhahahaha :)
11:09:59 <guus> I'm Guus Sliepen and I'm maintaining blobwars, blobandonquer and crawl
11:10:04 <pdewacht> I'm Peter De Wachter, I've packaged Kenta Cho's shooters and a few other games but haven't been involved in the team lately
11:10:44 <tshirtman> i'm gabriel pettier, and i develop a 2d game (ultimate-smash-friends), i have a ppa, and i'm here out of curiosity :)
11:10:59 <ThibG> pdewacht, yay! Found someone to bother if I were to consider using D for a next game!
11:11:18 <SynrG> ben armstrong, another lurker. have a gaggle of kids and am interested in keeping them amused while i work on debian.
11:11:59 <SynrG> also i work on debian-live and would be interested in using it to make a live image with some games (if only for the Examples section of our manual)
11:12:39 <Kamping_Kaiser> i'll give people another 2 min, but we've a good turn out so far
11:13:43 <pabs> lets ping some people: |{41444d494e}| Zhenech wRAR Tolimar thekittster the-me stump SQlvpapir Soliton softcoder sam rudi_s rmayorga RichiH Rhonda RainCT pmderodat pixie persia micahg__ marcon josef|rumba Jon jordanm jandd JanC_ helmut Goneri Fuddl eof|mob debfx Clint chipi captnfab astraljava ansgar aindilis _migerh
11:14:35 <pdewacht> ThibG: I'm actually not enthusiastic about D, I've found gdc to be rather buggy and there've been several compatibility-breaking changes to the language
11:15:44 * Fuddl awakes
11:16:28 <pabs> Fuddl: we're doing introductions now
11:16:35 <Fuddl> pabs: k, k
11:16:40 <Zhenech> moin
11:16:45 <Zhenech> sorry for being late
11:16:55 <ThibG> pdewacht, ok, thanks
11:17:27 <Fuddl> I'm Bruno "Fuddl" Kleinert, I'm mostly caring for sauerbraten, scorched3d, nexuiz and londonlaw packages
11:18:00 <tarzeau> i love nethack, bubnbros, jumpnbump, sauerbraten...
11:18:17 <pabs> SynrG: you might have seen this: http://wiki.debian.org/Games/Blends
11:19:00 * ansgar just arrived.
11:19:05 <wRAR> I'm Andrey Rahmatullin and I mainly play Dwarf Fortress
11:19:50 <pdewacht> (for all the roguelike fans, I've found brogue (http://sites.google.com/site/broguegame/) to be great. source code's a mess though)
11:20:05 <Kamping_Kaiser> wRAR: ironically, not in debian
11:20:12 <wRAR> pdewacht: that's a requirement for rogue-likes
11:20:19 <wRAR> Kamping_Kaiser: I'm tracking the ITP, yes
11:20:35 <Kamping_Kaiser> ok, i'll close intros, and move on to the next item
11:20:38 * guus forgot to mention he also maintains omega-rpg, also a roguelike.
11:20:38 * Zhenech is Evgeni Golov, joined the team for PokerTH, now maintaining some more games and emulators
11:21:21 <Kamping_Kaiser> #topic actions from last meeting
11:21:23 <ansgar> I am Ansgar (surprise!). My first packages I maintained were games (simutrans), now I am mostly active in the perl and ftp teams.
11:21:25 <SynrG> pabs: hmm. i hadn't. thanks
11:21:26 <arand> Oh, and I'm doing work for assaultcube (updating), and have an ITP up for redeclipse, openierox, lugaru, and glc-capture..
11:21:35 <ansgar> I mostly play board games nowadays ;)
11:21:50 <Kamping_Kaiser> http://meetbot.debian.net/debian-games/2011/debian-games.2011-04-30-12.00.html is the link to the last meetings actions
11:22:06 <Kamping_Kaiser> i'm amused at #8, which is 'ansgar will help'
11:22:21 <ansgar> :D
11:22:23 * pabs did his action, pinging folks where possible
11:22:36 <Zhenech> ansgar wanted to help me with 7, which he did
11:22:41 <pabs> shevek isn't here
11:22:53 <SynrG> pabs: everyone has their own tastes in games. i think an example for the manual is a good approach because then you can show gamers how to make a live image with their favourites to take to a party or so :)
11:23:28 <Kamping_Kaiser> please save it for after pabs  and SynrG
11:23:40 <pabs> Zhenech: any luck with 1 and 3?
11:23:41 <guus> Hm, I didn't know about past action #2, and I'm involved in that...
11:23:46 <Kamping_Kaiser> Zhenech: how did you go with your other items?
11:24:01 <Kamping_Kaiser> #info action 8 from last meeting relates to action 7
11:24:22 <Kamping_Kaiser> #info 7(8) is complete
11:24:28 <Kamping_Kaiser> #info 4 is complete
11:24:49 <Zhenech> Kamping_Kaiser, pabs: I started Games/Policy in the wiki with the content from the last meeting, it was extended via ML later
11:25:03 <Zhenech> makes #5 done as in started
11:25:08 <Kamping_Kaiser> #info 6 is shevek's, and he is absent
11:25:19 <Kamping_Kaiser> #action follow up with shevek next meeting about item 6
11:26:02 <Kamping_Kaiser> #info 5 done as in started
11:26:09 <Kamping_Kaiser> (ftr, #info is a public command)
11:26:41 <pabs> #help I'd like other folks to help with recruiting folks and pinging people about RC bugs until the next meeting
11:26:54 <pabs> any volunteers?
11:27:23 * pabs welcomes Kaimei to the meeting
11:27:29 <guus> #info 2 haven't seen any activity, hansg currently absent
11:27:39 <Zhenech> #info #1: we don't have open ITPs (just two RFPs) and I did not look into non-our RFP/ITPs on devel :/
11:28:12 <Zhenech> #info #1: I == Zhenech
11:29:09 <pabs> not sure if that is true Zhenech, for eg I have an open ITP on Sleep is Death
11:29:10 <Zhenech> #info #3 Zhenech wrote some ping-inactive-users script svn:pkg-games/software/list-inactive-members), but not the IRC one.
11:29:23 <Zhenech> pabs, not owned by pkg-games then
11:29:42 <pabs> true, I do intend it to be in the team though
11:29:53 <Zhenech> heh
11:30:21 <Zhenech> #info Games/Policy: packages intended for pkg-games should have their ITP owned by pkg-games
11:30:44 <pabs> IIRC usually qa folks change the ownership when they find ITPs that are not owned by humans
11:30:50 <Kamping_Kaiser> a last request before i #info no support for pabs #help - any volunteers to help with the pinging?
11:30:53 <ansgar> Hmm, I prefer them owned by the people who work on them.
11:31:14 <ansgar> There is nobody to ask about progress otherwise.
11:31:26 <pabs> agreed, I guess we need a different way to track them then
11:31:47 <Kamping_Kaiser> would usertags be up for the job?
11:32:11 <Zhenech> ansgar, well, there is still the submitter?
11:32:18 <Zhenech> but ok, usertag is fine for me too
11:32:32 <Kamping_Kaiser> this probably almost deserves its own agenda item
11:32:33 <ansgar> Is it possible to use "me@example.com, p-g-m@l.d.o" as the owner? (ie. two owners: team and a human being)
11:33:08 * pabs does a test
11:33:09 <SynrG> usertags give you an approximation of that
11:33:15 <ansgar> Zhenech: Submitter isn't always the person who wants to package it, he might just have asked for a package (RFP).
11:33:25 <Kamping_Kaiser> #topic owner of ITPs targeted at pkg-games
11:33:54 <ansgar> Or usertags. That gives an easy way to search for them as well.
11:34:01 <Kamping_Kaiser> #info Zhenech 's action item from last time involes catching games not on the wiki page that are itpd. what is the best way to track it
11:34:14 <Kamping_Kaiser> #idea use pkg games as owner
11:34:18 <Kamping_Kaiser> #idea usertags
11:35:07 <ansgar> How can one add comments to ideas via meetbot?
11:35:22 <pabs> http://wiki.debian.org/MeetBot
11:37:19 <Kamping_Kaiser> #info QA might change itp's not owened by a human, so assigning to the team might not work
11:37:20 <ansgar> #info using the team as owner would mean there is no human contact to ask about the current status
11:37:31 <Kamping_Kaiser> snap!
11:38:01 <pabs> #info the bts command from devscripts only accepts one owner mail right now
11:38:45 <ansgar> #info usertags can be search for (+), but are not visible on the web pages by default (-)
11:38:50 <Kamping_Kaiser> shall we trial using a usertag for a month or two and see if it works out?
11:39:03 * magnate is fully in attendance
11:39:06 <Zhenech> user:pkg-games-devel@l.a.d.o, usertag:pkg-games-itp ?
11:39:30 <ansgar> usertag:itp should be enough.
11:39:54 <ansgar> Or usertag:wnpp and use it for ITA as well.
11:40:05 <SynrG> we've been using usertags quite effectively for this sort of tracking with debian-eeepc
11:40:47 <SynrG> if the bug title has "itp" in it, that's duplication of information
11:40:48 <pabs> #info the control@bugs.debian.org bot accepts multiple owner addresses, but needs some fixes. for eg: http://bugs.debian.org/611793
11:40:53 <SynrG> which is generally a bad thing.
11:41:27 <SynrG> when the bug title gets rewritten when the status changes, it will go out of sync with the usertag
11:41:52 <pabs> usertag:wnpp sounds like the right thing to do then
11:42:01 <Zhenech> +1 @ wnpp
11:42:13 <pabs> ansgar: does PET interface with usertags at all?
11:42:20 <pabs> or wnpp bugs for that matter
11:43:01 <ansgar> pabs: PET1 does, PET2 does not yet. And they don't track bugs in wnpp at all.
11:43:07 * RichiH is minimally around
11:43:08 <RichiH> -ish
11:43:58 <ansgar> For wnpp, a link showing packages tagged with usertag:wnpp is probably better.
11:45:59 <Kamping_Kaiser> ansgar: is this correct? if so i'll add it. #info PET1 interfaces with usertags, PET2 does not yet
11:46:37 <Kamping_Kaiser> and i think we can #agreed to use user:pkg-games-devel@l.a.d.o with usertag:wnpp. any objections?
11:46:56 <SynrG> you might find http://wiki.debian.org/DebianEeePC/Bugs/About useful
11:47:17 <ansgar> The usertags part is: PET1 can show selected usertags (for given users). I am pretty sure about wnpp as well.
11:48:12 <ansgar> #link http://wiki.debian.org/DebianEeePC/Bugs/About
11:48:30 <SynrG> #link http://wiki.debian.org/DebianInstaller/Bugs
11:48:34 <SynrG> based on this page ^^
11:49:51 <pabs> ok, I think we can finish up this topic and move on
11:50:21 <pabs> #action pabs to write up info about pkg-games usertags on the wiki
11:50:26 <Zhenech> yepp
11:50:41 <Kamping_Kaiser> pabs: thanks
11:51:00 <Zhenech> pabs, imho subsection for policy?
11:51:13 <pabs> sounds good
11:51:22 <Zhenech> oki
11:51:32 <pabs> #agreed to use user:pkg-games-devel@l.a.d.o with usertag:wnpp
11:51:37 <Kamping_Kaiser> #agreed to use user:pkg-games-devel@l.a.d.o with usertag:wnpp, pabs to document on [[Games/Policy]]
11:51:42 <Kamping_Kaiser> heh. sna again
11:51:45 <pabs> :)
11:52:26 <Kamping_Kaiser> #topic Switching to a single PET instead of two instances
11:52:30 <BigMc> is that just for when the bug owner is in the team or can we go and tag any game itps with that?
11:52:41 <ansgar> Well, PET1 is currently broken.
11:52:51 <Kamping_Kaiser> BigMc: only if its meant to be part of the team
11:52:53 <ansgar> So we already have just one PET instance at the moment ;)
11:53:00 <Kamping_Kaiser> ansgar: hah :)
11:53:15 <ansgar> #info PET1 is broken due to Alioth move
11:53:19 <pabs> heh
11:53:36 <BigMc> problem solved
11:53:41 <Kamping_Kaiser> hm, that relates to my 2nd last item :p
11:54:08 <ansgar> PET2 works, but still has less features compared to PET1 (and more bugs).
11:54:32 <Kamping_Kaiser> ansgar: is pet a debian project/you project/something external you mangle?
11:54:38 <ansgar> #info PET2 working, but still has limitations compared to PET1. See also
11:54:49 <ansgar> #link http://lists.debian.org/debian-devel-games/2011/05/msg00117.html
11:55:12 <ansgar> Kamping_Kaiser: Hmm, currently there is only me working on PET2.
11:55:17 <pabs> #link http://pkg-games.alioth.debian.org/cgi-bin/PET/qareport.cgi
11:55:28 <pabs> #link http://pet.43-1.org/pkg-games/pet.cgi
11:56:09 <ansgar> It's hosted on my own server, the source is available on alioth.d.o (in the pet project's Git repository).
11:57:02 <ansgar> Help is of course always welcome ;)  I can give shell access to people interested in this (maybe only people in some debian keyring, ie. DM or DD).
11:57:27 <pabs> #info PET2 supports git, some pkg-games packages use git, so we can retire wiki.d.o/Games/Sponsors/Queue when PET2 is ready
11:57:53 <ansgar> (see also http://lists.alioth.debian.org/pipermail/pet-devel/2011-March/000105.html)
11:57:56 <Kamping_Kaiser> #help ansgar would appreciate help working on PET2. its source is hosted in git on alioth
11:58:13 <ansgar> #link http://lists.alioth.debian.org/pipermail/pet-devel/2011-March/000105.html
11:58:30 <ansgar> #info ansgar plans to work on PET during debcamp.
12:00:13 <ansgar> I think we can go to the next item?
12:00:16 <Kamping_Kaiser> i think we'll have to put up with multiple pets until git is supported , so i might move us on to the next item
12:00:29 <Kamping_Kaiser> #agreed to wait until pet2 is ready before revisiting this idea
12:00:39 <Kamping_Kaiser> #topic BoFs at DebConf with lightning talks
12:00:45 <Kamping_Kaiser> #
12:00:47 <ansgar> Kamping_Kaiser: Well, it's already mostly usable.
12:00:48 <Kamping_Kaiser> ?BoFs at DebConf with lightning talks where everyone can and should present their favorite game. a ?YouTube channel for pkg-games with videos once a week introducing people's favourite free software games.
12:01:02 <Kamping_Kaiser> i'm not sure whos item this is, could they please talk to it? :)
12:01:15 <pabs> that would be Rhonda's idea
12:01:22 <Kamping_Kaiser> ansgar: ok
12:01:25 <Zhenech> YouTube is Rhonda's idea
12:01:26 <Kamping_Kaiser> hm
12:01:45 <Zhenech> the lightning talks were too iirc
12:02:12 <pabs> #info Rhonda registered a games lightning talk session at DebConf11
12:02:22 <pabs> #help anyone coming to DebConf11, please prepare a lightning talk about your favourite game
12:02:41 <pabs> so, who is going?
12:02:59 <Kamping_Kaiser> sadly not me
12:03:00 * Zhenech is
12:03:07 * ansgar is as well.
12:03:08 <Zhenech> Tolimar is
12:03:11 <pabs> #action pabs to present warzone2100 and or chromium-bsu at DebConf11
12:03:12 <Zhenech> christoph is
12:03:21 <ansgar> Hmm, there will be another round of board games here.
12:04:17 <ansgar> I did only have one hour this time, will look at the meeting notes later.
12:04:38 <pabs> ok, thanks for coming ansgar :)
12:04:43 * Fuddl won't be at debconf
12:04:58 <Kamping_Kaiser> ansgar: thanks for making it
12:05:41 <Kamping_Kaiser> i'm not sure where else to go with this item (i didn't pay much attention to that thread), so unless someone else has something i'll moe on
12:05:58 <pabs> anyone else interested in doing a lightning talk or making a video for the pkg-games youtube channel?
12:06:55 <Zhenech> i'd do a talk
12:07:02 <Zhenech> but no idea what I should do in a video
12:07:14 <Zhenech> i'd love Rhonda to make some guidelines for that
12:07:27 <pabs> I guess we can ask her later
12:08:12 <pabs> something like the existing chromium-bsu videos on youtube might be the right format for youtube channel videos
12:08:30 <Zhenech> linky?
12:08:53 <arand> There would be nice to have or point to a good guide on how to record a game+ingame(+voice) with what tools..
12:08:56 <pabs> http://www.youtube.com/results?search_query=chromium-bsu
12:09:28 <pabs> #info Rhonda was investigating tools for recording youtube games channel videos
12:09:37 <Kamping_Kaiser> #action Zhenech to givea talk
12:09:50 <pabs> Zhenech: which game?
12:09:57 <arand> pabs: Ah, neat :)
12:10:20 <Kamping_Kaiser> #action Rhonda to provide some more details about how she thinks the videos could be structured
12:10:35 <Kamping_Kaiser> #info pabs suggests the format of chromium-bsu
12:10:40 <Kamping_Kaiser> #link http://www.youtube.com/results?search_query=chromium-bsu
12:11:15 <Zhenech> pabs, Kamping_Kaiser: uhm, most prolly pokerth
12:11:58 <pabs> I guess we can move on to the next topic?
12:12:11 <Fuddl> which tools are suggested to record desktop sessions? a long time ago I used gtkrecordmydesktop which I found ok but far from being satisfying
12:12:28 <Zhenech> Fuddl, rhonda was using some, she might tell later
12:12:41 <Fuddl> Zhenech: ok
12:13:17 <Kamping_Kaiser> #action ask Rhonda if she has recomendations for recording tools
12:13:22 <Kamping_Kaiser> pabs: yes, i think so
12:13:39 <Kamping_Kaiser> #topic Alioth migration - did everyone and everything survive it?
12:14:00 <Kamping_Kaiser> so, we've already found out that pet didn't, i just wanted to quickly check if there was 'stuff' broken that people needed help resolving
12:14:17 <pabs> #info PET1 did not survive: http://pkg-games.alioth.debian.org/cgi-bin/PET/qareport.cgi
12:14:28 <Kamping_Kaiser> i haven't got as far as updating my ssh configs yet, so i don't know if anything past that is broken
12:14:29 <arand> Fuddl: glc is good for opengl, (though won't capture mic afaik), I*m in the process of trying to package it..
12:15:07 <magnate> I haven't tried to rebuild my packages since the move, but the repos are still there and seem fine.
12:15:16 <Zhenech> old links in vcs fields are broken, but alioth admins are about so fx it afact
12:15:35 <Fuddl> arand: thx, I'll put testing it on my todo list once it's through NEW
12:15:58 <pabs> Zhenech: about to fix it? excellent, I thought they wanted to keep anonscm
12:16:18 <arand> I herd there was to be just a redirekt
12:16:24 <arand> *heard
12:16:33 <Zhenech> pabs, at least I read it that way on devel
12:16:38 <Zhenech> yepp, redirects
12:16:39 <Zhenech> btw
12:16:40 <Zhenech> evgeni@wagner:~$ ls /var/lib/gforge/chroot/home/groups/pkg-games/htdocs/tarballs/
12:16:43 <Zhenech> ls: cannot access /var/lib/gforge/chroot/home/groups/pkg-games/htdocs/tarballs/: No such file or directory
12:16:46 <Zhenech> where is out public_html now?
12:16:50 <Zhenech> our*
12:16:56 <Kamping_Kaiser> #info vcs-* fields are broken, but alioth admins are adding redirectors
12:17:04 <pabs> Zhenech: /home/groups/pkg-games/htdocs/tarballs/
12:17:21 <pabs> (chroot seems removed)
12:17:34 <arand> Note, that is onlu for VCS-Browse, faik the VCS: still does work
12:17:52 <pabs> (I already updated wiki.debian.org about the chroot stuff)
12:18:13 <Kamping_Kaiser> #info some post commit hooks may be broken, be aware :)
12:18:27 <Kamping_Kaiser> #info correction, arand notes only vcs-browse is broken atm
12:18:56 <pabs> hmm someone should investigate the commit hooks, maybe grep them for the chroot path
12:19:17 <Kamping_Kaiser> #info path that tarballs are stored in has changed
12:20:46 <Kamping_Kaiser> #help someone should investigate the commit hooks for path-change induced breakage
12:21:07 <Kamping_Kaiser> anything more? else i'll pass over to chris for the last two items
12:21:26 <magnate> thanks
12:21:27 <Zhenech> #info Zhenech updated his putsource.sh script for uploading tarballs
12:22:01 <Zhenech> packages/trunk/tarballs/putsource.sh that is
12:22:18 <Kamping_Kaiser> thanks
12:22:36 <pabs> #info pabs grepped our git hooks and none of them reference the chroot paths
12:23:46 <Kamping_Kaiser> #topic documentation regarding packaging
12:23:49 <magnate> These two agenda items are connected - the reason I asked about packaging documentation was because I wonder if the diversity of packaging approaches is part of the difficulty of getting packages sponsored.
12:23:54 <magnate> It seems to me there are four categories of games:
12:23:54 <magnate> - games not sponsored at all (i.e. not in Debian)
12:23:57 <magnate> - games maintained by DDs who are part of the Debian Games Team (DGT)
12:23:59 <magnate> - games sponsored/uploaded by DDs in the DGT but maintained by others
12:24:02 <magnate> - games maintained elsewhere and sponsored by DDs who are not part of DGT
12:24:04 <magnate> My questions are really about how to move from the last category up to one of the others. Things like moving your packaging VCS to pkg-games/ are already in the draft policy. But I assume that there are more games than the DDs in the team can sponsor, so what would help make sponsorship easier? Should there be more commonality between how games packages are built?
12:24:43 <magnate> There was a discussion on debian-mentors recently about a packaging tutorial - is there/should there be a games-specific one?
12:25:39 <magnate> Or doesn't it matter as long as all packages are lintian clean etc.?
12:25:50 <pabs> commonality would help a bit (IMO debhelper dh)
12:26:21 <magnate> So if I had never built a package before, you would recommend starting with debhelper?
12:26:58 <Kamping_Kaiser> i think something like Charles Plessys package review concept would be a good think to adopt in teh team for people who are not yet dds http://wiki.debian.org/PackageReview
12:27:31 <pabs> magnate: definitely. with debhelper 7's dh, most of the work is done instantly unless the game uses a non-standard build system, which most of them do ;)
12:27:40 <magnate> Heh
12:27:59 <guus> What about the category "games maintained by DDs who are not part of DGT"?
12:28:01 <magnate> Is autoconf/configure/make considered standard?
12:28:12 <pabs> magnate: yes
12:28:15 <magnate> guus: you're right - sorry to miss that one
12:28:23 <magnate> I guess I was oversimplifying for speed's sake
12:28:53 <pabs> guus: indeed, there are quite a few of those. I wonder how to get those DDs to join the team and help us with sponsoring ;)
12:29:02 <SynrG> i'm in that category and am interested in moving it into DGT
12:29:03 <magnate> I am wondering if a wiki page about "How to get your game into Debian" would help. It would need to be more introductory than http://wiki.debian.org/Games/Development
12:29:12 <SynrG> just never got around to it :P
12:29:37 <pabs> magnate: sounds like a good idea
12:29:50 <magnate> I am happy to create it, but I would need help filling in some of the blanks!
12:30:08 <pabs> I'm personally more likely to sponsor new games from folks who want to help out with existing games too
12:30:17 <Kamping_Kaiser> #idea a wiki page about "How to get your game into Debian". It would need to be more introductorythan http://wiki.debian.org/Games/Development
12:30:18 <magnate> And I guess it could be a good way to get new games packaged in accordance with the games policy
12:30:21 <Kamping_Kaiser> #link http://wiki.debian.org/Games/Development
12:30:44 <guus> Perhaps there could be an IRC session where DDs who want to join DGT can be helped migrating their packages to DGT?
12:30:45 <magnate> pabs: do you mean fixing bugs?
12:30:51 <Kamping_Kaiser> #idea something like package review would be a good think to adopt in the team
12:30:55 <Kamping_Kaiser> #link http://wiki.debian.org/PackageReview
12:30:58 <pabs> yeah, and updating to new versions etc
12:31:49 <magnate> hmmm
12:32:04 <Kamping_Kaiser> #idea ask those requesting sponsorship to help out with an existing games pakaging
12:32:39 <tshirtman> a page about "how to get your game into debian" would be interresting to me, i don't understand much of what's happening here ^^'
12:32:41 <magnate> As someone looking for sponsorship I'd find that an odd thing to be asked - but I guess it would help me learn more about packaging
12:33:03 <pabs> guus: sounds like a good topic for the pkg-games parties idea (http://wiki.debian.org/Games/Parties)
12:33:10 <pabs> guus: I don't want pkg-games to be a place where DDs dump packages and then become inactive though
12:33:29 <Kamping_Kaiser> #action magnate to create How to get your game into Debian wiki page.
12:33:50 <magnate> Packaging is quite a steep learning curve
12:34:04 * pabs willing to help with magnate's wiki page
12:34:07 <magnate> pabs: can you recommend an existing game I could help with?
12:34:36 <Kamping_Kaiser> #action pabs help magnate with wiki page
12:34:37 <magnate> The links on http://wiki.debian.org/Games/Development are a bit intimidating
12:35:01 <pabs> magnate: anything listed on our bug page or our PET pages
12:35:25 <BigMc> maybe it would be good to have a way to distinguish games with and without an active maintainer
12:36:04 <magnate> Ok but this is part of my point: to be helpful, I need to know what to do once I've followed those links and found something I can fix. I guess part of the introductory wiki page could be about teaching people how to help out.
12:36:19 <magnate> BigMc: good idea
12:37:28 <magnate> It's hard enough fixing bugs in software you know well
12:37:29 <pabs> the whole team is the maintainer for all our packages, so we should all feel free to work on any and all of them
12:37:44 <magnate> Ok, that's a good principle
12:38:05 <Kamping_Kaiser> #idea it would be good to have a way to distinguish games with and without an active maintainer
12:38:10 <Kamping_Kaiser> #info the whole team is the maintainer for all our packages, so we should all feel free to work on any and all of them
12:38:14 <magnate> I could imagine being able to help with lintian warnings, even if I don't know the source well enough to fix bugs
12:38:34 <magnate> (How often is that list of lintian warnings updated?)
12:38:35 <Zhenech> yeah, that what was decided last session
12:38:37 <Kamping_Kaiser> note that it isn't an invitation to redo the packaging unless you talk with whoever uploaded previously...
12:38:52 <Kamping_Kaiser> magnate: problem with the lintian stujff is its run on the archive
12:39:19 <magnate> Why is that a problem?
12:39:20 <Kamping_Kaiser> magnate: the biggest help in that regard is building updated source packages out of vcs(s) we use to get the packages updated
12:39:20 <pabs> magnate: I think lintian.d.o is daily updated
12:40:13 <pabs> magnate: because doesn't reflect what is in the vcs. I guess we should upload more often :)
12:40:26 <magnate> I think it would be helpful to have more text under the various "Get Involved" links on the Development page. I'm happy to propose some and see if ppl think it would help.
12:40:35 <Kamping_Kaiser> i think i missed the 'and get sponsored' off the end of my last comment. oops.
12:40:42 <magnate> At the moment it leaves a lot unsaid about what helping out actually involves.
12:40:59 <Kamping_Kaiser> magnate: please do expand the pages if you can
12:41:20 <magnate> Ok I'll have a go. I am better at wiki editing than at coding ;-)
12:41:22 <tarzeau> if anyone liked lemmings, i wouldn't mind a helping hand with Lix: http://asdfasdf.ethz.ch/~simon/
12:41:39 * magnate has to go because children are waking up
12:41:39 <tarzeau> they're migrating from lib allegro 4 to 5
12:41:41 <Kamping_Kaiser> tarzeau: ask around after the meeting, we're almost done
12:41:48 <tarzeau> ok
12:41:55 <magnate> Thanks for the discussion - will catch up later
12:41:58 <Kamping_Kaiser> #action magnate to expand the Games/Development wiki page
12:42:02 <Kamping_Kaiser> magnate: thanks for taking part
12:43:10 <Kamping_Kaiser> i propose we come back to a cobination of those last two points next meeting. hopefully some of the wiki editing actions will be done and things will have started to clear up
12:43:22 * pabs agrees
12:43:27 <Zhenech> +1
12:44:04 <Kamping_Kaiser> #agreed we come back to a combination of those last two points next meeting after the wiki editing actions are done and things will have started to clear up
12:44:26 <Kamping_Kaiser> #topic
12:44:30 <Kamping_Kaiser> #topic Seeking/Gaining sponsorship
12:44:36 <Kamping_Kaiser> #agreed we covered this in last item
12:44:45 <Kamping_Kaiser> #topic organiser for next meeting
12:45:03 <Kamping_Kaiser> i''d like to call for a volunteer to organise the next meeting.
12:45:26 <Kamping_Kaiser> its not particularly stressfull, we have a nice wiki page at http://wiki.debian.org/Games/Meetings to roll through
12:45:42 <pabs> #info meeting procedures are well documented on the wiki page
12:45:45 <pabs> #link http://wiki.debian.org/Games/Meetings
12:46:36 <pabs> myself, Zhenech and Kamping_Kaiser organised the previous meetings, so its someone else's turn :)
12:46:58 * Zhenech nods
12:47:50 * pabs nominates BigMc, guus, arand
12:48:41 <guus> I do not have time to do that.
12:48:58 <BigMc> not interested
12:49:29 <pabs> how about SynrG, tarzeau, tshirtman?
12:49:32 <arand> I may be able to jump on that, nex meeting would be in a month or soo?
12:49:43 <pabs> a month or two yeah
12:50:17 <SynrG> ah, no thanks. i was only barely here, and most times are like this :)
12:50:34 <SynrG> puttering about, serving coffee & breakfast to my family, etc.
12:50:41 <pabs> arand: do an #action for it if you think you have time and interest :)
12:50:42 <arand> Right, unless something unexpected pops up, I'm up for it.
12:50:50 * pabs :D
12:50:54 <Kamping_Kaiser> :)
12:51:33 <Kamping_Kaiser> arand: and you are able to come here and ask if you have questions about the process, we don't just dump it on you :)
12:51:45 <arand> #action arand volunteering to organize topics for next meeting
12:52:20 <Kamping_Kaiser> \o/
12:52:27 <Kamping_Kaiser> #info thanks to arand for volunteering
12:52:40 <Kamping_Kaiser> thats our agenda done
12:52:46 <Kamping_Kaiser> #endmeeting