20:04:27 <waldi> #startmeeting
20:04:27 <MeetBot> Meeting started Fri Jul 12 20:04:27 2019 UTC.  The chair is waldi. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:04:27 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:05:02 <waldi> well. i heard something from ansgar
20:05:44 <ansgar> Yes.
20:05:55 * ta is here
20:06:20 <waldi> #topic Check action items from last meeting
20:06:59 <waldi> he had only two items: new archive signing keys and kfreebsd and hurd removal
20:07:06 <ansgar> Those are all done.
20:08:39 <waldi> #topic any news for OpenSSL
20:08:55 <waldi> we wanted to discuss via mail, did something happen?
20:09:26 <ansgar> I did ask the FSF about related things (as GNUTLS should also be GPL-2-incompatible)... They didn't reply yet.
20:10:57 <ansgar> Other than that I think not much changed since last time.
20:11:34 <ta> there was this draft for an announcement ...
20:13:43 <waldi> okay, how do we want to go forward?
20:17:34 <ansgar> Probably try to agree on what might be a system library and what not.  Then try to agree if we should follow Fedora.
20:18:29 <ansgar> We did release with postgres linking openssl (#924937); (rdeps of postgres might be gpl; postgres itself is fine either way)
20:19:34 <ta> yes, we should not make things to complicated
20:20:04 <ansgar> I'm still interested what the FSF thinks about GPL-2 & GPL-2-incompatible system libraries...
20:20:15 <waldi> #info buster released with postgres linking openssl (#924937), contaminating gpl reverse-deps
20:20:35 <ta> so wait for N weeks for their answer?
20:22:17 <ansgar> Well, 2 weeks ago they said they hope to have an answer "soon"; my initial query was from April.
20:22:32 <ansgar> But we aren't in a particular hurry anyway :)
20:24:05 <Maulkin> ansgar: FYI, I can probably help escalate if it it becomes more urgent :)
20:24:12 * Maulkin re-lurks
20:26:38 <waldi> so we need to agree on: what is a system library; if we should follow fedora
20:29:21 <waldi> #action we need to agree on: what is a system library; if we should follow fedora
20:30:37 <waldi> #topic Any other business
20:31:21 <ansgar> The morgue sync (from /srv/ftp-master.d.o/morgue to lw03.d.o:/srv/morgue.d.o) is paused as lw03.d.o doesn't have enough free space there.
20:31:22 <waldi> the next meeting might be on 2019-08-09 at the same time
20:31:32 <ansgar> There is rt#7816 for that.
20:31:57 <jrtc27> some people were complaining about buster-backports using .xz rather than .gz+.xz for Packages I think
20:31:58 <jrtc27> (buster itself is .gz+.xz)
20:32:05 <jrtc27> generally speaking there's inconsistency in the database between different suites for the same release
20:33:33 <ansgar> Hmm, more or less everything should slowly get only .xz.
20:33:48 <waldi> -debug is .xz only?
20:33:50 <jrtc27> agreed; -debug seems to be consistently .xz
20:34:03 <jrtc27> but -backports was .gz+.xz for stretch and .xz-only for buster
20:34:15 <jrtc27> and also comes under the main /debian/, unlike -debug
20:35:46 <ansgar> jrtc27: What does break with .xz-only? Or why were some people unhappy?
20:36:12 <jrtc27> I was trying to remember that myself
20:36:25 <ansgar> I know we keep MD5sum for jigdo, but that is only for the "main" suite ("stable", but not -updates, -p-u, -security, -backports, ...)
20:36:27 <jrtc27> in the meantime, http://paste.debian.net/1091389/ is the query of interest
20:36:56 <jrtc27> (also stretch-bpo-sloppy falls under the same category)
20:38:12 <ansgar> (We should probably have a dak/doc/deprecated.rst document for what we deprecate and when or why something cannot be deprecated currently)
20:40:42 <ansgar> Aha, the default (nothing set in indices_compression) is gz+xz
20:41:23 <jrtc27> yeah
20:43:15 <ansgar> #info morgue sync to lw03.d.o broken (no disk space, rt#7816)
20:44:43 <ansgar> #info some people unhappy about buster-backports having only .xz indices; not sure what was broken
20:45:23 <waldi> #info the next meeting might be on 2019-08-09 at the same time
20:45:27 <waldi> anything else?
20:45:28 <jrtc27> I think this might just have been <CAFVMu-q2syZtesS7Xs3c-ExJYLVQ+H-TxBvnoA0mpyYgSNPHDw@mail.gmail.com>
20:45:29 <ScottK> So it turns out I'm eventually here.
20:46:01 <jrtc27> jessie's debmirror is broken with only xz, but stretch or newer should work fine
20:46:04 <waldi> jrtc27: so broken software?
20:46:17 <waldi> well, buster is way newer then jessie
20:46:19 <jrtc27> (even if the error message still looks unhelpful post-xz-only support)
20:46:20 <jrtc27> indeed
20:46:25 <jrtc27> so maybe a non-issue
20:47:09 <jrtc27> though if we're releasing suites like buster-bpo without gzip, might be worth also disabling gzip for testing...
20:47:25 <ansgar> * Add support for xz-compressed index files. Closes: #737057
20:47:26 <jrtc27> otherwise we're not properly testing this
20:48:12 <jrtc27> this would be #819044
20:49:05 <ansgar> Well, we could start disabling .gz for unstable?
20:49:21 <jrtc27> testing, unstable, whatever, I don't mind :P
20:50:11 <ansgar> I wonder how many clients still even download .gz?  I think apt prefers .xz.
20:50:27 <jrtc27> I don't recall what, if any, blockers remain for removing gzip
20:51:38 <ansgar> Related to that: juliank wanted to switch package translations to .xz too (Ubuntu already does that).
20:53:04 <jrtc27> I'd also suggest an `UPDATE suite SET indices_compression=array['gzip','xz'] WHERE indices_compression IS NULL;`, make the column NOT NULL and remove the default so this kind of thing is less surprising
20:55:57 <juliank> yes please!
20:57:13 <ansgar> juliank: Could you ask the i18n people to make sure their side is ready?
20:57:28 <juliank> not sure who to contact
20:57:49 <juliank> Ah found it
20:57:57 <juliank> It's the obvious debian-i18n@lists.debian.org
20:58:08 <juliank> or maybe debian-l10n-devel@lists.alioth.debian.org
20:58:17 <juliank> oops
20:58:20 <juliank> that's old
20:58:44 <ansgar> The web site should be https://ddtp2.debian.net/, but there is no contact.
20:58:45 <jrtc27> update122 already does ALTER COLUMN i18n_compression SET DEFAULT ARRAY['xz'],
20:58:53 <jrtc27> (as well as the ALTER COLUMN indices_compression SET DEFAULT ARRAY['xz'],)
20:59:34 <ansgar> https://www.debian.org/international/l10n/ddtp has debian-i18n@l.d.o
21:00:29 <jrtc27> so we already have 9 suites not doing bzip2-only compression http://paste.debian.net/1091396/
21:02:41 <jrtc27> given https://salsa.debian.org/ftp-team/dak/merge_requests/148/diffs is currently open, those are perhaps a bit premature?
21:03:44 <juliank> fascinating
21:04:49 <juliank> ansgar: I CCed them to the bug
21:05:06 <ansgar> jrtc27: That MR seems to only affect i18n stuff (only unstable/testing); generate-i18n-Index is no longer used (only in point release script for wheezy)
21:05:37 <juliank> It's unclear how much effect it has really, I just replaced all hardcoded instances :D
21:06:21 <juliank> I renamed it now :)
21:07:21 <jrtc27> yeah ok confirmed, extimportdists is only ever set to the testing+unstable codenames
21:07:41 <waldi> hmm. this code should stop importing pre-compressed stuff
21:08:04 <waldi> err, this was somewhere else
21:08:33 <jrtc27> can we just nuke generate-i18n-Index then?
21:08:51 <juliank> Anyhow, I'd think that we cou
21:09:12 * juliank wanted to press Ctrl+K muss have pressed something else
21:09:25 <waldi> anyway. do we have more?
21:09:38 <ansgar> jrtc27: Probably.  But getting too late today.
21:09:49 <jrtc27> yeah something for another day
21:09:53 <jrtc27> will comment on MR with another finding
21:10:38 <waldi> thank you all for your time
21:10:43 <waldi> #endmeeting