20:01:03 <waldi> #startmeeting
20:01:03 <MeetBot> Meeting started Fri Sep 14 20:01:03 2018 UTC.  The chair is waldi. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:03 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:01:29 <lamby> :)
20:01:51 <waldi> #topic Present? Who takes minutes?
20:02:02 <waldi> okay. first question, who's here?
20:02:38 <lamby> #info lamby is here
20:02:50 <waldi> i'm obviously here
20:02:55 <waldi> but i see noone else
20:04:46 <waldi> #topic Check action items from last meeting
20:05:00 <waldi> # lamby to send reminder-followup ping to 3425454.QfdHj6pzrc@kitterma-e6430
20:05:30 <lamby> That's re. NEW processing, right?
20:05:43 <waldi> i don't now, this mail seems to be from before my time
20:06:00 <lamby> I believe I sent/actioned that, indeed.
20:06:15 <lamby> (to ScottK, subtle ping…!)
20:06:27 * ScottK looks up.
20:06:58 * ScottK is here for once (although I may have to run off to retrieve $CHILD from school shortly)
20:07:37 <waldi> when i attended school we had to get home on our own
20:08:08 <waldi> so, done?
20:08:31 <ScottK> You probably lived closer to school (she has to stay late for an after-school activity, so the usual bus isn't an option)
20:08:34 <waldi> #done lfaraone to actually send mail about architecture inclusion
20:08:51 <waldi> ScottK: 20km or 1.5h by public transport
20:09:10 <waldi> for the first years, after that only 1h by public transport
20:09:18 <waldi> #done codesigning cron needs to be more silent
20:09:24 <waldi> #done ta to send reminder ping to draft email re. node.
20:09:26 <ScottK> No public transport available.
20:09:40 <waldi> that's a shame
20:09:43 <waldi> anyway
20:10:04 <waldi> #topic How much do we care about copyright holders in d/copyright (Scott K)
20:10:34 <waldi> ScottK: that's an old topic from you. should we skip that?
20:10:41 <ScottK> No.
20:10:51 <ScottK> It's old because I haven't been at a meeting to discuss.
20:11:00 <waldi> right
20:11:25 <ScottK> TLDR version is developers whine about how painful d/copyright is.  Can we make it less so.
20:11:41 <ScottK> Currently policy requires all copyright holders to be listed.
20:12:00 <waldi> so you would like to restrict it to cases where the license requires it?
20:12:05 <ScottK> If the policy were relaxed to not require it where the license didn't require it, would we be cool with that?
20:12:12 <ScottK> Yes.
20:12:54 <ScottK> For example, Apache 2.0 only requires it in source form.
20:13:25 <ScottK> In the source package, the original files are there, so is it really worth the pain to duplicate that in d/copyright?
20:14:35 <ScottK> Personally, I don't think we (as FTP team) should demand more of d/copyright than is required for license compliance.
20:14:47 <waldi> i agree
20:15:08 <ScottK> Policy can demand more, but if they do, I'd like to be clear where to aim the people with the torches and pitchforks.
20:16:10 <ScottK> My expectation is that if the FTP team made a clear statement of what it's requirements are, then policy would end up relaxed.
20:16:18 <lamby> Nodnod
20:16:22 <waldi> okay
20:17:17 <waldi> so we would like to relax the requirement for copyright hole´der
20:17:45 <ScottK> We should also address the question of some packages, like src:linux, getting a pass and that's not an excuse for everyone to whine they don't get an exception too.
20:18:09 <lamby> Good point
20:19:04 <ScottK> Just got the call to go get $CHILD, so I have to go.
20:19:18 <ScottK> It seems like those of use here are agreed.  We just need to work out text.
20:20:21 <waldi> isn't gpl also on the list of licenses not actually requiring list copyright holders on the binary?
20:20:25 <waldi> #agreed we would like to relax the requirement for copyright holders
20:21:29 <waldi> #topic Sources for architectures on ports (waldi)
20:21:50 <waldi> as you've seen there have been some fuss after i started to remove powerpc-only sources
20:22:22 <lamby> Can you remind us of the major points of objection?
20:22:47 <waldi> what do you mean with "objection"?
20:23:28 <lamby> What, exactly, was the "fuss" ?
20:24:31 <waldi> the people trying to handle powerpc on -ports complained that we are making there work too hard
20:24:56 <waldi> injecting sources not from the main archive seems to be a problem in the way the -ports archive is handled
20:25:39 <waldi> i don't think they ever talked to us, but the expected existing (cruft) sources to remain indefinitely
20:26:00 <lamby> okaley
20:26:47 <waldi> i asked them to actually talk to us if they want to change how we handle such cases, but they didn't manage to do that yet
20:28:22 <lamby> Ok.
20:28:44 <waldi> my question now is: would we be willing to find a solution with them, which would allow sources in the main archive without binaries of any known architecture. including NEW and the necessary dak changes
20:30:09 <lamby> Alas, this isn't my "area" so I can't really comment.
20:30:24 <lamby> I mean, how much work would it be?
20:31:26 <waldi> the dak changes would be the large part. as this needs a throw away binaries for NEW uploads feature, maybe some changes to ignore missing overrides and some code to not call them cruft
20:31:53 <waldi> we are talking about a handful of packages, most of them installer and bootloader related
20:32:11 <lamby> Hm.
20:37:03 <lamby> (Again, no real input…)
20:37:19 <waldi> okay. i don't think we can decide that now. i would just liked to get some feeling if this could work. but in the end the people wanting such thing would have to step forward
20:38:15 <lamby> I guess making them definitely aware of that (ie. them needing to do work) would be helpful, otherwise it might just get stuck in limbo
20:39:16 <waldi> yeah. i'll try to make them aware again if some mails actually show up
20:39:31 <lamby> Ah. :)
20:40:12 <lamby> Okay, I am being summoned again for dinner with parents so must dash.
20:40:12 <waldi> #topic Any other business
20:40:17 <lamby> Nothing from ,e.
20:40:19 <lamby> *from me
20:40:21 <waldi> yep
20:40:24 <waldi> #endmeeting