21:05:10 <Ganneff> #startmeeting
21:05:10 <MeetBot> Meeting started Sun May 17 21:05:10 2015 UTC.  The chair is Ganneff. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:05:10 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:05:19 <mhy> ah, ok
21:05:19 <Ganneff> #addchair mhy
21:05:20 <mhy> Ganneff: thanks
21:05:55 <mhy> #info mhy present
21:06:02 <mhy> who else is here?
21:06:03 <Ganneff> that it recognizes from who talks
21:06:06 <mhy> ah, ok
21:06:11 <ansgar> o/
21:06:16 <mhy> I haven't used this before
21:06:21 <mhy> Maulkin: are you here?
21:06:53 <Ganneff> #topic Debian FTPMaster meeting
21:06:57 <mhy> #topic Matters arising - sparc/hurd-i386
21:07:11 <mhy> the email was sent I believe, any further details, Ganneff?
21:07:29 <ansgar> There was a related thread on -devel@ which I haven't read fully yet.
21:07:44 <mhy> ansgar: I'm in the same boat, hoping Ganneff can fill us in with details
21:08:04 <ansgar> Mostly about waiting a bit until debian-ports is in a better state I think.
21:08:16 <ansgar> Though I'm not sure if sparc will move there?
21:08:17 <Ganneff> well, yes
21:08:20 <mhy> right, push to next meeting then, but we should definitely make a final decision then?
21:08:23 <Ganneff> hurd did a "release"
21:08:34 <Ganneff> and told us its so bad of us to kill em off - they are getting better.
21:08:48 <Ganneff> basically the same we heard all the tons of times before
21:08:55 <mhy> quite
21:09:02 <Ganneff> it then went into a discussion about debian-ports
21:09:15 <Ganneff> which is loaded and way understaffed
21:09:19 <mhy> right
21:09:50 <mhy> #action ansgar / mhy / Ganneff all to review debian-devel thread and deal with the issue finally at next meeting
21:09:52 <Ganneff> also, hurd people agree they dont need things like a wide mirror network that main archive offers
21:10:09 <mhy> #topic Matters arising - kfreebsd for jessie
21:10:26 <mhy> ansgar: I believe that this is mainly sorted?
21:10:47 <ansgar> Well, the suites are setup, the security updates from jessie are copied to jessie-kfreebsd.
21:11:12 <ansgar> The kfreebsd people have started working on the installer (to handle the different suite).
21:11:13 <Ganneff> interesting, seems it didnt take my #addchair?
21:11:16 <mhy> agenda is at https://ftpmaster.titanpad.com/61
21:11:21 <Ganneff> #topic Matters arising - kfreebsd for jessie
21:11:25 <mhy> Ganneff: is that why nothing is happening
21:11:26 <Ganneff> silly meetbot.
21:11:28 * ScottK pokes his head in.
21:11:40 <ansgar> Ganneff: Is it #chair or #addchair?
21:11:42 <mhy> ansgar: so, what's left ftp-side?
21:12:10 <Ganneff> #chair mhy
21:12:10 <MeetBot> Current chairs: Ganneff mhy
21:12:14 <ansgar> We still need to think about the security -> main import and the jessie-p-u -> jessie-kbsd-p-u thing.
21:12:15 <Ganneff> aha, #chair.
21:12:49 <ansgar> Might end with a policy queue and a few more changes to update-suite for that.
21:13:00 <mhy> ansgar: ok, but we can drop that from future meetings as it's in hand?
21:13:08 <ansgar> I think so.
21:13:37 <mhy> ok, I'm moving to the main agenda now
21:13:43 <mhy> #topic apophenia license
21:13:53 <ansgar> This was resolved upstream I think.
21:14:15 <ansgar> Next release is GPL-2 without extra bits (maybe +later, don't remember).
21:14:19 <mhy> I believe so, I was just reviewing #781566
21:14:28 <mhy> #agreed this has been resolved upstream - can be dropped
21:14:53 <mhy> we already did arch removals under matters arising
21:15:01 <mhy> #topic Removal of packages from security after p-u removal
21:15:05 <mhy> paultag: are you here?
21:16:09 <mhy> ok, let's skip to the new arch and come back to this if paultag arrives
21:16:15 <mhy> #topic     New architecture: mips64el
21:16:25 <mhy> ansgar: you added this to the agenda I believe
21:16:38 <Ganneff> this should be after an arch removal, but otherwise it looks fine.
21:16:45 <ansgar> Yes, we got a request from aurel32 to add mips64el.
21:16:47 <Ganneff> with the usual way of importing, ie. with own key and so
21:16:50 <ansgar> #info https://wiki.debian.org/ArchiveQualification/mips64el
21:16:54 <mhy> I don't see a problem
21:17:17 <mhy> and it's best to get new arches in early in the release cycle
21:17:26 <mhy> unlike Ganneff, I'm not that worried about dropping an arch first
21:17:27 <ansgar> I have no problem with adding it. Maybe after removing sparc or hurd, I defer that to Ganneff (with also his mirroring hat)
21:18:08 <mhy> Ganneff: are we so marginal on mirror space, if not, I'm not sure whether we should hold off
21:18:08 <jcristau> i haven't seen anyone speak up for keeping sparc, anyway?
21:18:17 <Ganneff> it adds more space, so dropping is good. especially as we seem to add .ddebs soonish too
21:18:39 <Ganneff> and hurd is just the usual "ohmygodno,wehurt" and sparc is noone speaking up
21:18:41 <ansgar> Ganneff: Well, the plan for ddeb is to have them not on the main mirror network.
21:18:42 <mhy> jcristau: hmm. in that case we should possibly consider dropping sparc sooner
21:19:03 <ansgar> The question for sparc is if someone wants to keep them at ports...
21:19:21 <Ganneff> i dont think ports is the place for sparc
21:19:32 <mhy> we don't have graveyard.debian.org do we?
21:19:33 <ScottK> Even ports needs a porter.
21:19:34 <Ganneff> even for hurd the real reason for ports doesnt fit fully
21:19:37 <jcristau> mhy: archive.d.o
21:19:44 <mhy> jcristau: indeed
21:19:54 <Ganneff> but unlike sparc, hurd IS active.
21:20:09 <mhy> Ganneff / ansgar: let's decide sparc on-list before the next meeting then?  It seems to be easier
21:20:21 <mhy> #agreed hurd-i386 deferred to next meeting, sparc to be decided RSN
21:20:26 <Ganneff> and if ports wouldnt have some requirements that make dak unfit, i think we should run it, but those "features" are meh
21:20:42 <ansgar> mhy: I thought we already agreed on dropping sparc? The last listed porter did so too...
21:20:44 <Ganneff> brb in ~5
21:21:06 <mhy> ansgar: ok, I misunderstood the discussion on -devel then
21:21:07 <ansgar> Ganneff: I think -ports could run dak, but they need some changes in their workflow.
21:21:44 <mhy> personally, I think that sparc is just *dead* and no point pulling it into ports
21:22:20 <ansgar> mhy: Well, I agree... The mailing list doesn't seem that alive either and the buildds seem to break more and more.
21:22:33 <mhy> #agreed mips64el to be bootstrapped in once sparc or hurd is gone
21:22:36 <Ganneff> huh, faster. (sorry, son woke up and sat in mddle of room, crying)
21:22:40 <mhy> ansgar: let's tackle it before the next meeting then
21:22:47 <mhy> #topic Any other business
21:22:47 <Ganneff> ansgar: if they agree, sure.
21:22:57 <mhy> for the public bit of meeting, does anyone have anything else?
21:23:28 <Ganneff> ansgar: i think it would be nice if we can make it work and have us run it (the archive technical side, not policy of it)
21:23:35 <mhy> as paultag isn't here, we'll have to push dak multi-db to the next meeting
21:23:55 * ScottK <- nothing
21:24:04 <mhy> no more business?
21:24:15 <ansgar> Ganneff: I would be fine with that, yes. It probably needs some more tools in dak (import from main archive), but that bit is something I am a bit interested for other reasons anyway.
21:24:20 <mhy> #endmeeting