19:01:41 <h01ger> #startmeeting
19:01:41 <MeetBot> Meeting started Fri Dec 18 19:01:41 2009 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:41 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:13 <h01ger> #topic 1. everybody say "hi" - agenda at http://wiki.debian.org/DebianEdu/Meeting - additions to the agenda also welcome, please notify me
19:02:20 * h01ger = Holger Levsen
19:02:27 * vagrantc = Vagrant Cascadian
19:02:34 * debalance = Philipp Huebner
19:02:45 <h01ger> i will probably have to go in 45min, but MeetBot is captable of multiple chairs now. also we should manage in short time IMO ;)
19:02:45 * OleA_ = Ole A Andreasen
19:02:48 * itais = José L. Redrejo
19:02:53 * jever = Jürgen Leibner
19:03:01 * klausade = klaus ade johnstad
19:03:45 <h01ger> #topic 2. who will write the summary?
19:04:01 <h01ger> meetbot provides logs and notes for the summary as usual
19:04:01 <MeetBot> h01ger: Error: "provides" is not a valid command.
19:04:06 <h01ger> jaja
19:04:17 <FBI> debian-edu: 3 de-build-guest committed revision 60258 to debian-edu: automatic commit after build from lenny-amd64-i386-powerpc-netinst
19:04:30 * pere = Petter Reinholdtsen
19:05:23 <h01ger> who volunteers for summary?
19:06:52 * pere can't, leaving north on sunday, and is rather busy until then.
19:07:01 <h01ger> #info we have no summary writer...
19:07:16 * h01ger suggests to proceed nonetheless... meetbot will provide something
19:07:40 <h01ger> one last try.
19:07:43 <h01ger> who volunteers for summary?
19:07:44 <h01ger> who volunteers for summary?
19:07:45 <h01ger> who volunteers for summary?
19:07:46 <h01ger> who volunteers for summary?
19:08:01 <h01ger> (shouldnt be more then 15min of work)
19:08:08 * jever volunteers for the summary
19:08:13 <h01ger> \o/
19:08:19 <h01ger> #info jever volunteers for the summary
19:08:30 <h01ger> #topic 3. status lenny
19:08:44 <h01ger> each bug should probably be covered in max. 5min and then discussed in the bug report or list
19:08:59 <h01ger> http://tinyurl.com/edulenny-releaseview-1
19:09:06 <pere> I'd say lenny-test is a lot better then the last release, and we should make a new alpha release soon.
19:09:19 <h01ger> lists 7 bugs atm. one we can ignore (updating the version), so 6 left
19:09:28 <h01ger> pere, (i agree) but thats topic #4
19:09:30 <h01ger> :)
19:09:47 <h01ger> #topic 3.1 status lenny - #1376: Removable media (like usb sticks) inserted into ltsp server show up on ltsp clients
19:10:02 <h01ger> do you agree that this bug can be fixed by documenting the issue as suggested in the bug?
19:10:16 <h01ger> i mean, a server should be in the server room, so this is a rare case...
19:10:45 <pere> did anyone try to fix it properly?
19:10:52 <h01ger> yes. danielsan.
19:11:02 <h01ger> didnt work out. itais is struggling with it too
19:11:09 <OleA_> this should not be a problem, I have to remove the USB in the middle of the installation ;)
19:11:27 <pere> not all ltsp servers will be placed in machine rooms.  some of them will be teachers machines in class rooms.
19:11:56 <h01ger> pere, thats why documenting it. but i dont think we must activily support such a use case (for us to be able to release. finally we should)
19:12:10 <h01ger> i'm happy to document and leave the bug open as p3
19:12:41 <h01ger> agreed thats good enough?
19:12:50 <h01ger> (for now/a first release)
19:12:52 <klausade> agree.
19:12:59 * pere is unsure
19:13:22 * itais is unsure too
19:13:23 <pere> any volunteer to look into the issue and try to debug the dbus rules?
19:13:43 <itais> I've tried without success , getting lost between so many layers
19:13:56 * h01ger takes this (klaus and him) as agreement still. the last meeting authorized me to set prios to enable us to release, so :-D
19:14:14 * jever agrees too
19:14:21 <pere> without any volunteer to look into the issue, reducing the severity seem like the only option.
19:14:35 <h01ger> #info documenting #1376 is enough to lower the severity of it to p3. then it shouldnt be closed but treated as p3 (and possibly fixed)
19:14:54 <h01ger> #topic 3.1 status lenny - #1383: usernames are caseinsensitive during login
19:15:31 <pere> need to be fixed, arthur said he was going to upload to lenny this weekend.
19:15:32 <h01ger> for this bug we have a patch, and SRM agreed to let it in lenny. if this doesnt happen til xmas, i propose an upload to lenny-test, based on the patch from the debian-bug
19:15:52 <h01ger> agreed + next?
19:15:57 <pere> h01ger: I would propose a upload to lenny test imediately, to test if the fix work.
19:16:04 <h01ger> (arthur is the debian maintainer of the affected package)
19:16:23 <h01ger> pere, fine by me, if you choose a version number which is defnitly lower as the one going to s-p-u soon
19:16:26 <pere> it might take a while after his upload before the package show up in lenny.
19:16:40 <h01ger> i would prefer to reupload his upload to lenny-test, thats all
19:16:55 <pere> yeah, me too.
19:16:58 * debalance agrees to to both ideas
19:17:13 <h01ger> #info 1383: for this bug we have a patch, and SRM agreed to let it in lenny. if this doesnt happen til xmas, i propose an upload to lenny-test, based on the patch from the debian-bug
19:17:44 <h01ger> #info maybe  upload to lenny test imediately, to test if the fix work.  prefer to reupload his upload to lenny-test
19:17:59 <h01ger> #topic 3.1 status lenny - #1398: DHCP server stops unexpectedly after less then 24 hours
19:18:14 <pere> vagrantc: awk isn't available in d-i, btw.
19:18:16 <h01ger> pere, did you find the issue to make "dynamic" not crash?
19:18:40 <pere> h01ger: I have not tried to fix it, only tried to understand it so far.
19:18:50 <h01ger> ah
19:18:58 <itais> I can promise to take a look trying to backport the fix from dhcp 4.1 to lenny, but: a) not sure it's possible, b) probably it won't be accepted in Lenny
19:19:18 <pere> three options: fix lenny, backport our version (if itais is right that it is fixed in unstable), or switch to static and rewrite lwat to restart dhcpd when ldap change)
19:19:21 <itais> so, changing dhcp-to-ldap connection to static is the best fix for lenny
19:19:24 <h01ger> itais, it should be accepted. that bug is important and important bugfixes (if non-.intrusive) are fine for lenny
19:19:30 <itais> pere: it's not fixed in unstable
19:19:34 <pere> itais: oh.
19:19:35 <itais> I have the patch to fix it in unstable
19:19:44 <itais> but haven't prepared its debianization yet
19:19:44 <pere> itais: submit to bts. :)
19:19:53 <h01ger> itais, yes, please submit to bts
19:19:54 <itais> that's on my vacation list
19:20:03 <itais> to Debian bts?
19:20:06 <pere> the problem only happen with little used dhcpd. :)
19:20:08 <itais> the link is already there
19:20:11 <pere> itais: yes.
19:20:20 <itais> little used dhcpd?
19:20:29 <h01ger> #info fix lenny, backport our version (if itais is right that it is fixed in unstable), or switch to static and rewrite lwat to restart dhcpd when ldap change)
19:20:34 <h01ger> who is working on this?
19:20:45 <pere> itais: yes.  if the ldap connection is idle for a long time, the server disconnect and the next time dhcpd try to talk to ldap, it dies with SIGPIPE
19:21:03 <itais> I vote to switch to static , and not depending on the fix, and on the fix being accepted in lenny
19:21:06 <OleA_> I changed to static, after this the dhcp has not stopped. Before this dhcp stopet every night
19:21:12 <itais> pere: understood
19:21:27 <itais> how long does it need to be idle?
19:21:34 <pere> I agree that switching to static and reloading dhcpd when lwat changes LDAP is the short term fix. volunteers?
19:21:42 <pere> itais: not sure.  over night is enough.
19:21:47 <h01ger> #info swithcing to static is safe and working. needs a mechanism to restart dhcpd though. (which can be done like the cronjob checking for samba(?) changes and restarting samba
19:21:51 <itais> because a cron could check it and restart the daemon if it's idle for more than, let's say 4 hours
19:21:51 <h01ger> was it samba?
19:21:53 <h01ger> sep, ^
19:21:58 <h01ger> sepski, ^
19:22:26 <pere> or perhaps a cron job to ask for IP addresses often, to make sure the ldap connection to not time out... :)
19:22:41 <h01ger> #info noone is activly looking into fix this atm :-( if you start doing so, please inform #1398
19:22:51 <h01ger> pere, ouch. /me closes eyes :-D
19:22:58 <h01ger> (could work though, but)
19:23:12 <h01ger> next topic?
19:23:15 <itais> looking at daemon.log to see how long is since the last dhcp activity is not hard
19:23:22 <debalance> we should decide on one way to go, so it's clear for the peson willing to fix it
19:23:29 <itais> and restart it if it's more than 4 hours
19:23:45 <pere> I would prefer keeping dynamic to make sure ldap changes are active imediately.
19:23:45 * h01ger proposes static and restart if less then 5min
19:24:02 <h01ger> cant we see that the config changed?
19:24:04 <itais> pere: anyway you have to restart powerdns after using lwat, to make dns changes active
19:24:13 <h01ger> itais, oh
19:24:26 <pere> itais: yeah, I would prefer powerdns to be dynamic too. :)
19:24:26 <itais> powerdns doensn't even have a "dynamic" option
19:24:37 <pere> itais: how is powerdns restarted when lwat change LDAP?
19:24:48 <itais> manually :)
19:25:03 <h01ger> #info if there is a cronjob (checking for changes and) restarting dhcpd, dnsd could also be restarted
19:25:14 <debalance> and should be
19:25:18 <OleA_> I had 2 laptops asking for IP ovet the night , the DHCP stopped anyway
19:25:18 <h01ger> #info restarting need of dnsd needs to be documented
19:26:07 <h01ger> #info holger volunteers to document the need to restart if pinged by the summary :)
19:26:09 <itais> well, I'm going to work on it after thursday, when schools close because of the christmas hollidays
19:26:36 <pere> ok, lets fix restarting of powerdns and dhcpd and switch to static for lenny.
19:26:36 <h01ger> #info itais will start looking at it in a week
19:26:44 <h01ger> #topic 3.1 status lenny - #1404: Gnash are filling up .xsession-errors
19:27:05 <pere> I've looked into this.
19:27:10 <h01ger> #info 1404 waits for SRM approval to let it into lenny, else we have a fixed package in lenny-test NEW
19:27:15 <h01ger> next?#
19:27:19 <pere> upgrading to the sid version would work too.
19:27:26 <h01ger> can of worms
19:27:30 <h01ger> security support etc
19:27:31 <pere> would solve more flash sites, but perhaps not worth it.
19:27:35 <pere> yeah.
19:27:52 <h01ger> #topic 3.1 status lenny - #1270: lwat-ticket #14: samba groupmaps are missing after installation
19:28:02 <h01ger> AFAIK stalled
19:28:07 <pere> if someone would take the resposibility to update gnash, I would be fine with it.  without a volunteer for that. no can do.
19:28:22 <h01ger> update+maintain gnash
19:28:33 <pere> h01ger: exactly.
19:28:52 <h01ger> anybody anything to say about #1270?
19:29:15 <pere> I have not looked at it, and hope someone else with windows and samba experience take care of it.
19:29:33 <h01ger> danielsan, sep?
19:29:55 <h01ger> #1270 is stalled, nobody is looking into it, needs someone with windows and samba experience
19:30:00 <jever> I think lwat should care about and upstream should provide fix
19:30:21 <klausade> about #1270, samba works fine (for me) even with this bug. but, I'm no expert.
19:30:54 <h01ger> klausade, are you using self created groups?
19:31:32 <klausade> h01ger: just using stuff out--of-the box, works without me doing anythinhg.
19:31:33 <debalance> or any groups at all? as long as only $home is used, that bug shouldn't matter
19:31:37 <OleA_> are there workarounds for this problem?
19:32:00 <h01ger> so 1270 can possibly be downgraded to p3?
19:32:05 <jever> #1270 shows, that lwat does not handle all tasks wich should be handled by such a tool, IMO
19:32:24 <h01ger> jever, thats undoubted ;)
19:32:29 <jever> downgrade to P3 is ok
19:32:34 <klausade> debalance: $HOME and some shared-dirs in /skole/tjener/home0/shared is used.
19:32:44 * pere have no opinion how important samba stuff is.
19:32:55 * klausade can't see the "problem".
19:33:02 <debalance> for german schools it's quite important
19:33:07 <h01ger> klausade, debalance, could you maybe upgrade the bug with info from this discussion and downgrade it to p3?
19:33:18 <klausade> debalance: please add info about the "problem".
19:33:22 <OleA_> i guess it's importan for my school as well
19:33:23 <h01ger> debalance, we could fix it in a pointrelease always and afaik german schools use cipux anyway
19:33:27 <klausade> educate me
19:33:36 <debalance> klausade, h01ger: haven't encountered the problem yet
19:33:48 <h01ger> then i say downgrade to p3 is ok
19:34:13 * debalance agrees, since by default only $home is used
19:34:16 <pere> might have to upgrade after the next alpha release, if more feedback is provided.
19:34:25 <h01ger> #info agreed to downgrade to p3, if you disagree and can explain why #1270 should be p2 please explain in the bug
19:34:30 <klausade> so, one can't see the problem, and one haven't encountered the problem yet (the blind and the deaf ...:-)
19:34:57 <h01ger> downgraded
19:35:16 <h01ger> #topic 3.1 status lenny - #1370 sound should work on thin clients
19:35:26 <debalance> h01ger: don't mention the curel c*** word
19:36:06 <pere> I guess we agree what need to work.
19:36:07 <h01ger> #info thinclients use esd, not pulseaudio. so some apps dont work. we should switch to PA in the long term (or now, if needed), if sound in the browser works as it is (this needs testing!!!), downgrading to p3 is ok
19:36:14 <h01ger> debalance, *lalala*
19:36:19 <itais> no, thinclients don't use esd
19:36:38 <pere> I actually believe we have switched to pulseaudio, but the switch is incomplete.
19:36:44 <itais> esd is not set up in ltsp, there's still some legacy scripts that setup some envirnoment variables, but it's not used
19:36:49 <vagrantc> what?!
19:36:49 <h01ger> itais, http://bugs.skolelinux.org/show_bug.cgi?id=1370#c5
19:36:58 <h01ger> vagrantc, ^
19:37:07 <h01ger> and #c6 too
19:37:15 <itais> h01ger: I've read the bug, and I disagree with some of the things written there ;)
19:37:30 <itais> the problem is that some applications are not pulseaudio-ready in lenny
19:37:32 <h01ger> itais, please disagree in the bug
19:37:41 <debalance> actually, ltsp-build-client sets up everything needed if the thin-client has a compatible soundcard
19:37:59 <h01ger> debalance, please update the bug :-)
19:38:04 * h01ger is afk for 2min, brb
19:38:10 <itais> like audacity, rosegarden, etc. for those apps, there's a workaround, adding pulseaudio emulation in the launcher
19:38:19 <vagrantc> unless debian-edu is doing something unusual, pulseaudio is enabled by default. esd is only an undesired compatibility layer.
19:38:20 <itais> but any application supporting pulseaudio works perfectly
19:38:49 <pere> I tried to remove the kde config, but no sound worked in kde then.
19:39:15 <debalance> h01ger: it's already in the bug, comment 2 from itais
19:39:22 <pere> itais: why isn't /dev/dsp working for thin clients?  I thought pulseaudio provided compatilibity layer.
19:39:24 * vagrantc suggests using the pulseaudio to alsa plugins
19:40:01 <itais> pere: don't know, I've never checked it, but launching the applications using "padsp audacity" they work when they're not pulseaudio-ready
19:40:22 <pere> If I understand this correctly, LTSP clients are already using pulseaudio, and we are just missing some config on the server to make sure more applications use pulseaudio or compat layers.
19:40:23 <h01ger> back
19:40:25 <itais> I think that's the way pulsaudio provides a fake /dev/dsp
19:40:56 <h01ger> who can update the bug / fix the problem?
19:40:57 <pere> itais: any way to do that without changing the desktop files for a lot of packages?
19:41:04 <itais> pere: we're just using some applications that are not ready to use pulseaudio, exactly like when we switched from oss to alsa
19:41:09 <vagrantc> check /usr/share/doc/ltsp-server/README.Debian.sound
19:41:19 <h01ger> #info check /usr/share/doc/ltsp-server/README.Debian.sound
19:41:22 <itais> but there shouldn't be a lot of packages, I only know audacity
19:41:36 <pere> itais: gtick did not work, and kde did not play any sound at all.
19:41:47 <itais> for the rest, it works. My memory might fail, but I recall rosegarden has an option in its menu to use pulseaudio
19:41:50 <pere> itais: did you try rosegarden?
19:42:13 <itais> for kde I don't know
19:42:26 <debalance> pere: I believe I had kde play sound, but I will check again 2morrow
19:42:51 <itais> in the worst case you'll need a launcher for jackd, audacity and jackd. Or switching back to esd
19:43:06 <itais> but that's not a good idea
19:43:28 <h01ger> next?
19:43:29 <pere> I believe kde, gcompris, gnash and mozilla-plugin in browser should work out of the box.
19:43:30 <itais> m
19:43:51 <itais> maybe there's some way to activate padsp permanently, I don't know
19:44:02 <pere> itais debalance: lets work together to find a solution out of the box in kde.
19:44:03 <itais> gcompris and gnash work for me
19:44:22 <pere> gcompris worked for me, I was unable to test gnash.
19:44:34 * h01ger suggest next topic and to discuss this later or in the bug
19:44:39 <pere> yeah.
19:44:47 <debalance> agree
19:44:53 <itais> ok, let's do it in the bug
19:45:00 <h01ger> #topic 4. RC1 for xmas? (alpha2 before..)?
19:45:11 <h01ger> i would propose to do alpha2 now
19:45:18 * pere want alpha2 released immedately.
19:45:39 <h01ger> #agree alpha2 should be released NOW
19:45:58 <h01ger> i can mv packages from lenny-test to lenny now/ish (or after the meeting)
19:46:00 <klausade> agree.
19:46:05 <h01ger> can probably stay the next 15min too :)
19:46:10 <pere> given the time of year, I suspect we will get limited testing before new years eve.
19:46:34 <h01ger> i would like rc1 on xmas, to then also mail d-d-a (as said in the october meeting...) to ask for more testers and translators
19:46:38 <pere> btw, why do we have differences in hal and consolekit between lenny and lenny-test?
19:46:55 <h01ger> iirc that was for #1270
19:46:56 <klausade> pere: for me, these days are the best for testing.
19:47:12 <pere> klausade: sure, but I believe we are the minority. :)
19:47:13 <OleA_> I'll do some testing the next days :)
19:47:24 <h01ger> pere, we dont have that diff (between our lenny and lenny-tzest)
19:47:31 <pere> we need to document how to change pxe setup to get diskless workstation by default.
19:47:40 <h01ger> pere, i think quite some people have (some) time then..
19:47:57 <h01ger> pere, thats on my list for the weekend (document pxe setup)
19:48:00 <pere> h01ger: oh.  then I misread http://ftp.skolelinux.no/skolelinux/lenny_needs_love.html
19:48:10 <h01ger> pere, "Packages newer in debian-edu/lenny than in debian/lenny"
19:48:22 <h01ger> and "Packages newer in debian-edu/lenny-test than in debian/lenny"
19:48:35 * jever will test the next days too
19:48:46 <pere> h01ger: I suspect we should adjust pxeinstall to write the default menu in debian-edu/, and write a few more files to use for diskless workstations and thin clients.
19:49:08 <pere> then the documentation would be easier, telling people to just switch a symlink.
19:49:11 <h01ger> sep, danielsan: can you do a alpha2 "now"?
19:49:14 <h01ger> pere, right
19:49:36 <OleA_> yes we need need to document how to change pxe setup to get diskless workstation by default.
19:50:26 <h01ger> #agreed we will try to get rc1 ready ASAP.
19:50:32 <pere> anyway, that is for alpha3. :)
19:50:43 <h01ger> #info that probably requeires putting the known issues into the release notes
19:50:51 <h01ger> next topic?
19:51:45 * h01ger moved the packages from lenny-test to lenny now. please test the soon builded dvd+cd
19:52:00 <h01ger> #topic 5. any other business? (like website)
19:52:38 <pere> would be nice if www.skolelinux.org had the donate request more prominently.  we need donations to keep the project going.
19:53:02 <h01ger> pere, add it to wiki.debian.org/DebianEdu/www/ToDo
19:53:17 <h01ger> (and/or get a login and do it yourself :)
19:53:22 <OleA_> we'll add a donate button to the webpages
19:53:43 <pere> h01ger: not going to happen any time soon.  will spend my time on the distro.
19:53:56 <h01ger> pere, sounds great to me :)
19:54:21 <h01ger> #topic 6. next meeting - next tuesday?!? :)
19:54:37 <h01ger> (same time?)
19:54:48 <debalance> fine for me
19:54:54 <h01ger> i would like two more meetings this year and get into a sprint :-)
19:55:00 * pere might be busy the next two weeks, do not know yet.
19:55:25 <pere> visiting my parents for christmas.
19:55:54 <vagrantc> by next, you mean which date?
19:55:59 <h01ger> will/would someone be here next tuesday? (or monday or wednesday?)
19:56:17 <h01ger> vagrantc, december 22nd
19:56:51 <vagrantc> tuesday's no good for me.
19:56:58 <vagrantc> but don't hold up a meeting on my account
19:57:25 <h01ger> we need participants other than only me :)
19:58:18 <h01ger> hmmm
19:58:20 <itais> I can on tuesday, we can be two ;)
19:59:11 <h01ger> itais, can you also on wednesday or monday, so that we get vagrant in? i'd prefer monday, wednesday wont probably work well for me
19:59:12 <vagrantc> monday 19:00 UTC probably works for me
19:59:56 <OleA_> I'll be around, but I guess I wount be that helpfull. (I can say OK or "please explain")
20:00:11 <vagrantc> though admittedly, most of the remaining issues are outside of what i'm likely to work on
20:00:19 <itais> I can't on mondays
20:00:21 <h01ger> vagrantc, #1370? ;)
20:00:40 * h01ger will set up a doodle poll then
20:00:43 * jever is like OleA_ with being around :)
20:00:50 <vagrantc> h01ger: i dread fighting with KDE's sound system
20:00:59 <h01ger> ok? (doodle and decide on sunday..)
20:01:25 <pere> why not.
20:01:37 <h01ger> #agreed next meeting date shall be decided by a doodle poll, holger will set it up, announce tomorrow and we'll decide on sunday. the meeting shall be either monday, tuesday or wednesday
20:01:45 <h01ger> thank you all for attending!
20:01:48 <h01ger> #endmeeting