19:00:42 <sepski> #startmeeting
19:00:42 <MeetBot> Meeting started Thu Oct 15 19:00:42 2009 UTC.  The chair is sepski. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:42 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:50 <sepski> #topic Debian-Edu Meeting in progress | Agenda at http://wiki.debian.org/DebianEdu/Meeting | State your presence with /me = RealName
19:00:56 * sepski = Ronny Aasen
19:00:58 * danielsan = Daniel Hess
19:01:13 * an3as = Andreas Tille
19:01:30 * klausade klaus ade johnstad
19:02:13 * jever = Jürgen Leibner
19:03:23 * h01ger = Holger Levsen
19:03:32 <h01ger> klausade, yes, just finished dessert :)
19:03:39 <h01ger> still here though :)
19:04:43 <sepski> #topic Debian-Edu Meeting in progress | Agenda at http://wiki.debian.org/DebianEdu/Meeting | Topic 1: Who moderates the meeting and who writes the summary?
19:04:44 * h01ger added timeline to the agenda
19:04:53 <sepski> i belive i does moderation
19:05:03 * h01ger will write summary and thinks sepski does moderation
19:05:15 <sepski> amazing :)
19:05:16 <h01ger> new meetbot also has a feature so that many people can chair
19:05:27 <sepski> #topic Debian-Edu Meeting in progress | Agenda at http://wiki.debian.org/DebianEdu/Meeting | Topic 2: Lenny status http://wiki.debian.org/DebianEdu/Status/Lenny
19:06:12 <danielsan> we have synced (almost) all packages from lenny-test to lenny
19:06:17 <sepski> I have not tested lenny in a while. anyone with recent experience ?
19:06:18 <h01ger> is lenny-test in a state we could base an alpha release on?
19:06:28 <sepski> #link http://wiki.debian.org/DebianEdu/Status/Lenny
19:06:49 <danielsan> my tests with the netinst still has the problems with popup messages about removable devices popup for remote users
19:07:04 <h01ger> white, can you please add "lenny" as a version to our bugzilla? (or should i open a rt ticket?)
19:07:04 <danielsan> which was fixed in lenny-test, ...
19:07:26 <h01ger> danielsan, and you still have the prob in lenny or with netinst in lenny-test?
19:07:36 <danielsan> the ltsp/pxeinstall stuff is still broken for the dvd, but I would thing we could fix that later
19:07:50 <danielsan> h01ger: lenny
19:07:54 <h01ger> isnt that #1374?
19:08:07 <danielsan> I think it once worked in lenny-test or I've gone mad
19:08:10 <sepski> h01ger, please make a rt ticket white is not present.
19:08:18 <h01ger> sepski, will do
19:08:31 <h01ger> #info holger will make a rt ticket to add "lenny" as a version to our bugzilla
19:08:41 <klausade> I install regulary using a netinst image from July ...Because I know that cd is a "good" one. Could we have an RC/beta release soon?
19:08:44 <danielsan> h01ger: no I never had that (1374) problem :)
19:09:03 <h01ger> danielsan, interesting. is there a bug about "your" problem?
19:09:05 <danielsan> about 95% of netinst installations are ok (beside that popup thing)
19:09:25 <danielsan> h01ger: it's one of the recently closed
19:09:31 <klausade> is killer gone from the cd/dvd now?
19:09:40 <h01ger> danielsan, i wonder if this is still the issue we saw with etch. the apache of ftp.s.o not serving all requests...
19:09:43 <danielsan> just finished my second testinstall to test if I've gone mad :)
19:09:49 <h01ger> klausade, i dont think so
19:09:56 <h01ger> klausade, trhats #1373
19:10:15 <danielsan> h01ger: maybe, but what is more of a problem is, that dvd installs have more problems
19:10:24 <klausade> h01ger: it should. i installed a server yesterday, and forgott to remove killer, and 30 users got logged out ..
19:10:24 <h01ger> klausade, i'd support removing it, but others probably dont. Ralf G. has contributed info about the cause of the problem
19:10:32 <danielsan> there one out of two testinstalls had problems for me
19:10:44 <sepski> if the installation routine goes thru to a complete system that is somewhat workable. we can do a rc even if there are known bugs it's interesting to discover new ones
19:10:45 <danielsan> and jever reported problems too
19:11:17 <jever> yes, but I investigated not that deep
19:11:20 * pere = Petter Reinholdtsen
19:11:31 <h01ger> shall we raise all problems which block installation as severity p1?
19:11:33 <danielsan> sepski: /me would like to do a dvd testinstall on real hardware later
19:11:53 <sepski> h01ger, i would say that was a good idea
19:12:03 * danielsan would thing netinst would be testrelease releaseable
19:12:21 <h01ger> another problem is that appearantly usplash is causing installations "to not work" on virtualobx...
19:12:22 <danielsan> but the dvd should work too
19:12:27 <h01ger> danielsan, yes
19:12:29 <sepski> we can ofcourse do a rc of the netinstall only
19:12:42 <sepski> to get feedback
19:12:43 <h01ger> sepski, no. i think we shouldnt. or hmmm
19:12:55 <h01ger> sepski, i'd call that an alpha
19:12:56 <pere> did anyone investigate the broken dhcpd and dns server with my dvd install?
19:13:02 <jever> netinstall is a time eating thing
19:13:03 <sepski> there are so many things that need to work deeper into the system that getting more testing is important
19:13:03 <h01ger> which is also good to have...
19:13:10 <sepski> h01ger, yeah :)
19:13:36 <jever> pere: no, never had that problem
19:13:37 <sepski> pere i looked at them for a few sec but didn't see anything screamingly obvious
19:13:43 <h01ger> pere, i dont really follow stuff only on the list. bugzilla has enough issues to tackle :) and its easier to track
19:13:52 <danielsan> ok, maybe do a test release with netinst only asap and fix dvd for rc1 then?
19:14:17 <klausade> h01ger: i think i've seen usplash to casue problems with single-user  (recovery) boot. the screen was just black, with a white cursor up in the corner.
19:14:17 <danielsan> in anyway the release mail needs some love
19:14:20 <danielsan> #link http://wiki.debian.org/DebianEdu/ReleaseNotes
19:14:21 <pere> ok, I'll stop publishing test logs then.
19:14:52 <h01ger> pere, file bugs
19:15:09 <h01ger> then we can merge bugs and your work doesnt get lost
19:15:23 <pere> h01ger: do not have time.  barely had time to copy the logs to a public space.  if no-one looks at them, I'll save me the time.
19:15:25 <danielsan> pere: I did have a short look, but I was not realy sure why dhcp was not there
19:15:37 <h01ger> klausade, file bugs too. (about usplash)
19:16:07 <danielsan> an other question: who can copy the images for test/rc releases?
19:16:10 <h01ger> pere, not filing bugs costs everybody time with tracking...
19:16:29 <h01ger> danielsan, i think you should be (made) able to do so
19:16:37 <sepski> i can do a alpha release of netinstall.
19:16:57 <h01ger> danielsan, and drift people are here who can give you access to do so...
19:17:00 <danielsan> alpha = test release?
19:17:05 <h01ger> yes
19:17:06 <h01ger> alpha1
19:17:09 <pere> h01ger: either one want test reports and take what people have time to submit, or one do not.
19:17:10 <h01ger> even
19:17:14 <sepski> yeah we'll call them rc's when dvd is also working
19:17:28 <klausade> sepski: yes please, and make a corresponding entry for it in bugzilla.
19:17:51 <sepski> klausade,  i would... if someone could teach me how
19:18:10 <danielsan> ok, than we need to adopt the release mail to say that we only have a multi arch netinst cd
19:19:04 <danielsan> and add a note about the spooky popups are already known :)
19:19:17 <h01ger> pere, i dont want more reports. i want to release our lenny before debian squeeze is released. so i strictly want to go by the bugzilla list. critical stuff will be there and if "fancy" stuff gets lost somewhere, i honestly dont care. (and no, i dont think the stuff you reported is "fancy", its definitly critical. but for following up reasons, i want it in the bts)
19:19:39 <h01ger> we have >10 p2 issues...
19:19:47 * jever would like to have a separate rsync module from which to rsync the alpha1
19:19:50 <danielsan> did anyone had problems with the netinst recently?
19:20:03 <jever> yes
19:20:23 <jever> I could not made it use my own mirrors or proxy
19:20:26 <danielsan> jever: oh, ok I thought this was about the dvd
19:20:47 <danielsan> ah, ok, this one I remember :)
19:21:38 <jever> see for that point 5 of the agenda
19:22:07 <sepski> jever, i am not sure i understand the problem with using the skolelinux-cd module ?
19:22:34 <danielsan> ok, than let us release a netinst only alpha0 release today
19:22:43 <h01ger> \o/
19:23:08 * danielsan would copy the images himself, if someone would give him access and tell him how to do
19:23:09 <h01ger> we need to get moving and on speed again, /me thinks. thats why i'm pushing :)
19:23:10 <sepski> done with this item ?
19:23:12 <jever> sepski: I'm mostly confused finding the right iso
19:23:57 <danielsan> jever: there will/should be a special place for the test/alpha0 relase
19:23:59 <h01ger> what do you think of adding danielsan to the unix group which can copy images and tag releases?
19:24:20 * h01ger is in favor :)
19:24:21 <jever> danielsan: I hope so :)
19:24:58 <danielsan> jever: the normal place is a moving target anyway
19:25:10 <jever> :)
19:25:21 <danielsan> and we do test release to make people able to test the same thing
19:25:45 <sepski> h01ger, good idea i think
19:25:57 <h01ger> sepski, can you do it then? :)
19:26:42 <sepski> h01ger, yeah but i will forget.
19:26:51 <sepski> danielsan, mail drift@ about it please so i get remineded :)
19:26:54 <sepski> next item ?
19:27:02 <danielsan> sepski: ok, thanks
19:27:11 <h01ger> next, yes. (finish in 34min?)
19:27:13 <sepski> #topic Debian-Edu Meeting in progress | Agenda at http://wiki.debian.org/DebianEdu/Meeting | Topic 3: Gathering in Oslo 30 oct  http://friprogramvareiskolen.no/Gathering/2009-10-30-01-Oslo
19:27:14 <pere> I can do it right now.  www group, right?
19:27:21 <sepski> pere yes please do
19:27:42 <h01ger> regarding the timeline... see the thread on the list... i have three basic ideas with it:
19:28:09 <h01ger> 1. agree on some timeline with an somewhat ambitious aim (ie mid november), so that we make it by december 31st ;) :-D
19:28:28 <jever> which year?
19:28:39 <h01ger> 2. publish the ambitious timeline on debian-devel-announce and call for translations of the manual and for help to fix #311188 for squeeze
19:28:43 <h01ger> jever, 2009
19:28:54 <jever> oh, ok. ;-)
19:29:06 <pere> danielsan: you should have access now.
19:29:09 <h01ger> 3. find agreement that we do a almost perfect release now and fix the fancy stuff in a pointrelease 2-3 months later
19:29:25 <h01ger> (now = mid november...)
19:29:43 <danielsan> pere: thanks! On which machine are the images?
19:29:44 <h01ger> perfect is the enemy of very good
19:30:17 <h01ger> so i would suggest to really only tackle p2 bugs and move some bugs to p3 and fix some p2 bugs by removing functioniality / not implementing new features
19:30:26 <h01ger> IMO if we dont release soon, we become obsolete
19:30:34 <pere> danielsan: a.s.n.
19:30:43 <danielsan> pere: thanks
19:30:53 <sepski> h01ger, very true
19:31:00 <h01ger> danielsan, which really is a.skolelinux.no. iirc it doesnt resolve as admin.s.n
19:31:28 <h01ger> what do other people think about the timeline and reasoning?
19:31:33 <h01ger> (and action ;)
19:32:03 <sepski> h01ger, i think it's ambitious, but there is no other way to do it. you are very correct in that we are begining to become obsolete
19:32:37 * jever thinks that we should be as fast as possible ...
19:33:05 <h01ger> some schools in germany are doing deployments based on debian lenny and debian edu lenny-test already anyway, using some custom+fragile howtos...
19:33:26 <h01ger> (some others are probably using frozen snapshots like extremadura does)
19:33:34 <sepski> h01ger, several in norway as well
19:33:35 <danielsan> at least for the point release we should not wait 3 month if we have enough bugs fixed, ...
19:33:55 <h01ger> danielsan, absolutly. i'm very very fine with a pointrelease per month ;)
19:34:10 <h01ger> (but i doubt we have the power - so every 2 months is also great)
19:34:13 <pere> every week is fine. :)
19:34:16 <h01ger> but whatever. first release
19:34:26 <danielsan> right :)
19:34:44 <pere> just do not put much effort into a test release.  cp images, send email.  no more, no less.
19:34:53 <jever> release early and often,yes?
19:34:57 * h01ger volunteers to write the mail to d-d-a and to (somewhat) aggressivly deal with bugs by downgrading etc...
19:35:04 <h01ger> jever, yup :)
19:35:12 <sepski> the main issue is to get a more stable image to test with.
19:35:25 <sepski> h01ger, good
19:35:29 * h01ger also hopes to get more developers (in the long/medium run) with this call for manual translations :)
19:35:48 <sepski> i can do a rc/beta/alpha on short notice if we have a mail semi redy in the wiki,
19:35:49 <h01ger> sepski, i think this alpha0-netinst-only is a good step in that direction :)
19:36:04 <sepski> hope we dont need >46 rc's like  woody :)
19:36:14 <h01ger> sepski, can you write a mail to the list, announcing a wiki-page where we can draft such a mail?
19:36:17 <h01ger> sepski, ouch :)
19:36:58 <sepski> h01ger, ack
19:37:06 <jever> rc32 was my entry point :)
19:37:28 <danielsan> are we still talking about the timeline?
19:37:49 <jever> yes
19:37:52 * h01ger thinks we are done, assuming people present agree
19:37:53 <sepski> h01ger, you wrote the timeline and nobody else is stepping up as RM so yes you get unlimited powers in this matter :)
19:38:10 * h01ger hides^wgrins^wcheers
19:38:17 <sepski> the topic does say gathering tho....
19:38:18 <h01ger> hopefully i can keep smiling :)
19:38:29 <h01ger> sepski, thats next, afaics
19:38:46 <sepski> h01ger, you have been in editing after i loaded the wiki.
19:38:51 <h01ger> ah
19:39:02 <sepski> thanks for throwing me off track with the timeline :)
19:39:07 <h01ger> :)
19:39:14 <sepski> ok gathering in oslo.
19:39:15 <h01ger> so about the oslo gathering...
19:39:25 <danielsan> sepski: h01ger has to write the summary, ...
19:39:26 <sepski> hope you all saw my email about accommodations ?
19:39:33 * h01ger wonders if k4x is here as his name is on the agenda... :)
19:40:17 <jever> sepski: yes
19:40:22 <sepski> #link http://lists.debian.org/debian-edu/2009/10/msg00076.html
19:40:26 <klausade> i pinged him without an answer in #skolelinux.de a few hours ago
19:41:07 <h01ger> so what else to say about the gathering?
19:41:40 <h01ger> we will have test hw, a test release (whether alpha or rc), nice people, nice food and beer, snow? :)
19:42:02 <jever> too many Germans there ... ;-)
19:42:34 <h01ger> next topic?
19:42:39 <danielsan> jever: maybe if we talk english nobody notice?
19:42:54 <sepski> if people want to work for Frisk   they should all talk to klausade :) the board is in dire need of capable personell
19:42:55 <jever> danielsan: let us try :)
19:43:00 <h01ger> we dont have to fill an hour and i could go back drinking red wine with my dinner hosts ;)
19:43:26 <jever> so next please
19:43:34 <sepski> #topic Debian-Edu Meeting in progress | Agenda at http://wiki.debian.org/DebianEdu/Meeting | Topic 4: Certification
19:43:35 <h01ger> danielsan, si. tenemos probar eso o hablamos castellano ;)
19:43:49 <sepski> Who wrote this item ?
19:43:57 <danielsan> h01ger: �vale!
19:44:06 <jever> sepski: k4x
19:44:14 <jever> so go ahead
19:44:33 * h01ger guesses this is about the certification they are introducing in rheinland-pfalz (=state in germany)
19:44:41 <klausade> k4x: has to step up now, or step down.
19:44:47 <h01ger> so if k4x isnt here, next
19:44:57 <sepski> #topic Debian-Edu Meeting in progress | Agenda at http://wiki.debian.org/DebianEdu/Meeting | Topic 5: other business?
19:44:58 <h01ger> (or anybody else who knows more)
19:45:08 <sepski> jever, :
19:45:16 <sepski> you had one
19:45:19 <h01ger> jever wrote: Does someone know, where one can force the debian-edu-installer to use a local mirror and/or proxy like the debian-installer does with fetching the values via dhcp?
19:45:43 * danielsan was unsuccessful so far
19:45:45 <pere> I believe one can force it to use a proxy at least.
19:45:59 <sepski> jever, boot with expert mode ? or preseed the values on the boot line
19:46:04 <h01ger> a transparent proxy could rewrite all urls ;)
19:46:07 <danielsan> maybe using a transparent proxy and squidguard may work, ...
19:46:14 <jever> nothing worked
19:46:29 <h01ger> we had such a setup at debconf8+9 but i wasnt involved in the details
19:46:36 <jever> the d-i does all well, not the d-e-i
19:46:38 <danielsan> h01ger: you are faster, even if you drink red wine :)
19:46:43 <sepski> all of the above should work...
19:46:58 <sepski> but is this a item for the meeting ? more for the bts i belive..
19:47:30 <pere> jever: you can use url=http://location/of/preseed/file, and put a proxy setting in there.
19:47:40 <h01ger> danielsan, i enjoy responsible ;)
19:47:56 <jever> it would be great to find a person here who kows how install of debian edu realy works ...
19:48:11 <h01ger> jever, if you find out, please add it to the manual ;)
19:48:27 <sepski> it's made by different people dont know if a single person have the whole picture any more :)
19:48:32 <jever> pere: yes, but it does not work with our installer, only with d-i original
19:48:51 <h01ger> jever, appearantly i have access to a howto. ping me tomorrow and mention cabalutils please. (/me hates the name but thats the name of that specific doc...)
19:48:52 <pere> jever: really?  I have used it with our installer.
19:49:09 <h01ger> (for transparent proxy which rewrites urls)
19:49:16 <pere> jever: the pxe install is set up that way to use the debian edu proxy.
19:49:51 <jever> I can preseed the d-i per dhcp and it does, our does not
19:50:15 <pere> jever: as far as I know, our d-i modules do not touch the mirror stuff.
19:50:26 <sepski> jever, what version d-i ?
19:50:31 <sepski> lenny ?
19:50:33 <jever> sepski: lenny
19:50:58 <sepski> that was strange. put as much detail in a bug report so we can try to recreate
19:51:15 <jever> sepski: will do
19:51:28 <sepski> any other items ?
19:51:36 <pere> gather donations?
19:51:58 <pere> seriously, the project is running out of funding for gatherings, and we need to do something to get more funding.
19:52:41 <pere> #url http://www.linuxiskolen.no/slxdebianlabs/donations.html
19:52:46 <h01ger> sponsors?
19:52:56 <pere> yes, please. :)
19:53:13 <h01ger> sponsors usually want something offered..
19:53:24 <sepski> bzz.no sponsors the upcoming gathering and this is awsome.
19:53:27 <pere> I've asked the DPL if debian can provide some money, but no response so far.
19:53:35 * h01ger nods sepski and cheerzs bzz.no
19:53:50 <h01ger> maybe we can ask rhineland-pfalz too
19:53:55 <pere> yeah.  how much is sponsored for the gathering?
19:53:58 <jever> good idea
19:53:58 <h01ger> there should be the right people to ask in oslo :)
19:54:02 <sepski> I have been trying to talk to the local muncipiality. but i obviously do not know the right people
19:54:47 <pere> just wanted more people to be aware of this issue.
19:55:10 <h01ger> next?
19:55:21 <pere> another issue is the upcoming board election for the member organization.  candidates are most welcome.  I'm on the election board, with klausade and knuty.
19:55:42 * h01ger is busy getting _off_ the olpc.de board :)
19:56:08 <h01ger> and generally cutting down on things and doing things more concentrated - so not me :)
19:56:17 <jever> pere: what has one to do there?
19:56:26 <pere> please contact us if you are curious on the member organization.
19:56:49 <h01ger> (but i absolutly applaud frisk activities and opening up frisk to non-norwegians! :)
19:56:54 <pere> jever: organize gatherings, publicity, events, etc.
19:56:55 <sepski> jever, raise money, organize gatherings,
19:57:23 <pere> one of the first things frisk need to do is to get the member list in order.
19:57:24 <jever> pere: sepski: where to sign up?
19:57:35 <pere> jever: email me, klausade and knuty.
19:58:12 <jever> ok
19:58:20 <sepski> http://medlem.friprogramvareiskolen.no/index.php but i am not 100% sure i trust it yet
19:58:23 <pere> I can not remember any other topics that I want to rais. :)
19:58:56 <pere> s/rais/raise/
19:59:08 <sepski> that was many tho :)
19:59:11 <h01ger> next?
19:59:46 <sepski> also if someone have housing to give to developers in oslo. state so on the list or arrange directly. money saved is money earned :)
19:59:57 <sepski> #topic Debian-Edu Meeting in progress | Agenda at http://wiki.debian.org/DebianEdu/Meeting | Topic 6: Next meeting?
20:00:03 <jever> h01ger: don't kill your brain, don't drink too much red wine
20:00:04 <sepski> i guess that's oslo ?
20:00:07 <h01ger> november 15th?
20:00:20 <h01ger> sepski, well, next irc meeting :)
20:00:35 <h01ger> (which is a sunday)
20:00:56 <pere> could work for me.
20:01:03 <danielsan> we are back to normal (winter) time after the 25th, whould we stay at 21:00 CET?
20:01:30 <danielsan> (and switch to 20:00 UTC)
20:01:40 * h01ger likes 20 CET better but can life with 21 CET
20:01:57 <sepski> i like 21 cet since kids are in bed and i can attend
20:01:58 <sepski> :)
20:02:01 <h01ger> (and i'm flexible, so dont listen much to me here)
20:02:10 * pere do not care much.
20:02:25 <h01ger> so 21 CET, november 15th?
20:02:33 <sepski> since nobody else complain yes
20:02:36 * jever is comfortable with every date
20:02:45 <danielsan> november 15th should be ok for me too :)
20:02:55 <sepski> #agreed   21 CET, november 15th?
20:03:04 <sepski> to late now :)
20:03:25 <sepski> thank you all for participating. we are 22:03 :)
20:03:27 <sepski> #endmeeting