17:00:33 <lucas> #startmeeting
17:00:33 <MeetBot> Meeting started Tue May 28 17:00:33 2013 UTC.  The chair is lucas. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:33 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:34 <Maulkin> o/
17:00:51 <lucas> #topic roll call
17:00:56 <bgupta> here
17:00:57 <nhandler> o/
17:01:00 <Maulkin> o/
17:01:01 <bremner> here-ish.
17:01:02 <lucas> agenda is http://titanpad.com/debiandpl-20130528
17:02:15 <lucas> maybe we could start with the two points that bgupta proposed, while waiting for others to arrive
17:02:28 <lucas> #topic Debian/SPI relationship
17:03:04 <lucas> one problem we have with SPI is that they are not able to provide a detailed list of transactions involving Debian
17:03:35 <lucas> we get monthly statuses, so we know how much money we have, but we don't have a list of incoming/outcoming transactions
17:03:44 <lucas> with the exception of credit card donations
17:04:18 <lucas> that's something that is very demotivating for the work of our auditors, of course
17:04:40 <lucas> zack has been pushing quite a lot for this, me too (my last ping is from mid-may)
17:05:14 <lucas> besides more pushing, I don't think there's anything else to do, but since it has been raised, I wanted to clarify the situation
17:05:53 <lucas> (of course, the dramatic measure would be to look for another US-based trusted organization, but I don't think that we are there yet)
17:06:16 <lucas> comments?
17:06:20 <lucas> questions?
17:06:21 <moray> [stuck on the phone]
17:06:26 <bgupta> I'll also add that there is a sense from some in the project, (perhaps a minority) that the fees they charge (5% or so) combined with the inconsistantly responsiveness of the service provided, feels like we are not getting a great deal. (I am paraphrasing)
17:07:04 <bgupta> I personally think that the issue is likely volunteer/manpower on SPIs side.
17:07:22 <bgupta> and some of the things they are doing manually now, could stand to be automated
17:07:41 <bgupta> It's also complicated by the fact that they are supporting multiple projects.
17:07:54 <lucas> yes, that's likely, but from our exchanges so far, it's hard to tell
17:08:27 <bremner> isn't the majority of the SPI board Debian folk?
17:08:34 <lucas> it is
17:08:45 <bgupta> I have a feeling that if they opened up aseperate bank accounts for debian, and allowed certain debian staff access to those accounts, it would be the simplest way to resolve this.
17:09:41 <lucas> I'm keeping an eye on this, and will raise it with the SPI board if it doesn't get solved
17:10:01 <bgupta> Basically remove the administrative burden from them, but still allow them to legally own the accoutns.
17:10:13 <lucas> #action lucas ping again on the SPI transactions issue
17:10:18 <lucas> (so that i don't forget)
17:10:20 <bgupta> (Debian can't own anything)
17:11:09 <lucas> I don't think that we should propose such a thing, esp. if it involves stepping on their toes
17:11:38 <lucas> there's a risk of demotivating them, too
17:12:03 <bgupta> well, on the flip side, they might welcome a lowering of their workload.
17:12:22 <bgupta> and they'd be able to provide better service to other projects.
17:12:28 <lucas> it's not something they expressed so far, and they had the possibility to do it
17:12:32 <bgupta> Just floating an idea..
17:12:48 <lucas> #topic listing of trusted organizations + criterias for becoming one
17:13:12 <lucas> the specific Q being: what the timeframe is on having the TO definition finalized, so the list of TOs can be finalized
17:13:40 <lucas> I must admit that this is a topic I don't know well, and receiving the question 30 mins before the meeting didn't help :P
17:13:59 <bgupta> It's on auditor's TODO list.
17:14:12 <bgupta> perhaps, I'll just send email to auditor@?
17:14:23 <lucas> generally, I don't think that we have a need to increase our number of TO *a lot*
17:14:46 <lucas> clarifying what we expect from existing TO would be good
17:14:56 <bgupta> well the issue is that their list in a ittle nebulous as to what is and isn't TO
17:14:57 <lucas> but we don't really have candidate TO currently
17:15:08 <lucas> there's debian france, but I don't think that things are very active on that front
17:15:33 <bgupta> LIke the spanish debian org, is that TO?
17:15:47 <bgupta> anyway, we can take this offline..
17:15:50 <lucas> yes, ok
17:16:19 <lucas> can you add an action for you :) to clarify the status with auditor@?
17:17:00 <bgupta> #action bgupta follow up with auditor@ regarding status of TO criteria
17:17:24 <lucas> #topic DAM, keyring maint and DM keyring maint statuses
17:17:44 <lucas> so, first, those teams are working well, and there's no need to worry in the near future
17:18:27 <lucas> however, there's some work to do in terms of checking who is active, what the role of the team is (esp. for DM keyring maint), and who should be delegated
17:18:58 <lucas> for example, the DM keyring maint does not manage the DM keyring anymore, and is composed of 3 DDs, 2 of them being inactive
17:19:14 <lucas> so there's room for improvement ;)
17:19:41 <lucas> I'm mentioning it here because it's a task that is quite self-contained, and that i wouldn't mind delegating
17:20:30 <lucas> the expected outcomes being 1 to 3 delegation emails clarifying team members and role of each team
17:20:41 <lucas> is someone interested?
17:20:53 <lucas> (I was thinking that moray could be)
17:21:44 <lucas> erm, it looks like it will be for me
17:22:11 <bgupta> (I would, but I don't think I am the right person for the task)
17:22:12 <moray> lucas: hi, just coming back online
17:22:40 <moray> lucas: working out what each time is/should be doing could fit with other "look at teams" stuff, the actual delegation part is a bit separate obviously
17:22:51 <moray> s/time/team/
17:24:14 <lucas> yes, but I think that the priority is a bit different, since we know those teams could become weak points
17:24:38 <moray> there is a wider issue about how delegations should be handled
17:24:39 <moray> (not a new one)
17:24:49 <lucas> what do you mean?
17:24:58 <moray> e.g. when people are inactive, how quickly is it sensible to try to push changes
17:25:20 <moray> DPLs have tended to be scared of annoying delegates, even inactive ones :)
17:25:40 <lucas> heh
17:25:58 <lucas> note that having people around is helpful even if they are not doing the day-to-day work
17:26:13 <lucas> I think that we kind-of solve this with "wizards"
17:26:22 <moray> sure.  I think the problematic case is when they are (sometimes unintentionally) blocking new people helping on the work
17:26:39 <moray> (which can be simply because it appears from outside that there are enough people doing it)
17:27:24 <lucas> sure
17:28:22 <lucas> sorry, I don't think we reached a decision: I'm fine doing this specific task, but if you want it, it's yours
17:28:59 <lucas> moray: ^
17:29:03 <moray> I think it's mostly just sorting out the delegation (possibly including killing off a separate DM delegation), so probably you can do it without too much help :)
17:29:25 <lucas> ok, as you want
17:29:30 <moray> (or I fear that the extra coordination between more people may add more work than it removes)
17:30:24 <lucas> we inverted "next meeting" and "new topics" earlier, so let's go back to next meeting
17:30:32 <lucas> #topic next meeting
17:30:38 <lucas> [2013-06-11 Tue 17:00] ? (date -d @1370970000)
17:30:45 <lucas> moray?
17:31:02 <moray> should work for me, currently
17:31:18 <lucas> #agreed next meeting [2013-06-11 Tue 17:00] ? (date -d @1370970000)
17:31:22 <lucas> ok, let's do that
17:31:43 <lucas> I'm going to copy/paste from the agenda the things that might not require discussion
17:31:58 <lucas> if you think differently, of course, feel free to ask questions or to comment
17:32:03 <lucas> #topic actions from last meeting
17:32:14 <lucas> ** DONE lucas to finish work on bits.d.o delegation
17:32:15 <lucas> https://lists.debian.org/debian-devel-announce/2013/05/msg00012.html
17:32:15 <lucas> ** TODO bgupta to flesh out debian-sponsors wiki here http://wiki.debian.org/Fundraising, and ping list again to share
17:32:17 <lucas> Finally starting working on it, have made progress, but really still need to organize the ideas into categories to focus discussions. Expect to be ready to start dicussions on list within a week or two
17:32:22 <lucas> ** TODO bgupta Write to Mishi@SFLC and confirm that no changes are required to TM policy if we register Logo
17:32:25 <lucas> Repinged - still waiting - recently pinged - no need to discuss
17:32:27 <lucas> ** TODO bgupta investigate full madrid costs
17:32:30 <lucas> Repinged - still waiting - recently pinged - no need to discuss
17:32:33 <lucas> ** TODO zack to answer on -cloud@ about general philosophical statements from Debian
17:32:38 <lucas> ** DONE lucas update organization web page to add " (delegate)" and send email about current known+active delegations
17:32:41 <lucas> - organization.en.html updated
17:32:44 <lucas> - mail sent to d-d-a, with a deadline on June 15th for feedback
17:32:45 <lucas> ** TODO moray to propose a more detailed process about the teams survey
17:32:48 <lucas> Waiting for some responses, e.g. have asked Steve McIntyre for comments based on his experience of the previous teams survey.
17:32:51 <lucas> ** TODO moray to initiate work on paths into the project
17:32:54 <lucas> Still on hold until previous item has progressed more.
17:32:56 <lucas> ** TODO Diziet make progress on inbound trademark policy
17:32:59 <lucas> Lucas clarified that the DPL position did not change with the DPL switch
17:33:02 <lucas> ** DONE lucas to check with auditor about current status of reimbursement requests
17:33:05 <lucas> Answer is: they are not aware of any problems recently
17:33:06 <lucas> ** DONE lucas investigate moving the initd discussion to the TC
17:33:09 <lucas> TC suggests organizing more discussions, possibly during a "summit" meeting or at DebConf.
17:33:12 <lucas> In the meantime, new discussion on -devel@. Next action is probably on systemd supporters to answer the various questions
17:33:15 <lucas> ** TODO paultag do ics automailer
17:33:18 <lucas> -- I'll re-action what needs to be re-action
17:33:22 <lucas> #action bgupta to flesh out debian-sponsors wiki here http://wiki.debian.org/Fundraising, and ping list again to share
17:33:29 <lucas> #action bgupta Write to Mishi@SFLC and confirm that no changes are required to TM policy if we register Logo
17:33:32 <paultag> re-action sorry
17:33:36 <lucas> #action bgupta investigate full madrid costs
17:33:47 <lucas> #action zack to answer on -cloud@ about general philosophical statements from Debian
17:33:55 <lucas> #action moray to propose a more detailed process about the teams survey
17:34:02 <lucas> #action moray to initiate work on paths into the project
17:34:10 <lucas> #action Diziet make progress on inbound trademark policy
17:34:17 <lucas> #action paultag do ics automailer
17:34:32 <moray> on the TC/summit/debconf point: I think it would be nice if we could get someone from each faction to present their case in a session at debconf
17:35:11 <lucas> yes. however I hope that we will make progress by then
17:35:25 <moray> well, sure, maybe we can have a "winner" doing a presentation :)
17:36:00 <moray> but the same potentially goes for other topics
17:36:19 <lucas> we should be careful about not postponing everything until debconf, too ;)
17:37:18 <moray> right, I mentioned it as I think one of the most useful types of DebConf talk is to present a possible option for enhancing Debian, without necessarily trying to reach a solution
17:37:23 <lucas> (but I agree that debconf sessions on the active topics that could use it would be nice)
17:37:33 <moray> and that any of us (or others) should look for relevant things and actively ask people to present about them
17:38:11 <lucas> indeed, very good point
17:38:30 <lucas> generally, I'm not sure that "what's wanted in terms of talks" is clearly stated for debconf
17:38:35 <moray> no
17:38:51 <lucas> what's the deadline for talk proposals?
17:39:06 <moray> there is some deadline soon, but it will be possible to take more much later
17:39:29 <moray> we could even reserve some slots for "current discussion topics" in advance, I guess
17:39:40 <lucas> ok, I'll make sure to mention debconf submissions in my next d-d-a bits
17:40:07 <lucas> other comments,
17:40:08 <lucas> ?
17:41:05 <lucas> ok, let's look at items that could use more discussion
17:41:06 <lucas> ** TODO bgupta to move list of ideas to wiki and go through end of campaign's discussions -- http://wiki.debian.org/Teams/DPL/campaignideas
17:41:09 <lucas> Done - ready for folks to start reviewing
17:41:33 <moray> maybe something to post to -project or -vote?
17:41:47 <lucas> maybe s/campaignideas/Ideas in the page title
17:41:50 <lucas> yes, -project
17:41:53 <bgupta> Please confirm this is roughly what was envisioned, and that my catagorization makes sense.
17:42:32 <lucas> yes, totally. great work, overall.
17:42:50 <bgupta> thanks.
17:43:11 <lucas> that's something that will be very useful in the future. one challenge is to keep it roughly updated when new things come up
17:44:02 <bgupta> I would say one thing, that it is kind of a laundry list, with some things making sense and others maybe not so much.
17:44:09 <lucas> ah, something else that should be mentioned is "criteria for addition to the list"
17:44:22 <lucas> I don't think that we should add ideas that have not been discussed somewhere before
17:44:53 <lucas> that's kinda unavoidable
17:45:05 <lucas> and one of the rules of brainstorming is not criticizing ;)
17:45:10 <moray> yeah, if people just add arbitrary things to the wiki page it's unlikely to stay useful
17:45:41 <bgupta> lucas: I did hae a thought.. there was a question raised about how to do this more often. Realistically this list is rather large and that once per year as part of -vote proceedings, perhaps is enough?
17:46:09 <lucas> #action lucas/bgupta to add header of criterias for adding things and general goal
17:46:24 <lucas> s/of/with
17:46:41 <lucas> bgupta: sometimes ideas are mentioned in random mailing list threads
17:47:03 <lucas> a good sign that soemthing should be added is when someone points out that this has already been raised before
17:47:13 <bgupta> ok..
17:47:39 <bgupta> Yeah, being able to point to list archive perhaps shoud be criteria..
17:47:54 <lucas> yes
17:48:04 <lucas> other comments?
17:48:38 <bgupta> lucas: I think before we share list more widely, you should formulate Why we adoing this.
17:48:38 <lucas> ** TODO bgupta to investigate domain held by Debian with dsa, hostmaster@spi, auditor@
17:48:41 <lucas> DONE? Email sent 5/24 - Awaiting replies (added ffis to list of recipients). Expanded to tracking list of all debian.* domains. Status only 8 out of 28 debian.* domains are held by TOs. Question s: Where should this list be tracked? I can check into dpl-helpers trademark folder for now, if people think that's a reasonable place.
17:48:51 <lucas> bgupta: yes
17:49:08 <lucas> bgupta: I think that dpl-helpers git is fine
17:49:26 <lucas> bgupta: please notify auditors@ that we have such a list, too
17:50:01 <bgupta> #action bgupta commit list of debian.* domains to dpl-helpers repo and notify auditors about list
17:50:53 <lucas> ok, with this we end the agenda
17:51:36 <lucas> does someone have something else to add?
17:52:17 <lucas> ok, I'll handle posting the meeting notes
17:52:22 <lucas> #endmeeting