17:59:55 <zack> #startmeeting
17:59:56 <MeetBot> Meeting started Tue Dec 11 17:59:55 2012 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:56 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:07 <paultag> o/ (in and out, just landed in washington dc for $WORK)
18:00:12 <zack> hi everyone
18:00:21 <zack> .oO( I should probably learn about the pingall command... )
18:00:24 <zack> paultag: heya!
18:00:27 <zack> who's around?
18:00:29 <paultag> howdy!
18:00:31 <nhandler> o/
18:01:12 <zack> uhm, not a crowd for the moment ... ;)
18:01:19 <zack> Maulkin mentioned he'll be late
18:01:27 <zack> so, I've pushed the agenda to Git
18:01:39 <zack> thanks a lot nhandler for adding the actions items from last week!
18:01:46 <nhandler> No problem
18:01:51 <zack> #topic next meeting
18:01:55 <zack> I've pushed a proposal for that
18:02:20 <zack> given nhandler correctly observed that now+2 weeks is xmas
18:02:27 <zack> and now+3 weeks is january 1st
18:02:35 <zack> the proposal is to have a meeting on december 28th
18:02:35 <moray_> (hi)
18:02:48 <zack> and then gets back to the usual schedule on january 8th (which is Tue again)
18:02:57 <zack> moray_: hi moray_! (I've a new topic for you, hint hint)
18:03:08 <zack> how about the next meeting(s) proposal?
18:03:25 <nhandler> I'll be VAC for a week starting on the 22nd, so I'll have to miss that one. January 8 should work though
18:03:33 <moray_> that sounds sensible to me
18:03:45 <lucas> I'll probably be VAC
18:03:48 <lucas> (hi!)
18:03:52 <zack> lucas: hi!
18:04:32 <zack> nhandler: would you prefer a non-Tue slot, in general?
18:04:33 <zack> I don't think we can change that now, but it'd be useful to know in general
18:05:08 <nhandler> zack: After the new year, my conflict that has forced me to leave early should go away.
18:05:41 <zack> ah, "should work" as in "OK", not in "I should work so I won't make it" ;-)
18:05:52 <zack> great, so let's say that the proposal on the agenda is fine
18:06:00 <nhandler> zack: Yep, sorry for the confusion :)
18:06:22 <paultag> as long as it's this time, most days will work great here
18:06:29 <paultag> it's actually a perfect time for me
18:06:39 <zack> I'll try to announce the 28th meeting with advance
18:06:40 <zack> so we can cancel if there are many regrets
18:06:40 <zack> #agreed next meetings dec 28th, jan 8th (usual time)
18:06:40 <zack> paultag: great!
18:06:51 <zack> #topic review action items from last meeting
18:07:05 <nhandler> I'll update the /topic and calendar after the meeting
18:07:10 <zack> (I'll follow the order from http://anonscm.debian.org/gitweb/?p=dpl/dpl-helpers.git;a=blob_plain;f=meetings/agenda.txt)
18:07:19 <zack> nhandler: cool, thanks
18:07:48 <zack> the DPL-ish pseudopackage is still pending, I'll just re-act it
18:07:59 <zack> #action someone to check with bugs.d.o if a DPL-ish pseudopackage would be acceptable
18:08:14 <zack> paultag: you tested the script made by nhandler and it works, right?
18:08:21 <paultag> yessir.
18:08:26 <paultag> (to both)
18:08:35 <zack> cool, so it works for different accounts
18:08:47 <paultag> had a minor perl dep issue
18:08:48 <paultag> sorted now
18:08:59 <zack> so that's rightfully DONE
18:09:00 <nhandler> paultag: Did you ever commit that readme you had talked about?
18:09:19 <paultag> erm, no
18:09:28 <zack> tsk tsk ;)
18:09:31 <paultag> task me with that, I can get to it after I get back home :)
18:09:47 <zack> paultag: you can task yourself!
18:10:12 <zack> (it'll even feel more masochist that way)
18:10:17 <paultag> #task paultag to do the readme for the dpl magic ical script
18:10:21 <paultag> erm, hurm.
18:10:24 <nhandler> (#action)
18:10:25 <zack> s/task/action/
18:10:28 <paultag> #acton paultag to do the readme for the dpl magic ical script
18:10:32 <zack> great!
18:10:33 <paultag> #action paultag to do the readme for the dpl magic ical script
18:10:34 <paultag> ugh! :)
18:10:53 <zack> as you can see at http://anonscm.debian.org/gitweb/?p=dpl/dpl-helpers.git;a=blob_plain;f=meetings/agenda.txt the agenda is done too
18:11:03 <zack> it's also great that we have meeting archives
18:11:14 <zack> I guess eventually I'll need to separe the agenda from a more broad todo list
18:11:40 <zack> (I suspect there will *always* be more DPL-ish tasks at hand than those we can discuss in a meeting)...
18:11:53 <zack> nhandler: good if I had a TODO list top-level, and we keep agenda.txt where you put it?
18:12:14 <nhandler> zack: No objections from me.
18:12:27 <zack> #action zack to add a top-level TODO list, as opposed to agenda.txt (which will be running "next meeting" agenda)
18:12:54 <zack> lucas: no news on the salvaging discussion front, right?
18:12:59 <lucas> #action lucas to wrap-up the salvaging/orphaning thread and submit dev-ref patch. also address #681833. also look at the recent debian-qa@ thread.
18:13:05 <lucas> no, still ENOTIME on my side
18:13:16 <zack> lucas: np. Do you think you could do it before xmas VAC?
18:13:26 <lucas> not realistically
18:13:27 <zack> (I know, it's end of semester ;))
18:13:30 <lucas> during, maybe
18:13:43 <zack> oki
18:13:45 <lucas> if someone else volunteers, I don't mind
18:13:54 <lucas> otoh, it doesn't sound very urgent
18:13:55 <Diziet> Hello.
18:13:57 <Diziet> Sorry I'm late.
18:14:03 <zack> lucas: agreed
18:14:11 <zack> Diziet: I was right about to ping you
18:14:12 <Diziet> #insert <lame-excuse.h>
18:14:20 <zack> welcome!
18:14:34 <Diziet> Heh.
18:14:35 <zack> Diziet: agenda is at http://anonscm.debian.org/gitweb/?p=dpl/dpl-helpers.git;a=blob_plain;f=meetings/agenda.txt now
18:14:48 <zack> and we are right at the point starting with "Diziet" :)
18:16:13 <Diziet> I haven't done anything about my items, one of which is obviously blocked on the other.
18:16:19 <zack> right
18:16:31 <zack> do you dare proposing an ETA? (if not, we can simply postpone of course)
18:16:57 <Diziet> I would say "I will do this by the next meeting" but that's what I told myself last time.
18:17:10 <zack> eh :) just re-action them, so that we won't forget
18:17:11 <Diziet> It's trivial though so maybe this time if I promise "by next meeting" maybe I actually will.
18:17:27 <Diziet> #action Diziet to ask secretary@d.o about https://lists.debian.org/debian-project/2012/11/msg00009.html by next meeting
18:17:36 <Diziet> #action Diziet draft more formal statement re trademarks and discuss on -project,
18:17:43 <Diziet> #action Diziet draft more formal statement re trademarks and discuss on -project, apropos of https://lists.debian.org/debian-project/2012/02/msg00073.html
18:17:46 <Diziet> (oops)
18:18:01 <zack> i'll reuse your #include <lame-excuse.h> header for the next one
18:18:14 <zack> #action zack to write an outline of the -companies announcement and mail it to press@d.o
18:18:42 <zack> since last meeting, I've been sucked up in quite a bit of day to day work + the debconf urgent stuff + bits, etc
18:18:58 <zack> I should be more available starting next week too, past end of semester \o/
18:19:01 <zack> algernon: around?
18:19:50 <zack> apparently not
18:20:11 <zack> I might end up reviewing the draft algernon already prepared myself during xmas vac, but in the avoidance of doubt I'll just re-action it as it is
18:20:22 <zack> #action algernon to update the DMCA draft directly with the identified changes, for easier review
18:21:24 <zack> anything else we might have forgot? If not we may move to the new-er stuff...
18:21:50 <nhandler> Nothing from me
18:21:55 <zack> #topic new topics
18:22:06 <zack> (how meta this change is...)
18:22:15 * nhandler -> away
18:22:18 <zack> easy stuff first
18:22:29 <zack> while working on the agenda it occurred to me that the usual IRC notifications might be nice
18:22:50 <zack> nhandler volunteered to work on KGB integration, so unless someone else want to do that, I'll just assign it to him
18:23:22 <lucas> +1 for nhandler doing it :-)
18:23:26 <zack> #action nhandler to add KGB bot to #debian-dpl
18:23:39 <zack> next one is more juicy
18:24:08 <zack> are you all up to date with the debconf13 venue debate / flame ?
18:24:29 <zack> as in, you've an idea of wth I'm talking about?
18:24:40 <lucas> yes
18:24:43 <zack> moray_: ^^^
18:24:58 <moray_> zack: I am aware of what you're talking about :P
18:25:05 <zack> just pinging you :-P
18:25:17 <zack> so, the part that concerns me here is the part about the delegation
18:26:12 <zack> reference is <20121126202237.GA6101@upsilon.cc>
18:26:25 <zack> and there's a small executive summary in the agenda
18:26:46 <moray_> I don't think that a stronger Chairs delegation would have helped anything here
18:26:54 <paultag> ugh, more debconf
18:26:59 <zack> in short, even if some debconf team members complained at the time of the chairs delegation that that was "disrupting" a bit the consensus based decision making of the time
18:27:02 <zack> team
18:27:12 <zack> it seems to me that the team had no good way to escalate an urgent decision
18:27:17 <zack> or am I reading this wrong?
18:27:33 <Diziet> http://lists.debian.org/msgid-search/?m=%3C20121126202237.GA6101%40upsilon.cc%3E     no hits
18:27:41 <moray_> and I think that the origins of the issues were from weaknesses in other areas, like the bid decision process and "local team" to "long-time DebConf people" interaction
18:27:48 <zack> Diziet: sure, it can be escalated to the DPL, but for any urgent decision, that would be a bit unfair
18:27:55 <zack> sorry, copy/past error
18:27:59 <zack> Diziet: http://article.gmane.org/gmane.linux.debian.conference.team/8966
18:28:05 <Diziet> ta
18:28:16 <zack> (thanks debconf.org different infrastructure than debian.org for that search failure...)
18:28:41 <zack> moray_: so, how do you think this can be avoided in the future?
18:29:02 <zack> I think debconf team does need an authoritative way to take urgent / non delegated to other decisions
18:29:19 <zack> that is similar to what the DPL does for Debian, but the 2 cannot be reasonably merged into a single person
18:29:26 <zack> it'd just be madness, imho
18:29:57 <moray_> zack: part of the problem in this case was that many people (including me) didn't *want* to take a decision for most of the period involved
18:30:00 <zack> hence the 2 ideas in the agenda ( *obviously* to be discussed with debconf team), but I welcome comments/suggestions even here
18:30:05 <moray_> i.e. thought that taking a decision was actively harmful
18:30:42 <Diziet> Other long-running conferences (eg SF cons) have a committee which makes all decisions and is formally responsible for everything.  But those communities have more of a tradition of conrunning.
18:30:48 <zack> that's just side-stepping the issue, it's equivalent to someone deciding "postpone the decision"
18:30:49 <moray_> for forcing decisions, I would, as you guessed, point to the Committee thing though, sure
18:30:56 <Diziet> So we probably shouldn't adopt the "bid team is in charge".
18:31:20 <zack> ok
18:31:27 <moray_> Diziet: the "Committee" idea here is having more experienced people involved
18:31:30 <Diziet> I think the DPL delegation should be to a standing committee who are formally responsible for making decisions.  And naturally most of the time they wouldn't do so.
18:31:33 <Diziet> moray_: Right.
18:31:51 <zack> moray_: how "stable" the debconf committee you think is? (wrt change overtime, that is)
18:32:00 <Diziet> I mean mostly things go straightforwardly and no-one needs to make a Decision with a capital D
18:32:19 <moray_> zack: I would rather that there was a rotation, rather than it being the same people in 10 years' time
18:32:45 <moray_> zack: but I'm not sure about legislating details of that, as we find that different years' DebConfs give different numbers of long-term useful people staying around
18:33:06 <moray_> (and a big part of DebConf's problems have been a lack of those over a number of years, indeed)
18:33:12 <zack> moray_: are you saying that there's no better solution than the status-quo? :)
18:33:17 <Diziet> moray_: I agree there should be turnover.  People with experience and enthusiasm can gradually come in in the usual way we have with core teams.
18:33:28 <Diziet> long-term useful people> Right.
18:33:31 <moray_> zack: I think the "consitutional" arrangements can be improved
18:33:38 <moray_> zack: and would be happy to draw up some ideas on that
18:33:55 <zack> I was hoping something like that ;)
18:34:03 <zack> so, I'm all in favor of committees, with rotations
18:34:08 <moray_> zack: but for the specific case, I'm not really convinced that the *process* went wrong/wasn't enough in itself
18:34:24 <zack> if you mean the bid process, I agree with you
18:34:37 <moray_> zack: I include the decision-making process there
18:34:44 <zack> what bothers me is that there is no other escalation mechanism than "ask the DPL" (which likely knows nothing about what you're talking about)
18:35:00 <moray_> the team was significantly split, so I don't accept that just making a quick decision would have been the right thing
18:35:12 <zack> I see, that's a good point
18:35:19 <moray_> zack: whatever you have in place, *someone* will try asking the DPL :)
18:35:26 <zack> tell me about that....
18:36:19 <zack> my idea was to eventually, ask debconf-team a sort of self-assessment of the team decision procedures
18:36:24 <zack> and see what the response is
18:36:33 <zack> if team members are fine with the status quo -> fine by me
18:36:43 <zack> if not, I'll be happy to evaluate alternatives
18:37:06 <moray_> zack: well, asking that too much will just repeat the recent discussion
18:37:17 <moray_> with people taking "party lines" depending on which group they were in
18:37:20 <zack> moray_: after this experience, do you think the "chairs" delegation is useful, considering its de facto "weakness"?
18:37:56 <moray_> zack: from my point of view many people involved already assume that the Chairs have more power than I would like them to have
18:38:11 <zack> yeah, I agree with that
18:38:16 <moray_> so yes, it's been useful in avoiding there just being no ability to decide what happens
18:38:18 <zack> (not sure if that's a problem per se)
18:38:41 <moray_> but I don't see an immediate need to increase the delegated powers
18:39:06 <moray_> I think trying to make the Committee more real is worth an attempt
18:39:15 <zack> "immediate" <- me neither, I was more thinking at something for the next debconf cycle
18:39:24 <zack> (hence to pass on to the next DPL)
18:39:33 <zack> moray_: I agree with the Committee part
18:39:47 <zack> and TBH, formal rotations are a mechanism I very much like, in general
18:39:58 <zack> and of which Debian needs quite a bit in various places
18:40:26 <zack> moray_: I don't see the need of adding any immediate action, but if you can keep in the backburner the Committee part and work on some improvement proposal, I'll be glad
18:40:51 <moray_> zack: for the specific case, also bear in mind that the push to "decide now" started months back, at a time when none of the experienced people really wanted to have a yes-or-no decision that was being asked for by the Swiss
18:41:33 <moray_> so most of this is about setting shared expectations in a better way rather than decisions as such
18:42:47 <zack> fair enough, although that sounds easier to do in theory than in practice :)
18:43:12 <zack> anything else on this? suggestions are welcome
18:43:53 <zack> ok
18:43:58 <zack> Maulkin: around?
18:44:04 <moray_> zack: well, there is an opportunity to set expectations better when starting with future bid teams
18:45:05 <moray_> fwiw, another part of the problem was the Swiss enthusiastically having lots of local face-to-face meetings during the DC12 period (although asked not to); I am intending to propose that we have one or two experienced non-local people focus more on DebConfN+1 much earlier
18:45:58 <zack> I don't know the details, but in general F2F meetings are fine *as long as* they're properly reported to the people unable to participate. Did the last part happen?
18:47:20 <moray_> zack: making decisions in those meetings isn't ideal, though -- and for reporting, there was a mixture, including some vastly too detailed meeting minutes that no one had time to read due to DC12 being more urgent :)
18:47:37 <zack> making decision <- sure, I agree
18:47:56 <zack> anyway, as Maulkin is not around, just a comment on the next point "release team delegation"
18:48:14 <zack> the release team at present is *not* delegated, afai(and others)ct
18:48:23 <zack> that's bad, as they do have more powers than any other DD
18:48:35 <zack> I've discussed that with Maulkin long time ago
18:48:46 <zack> and I think it should be fixed, although it has been a big ENOTIME for me
18:49:09 <moray_> Yes
18:49:24 <zack> the typical "exercise" to do at this point, is to ask the team what they *think* their responsibilities are, and compare it with what you (the DPL or helper :-P) think they are
18:49:30 <zack> better if written independently
18:49:31 <moray_> As soon as a group like that starts mentioning that it is not delegated, it is time to fix things :)
18:49:56 <zack> Maulkin: mentioned something about that before the meeting started, but I didn't get what he meant
18:50:09 <zack> I'll look into this, with the goal of having a delegation before my term ends
18:50:30 <zack> but if anyone else wants to try writing down the important parts, it'll be a nice "DPL exercise" :)
18:50:57 <zack> #action zack to contact debconf-team to draft a "job description" for future delegation
18:51:10 <lucas> if it doesn't make progress before I have some free time again, I could give it a try
18:51:41 <zack> lucas: ah, you fool :), ok, thanks
18:52:02 <zack> I'm short on time now as I've a dinner shortly after the meeting
18:52:16 <zack> so I'll just leave the remaining items in the agenda, probably moving them to a more broader todo list
18:52:29 <zack> anything else anyone wants to mention (in, say, 5 minutes)?
18:53:10 <lucas> still no big progress on the "renewing AWS credits" front, I'm getting worried
18:53:17 <zack> uff, that sucks
18:53:38 <zack> jeb went MIA or ...?
18:54:03 <lucas> no, he forgot to Cc you his last mail, which was "If we don't get a response by Monday from the people I've asked I'll put in for a credit myself for you."
18:54:25 <lucas> with monday being yesterday, I'll ping him again ;)
18:54:26 <zack> lucas: can you bounce me that?
18:54:41 <lucas> done
18:55:06 <zack> thanks, if nothing works in the next week, I'll try to escalate to the other people involved in the marketplace parts
18:55:27 <zack> (which was not exactly jeb's team, so it might give another lead)
18:55:33 <zack> please ping me if I forget!
18:55:59 <zack> ok, time to stop meeting for me
18:56:04 <zack> #endmeeting