15:59:39 <matthieucan> #startmeeting
15:59:39 <MeetBot> Meeting started Thu Aug  6 15:59:39 2015 UTC.  The chair is matthieucan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:39 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:44 <matthieucan> clemux: ping
15:59:47 <matthieucan> orestis: ping
15:59:56 <orestis> pong
16:00:00 <clemux> pong
16:00:10 <matthieucan> #topic next meeting
16:00:19 <matthieucan> agree to make a meeting next week before debconf?
16:00:26 <clemux> yes
16:00:34 <orestis> on friday?
16:00:44 <matthieucan> I'd be strongly enclined for thursday
16:00:49 <matthieucan> if you're both available
16:01:05 <orestis> yeap, coz on friday i ll be in the train for debconf :p
16:01:19 <clemux> I'll be at debcamp from wednesday, so no problem for me
16:01:40 <matthieucan> is 15:00 CEST ok for you?
16:01:43 <orestis> yeap
16:01:45 <clemux> yes
16:01:48 <matthieucan> clemux: oh cool, didn't know you go there
16:02:03 <matthieucan> #agreed next meeting thursday 13 aug, 15:00 CEST
16:02:14 <matthieucan> #topic orestis - last week
16:02:39 <orestis> so file deltas along with some bug fixes got merged (PR#34)
16:02:54 <orestis> and then the description etc in PR#35
16:03:05 <orestis> i ll move those from review to merged right?
16:03:13 <matthieucan> yes
16:03:58 <orestis> then there's the api proposal PR#36 which needs some editing
16:04:18 <orestis> i also PRed the spdx export as i had forgotten when i did it :p
16:04:20 <matthieucan> ok, do you miss any reviewing work for this point?
16:04:36 <matthieucan> yes, I looked a bit at that
16:04:48 <matthieucan> few points need to be discussed later, like the Creator fields
16:04:49 <orestis> no i think its ok.. i ll edit the proposal tonight but i can start the api by next week
16:05:19 <matthieucan> ack for api
16:05:20 <orestis> yes there are field i wasn't sure what exactly to add.. anyway that is probably the least urgent PR
16:05:28 <orestis> fields*
16:05:53 <matthieucan> ok, I'll write my thoughts about it, but we'll need zack's advice on some uncertain fields
16:06:08 <orestis> yes maybe we can see this at debconf
16:06:17 <matthieucan> for sure!
16:06:20 <matthieucan> other points we forgot?
16:06:52 <orestis> there's the PR#37 for the bug with missing d/copyright files
16:06:57 <orestis> which you reviewed and updated
16:07:00 <orestis> i think that's all
16:07:23 <matthieucan> oh true, I didn't check your comment for file renaming
16:07:29 <matthieucan> should be merged soon I believe :)
16:07:44 <matthieucan> ok, great, that week looks productive
16:07:49 <matthieucan> can we move on to next week?
16:07:52 <orestis> yeap
16:08:01 <matthieucan> #topic orestis - next week
16:08:21 <orestis> so 1) is the api
16:08:47 <matthieucan> can you prioritise items, according to what should be done before debconf/what would be better done there?
16:08:50 <orestis> then 2) i think a DB proposal and maybe the plugin to fill relevant info
16:08:53 <matthieucan> yes for API, great
16:09:30 <orestis> hm maybe the thing we talked via email? for being more explicit when there are no patches etc
16:10:01 <matthieucan> yes, follow zack's message for that, with an explicit text
16:10:10 <orestis> yeap i ve taken note for that
16:10:16 <matthieucan> what about documentation for /patches?
16:10:31 <orestis> yes i can also do that
16:10:40 <orestis> do you prefer doing db relevant things at debconf?
16:10:41 <matthieucan> a first shot should be doable by recycling the .txt proposal(s)
16:10:55 <orestis> true
16:11:06 <matthieucan> that's a good point, yes we should do that
16:11:40 <orestis> ok.. then to summarise:
16:12:18 <orestis> 1) api 2) explicit mention fo versions without patches 3) documentation and templates for patches.d.n
16:12:33 <orestis> i think that's not going to take me much time though
16:12:42 <orestis> and i am not sure if i can pick anything else
16:13:02 <matthieucan> in that case what about checksum of orig.tar.gz, via the updater as zack suggested via email?
16:13:14 <matthieucan> oh
16:13:17 <orestis> yes but to cache it where?
16:13:17 <matthieucan> db is needed for that
16:13:20 <orestis> yeap :/
16:13:21 <matthieucan> sorry
16:13:47 <matthieucan> then:
16:14:02 <matthieucan> what about the items in copyright? a few of them seem to be doable quite shortly
16:14:17 <matthieucan> verify license links or complete regexes, etc
16:14:35 <orestis> that's actually in the PR of the license statistics
16:14:50 <orestis> i have put that trello to remember to check them
16:15:11 <orestis> in the license statistics PR i did all the regexes for all the licenses (
16:15:16 <orestis> (the standard ones)
16:15:29 <matthieucan> ok, that's great. So it
16:15:54 <orestis> the author we said that we won't return it for now, work on the version handling so we avoid to c/p paste that code verywhere
16:15:54 <matthieucan> 's blocked by #22, and by the update of testdata, which I have no idea how to do (I didn't file the doc)
16:16:00 <matthieucan> it's probably postponed to debconf
16:16:34 <orestis> maybe i can work on the version handling.. but i have no clue how to do it.. but i can try
16:16:44 <matthieucan> what is that?
16:17:20 <matthieucan> oh ok
16:17:21 <orestis> for now the version handling is copy pasted every time
16:17:26 <matthieucan> just saw the GH discussion
16:17:29 <orestis> to make the redirects etc
16:17:44 <orestis> which one?
16:17:50 <matthieucan> https://github.com/Debian/debsources/pull/6#issuecomment-110124698
16:18:11 <orestis> ah yeah !
16:18:41 <matthieucan> ok, let's keep it for this week in case you have some time, I might be around to help anyway
16:18:50 <matthieucan> so I think we're good to go?
16:18:56 <orestis> yes great :)
16:19:09 <matthieucan> let's move on
16:19:14 <matthieucan> #topic clemux - last week
16:19:23 <matthieucan> how's the async going?
16:19:39 <clemux> so, the garbage collector stage is done, but I need tests to be sure
16:19:50 <matthieucan> great!
16:19:50 <clemux> the update_metadata stage is also done
16:19:57 <matthieucan> needs tests as well?
16:20:00 <clemux> yes
16:20:05 <matthieucan> ok
16:20:12 <clemux> I spent the rest of the week working on the tests
16:20:31 <clemux> I still have issues with them :/
16:20:35 <matthieucan> for the other stages?
16:21:01 <matthieucan> do you mean issues for testing, or issues for the stages themselves?
16:21:23 <clemux> issues for testing
16:21:46 <clemux> I have modified assert_db_schema_equal (https://github.com/Debian/debsources/blob/master/debsources/tests/test_updater.py#L85) for comparing specific tables
16:22:03 <clemux> so that we can have an assertion for each stage/task
16:22:14 <matthieucan> that sounds good
16:22:28 <clemux> I intend to test each plugin separately, etc.
16:22:47 <clemux> but for now, the "actual" list of objets is empty
16:23:02 <clemux> even though the test database is correctly filled with data from the async updater
16:23:31 <matthieucan> you mean you fill the db, and can't retrieve its content?
16:23:36 <clemux> yes
16:23:43 <clemux> I'll commit the code and ask for help
16:23:54 <matthieucan> good idea
16:24:02 <matthieucan> hard to say without diving in the code
16:24:05 <clemux> yup
16:24:23 <matthieucan> do some stages work or is it the same for all?
16:25:13 <clemux> it's the same for all tables
16:25:34 <clemux> anyway, I'll show you the code and explain the problem better :)
16:25:45 <matthieucan> ok, let's do that!
16:26:00 <matthieucan> anything else to add for last week? were there other stages scheduled?
16:26:19 <clemux> stats and charts were scheduled, but I haven't got around to do them
16:26:59 <matthieucan> if you're blocked by the tests, send code/shout for help as soon as possible
16:27:12 <clemux> yup
16:27:24 <clemux> besides that, I've worked on improving the worfklow of celery tasks in the updater
16:27:37 <matthieucan> what changed?
16:27:52 <clemux> for example, currently the update_suites main task is called in the extract_new stage
16:28:09 <clemux> this is annoying for unit tests (I need to mock out the update_suites task)
16:28:20 <clemux> and means we can't disable stages as in the sync updater
16:28:35 <clemux> I still need to do some research, but I think I've found out how to do it
16:28:46 <clemux> I'll submit a PR for the async documentation once I'm sure
16:29:11 <clemux> (I'll add that to trello right after the meeting)
16:29:12 <matthieucan> ok, that goes in the category "fix tests" then?
16:29:35 <clemux> it's more of a general improvement
16:29:50 <matthieucan> ack
16:29:53 <matthieucan> anything else?
16:29:56 <clemux> that's it :)
16:30:05 <matthieucan> #topic clemux - next week
16:30:18 <matthieucan> do you think we can expect to merge the async branch at debconf?
16:30:20 <clemux> yes!
16:30:41 <matthieucan> awesome! so let's list precisely the blockers and needed steps?
16:31:18 <clemux> 1) finish the tests, current blocker: problem with the fixture/test db comparison
16:31:27 <clemux> 2) update_stats
16:31:32 <clemux> 3) update_charts
16:31:56 <clemux> 4) "task workflow improvements" (I can't find a better name)
16:32:20 <matthieucan> not necessarily in that order I presume?
16:33:07 <clemux> that order would be best (for 1,2,3 at least)
16:33:39 <matthieucan> ok, then it looks like a week plan, doesn't it? :)
16:33:52 <clemux> I've added 4 on trello with a better name: "make tasks independant from each other"
16:34:03 <clemux> matthieucan: yup
16:34:50 <matthieucan> independent tasks look great for async! :)
16:34:51 <clemux> after that (and fixes to the likely bugs found with the tests), it'll be time for merging and testing on sourcesdev
16:35:23 <matthieucan> do you expect a smooth merge or will we fight with conflicts?
16:35:55 <matthieucan> sourcesdev uses the same db as s.d.n, I don't know if we should do it this way
16:35:56 <clemux> there will be conflicts with orestis' changes to the statistics stages (iirc)
16:36:01 <clemux> matthieucan: oh, right
16:36:11 <orestis> (they are not merged)
16:36:29 <clemux> (ah, yes, indeed)
16:37:12 <matthieucan> so we'll see that when needed I guess!
16:37:22 <matthieucan> can we move on? incoming week is clear?
16:37:25 <clemux> yup
16:37:30 <matthieucan> cool :)
16:37:35 <matthieucan> #topic misc
16:37:43 <matthieucan> anything to add or discuss?
16:37:53 <clemux> matthieucan: will you be at debcamp?
16:38:10 <matthieucan> clemux: no, I'll arrive saturday 15
16:38:17 <clemux> oh, ok
16:38:59 <clemux> nothing else to add :)
16:39:04 <orestis> ah yes me neither :p
16:39:09 <matthieucan> alright!
16:39:15 <matthieucan> thank you for the meeting
16:39:16 <matthieucan> #endmeeting