12:59:31 <matthieucan> #startmeeting
12:59:31 <MeetBot> Meeting started Fri Jul 31 12:59:31 2015 UTC.  The chair is matthieucan. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:31 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:59:39 <matthieucan> #topic roll call
12:59:42 <clemux> hello
12:59:59 <orestis> lo
13:00:10 <matthieucan> clemux: orestis: hi!
13:00:20 <matthieucan> #topic next meeting
13:00:28 <matthieucan> next friday, usual time?
13:00:33 <orestis> i think i won't be able on friday next week :/
13:00:46 <orestis> is it possible to reschedule?
13:00:56 <matthieucan> yes, when are you available?
13:01:14 <orestis> Thursday?
13:01:25 <matthieucan> fine for me. clemux?
13:01:48 <clemux> I'd prefer saturday, but thursday is fine
13:02:08 <matthieucan> as you wish. orestis, saturday?
13:02:16 <orestis> i ll be away on the wk without net
13:02:21 <clemux> oh
13:02:41 <clemux> ignore me then, thursday works for me
13:02:41 <matthieucan> so let's say thursday. 15:00 CEST?
13:02:55 <orestis> clemux: thanks :)
13:03:30 <matthieucan> #agreed next meeting next thursday, 15:00 CEST
13:03:40 <matthieucan> #topic orestis - weekly review
13:03:45 <matthieucan> what's up?
13:04:10 <orestis> So PR#32 which includes the blueprint skeleton
13:04:17 <orestis> and the browsing for the patch tracker
13:04:45 <orestis> and then i opened PR#33 with the package summary, downloading and viewing patches
13:04:52 <matthieucan> I've seen that on GH. Is it mergeable, or does that depend on previous unmerged/blocked PRs?
13:05:05 <orestis> Mergeable
13:05:10 <matthieucan> awesome
13:05:18 <matthieucan> I'll have a look at that after the meeting
13:05:20 <orestis> well it does not depend on the copyright one
13:05:35 <matthieucan> all the blocked PRs are related to copyright?
13:05:38 <orestis> i ve let them in the done list since i wasn't sure what's more important
13:06:15 <orestis> There is one PR blocked by the testdata problem, and then the rest of them which are based on that PR
13:06:34 <orestis> but all the PRs for the patch tracker are mergeable
13:06:49 <matthieucan> yes, I can try to update the testdata but to be fair, never done that, so I'll see what I can do
13:06:52 <orestis> There is also PR#30 from last week on the patch tracker which is squashed and ready for merge as well
13:06:53 <matthieucan> ok, that's great
13:07:09 <matthieucan> I didn't read it, it's the one xack reviewed via email?
13:07:14 <matthieucan> zack*
13:07:15 <orestis> yeap
13:07:33 <matthieucan> ok, I'll check it as well then
13:07:36 <orestis> oki
13:07:49 <orestis> so should i move the one from the done list to the need review?
13:07:52 <matthieucan> so you already have something working for the patch tracker, if I understand correctly?
13:07:56 <matthieucan> yes please
13:08:09 <orestis> yes this week i started coding the patch tracker
13:08:26 <matthieucan> ok, can't wait to see that!
13:08:34 <matthieucan> anything else?
13:08:41 <orestis> that's all this week
13:08:51 <matthieucan> #topic orestis - next week
13:08:56 <matthieucan> what do you pick?
13:09:31 <orestis> hm
13:09:49 <orestis> i d like to make a cache for the package summary to avoid parsing the patches every time
13:10:06 <orestis> coz i think it has a performance impact..
13:10:07 <matthieucan> cache = db table?
13:10:22 <orestis> no in a file.. similar to the job we do in the statistics
13:10:58 <matthieucan> hm... what's the benefit of using a file instead of db? doesn't it make things more complicated?
13:11:23 <orestis> hm last week with zack i understood we wouldn't need a db
13:11:27 <orestis> that's why
13:11:42 <matthieucan> but was caching involved in the debate?
13:11:48 <orestis> no :)
13:12:22 <orestis> maybe i should let this for later and work on the links from the file-deltas to debsources, links to the BTS and extracting the summary-description from the patch?
13:12:48 <matthieucan> yes, that looks more reasonable indeed :)
13:13:00 <matthieucan> I think a file cache would require more discussion
13:13:11 <orestis> ok works
13:13:19 <matthieucan> thanks
13:13:23 <orestis> i ll probably send an email to the list explaining my thought
13:13:37 <orestis> i don't know if that is enough though (the 3 tasks)
13:13:45 <matthieucan> yes, that's a great idea, also to have zack's input on that
13:13:51 <matthieucan> hm
13:13:54 <orestis> but i am not sure what else to do :/
13:14:08 <matthieucan> what about the api?
13:14:19 <matthieucan> or is that already done?
13:14:31 <orestis> nope
13:14:38 <orestis> nothing with the api yet..
13:14:51 <orestis> but i am no really sure what functionalities the api can have
13:15:04 <orestis> but i can give some thought and maybe discuss it with you?
13:15:19 <matthieucan> well, in the first place, all the funcs that are in the UI (patches list, description, etc)
13:15:22 <matthieucan> yes, of course
13:15:48 <orestis> ok works then.. i ll pick that one
13:15:51 <matthieucan> looks like enough work for the week with the api, right?
13:16:05 <orestis> yeap
13:16:10 <matthieucan> cool
13:16:16 <matthieucan> #topic clemux - weekly review
13:16:19 <matthieucan> clemux: you're up!
13:16:42 <clemux> so, the update_suites stage is done and works correctly
13:16:50 <matthieucan> awesome!
13:16:51 <clemux> (https://github.com/clemux/debsources/commit/08b05cd7684ffc0d6ec299410c8704bd59419dcc)
13:17:00 <matthieucan> will you PR it?
13:17:17 <matthieucan> oh
13:17:29 <matthieucan> no, dependencies are not there yet, right?
13:17:55 <clemux> same problem as always: can't be merged in master when the rest is not done
13:18:19 <matthieucan> yep, sorry
13:18:53 <matthieucan> (did you get unblocked from last week's technical issues?)
13:19:10 <clemux> oh, yeah, sorry, the tests
13:19:22 <matthieucan> work now?
13:19:24 <clemux> so, I managed to make a few unit tests
13:19:42 <matthieucan> celery- or general-related?
13:20:48 <clemux> but they're not as good as I wanted, testing a few packages only, what I've done are mostly "toy" tests that help me understand how to do them correctly
13:20:59 <clemux> I will submit a PR with the documentation for those tests
13:21:10 <matthieucan> ok, great
13:21:10 <clemux> basically, I use the DB fixtures in the current test data
13:21:17 <clemux> I'll use*
13:21:20 <matthieucan> incrementally moving forward is the way to go anyway :)
13:21:27 <clemux> and instead of comparing the whole of the DB
13:21:37 <clemux> I'll compare specific tables at each stage of testing
13:22:12 <matthieucan> that looks super good, and should even avoid us problems when we add tables, right?
13:22:28 <clemux> oh, indeed
13:22:45 <matthieucan> which is actually the problem we have with orestis currently :)
13:22:57 <clemux> anyway, I did not finish that, because it was taking a lot of time and I wanted to be sure I'd have tangible results by the end of the week
13:23:13 <clemux> so I put the tests aside and implemented update_suites
13:23:29 <clemux> as well as the garbage collection stage, which still has a few issues
13:23:57 <matthieucan> well done for update_suites
13:24:06 <matthieucan> and for gc. Do you think it will work soon?
13:24:13 <clemux> yes, tonight or tomorrow
13:24:19 <matthieucan> nice!
13:24:37 <matthieucan> anything else for last week?
13:24:43 <clemux> nope, we can move to next week
13:24:52 <matthieucan> #topic clemux - next week
13:25:05 <matthieucan> finish gc, I guess?
13:25:12 <clemux> so, the updater is nearly finished:
13:25:34 <clemux> sorry
13:25:41 <clemux> so, the updater is nearly finished, what's left is:
13:25:48 <clemux> - finalize gc
13:26:19 <clemux> - update_metadata (should be real quick, it doesn't do much)
13:26:42 <clemux> - update_statistics
13:26:47 <clemux> - update_charts
13:27:18 <clemux> I believe all, or nearly all of that is doable next week
13:27:36 <orestis> (sorry to jump in) in the copyright tracker i had to touch update_statistics and update_charts (for the license statistics)
13:27:42 <matthieucan> (for update_statistics, you're mentioned in https://github.com/Debian/debsources/pull/28, see with orestis that everything is fine)
13:27:56 <matthieucan> clemux: that's great news!
13:28:03 <matthieucan> so pick everything? :)
13:28:18 <matthieucan> orestis: oh, I think we got the same idea
13:28:23 <orestis> :P
13:28:29 <clemux> oh, thanks, I'd missed that
13:29:16 <clemux> I don't think it'll be a problem
13:29:23 <matthieucan> clemux: ok, looks like a busy enough week, that'd be awesome to see all the process working at the next meeting :)
13:29:24 <clemux> I'll coordinate with orestis next week
13:29:29 <matthieucan> perfect
13:29:36 <matthieucan> anything else for next week?
13:30:03 <clemux> I think that's enough; if I'm done sonner I'll work on the plugin re-run support
13:30:10 <clemux> and improving the tests if needed
13:30:35 <matthieucan> that sounds awesome
13:30:39 <matthieucan> ok, let's move on
13:30:44 <matthieucan> #topic misc
13:31:24 <orestis> nothing from me
13:31:32 <clemux> I have nothing to add :)
13:31:40 <matthieucan> alright
13:31:45 <matthieucan> let's adjourn then
13:31:53 <matthieucan> and good luck for both of you for the incoming week!
13:31:56 <matthieucan> #endmeeting