12:59:55 <zack> #startmeeting
12:59:55 <MeetBot> Meeting started Fri Jul 17 12:59:55 2015 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:55 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:00 <zack> #topic roll call
13:00:05 * orestis 
13:00:09 <zack> matthieucan is on VAC so he won't be joining us
13:00:15 <zack> jpleau: around?
13:00:23 <zack> otherwise it will be the 3 of us
13:00:44 <zack> #topic next meeting
13:01:10 <zack> next week I'll be in Portland, OR, -9 hours from EU timezone
13:01:17 <zack> so 15h will definitely be too early for me
13:01:22 <zack> and matthieucan will still be on VAC
13:01:35 <clemux> later is fine for me
13:01:40 <zack> can we, say, postpone to 17h ?
13:01:43 <orestis> yeap
13:01:54 <clemux> yes
13:01:57 <zack> that would be 8 am for me, which is OK
13:02:02 <zack> ok, so:
13:02:16 <zack> #agreed next meeting next friday, exceptionally at 17 CEST
13:02:27 <zack> #topic meta
13:02:35 <zack> so, a few meta-points before the weekly review
13:02:42 <zack> clemux: I believe you've had issues this week, right?
13:02:54 <clemux> my laptop was stolen last friday
13:03:09 <clemux> and I haven't been able to make progress since
13:03:09 <zack> (which sucks, I'm really sorry about that)
13:03:14 <zack> ok
13:03:15 <orestis> :/
13:03:22 <clemux> the issue is now solved and I have a new laptop
13:03:35 <clemux> so I'll work extra to make up for it
13:03:52 <zack> don't worry, it's just good to know that you're back on track now
13:04:11 <zack> so we will not have a section about clemux in the weekly review / planning, we will just refresh all pending items from last week
13:04:22 <clemux> yes
13:04:24 <zack> another meta point
13:04:36 <zack> next week I will be available, but at a conference (OSCON)
13:04:46 <zack> so I'll have limited IRC time, and should be reactive mostly via email
13:04:55 <zack> it sucks a bit that that coincides with matthieucan not being around
13:05:03 <zack> so it is likely that the patch/review backlog will go up
13:05:08 <zack> (sorry about that)
13:05:19 <zack> but I'm not worried, as we will have time together at debconf to catch up
13:05:44 <orestis> not an issue for me as i started the patch tracker
13:05:50 <zack> ok, let's move to orestis review then
13:05:57 <zack> #topic orestis - weekly review
13:06:03 <zack> orestis: floor is yours!
13:06:20 <orestis> so PR#25 (online doc) was merged
13:06:26 <orestis> i guess i can take it to merged
13:06:37 <jpleau> zack: pong
13:06:42 <zack> jpleau: welcome!
13:06:45 <orestis> jpleau: hey
13:06:55 <zack> orestis: great, move it to merged then
13:07:18 <orestis> and then i have 3 new PRs
13:07:35 <orestis> PR#29 about the license synopsis and the parsing in the fancy rendering
13:07:46 <orestis> plus a link from s.d.n to c.d.n in the infobox
13:07:51 <zack> nice
13:07:52 <jpleau> Sorry again for lack of involvment from me, been away from my PCs lately, and starting my 2 weeks vacation in 3 hours, probably will be away a bit more :p
13:08:22 <orestis> then PR#30 which is a review of the old patch tracker
13:08:25 <zack> jpleau: ah, too bad, I was hoping to offload to you some reviews :), but it looks like it's holiday season for all of us at the same time ;)
13:08:32 <orestis> heheh!
13:08:43 <zack> orestis: so, I guess PR#30 should be the priority here, as it is basis for future work, right?
13:09:00 <orestis> this is not much problem.. as i started the patch tracker the rest of PRs are not blocking
13:09:04 <zack> ok
13:09:05 <orestis> zack: yes
13:09:07 <zack> another question
13:09:18 <zack> are there dependencies among the pending review PRs?
13:09:35 <zack> if so, it would be nice to note them in the title, so that we know in which order process them
13:09:42 <orestis> ok yes sure
13:09:49 <orestis> i ll do that after the meeting
13:09:52 <zack> sounds great
13:10:11 <zack> other matters you want to discuss before next week planning?
13:10:14 <orestis> spdx export is done but i am not opening a PR since it is based on other works
13:10:42 <orestis> and i opened PR#31 for the search problem you mentioned last week
13:10:43 <zack> oh, I see that you noted it in the done cart
13:10:46 <zack> that's great, yes
13:10:57 <zack> orestis: was that (search) hard to fix?
13:10:57 <orestis> that's all for this week i guess
13:11:23 <orestis> no no, i just added the routes in the copyright BP and moved a template in the core ones
13:11:29 <orestis> didn't have to change code
13:11:39 <zack> oh, so not even a need to pass around a url parameter?
13:11:47 <orestis> no
13:11:50 <zack> interesting
13:12:31 <zack> ok, let's plan next week then
13:12:35 <zack> #topic orestis - next week
13:12:41 <zack> what would you like to work on?
13:12:45 <orestis> the endpoints starting with . such as .search automatically take the current blueprint so we didnt need anything else
13:13:00 <orestis> sooo next week i guess i can start the use cases and stories right?
13:13:08 <zack> for patch tracker, yes
13:13:31 <orestis> i don't know if i can code something next week..
13:13:42 <zack> that's ok
13:13:53 <zack> we just need something easily verifiable, even if it's not code related
13:14:03 <zack> let's say: write down all user stories for patch-tracker?
13:14:14 <orestis> yes.. maybe also identify target users
13:14:32 <zack> yeah, good point, that's kind of a requirement for doing user stories
13:14:43 <zack> I'm fine with splitting it in two
13:15:08 <orestis> yes i ll do that
13:15:10 <zack> cool
13:15:19 <zack> anything else? ("no" is fine as an answer :))
13:15:35 <orestis> is there a suggested workflow for identifying target users?
13:15:46 <zack> well, not in general
13:16:03 <orestis> i think that's good for next week and if i have time i might pick up a bug to work
13:16:12 <zack> but in this case I think you should focus on debian roles (e.g., maintainers/developers), upstream role (to undesrstand differences between their version), and
13:16:23 <zack> 3rd party distributors (e.g. ubuntu, red hat, etc.) for patch sharing purposes
13:16:31 <zack> so, not really a workflow
13:16:36 <zack> but areas to be explored
13:16:41 <zack> it should help
13:17:04 <zack> ok?
13:17:21 <orestis> so do we set as a goal from now cross-distro capabilities?
13:17:39 <zack> you mean, supporting multiple distros in debsources?
13:18:11 <orestis> i am not sure i understood what you meant by 3rd party distributions.. how could they use the patch tracker?
13:18:16 <zack> oh, sorry
13:18:19 <zack> so, here is the idea
13:18:20 <orestis> or is this what i am suppsoed to think ?
13:18:30 <zack> there is an important bug in some upstream software, and I'm a red hat developer
13:18:39 <zack> I want to see if the bug has already been fixed in debian
13:18:48 <zack> I go to the patch tracker, I find the patch, I download it
13:18:53 <zack> and I apply it to my package (in red hat)
13:19:07 <orestis> oh i see ok
13:19:11 <zack> the patch tracker will be responsible only up to the point where the dev download the patch
13:19:18 <zack> from there on, it's up to the dev
13:19:25 <zack> so, no need to support multiple distros for this use case
13:19:42 <zack> (more generally, I don't think you should worry about multiple distros at all, at this stage)
13:20:15 <orestis> ok got it
13:20:22 <zack> ok, let's move to misc then
13:20:24 <zack> #topic misc
13:20:27 <zack> anyone? anything?
13:20:52 <clemux> nope
13:20:54 <orestis> nope
13:21:01 <zack> ok
13:21:03 <zack> #endmeeting