12:59:48 <zack> #startmeeting
12:59:48 <MeetBot> Meeting started Fri Jul  3 12:59:48 2015 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:48 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:59:51 <zack> #topic roll call
12:59:55 <zack> who is around?
13:00:00 * orestis 
13:00:10 <zack> matthieucan sent regrets, so he won't be
13:00:15 <matthieucan> zack: I'm here, but might suddenly disappear
13:00:15 <zack> jpleau: clemux: ping
13:00:20 <zack> oh, hello :)
13:00:33 <matthieucan> hi everyone :)
13:00:49 <clemux> hello
13:00:55 <zack> #topic next meeting
13:00:59 <zack> next week, usual time?
13:01:08 <orestis> Next week i won't be able to attend at this time
13:01:09 <clemux> ok for me
13:01:12 <matthieucan> won't work for me at 3pm
13:01:25 <orestis> well friday is pretty difficult for me next week all day
13:01:31 <zack> 2 down
13:01:36 <zack> how about thursday next week then?
13:01:47 <orestis> works for me
13:01:50 <zack> same for me
13:02:13 <zack> matthieucan: clemux: ?
13:02:16 <clemux> ok for me
13:02:41 <zack> 3 ok for thu, and matthieucan can't make it on fri anyhow
13:02:44 <zack> so let's settle for thu
13:02:55 <zack> #agreed anticipate next week meeting by 1 day, to next Thursday
13:02:58 <matthieucan> sorry
13:03:01 <matthieucan> yep, works for me
13:03:04 <zack> awesome
13:03:09 <zack> #topic weekly review - orestis
13:03:17 <zack> so, I should start this section apologizing
13:03:31 <zack> as I haven't yet had time to review PR#22
13:03:37 <jpleau> zack: pong sorry
13:03:54 <matthieucan> PR#22 looks great
13:03:55 <zack> so the first 3 items on orestis' plate are still pending, and blocked on me
13:03:58 <matthieucan> but is blocked by the testdata
13:04:18 <zack> matthieucan: oh, ok
13:04:23 <zack> so it "just" need testdata update now?
13:04:36 <zack> anyway, I'm on it
13:04:41 <jpleau> PR#22 looked good to me too, I checked each commits and commented here and there
13:04:46 <matthieucan> yeah, and I still need to review it deeplier
13:05:01 <zack> I'll try to update the testdata soon then -- unless someone wants to pick it up
13:05:03 <jpleau> I haven't tested it though :)
13:05:06 <zack> I can probably do it over the week-end
13:05:07 <orestis> hehe, it is not that of a blocker. i mean i am basing future work on that but its ok for now
13:05:12 <matthieucan> TBH I have no idea how it works
13:05:44 <zack> it's like: apply code; run the updater on your real system; recreate the DB dumps (there's a makefile for that); fix all broken tests
13:05:51 <zack> (e.g., stats and the like)
13:06:35 <zack> anyway: orestis: what's next after PR#22?
13:06:45 <orestis> PR#21 got merged
13:06:52 <orestis> the views for the file-by-file apoi
13:06:56 <orestis> api*
13:07:00 <zack> *nod*
13:07:03 <matthieucan> yep, that was great
13:07:28 <orestis> license statistics is almost finished but i can't PR anyway before PR#22
13:07:34 <zack> indeed
13:07:42 <zack> orestis: all is clear on the expected behavior now?
13:07:55 <orestis> yeap
13:08:00 <zack> cool
13:08:09 <zack> what else?
13:08:16 <orestis> that's all this week
13:08:28 <zack> so the 2 items mentioning PR#21 can go under reviewed, right?
13:08:29 <orestis> i didn't have time for the other cards
13:08:32 <orestis> yes
13:08:53 <zack> good work!
13:08:57 <zack> #topic orestis - next week
13:09:03 <zack> how about next week?
13:09:30 <matthieucan> orestis: what about the doc? any improvement on that?
13:09:42 <orestis> i should finish the license stats, work on the things i picked up last week and probably spdx
13:09:52 <matthieucan> (afk)
13:10:14 <zack> looks good to me
13:10:24 <orestis> i didn't have time for the other three cards on this week yet.. i spend much time on license statistics
13:10:49 <zack> please assign to yourself the relevant tasks
13:11:00 <orestis> yeap doing this now :)
13:11:03 <zack> (also, next week will be shorter, as we meet on thu)
13:11:22 <zack> #topic clemux - weekly review
13:11:27 <zack> clemux: your turn!
13:12:10 <clemux> first task: add_package hook for hello world plugin
13:13:13 <zack> (clemux is having network issues, apparently)
13:14:52 <clemux> since the plugin doesn't do much, it was easy, but now the call_hooks tasks is ready for other plugins
13:15:02 <zack> he's back \o/
13:15:04 <zack> *nod*
13:15:36 <clemux> next task, which I added during the week because I spent some time on it: how to make pluggable celery tasks
13:15:49 <clemux> the documentation was merged in PR #23
13:16:09 <clemux> and I updated the hello world plugin, which does not depend on the updater's celery app anymore, in my branch
13:16:18 <zack> ok, cool
13:16:59 <zack> anything else?
13:17:03 <clemux> next task was supposed to be "update tests for testing async updater", but first I had to make the tasks pass with my changes
13:17:15 <zack> yeah, the fight with tests :)
13:17:26 <clemux> I should have done that earlier, when I made the changes to db_storage and fs_storage, but I didn't
13:17:40 <clemux> so, I fought with the test suite yesterday and this morning
13:17:51 <zack> did you win?
13:17:58 <orestis> :P
13:17:59 <clemux> I still couldn't run everything, but I worked around it and disabled the webapp tests
13:18:36 <clemux> and I fixed the tests, the sync updater and db/fs_storage (trello task "make updater pass unit tests (changes to db_storage, fs_storage, debmirror)
13:18:41 <clemux> ")
13:18:46 <zack> cool
13:18:59 <zack> so what stages / plugins still need porting to async now?
13:19:08 <clemux> so I've started working on creating a test suite for the sync updater
13:19:20 <clemux> that's it for the week
13:19:27 <zack> (you mean "async", right?)
13:19:34 <clemux> async, sorry
13:19:38 <zack> ok, cool
13:19:57 <zack> #topic clemux - next week
13:20:01 <zack> what's next now?
13:20:37 <clemux> 1) finish the test suite for the async updater
13:21:01 <clemux> 2) debug/fix a problem in the extract_new stage: the file_table retrieved from the DB is always None
13:21:20 <zack> oh, ok, that's bad indeed
13:21:47 <zack> back to my previous question: how many stages / plugins still need porting to async?
13:21:50 <clemux> 3, 4, 5, 6) port the 4 plugins to celery tasks
13:22:05 <zack> all the other stages are done already?
13:22:10 <clemux> zack: no :(
13:22:19 <clemux> I only worked on the extract_new stage
13:22:23 <zack> ok
13:22:36 <zack> so you prefer working on the plugins than on the other stages, right?
13:22:42 <zack> (it's to understand the status, no worries :))
13:22:50 <clemux> yes
13:22:55 <zack> fair enough
13:23:06 <clemux> though I'll update the rm_package hooks at the same time, since it's mostly the same thing
13:23:19 <clemux> (well, make them celery tasks, not test them in depth)
13:23:22 <zack> looks good to me
13:23:41 <zack> please fiddle with the tasks on trello as needed
13:23:42 <clemux> I think the update_suite and maybe the gc stages could be done next week
13:23:49 <clemux> but I've always been too optimistic until now
13:24:00 <zack> indeed, I was about to say: let's avoid overcommitting
13:24:25 <zack> anything else before we move to misc?
13:24:39 <clemux> I should add one task though: make the async updater use the desources configuration
13:24:52 <zack> uh? what does it use now?
13:24:54 <clemux> I've starting preparing for that, using structures similary to the configuration
13:24:59 <clemux> similar
13:25:08 <clemux> but it's still hard-coded
13:25:20 <zack> oh, and that's was part of the test case failures?
13:25:35 <zack> but yes, definitely, it should use the same conf
13:25:41 <zack> maybe you should pass it as a parameter of the jobs
13:25:48 <zack> so that the central updater sends it to the workers
13:25:49 <clemux> yup
13:25:57 <zack> that way we know they're all on the same page
13:26:16 <zack> I suggest prioritizing this task then
13:26:21 <zack> it looks pretty important to me
13:26:25 <clemux> got it
13:26:36 <zack> ok, let's move on
13:26:37 <zack> #topic misc
13:26:50 <zack> free for all!
13:26:55 <orestis> nothing from me
13:27:04 <jpleau> hmm
13:27:26 <zack> jpleau: what's brewing? :)
13:27:37 <jpleau> For the rendering of a file's license, was it planned to rework the rendering (the design)
13:28:16 <zack> jpleau: if there is something you don't like, certainly ;-)
13:28:17 <zack> orestis: ?
13:28:50 <jpleau> It works great, I wasn't sure about how the folding was laid out particularly, I can make a list of suggestions and make a github issue
13:28:53 <orestis> jpleau: i am not sure i understand. i plan on redoing the links for the license synopsis
13:29:08 <orestis> that's all i am aware of
13:29:19 <zack> jpleau: by all means, if you've improvements to suggest, please report them
13:29:51 <jpleau> sure :)
13:30:04 <zack> anything else?
13:30:47 <clemux> I'm fine
13:31:01 <zack> let's adjourn then
13:31:33 <zack> #endmeeting