12:59:48 <zack> #startmeeting
12:59:48 <MeetBot> Meeting started Fri Jun 19 12:59:48 2015 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:48 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:59:55 <zack> #topic roll call
12:59:57 <zack> who is here?
13:00:00 * zack is
13:00:02 * orestis 
13:00:17 <zack> matthieucan: jpleau: clemux: ping
13:00:22 <matthieucan> zack: pong
13:00:30 <jpleau> zack: pong
13:00:53 <clemux> pong
13:01:09 <zack> next week, same time?
13:01:14 <clemux> ok for me
13:01:15 <orestis> fine for me
13:01:16 <jpleau> yep!
13:01:36 <zack> #agreed next meeting next week, usual time slot
13:01:37 <matthieucan> yes!
13:01:42 <zack> #topic weekly review - orestis
13:01:51 <zack> orestis: you're up
13:02:29 <orestis> so PR#10 got merged.. so file-by-file api items are done
13:02:42 <zack> \o/
13:02:51 <zack> so can go to reviewed
13:03:36 <orestis> then pr#12 for the batch doc is done.. i need to send a small patch for url schema we were discussing yesterday
13:03:52 <zack> orestis: we're good on that topic now?
13:04:02 <zack> so it's URL encoded, right?
13:04:06 <orestis> yeap
13:04:17 <zack> just say so, and possibly turn the current code into a _python_ code exemple, using requeusts
13:04:29 <orestis> yeap i am planning on doing so
13:04:32 <zack> wonderful
13:04:46 <matthieucan> happy this worked out :)
13:04:47 <zack> let's leave the task where it is; if you can update the PR later, i'll be happy to merge it on the fly
13:05:04 <orestis> yes sure
13:05:07 <jpleau> matthieucan: yep, was a good "debate" :P
13:05:32 <matthieucan> jpleau: indeed, and I worked on my http knowledge ;)
13:05:46 <orestis> ^^
13:05:47 <zack> (yeah, sorry, I hope I havent' been rude :( )
13:05:55 <zack> was not my intention
13:06:06 <orestis> not at all!
13:06:33 <orestis> then there's PR#15 which got merged yesterday
13:06:42 <zack> cool, move to reviewed then too
13:06:45 <jpleau> zack: nah, all good :)
13:07:07 <orestis> fixing the 500 error and added better heuristics for determining machine readable files
13:07:40 <zack> orestis: ok, what else?
13:07:41 <orestis> and still pending the work for the views (PR#11) which i need to do some more testing i think
13:07:54 <matthieucan> orestis: 500 error is linked to PR#11, right?
13:07:57 <zack> ok, so PR#11 is still ongoing
13:08:09 <zack> orestis: should it be under Done then?
13:08:39 <orestis> matthieucan: no it was for the #15.. (remember the 500 error for libreoffice when there was a typo...)
13:08:52 <orestis> yes maybe i have to change it to doing yes
13:08:53 <matthieucan> orestis: oh I see, I misunderstood then
13:09:46 <zack> orestis: the other item PR#11 is done?
13:09:55 <zack> "license api (batch) contains modif..."
13:09:58 <zack> I don't get what that is
13:10:38 <orestis> so the implementation of the batch api is done.. although i based my work on PR#11.. and as PR#11 is not merged i can't Pull Request it..
13:10:49 <zack> oh, I see
13:11:02 <zack> so maybe annotate it as "PR pending; waiting for PR#11"
13:11:05 <orestis> but i can fix this tonight since the views are going to require more work
13:11:07 <zack> that would make the status clearer
13:11:12 <orestis> yes sure
13:11:32 <zack> so PR#12 is still pending too, right?
13:11:39 <zack> oh silly me
13:11:40 <zack> we'
13:11:45 <zack> ve discussed that already. sorry
13:11:57 <zack> orestis: anything else before we plan next week?
13:12:21 <orestis> for the db schema i prepared something.. i am sending an email today or tmr..
13:12:34 <zack> ok
13:12:35 <orestis> and that's all for this week
13:12:40 <zack> so, next topic
13:12:45 <zack> #topic next week - orestis
13:12:53 <zack> what would you like to pick?
13:13:33 <orestis> so i intend to finish the views and the db schema.. and then the d/copyright plugin
13:14:14 <orestis> is this ok?
13:14:17 <zack> what do you mean with d/copyright plugin?
13:15:10 <orestis> well you added it on trello :p.. i understand this as retrieving the license of files on update time
13:15:19 <zack> let me review it :)
13:15:31 <zack> ah, yes, that's it :)
13:15:46 <zack> that would complete the circle with working on the db schema, yes
13:15:51 <zack> so cool, looks good to me
13:15:54 <orestis> i hope this won't interfere with clemux though
13:16:11 <clemux> we probably should split this task
13:16:21 <clemux> 1. plugin for sync updater
13:16:30 <clemux> 2. port plugin to async updater once it's ready
13:16:38 <clemux> that way it wouldn't interfer with my work
13:16:46 <zack> right, I like small steps, so orestis can probably pick up 1, right?
13:17:03 <zack> clemux: porting it to async should be relatively easy, once the code for the sync part is available, I guess
13:17:10 <clemux> yup
13:17:15 <orestis> fine by me!
13:17:18 <zack> ok, deal!
13:17:25 <zack> we can move to next topic then
13:17:33 <zack> #topic weekly review - clemux
13:17:37 <zack> clemux: you're up!
13:18:10 <clemux> so, 1. how to handle the session in tasks
13:18:35 <clemux> the doc was merged in PR  #14
13:18:40 <zack> k
13:19:09 <zack> clemux: was PR#14 on trello? I don't see it...
13:19:54 <zack> see it now, thanks
13:19:55 <clemux> I juste added it
13:20:08 <clemux> I'll add that to the other tasks from now on
13:20:15 <zack> cool
13:20:18 <zack> (and you can move that to reviewed)
13:20:25 <zack> what else?
13:20:30 <clemux> next task, update the prototype with sqlalchemy queries
13:20:51 <zack> that's in your branch somewhere?
13:20:56 <zack> I haven't checked that
13:21:12 <clemux> that was done in the PR #13, that you merged into the branch async
13:21:25 <zack> ah, ok
13:21:35 <zack> fwiw I'm not reviewing stuff that's not in master for now
13:21:50 <clemux> oh, ok
13:21:51 <zack> the idea being that merging into master is the gate keeping
13:22:02 <zack> so, if you want feedback on some specific code in other branches, just let me know
13:22:08 <clemux> got it!
13:22:25 <zack> what else?
13:22:38 <clemux> deisgn: failure mode for hooks
13:23:21 <clemux> this was decided last week and was merged this week in PR #16
13:23:37 <zack> great, please add PR#16 to the title, and move to reviewed
13:23:53 <zack> the other two seems done to me as well, right?
13:24:44 <clemux> next: define which tasks need what data
13:25:04 <zack> it's in the last incarnation of the graph, isn't it?
13:25:16 <clemux> yes
13:25:21 <clemux> in PR #17
13:25:34 <zack> great -> add number and move to archived
13:25:41 <zack> sorry: *reviewed*
13:26:00 <clemux> not merged yet, though (I think I did something wrong, I'll check after the meeting)
13:26:11 <zack> ah, it's yesterday's evening PR, that doesn't apply
13:26:16 <clemux> yup
13:26:21 <zack> ok, leave it there, and ping me when you've something that I can get into master
13:26:25 <zack> last topic: data locality
13:26:41 <clemux> I just realized that that task was done in the same PR
13:26:51 <clemux> (it's the commit that add stuff to doc/celery.txt)
13:26:55 <zack> I know we discussed/solved it, but I'm unsure it went in
13:27:00 <zack> ok, great
13:27:08 <zack> so, same treatment
13:27:15 <zack> looks like a very productive week for both of you :)
13:27:26 <clemux> that's it for the week
13:27:39 <zack> #topic next week - clemux
13:27:48 <zack> what would you like to pick for next week?
13:27:53 <clemux> I still have a lot of tasks in the current week list
13:28:28 <zack> oh, right :) so you'd like to preserve all of them
13:28:35 <zack> or maybe put something back to backburner?
13:28:50 <clemux> I think I still have too many coding tasks in the queue
13:29:00 <zack> possibly, yes
13:29:14 <clemux> I'm not sure how I should start
13:29:29 <clemux> I initially planned to implement the base stages first, without hooks
13:29:40 <zack> so, it's not clear to me how easy it is to test individual stages if you haven't ported the updated itself
13:29:45 <zack> can you easily do that?
13:30:09 <zack> the good news is that the updater is relatively stable, so the chances it will change while you're working on its async replacement are pretty low
13:30:16 <clemux> but now i wonder whether implementing the extract_new stage fully, with the plugin architecture, wouldn't be better
13:30:34 <clemux> since it's the hardest thing to design correctly
13:30:51 <zack> that's ambitious, but it probably reduces the chances of "wasting" work on stuff that will have to be changed later on
13:30:54 <clemux> and I might step onto unforeseen problems
13:30:57 <zack> because we discover the arch/protocol doesn't work
13:31:02 <clemux> exactly
13:31:05 <zack> clemux: so, if you want to pick that up, I'm all for it
13:31:46 <zack> so, public service announcement, if you want to touch the updater in the upcoming week: please let clemux know
13:31:57 <clemux> ok, put the gc, update_suites and update_metadata tasks in ToDo
13:32:00 <zack> we would like to avoid creating backporting backlog if it's not needed
13:32:07 <zack> great
13:32:12 <clemux> and the plugint asks to this week
13:32:23 <clemux> they will need reorganizing, though
13:32:30 <zack> probably, but no need to do it now
13:32:42 <orestis> sorry to jump in.. wouldn't creating the d/copyright plugin interfere then?
13:32:51 <zack> orestis: not really, no
13:33:00 <zack> because you can create it sync, as the other current plugins
13:33:12 <zack> porting to async would essentially mean wrapping them into some boilerplate, mostly
13:33:21 <zack> ( clemux: right? )
13:33:26 <clemux> yup
13:33:31 <orestis> but i ll have to touch the updater base to include that stage no?
13:33:32 <zack> orestis: so your work on it will easily be portable to async, when the core is ready
13:33:43 <zack> orestis: nope, it should just be a configuration line
13:33:58 <zack> it's the plugins that register into the updater, not vice-versa
13:34:18 <zack> they're _real_ plugins, at least in that sense (they aren't in many other ways though :))
13:34:37 <orestis> ok works :)
13:34:46 <zack> ok, last topic then
13:34:47 <zack> #topic misc
13:34:57 <zack> free for all! anything else to discuss?
13:35:26 <clemux> nope
13:35:40 <zack> jpleau: matthieucan: I've kinda monopolized this meeting, sorry about that
13:35:52 <matthieucan> zack: no problem :)
13:36:07 <matthieucan> well done for handling all of that :o
13:36:12 <zack> cheers
13:36:17 <zack> oh, maybe useful info
13:36:26 <zack> this week we've deployed ~60 pending commits to sources.d.n
13:36:35 <zack> and the world is still in one piece, surprisingly enough
13:36:48 <matthieucan> well done everyone, then!
13:36:56 <zack> orestis: I think that also includes a very old change of your, regarding stats and graphs
13:37:01 <zack> but I haven't checked the result yet
13:37:18 <zack> looks like we can adjourn
13:37:35 <zack> #endmeeting