10:59:44 <zack> #startmeeting
10:59:44 <MeetBot> Meeting started Fri May 29 10:59:44 2015 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:59:44 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:59:49 <zack> #pingall
10:59:55 <zack> gah, wathever :)
10:59:58 <orestis> pong
10:59:59 <zack> #topic roll call
11:00:00 <orestis> :p
11:00:09 <zack> clemux: matthieucan: around?
11:00:16 <clemux> I'm here
11:00:51 <matthieucan> yep, sorry
11:00:52 <matthieucan> Hi everybody
11:00:55 <zack> heya!
11:00:59 <zack> #topic next meeting
11:01:15 <matthieucan> chances are I'll be traveling next friday afternoon
11:01:15 <zack> so, it's been proposed to move the weekly meeting to Fri, 15 CEST to allow to jpleau to participate
11:01:28 <matthieucan> ok in general, won't be here next week
11:01:30 <zack> ok, so we've 2 decisions to make, I'll explain
11:01:42 <zack> as per previous discussions, it's _in general_ ok to move, so:
11:01:51 <zack> #agreed regular weekly meetings moved to Fri, 15 CEST
11:02:07 <zack> I'll have a problem as well next Fri, all day "soutenances de projet" with students
11:02:22 <zack> given matthieucan will not be around either, how about anticipating it to Thu, but just for next week?
11:02:42 <orestis> fine for me
11:02:45 <matthieucan> iden
11:02:45 <clemux> ok for me
11:02:47 <matthieucan> idem
11:02:48 <zack> ok
11:03:00 <zack> #agreed for next week only, meeting anticipated to Thu, 15 CEST
11:03:11 <zack> #topic weekly review - clemux
11:03:23 <zack> clemux: you're on stage :)
11:03:31 <zack> let's go briefly to your work for this week, one item at a time
11:03:36 <zack> s/to/through/
11:04:40 <zack> clemux: ?
11:05:25 <zack> (1 more min, than we switch to orestis, to avoid idling everyone)
11:05:40 <clemux> yes sorry
11:06:09 <clemux> my research on persistence and transaction tasks with celery are here https://github.com/clemux/debsources/blob/async/doc/celery.txt
11:06:42 <zack> clemux: cool, so short summary is "they can be made transactional, as long as they're idempotent", right?
11:07:08 <matthieucan> because "at least once" semantics?
11:07:30 <clemux> can be made persistent, yes
11:07:39 <zack> but anyhow, there is no need to enter into details now, I'll review that document, and we can discuss it after the meeting to decide what to do for our tasks
11:07:39 <clemux> if a worker crashes, the task won't be retried by default
11:07:44 <zack> clemux: (yes, sorry, persistent)
11:08:17 <zack> clemux: how about the prototypes?
11:08:20 <clemux> summary on transactional tasks: not possible, several libraries try to do that but I'm not sure how they would work for us
11:08:55 <clemux> summary on prototypes: I've had more trouble setting up celery than I thought
11:09:20 <zack> ok, spending more time than expected there is not a big deal
11:09:21 <clemux> and then I'm run into issues pickling SourcePackage, for passing a package through tasks
11:09:26 <zack> but do you see any blocker?
11:09:45 <zack> I _think_ that might be done to some deb822 weirdness, but I'm not too worried
11:10:05 <zack> I guess we can either serialize the needed information by hand
11:10:06 <clemux> I can see two solutions: only pass package names/versions, and make each task retrieve the package from the mirror
11:10:14 <zack> yes, that's the other possibility
11:10:45 <clemux> 2) not serialize the deb822 stuff that is not needed
11:11:02 <zack> looks like we're aligned on the possibilities
11:11:12 <clemux> actually, 3) build a smaller object from SourcePackage with only essential data, to be serialized
11:11:22 <zack> ok
11:11:43 <zack> no need to decide on that now during the meeting, please ping us post-meeting (even during the week) and we'll decide what to do
11:11:51 <clemux> ack
11:11:57 <zack> anything else to report about the past week?
11:12:37 <zack> if not, let's move to task for next week: what would you like to pick?
11:13:03 <clemux> well, I need to discuss the scrumban workflow, several things were not right for me (tasks not granular enough that I should have split earlier)
11:13:09 <clemux> maybe later?
11:13:18 <zack> yes, I plan to have a specific section of this meeting dedicated to that
11:13:50 <zack> clemux: do you have stuff that you can pick right now, or do you need to wait for the workflow discussion to be able to do that?
11:14:14 <clemux> for next week: 1) finish the protoype will all basic stages 2) design the protocol/events 3) change the prototype according to that protocol, maybe 4) implement the  extract_new stage
11:14:31 <zack> sounds awesome :)
11:14:50 <zack> clemux: please create the corresponding tasks, if missing, and assign them to yourself, in the "this week" column
11:15:18 <zack> (thanks)
11:15:23 <zack> #topic weekly review - orestis
11:15:26 <zack> orestis: you're up!
11:15:39 <orestis> yep
11:15:59 <matthieucan> there's a pending PR that I'm reviewing, looks perfectly ok for me :)
11:16:12 <zack> and that's a PR that will address which item?
11:16:13 <matthieucan> I'll merge it this evening
11:16:29 <orestis> if that's ok then i can submit another PR for the nav code in copyright BP
11:16:48 <orestis> the current PR is about the refactoring of the nav code
11:16:55 <zack> ok
11:17:10 <orestis> and if nothing is supposed to change in that i can submit another one for browsing
11:17:19 <zack> the copyright.d.n spec review item is done as well, right?
11:17:22 <matthieucan> are they ready already?
11:17:28 <zack> orestis: do you want me to go through the new .txt file?
11:17:31 <orestis> yeap
11:17:34 <zack> (I haven't yet)
11:17:42 <orestis> yeap was the answer to matthieucan
11:18:02 <orestis> zack: well as you want. i think i ll modify again as soon as the new tasks are picked
11:18:12 <matthieucan> orestis: oh alright, then sorrt again for latency. I'ts merge ready, I only need my ssh key ^^
11:18:22 <orestis> i did not change much things though
11:18:29 <zack> orestis: it's really up top you. For now I will _not_ review it then; please ping me when you want me to
11:18:52 <zack> just do not assume I'll do that unless you ping me explicitly :)
11:19:02 <orestis> heh ok :)
11:19:15 <matthieucan> orestis: so the whole task item is done on your machine? everything works?
11:19:28 <matthieucan> the browse d/copyright I mean
11:19:31 <zack> the only other item that we haven't discussed yet is browse d/copyright files, right?
11:19:34 <orestis> matthieucan: i think i want to change something on my PR.. we can discuss this later right?
11:19:43 <matthieucan> orestis: sure
11:19:51 <orestis> yes on my machine everything is ready for browse d/copyright
11:19:52 <matthieucan> you mean PR#4 or the next one?
11:20:01 <matthieucan> zack: yeah the pending PR is about that
11:20:06 <orestis> PR#4
11:20:07 <zack> I see, thanks for clarifying
11:20:26 <matthieucan> orestis: alright, then should I wait before merging it?
11:21:08 <orestis> its really something minor i need to test.. maybe i changed something i didn't need to in the macros.. are you merging tonight?
11:21:35 <orestis> i can check this out after the meeting
11:21:35 <matthieucan> I can't merge before tonight, but I can definitely wait if you want to :)
11:21:40 <matthieucan> anytime
11:21:47 <zack> looks like you two are on top of this item anyhow
11:21:48 <orestis> yes tonight is fine :) i ll let you know
11:21:55 <matthieucan> perfect
11:21:58 <zack> so we can move the details after the end of the meeting
11:22:03 <matthieucan> zack: alright
11:22:09 <zack> and, awesome, good progress for both clemux and orestis it seems!
11:22:23 <zack> orestis: what do you want to pick for next week?
11:22:34 <matthieucan> (yes, kudos for this first week ;) )
11:22:44 <zack> (it's quite exciting, yes! :))
11:22:59 <orestis> render of d/copyright files, dump of non machine readable ones.
11:23:16 <matthieucan> render = parsing/styling?
11:23:17 <orestis> i don't know if the render is something huge though.. i didn't have time to think that :/
11:23:26 <orestis> yes
11:23:32 <zack> so, there is a parser for that already, in python-debian
11:23:42 <matthieucan> yes
11:23:43 <zack> it should just be a matter of deciding how to proper show them
11:23:55 <zack> and for the non-machine-readable ones, you probably just want a <pre>...</pre>
11:24:11 <zack> ok, that item sounds good
11:24:16 <zack> anything else you'd want to pick?
11:24:16 <orestis> yeap i checked that. so if its only styling i need to do maybe i can research the SPDX format
11:24:45 <zack> sounds good too, it'll probably take a while to wade through the format spec
11:25:08 <zack> anything else? (note: no pressure intended, it's really up to you to estimate how much you thing you'll do next week :))
11:25:17 <zack> (I ask only to know when we can move to next item on the agenda ;))
11:25:22 <matthieucan> yeah better to check that in advance. But I think it's lower priority than "render license of individual files" e.g.
11:25:45 <zack> matthieucan: good point
11:26:10 <zack> I guess the main reason to take a "research SPDX" item would be if orestis would like to alternate between coding and non-coding tasks during the week
11:26:19 <matthieucan> orestis: I'd suggest splitting this in two tasks: check/learn the format, and write the export code
11:26:35 <matthieucan> zack: yes
11:26:38 <orestis> yes that's what i want
11:27:05 <zack> orestis: please do that then, and assign to yourself the relevant items, under "This week"
11:27:28 <orestis> if i finish early can i pick something else later during the week? i am not sure how much time that would need :/
11:27:45 <zack> orestis: sure, there is no shortage of stuff to do :)
11:27:54 <orestis> heheh ok! then i ll do that :)
11:28:08 <zack> awesome, let's move to next (and last) item then
11:28:13 <zack> #topic work flow review
11:28:14 <matthieucan> orestis: perfect :) don't forget to move the items we just mentioned
11:28:31 <orestis> sure i ll do that after the meeting :)
11:28:33 <zack> I have 3 comments, than we can take every questions you might have
11:28:46 <zack> 1) was renaming the list to be "This week", which we've done shortly before the meeting
11:29:15 <zack> 2) it is better to not move the item to "done" during the week, as that makes the meeting a bit more cumbersome
11:29:33 <zack> so, either a) you keep the stuff under "this week" even when it is done, and we move there together during the meeting
11:29:55 <zack> or b) you move stuff to "done", and we add a "reviewed" list *after* done, and we move stuff from done to reviewed during the meeting
11:30:00 <zack> I'm fine with either option
11:30:03 <zack> comments?
11:30:16 <clemux> I like the "reviewed list" solution better
11:30:23 <matthieucan> depends if we're limited in height or width on trellom I guess :D
11:30:35 <orestis> agree with clemux
11:30:41 <zack> matthieucan: I guess it depends on screen size :)
11:30:55 <zack> ok, I like that one more too, because it will give you a sense of completion when you move stuff to "done"
11:30:59 <zack> so, let's do that
11:31:09 <zack> #agreed add a "reviewed" list, after "done"
11:31:14 <matthieucan> great :)
11:31:19 <zack> any volunteer to implement that?
11:31:38 <orestis> aye
11:31:39 <zack> (of course you can directly move there all the "done" items that we've discussed today"
11:31:44 <zack> orestis: thanks!
11:31:59 <zack> my last comment was related to what clemux was asking, I think
11:32:17 <zack> 3) task refactoring: feel free to split tasks/add new sub tasks on trello anytime you see fit
11:32:29 <zack> especially when something you're working on is not already represented on the board
11:32:42 <zack> clemux: does that adress your doubts on the work-flow?
11:32:52 <clemux> yes :)
11:32:57 <zack> mind reading ;)
11:33:27 <zack> maybe just ping us here when you've done so but, as they say, "be bold"  and do not wait for our comments before doing it
11:33:36 <zack> after all, there is nothing that cannot be easily undone
11:33:53 <zack> any other question/comment on the work-flow?
11:34:08 <clemux> that's what I did this week, but I wanted confirmation that it's okay
11:34:25 <clemux> no other question
11:34:27 <zack> it's totally ok
11:34:36 <zack> #topic misc
11:34:46 <zack> any other stuff to discuss / questions?
11:35:07 <orestis> nop
11:35:20 <clemux> not that I can think of
11:35:40 <matthieucan> nothing for me, pretty happy with your work and the ambiance here :)
11:35:55 <zack> same here, kudos for this exciting start
11:35:58 <zack> let's adjourn the meeting
11:35:59 <zack> #endmeeting