10:58:35 <matthieucan> #startmeeting
10:58:35 <MeetBot> Meeting started Thu May 21 10:58:35 2015 UTC.  The chair is matthieucan. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:58:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:58:49 <matthieucan> #topic what's up
10:58:51 * clemux ready
10:58:59 <matthieucan> any information to write before we review the points?
10:59:18 <clemux> nothing from me
10:59:23 <orestis> me neither
10:59:30 <matthieucan> cool
10:59:36 <matthieucan> #topic next week preparation
10:59:48 <matthieucan> so, have you picked any precise items?
11:00:10 <matthieucan> just saw the new async updater items
11:00:13 <matthieucan> great job
11:01:15 <matthieucan> I created a list for next week items
11:01:21 <matthieucan> please move the relevant tasks there
11:03:47 <clemux> I will 1) research the queue managers (should be quick, rabbitmq looks like the best choice), 2) make a 'hello world' example updater using celery, what won't do much but will help me for 3) research whether/how celery can be made transactional and guaranteed not to lose tasks
11:04:22 <matthieucan> clemux: great
11:04:27 <clemux> I moved those tasks to the list
11:04:31 <matthieucan> it might be nice to document your search results in doc/
11:04:44 <orestis> i ll finish the copyright spec file and then do the refacroting of the nav code..
11:04:57 <clemux> matthieucan: that was my plan, yes
11:05:04 <matthieucan> so that we see the advancement, and don't lsoe anything. Might be helpful for me as well since I don't know celery at all
11:05:10 <matthieucan> clemux: perfect
11:05:49 <matthieucan> orestis: ok. Any subtasks ideas? do you know where to begin with the refactoring?
11:06:41 <matthieucan> clemux: orestis: Trello permits to add "Due dates" to items. If you can/want set deadlines, I think it'd be nice
11:07:16 <orestis> yes i need to refactor SourceView (move the package relevant code to the core app) and then move templates accordingly
11:07:30 <clemux> I think I'll add tentative deadlines to my tasks after doing preliminary research this WE
11:08:07 <matthieucan> orestis: cool, don't hesitate to ping me on that
11:08:08 <matthieucan> clemux: ack
11:08:49 <orestis> i should have ready the spec file by Monday.. the other two tasks i guess i ll update the board by Monday again
11:09:29 <matthieucan> I agree with next week's items for both of you, if you complete them you'd be diving deep enough in the code base :)
11:09:48 <matthieucan> orestis: ok
11:09:55 <matthieucan> thanks for the date, looks good
11:10:45 <clemux> matthieucan: also I think the "research transactionality" and "sample celery program" should be split into subtasks, but I'm not sure how exactly at the moment
11:11:26 <matthieucan> clemux: ok, feel free to split when you know more in that case
11:11:49 <orestis> shall i split the navigation code?
11:11:51 <matthieucan> so if I understand correctly, we should receive patches from both of you before monday? c.d.n file for orestis, and doc/celery for clemux ?
11:12:10 <orestis> yeap
11:12:11 <clemux> matthieucan: yes
11:12:35 <matthieucan> orestis: yes, sure. Unless it creates too small tasks I think it's better to split, so that we see the advances/blockers/etc more precisely
11:14:10 <matthieucan> clemux: orestis: anything else regarding next week's tasks?
11:14:21 <clemux> that's all for me
11:14:48 <orestis> fine by me
11:14:55 <matthieucan> awesome
11:14:59 <matthieucan> #topic next meeting
11:15:05 <matthieucan> everybody ok for next friday?
11:15:08 <matthieucan> 1pm CET
11:15:11 <clemux> yes
11:15:14 <orestis> yes
11:15:34 <matthieucan> #agreed Next meeting Fri 29, 13:00 CET
11:16:00 <matthieucan> #topic conclusion
11:16:14 <matthieucan> I'm pretty happy with next week's plan, looks clear and efficient to me.
11:16:17 <matthieucan> anything to add?
11:16:52 <orestis> nope
11:16:58 <clemux> me neither
11:17:23 <matthieucan> awesome! in that case, thanks for joining and good luck for your respective tasks
11:17:24 <matthieucan> #endmeeting