17:57:46 <spwhitton> #startmeeting
17:57:46 <MeetBot> Meeting started Tue Oct 10 17:57:46 2023 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:57:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:57:52 <spwhitton> #topic Roll Call
17:57:53 <Myon> Christoph Berg
17:57:55 <spwhitton> Sean Whitton
17:57:56 <smcv> Simon McVittie
17:57:57 <tumbleweed> Stefano Rivera
17:58:22 <mjg59> Matthew Garrett
17:58:23 <Emperor> Matthew Vernon
17:58:31 <spwhitton> Myon: glad you could join us :)
17:58:36 <helmut> Helmut Grohne
17:58:47 <Myon> a bit tired, but I'm here :)
17:59:22 <spwhitton> roehling: ping
17:59:42 <roehling> Timo Röhling
17:59:49 <spwhitton> welcome welcome
17:59:54 <roehling> ^^
17:59:55 <spwhitton> #topic Review of previous meeting's AIs
18:00:05 <spwhitton> helmut and smcv had AIs, and I think they are all done?
18:00:35 <helmut> huh. does someone have a link to the previous meeting at hand?
18:00:47 <smcv> http://meetbot.debian.net/debian-ctte/2023/debian-ctte.2023-08-08-17.58.html
18:01:37 <smcv> > helmut to get all changes that need to go to stable debootstrap into sid
18:01:43 <smcv> > smcv to prepare (old)stable update for debootstrap once helmut's upload has been in sid for three weeks
18:01:49 <smcv> which we have done, sort of
18:01:53 <helmut> hah. seems like I did my bug closure right after the previous meeting and then swapped it out
18:02:16 <smcv> the (old)stable updates are in -proposed-updates, but need d-i team review
18:02:30 <spwhitton> def. counts as "preparing" the updates :)
18:02:35 <helmut> I think that all happened
18:02:39 <spwhitton> do you anticipate that happening soon (enough)?
18:02:51 <smcv> we had two big things we needed to do
18:02:58 <smcv> 1. get buildds merged-/usr
18:03:14 <helmut> what also happened is that aurelien merged my dsa-puppet.git patch such that trixie buildds really are merged right now
18:03:18 <smcv> 2. change chroot creation sequence to facilitate some of helmut's work
18:03:40 <smcv> we have bypassed debootstrap for 1. as helmut said, so that part is out of the way
18:04:19 <helmut> part 2 will need about a month of my work before it becomes a unique blocker
18:04:27 <smcv> we eventually still need a debootstrap stable update (or possibly all official buildds using a backport) but only later
18:04:47 <spwhitton> I'm not sure it makes sense to continue to track any of this as TC action items, though?
18:04:50 <helmut> and even that is more of a lower bound
18:04:58 <helmut> spwhitton: +1
18:05:11 <smcv> I suppose Someone™ needs to learn how to do complete d-i builds so that we can do the testing to encourage kibi to review debootstrap
18:05:51 <spwhitton> well, if there are blockers, we can add it to next month's agenda.  let's move on to the moratorium repeal.
18:05:54 <smcv> I'll try to find time to do that, but no guarantees
18:06:02 <spwhitton> #topic Lifting the merged-/usr moratorium
18:06:43 <spwhitton> I think we can have a vote to repeal the advice, and instate new advice advising users to consult with [some description that picks out helmut and co.] before performing any moves ?
18:07:12 <helmut> yes please
18:07:16 <roehling> +1
18:07:19 <Myon> does that need a formal vote, or simply agreement in the meeting?
18:07:32 <helmut> I have started documenting that on https://wiki.debian.org/UsrMerge
18:07:47 <spwhitton> we could do it either way, but I think that people might like an official statement given that what we're undoing it an official statement
18:07:51 <helmut> given that we change a formal decision, we need a text and a vote, no?
18:08:27 <spwhitton> I'll come up with text and start a vote if no-one objects
18:08:31 <Myon> +1
18:08:34 <Emperor> 👍
18:08:39 <roehling> +1
18:08:51 <tumbleweed> +1
18:08:53 <spwhitton> #action spwhitton to start vote to repeal moratorium
18:08:53 <helmut> spwhitton: thank you. is it ok to defer the moratorium to that wiki page?
18:09:08 <spwhitton> helmut: I'm gonna come up with text that does that.  I think it's fine.
18:09:30 <spwhitton> okay.  is there any other merged-/usr business this month?
18:09:51 <smcv> my only concern about making a wiki page authoritative is that ... it's a wiki, so it would be very easy for someone angry about merged-/usr to insert misinformation
18:10:04 <spwhitton> smcv: I was thinking I'd write "as edited by those driving the transition" or somesuch
18:10:22 <helmut> I've subscribed the page. is that sufficient?
18:10:29 <smcv> yeah, I hope enough of us are subscribed to avoid that failure mode
18:10:38 * smcv subscribes
18:10:40 <Myon> let's worry about that when it actually happens
18:11:08 <spwhitton> yeah, I think temperatures are such that it should be okay, atm
18:11:17 <spwhitton> okay to move on smcv & helmut?
18:11:47 <helmut> unless you want more details on the state of /usr-merge, please go on. also the status is summarized on d-devel rather recently
18:11:56 <spwhitton> indeed, and thank you for that
18:12:08 <smcv> OK to move on
18:12:09 <spwhitton> thank you to smcv for his parts of the MRs & threads, too
18:12:13 <spwhitton> #topic Recruitment
18:12:21 <spwhitton> Simon will be leaving us soon, sadly
18:12:42 <spwhitton> We should write to d-d-a with the usual "we're always recruiting but now have an actual seat"
18:12:56 <spwhitton> And we should figure out which of our previous candidates we intended to write to the following year
18:13:09 <spwhitton> Apart from that, does anyone have thoughts on what we should do or not do?
18:13:39 <spwhitton> And, volunteers for those two tasks? :)
18:14:05 <Emperor> I'm not sure if my less-formal announcement last time worked better or less well than your more formal style
18:14:36 <tumbleweed> as a new recruit, I'll say that the arm-twisting mattered more than the style of the announcement
18:15:16 <Emperor> that's a shame, in that it means we're a bit limited to "candidates already known to the cttee" :-/
18:15:37 <spwhitton> #link https://lists.debian.org/debian-devel-announce/2022/08/msg00000.html
18:15:52 <helmut> am I right in recalling that spwhitton will be next after smcv?
18:15:58 <spwhitton> helmut: indeed
18:16:18 <spwhitton> #link https://lists.debian.org/debian-devel-announce/2023/04/msg00006.html
18:17:01 <helmut> in that case, I propose handing over the chair position, not because I have any issue with sean, but to have a smoother transition where the new chair can still draw from the experience of the previous chair being actively present.
18:17:19 <spwhitton> yes, I thought of this too.  I took over from marga during her final year.
18:18:49 <spwhitton> coming back to recruitment tho, would someone like to volunteer to write to d-d-a?  they would decide the tone of the message.  could just reuse one of ours, or whatever seems good.
18:19:52 <Emperor> I don't mind re-hashing my previous one
18:19:57 <spwhitton> cool thank you
18:20:06 <spwhitton> #action Emperor to write to d-d-a
18:20:42 <spwhitton> #action spwhitton to figure out which candidates we wanted to invite to be considered again
18:21:40 <spwhitton> I'm not sure we can do much more until we see how much interest our d-d-a post gets
18:21:48 <Emperor> Mmm
18:21:48 <spwhitton> We could be fine, and there's only one seat this time, not three.
18:21:55 <spwhitton> So, anything else on this?
18:22:06 <Emperor> I'll try and remember to suggest before-next-meeting-date
18:22:19 <spwhitton> Emperor: cool.  also it would be nice to "take the opportunity" to thank simon
18:23:34 <Emperor> surely
18:24:00 <spwhitton> but I suppose that is my formal wording isn't it :)
18:24:09 <spwhitton> #topic Any Other Business
18:24:13 <spwhitton> Is there anything else going on?
18:25:15 * Emperor has nothing further
18:26:00 <roehling> the common-licenses discussion is worht a look, but probably not going to involve us
18:26:12 <roehling> *worth
18:26:21 <spwhitton> yeah, I think Russ is doing a great job getting it sorted
18:28:29 <spwhitton> it will be really nice to stop having the same dsicussions about it in new policy bugs
18:29:32 <spwhitton> #endmeeting