17:58:07 <spwhitton> #startmeeting
17:58:07 <MeetBot> Meeting started Tue Jun 13 17:58:07 2023 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:07 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:58:11 <spwhitton> #topic Roll Call
17:58:12 <spwhitton> Sean Whitton
17:58:15 <Myon> Christoph Berg
17:58:16 <mjg59> Matthew Garrett
17:59:40 <spwhitton> Do join us on Jitsi for recruitment.
18:01:13 <smcv> Simon McVittie
18:01:52 <helmut> Helmut Grohne
18:01:56 <Emperor> Matthew Vernon
18:02:05 <spwhitton> #topic Recruitment
18:29:10 <spwhitton> #action spwhitton to handle the final admin for this
18:29:16 <helmut> Did I understand correctly that we move to the general /usr-merge aspect now?
18:29:44 <spwhitton> #topic Bug#1035904: dpkg currently warning about merged-usr systems
18:29:57 <helmut> Most of the things that changed happened at hamburg
18:30:08 <spwhitton> Based on things that have already been said on MLs and on Jitsi, we think we should close this bug as premature
18:30:15 <spwhitton> Is there someone who would volunteer to do the closing?
18:30:39 <Emperor> I can if no-one else wants to.
18:30:54 <mjg59> I've been largely uninvolved in the discussions so far, so maybe it looks better if I do?
18:31:01 <Emperor> +1
18:31:07 <spwhitton> #action mjg59 to close #1035904.
18:31:11 <spwhitton> thank you.
18:31:24 <spwhitton> #topic Working towards lifting the merged-/usr moratorium
18:31:27 <helmut> when I arrived there it looked as if I had a reasonable plan and so on and we had a bof where lots of people agreed with the way this is going. and then andreas beckmann came around with a new issue (empty directory loss) and I morphed that into multiarch:same file loss.
18:31:46 <spwhitton> #link https://subdivi.de/~helmut/dep17.html
18:31:53 <helmut> so now we know about 9 (nine) distinct problem categories.
18:32:03 <spwhitton> ah, sorry helmut, you said you didn't want to share that with the world quite yet, my apologies :\
18:32:26 <mjg59> helmut: Thank you for explicitly enumerating the set of categories, it's extremely helpful to have all of this in one place
18:32:37 <helmut> yeah, that's my working draft on rewriting it, the reason to not circulate it too wide was saving people's brain cycles for the later versions ;)
18:33:23 <Myon> which of these are "bad" and/or "fixable"?
18:33:30 <helmut> the new problem categories argue in favour for changing dpkg
18:34:15 <mjg59> I think I agree that based on this analysis, changing dpkg is the most complete solution
18:34:16 <helmut> I guess we have a majority for "we move all the files" and for "we don't teach dpkg about aliasing in general"
18:34:38 <helmut> mjg59: it also is the most involved one ;)
18:34:55 <mjg59> Yes, I was about to say "simplest" but I think that has the wrong connotations
18:35:23 <Myon> fixing dpkg was the best thing from the start but deemed infeasible
18:35:31 <helmut> Raphael Hertzog at some point proposed a very subtle change to dpkg's behaviour (dubbed M2 in the document)
18:36:11 <spwhitton> helmut: is it the case that changing dpkg has always been a good/the best option?  or have there been stages of your investigation where the other approaches you've been testing seemed better than doing that?
18:36:13 <helmut> and whether that's the best way forward is not clear to me at this time
18:37:00 <helmut> the table may make it look like changing dpkg would be the best of options, I'm far from convinced
18:37:21 <helmut> the big downside with that M1 option is that we cause a maintenance legacy
18:37:24 <spwhitton> that is helpful to know, thank you.
18:37:49 <spwhitton> what are the next questions you are hoping to find answers to?
18:37:53 <helmut> the partial change to dpkg is reversible once we are done
18:38:45 <helmut> My Freexian work plan here is: Get that DEP17 update into shape and base a consensus call on it
18:39:31 <helmut> there are multiple questions that independently need consensus such as whether the symlinks should be shipped in a data.tar. whether we want to change the bootstrap protocol. whether we want to modify dpkg.
18:39:34 <spwhitton> a consensus call on what solution or combination of solutions you think we should go for?
18:39:56 <helmut> and from these things, I can construct a strategy/proposal
18:40:58 <helmut> another question likely is whether people agree that the problems I identify are the ones we need to solve (missing/excess)
18:41:50 <spwhitton> if you want any review regarding trying to word things diplomatically in your final report, so to speak, I'm sure TC members would be up for it
18:41:54 <helmut> what it means to "finish" the transition is actually quite different depending on whom you ask
18:42:09 <spwhitton> currently this is a DEP.  are you thinking that's the appropriate process, that is, is it going to stay a DEP?
18:42:19 <helmut> defining that goal kinda is the most difficult thing about this whole matter
18:42:49 <helmut> raphael proposed the DEP process and I think the framework is useful
18:44:13 <spwhitton> okay.  well, we are all eagerly awaiting your next draft.
18:44:37 <spwhitton> I don't believe there is anything for the TC atm, so shall we move on?
18:44:52 <spwhitton> I mean, in an official capacity.
18:44:53 <helmut> more and more I have less and less of an opinion about it other than "can we please agree somehow?"
18:45:13 <helmut> yes
18:45:37 <spwhitton> thank you for your perseverance and attention to detail.
18:45:40 <spwhitton> #topic Any Other Business
18:45:48 <spwhitton> Does anyone have anything?
18:45:56 <Emperor> not I
18:46:00 <helmut> -
18:46:19 <mjg59> nope
18:47:13 <smcv> no
18:47:24 <Myon> not from me
18:47:41 <spwhitton> #endmeeting