18:03:41 <spwhitton> #startmeeting
18:03:41 <MeetBot> Meeting started Tue Jan 10 18:03:41 2023 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:41 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:03:50 <spwhitton> #topic Roll Call
18:03:51 <spwhitton> Sean Whitton
18:03:55 <smcv> Simon McVittie
18:03:58 <spwhitton> Apologies for lateness.
18:03:59 <helmut> Helmut Grohne
18:03:59 <mjg59> Matthew Garrett
18:04:01 <Myon> Christoph Berg
18:04:20 <Emperor> Matthew Vernon
18:04:45 <Myon> that's everyone
18:04:49 <spwhitton> #topic Review of previous meeting AIs
18:04:55 <spwhitton> welcome mjg59.
18:05:09 <Myon> welcome!
18:05:11 <mjg59> \o/
18:05:15 <spwhitton> have you found tech-ctte.git yet?  we don't have much introductory material other than that repo.
18:05:29 <mjg59> Nope, I'll check that out now
18:05:34 <Emperor> our Matthew density is almost good enough now ;-)
18:06:05 <spwhitton> can anyone else think of anything else we should point mjg59 towards?  I guess it is worth re-reading the relevant parts of the constitution if you haven't recently.
18:06:47 <Emperor> not OOTOMH
18:07:32 <spwhitton> okay cool.
18:07:33 <helmut> mjg59: I can recommend adding https://salsa.debian.org/debian/tech-ctte/-/blob/master/meetings.ics to your calendar (if you have some icalendar-ish thingy)
18:07:40 <spwhitton> ah yes, the famous .ics
18:08:02 <spwhitton> if you happen to use the emacs diary: %%(diary-float t 2 2) 11am tech-ctte meeting
18:08:21 <spwhitton> Myon: any updates on your AI?
18:08:40 <Myon> no, sorry
18:08:58 <spwhitton> okay.  do you want to keep it as an AI?  only if that's helpful to you.
18:09:18 <Myon> I should have time this month
18:09:22 <spwhitton> coolio
18:09:25 <spwhitton> #action Myon to continue working on updating our www.debian.org page
18:09:31 <Myon> December was complicated
18:09:52 <spwhitton> The other AIs are about recruitment and I completed them.  mjg59, you probably inferred, we didn't have enough candidates to fill up to 8 members.
18:10:17 <spwhitton> candidates we were all on board with, that is.
18:10:44 <spwhitton> do we want to do anything about recruitment in the near future?  it's a relatively good time for it with us not having any hard bugs.
18:10:50 <spwhitton> on the other hand, it's not a long time since our last attempt.
18:11:14 <mjg59> I think I should probably get a couple of meetings in at least before I can earnestly recommend it to people :)
18:11:27 <Myon> perhaps wait a month or two
18:11:28 <spwhitton> heh
18:11:36 <helmut> given that the situation is not improving, I think we can do more advertising such as d-d-a
18:11:37 <Myon> and then we try again
18:12:34 <spwhitton> mjg59: there is this cron script that randomly asks for nominations
18:12:42 <spwhitton> so in a sense we are always recruiting.
18:14:03 <spwhitton> helmut: what do you think about doing that, but not this month?
18:14:21 * Emperor +1 to waiting a month or two
18:15:31 <helmut> waiting a month is ok-ish, but if we defer it too long, we drag the problem forward and it can happen that someone resigns for unforseen reasons at any time
18:15:51 <spwhitton> yes.  we should definitely not just leave it.
18:16:13 <spwhitton> #action spwhitton to raise taking action on recruitment again next meeting
18:16:22 <helmut> if we get down to 5 memebers, I think we need to start reading the constitution
18:16:51 <spwhitton> yes.  and it's generally just not good for transparency etc.
18:16:57 <spwhitton> s/transparency/<better word>/
18:17:04 <spwhitton> okay.
18:17:08 <spwhitton> #topic Bug#1026104: longstanding problem with dependencies of python3-numpy in testing
18:17:18 <spwhitton> thank you for following up on this as much as you have helmut
18:17:39 <spwhitton> you think we should close it, right?  esp. given that maintainer has said they'd review a patch but there is no such patch.
18:17:48 <spwhitton> and we don't think there is any bad faith/delaying going on.
18:17:48 <Myon> I agree that someone needs to step forward to propose a solution first
18:17:50 <Emperor> I think the maintainer isn't interested in fixing this, but has indicated they'd at least consider reviewing patches to fix it?
18:18:05 <smcv> disclosure: I maintain one of the three packages that depends on more than one python3.x (python3-dbus-tests)
18:18:19 <spwhitton> smcv: any thoughts on the maintainer's design?
18:18:23 <mjg59> My interpretation of this is that the maintainer was saying "This is the inevitable outcome of the behaviour of our tooling" and people were interpreting that as "This is a deliberate design choice"?
18:18:38 <Myon> it's too early to overrule, so we could just say "come back when serious attempts at fixing this have failed"
18:18:51 <smcv> I think people, and possibly the maintainer, are conflating the behaviour of two parts of our tooling in unhelpful ways
18:19:13 <mjg59> In the absence of the maintainer rejecting reasonable patches I think there's still space for this to be worked out without us being involved
18:19:15 <helmut> maybe we can close it more politely saying that the submitter can come back after providing a solution that has been rejected by the maintainer?
18:19:31 <smcv> we can view python3-numpy as being isomorphic to python3-dbus + python3-dbus-tests
18:19:34 <spwhitton> helmut: I agree.  would you be up for writing the closure message?
18:19:45 <Myon> helmut: ack
18:19:49 <helmut> do we need a vote on this? or can I just close it?
18:19:49 <smcv> and notice that python3-dbus doesn't have this problem
18:19:56 <mjg59> Sounds good to me
18:19:57 <spwhitton> no need for a vote unless someone asks for one.
18:20:05 <Myon> fine with me
18:20:17 <helmut> I'm in favour of closing and you can action me.
18:20:30 <smcv> I'll try to follow up on the original bug with a "TC member, not currently wearing that hat" opinion
18:20:49 <spwhitton> smcv: thanks.  it's probably a bug we'll have to keep eyes on.
18:20:54 <smcv> because I'm pretty sure it can't actually be as intractable as people are making out
18:21:16 <helmut> I event sent a PoC to the bug on how to fix the numpy part
18:21:29 <spwhitton> Emperor: do you want to add anything?
18:21:39 <Emperor> spwhitton: no, I'm content
18:21:59 <spwhitton> smcv: would you like me to action you for your followup?
18:22:25 <smcv> sure, why not
18:22:45 <spwhitton> #action smcv to follow up to bug, not speaking as TC member
18:22:55 <spwhitton> #action helmut to close bug according to meeting discussion
18:22:57 <spwhitton> many thanks both.
18:23:03 <spwhitton> #topic Any Other Business
18:23:07 <spwhitton> please vote in the election of the chair.
18:23:23 <spwhitton> that, er, also applies to me.
18:23:32 <spwhitton> despite calling the vote.
18:23:45 <smcv> thank you spwhitton for doing such a good job of chairing since last time, and re-volunteering
18:24:16 <spwhitton> no problem.  thank you to mjg59 for volunteering to join us.
18:24:35 <Myon> does that ballot need a FD option?
18:24:38 <spwhitton> although the three people we have lost will be missed I think the TC is in great shape.
18:24:46 <Myon> (formally, not that I want to rank it high)
18:24:47 <spwhitton> Myon: they don't normally have one, looking at my mail archives.
18:24:54 <Myon> ok
18:24:58 <spwhitton> but that could be unconstitutional.
18:25:14 <smcv> isn't it NOTA these days?
18:25:15 <Myon> let's not open that can then
18:25:31 <spwhitton> smcv: I think it's further discussion for the TC and nota for GRs
18:25:43 <smcv> and iirc we can't not elect a chair, because the constitution says we have one
18:25:47 <spwhitton> but yes, let's leave it unless someone wants to vote for it, and they can just invent their own letter.
18:25:56 <spwhitton> does anyone have anything else on their radar?
18:26:01 <Emperor> nothing here
18:26:02 <Myon> nope
18:26:31 <helmut> I note that discussion of /usr-merge stuff with Guillem is not progressing well
18:26:44 <spwhitton> helmut: ah :\  what in particular has happened?
18:26:48 <helmut> nothing
18:26:56 <spwhitton> ah right.
18:27:05 <smcv> fwiw, constitution says "there is no default option", so electing the TC chair is the only vote in Debian that doesn't have NOTA or FD
18:27:08 <helmut> i.e. lack of replies
18:27:35 <spwhitton> thank you for continuing to keep tabs.  I guess that we probably don't want to do anything until after freeze?
18:28:07 <helmut> well, yeah Guillem certainly is busy getting his latest stuff into unstable before toolchain freeze. but it was silent earlier as well
18:28:44 <spwhitton> It seems inevitable that the TC will end up involved again if this situation persists.
18:29:03 <smcv> I wonder whether it would make things more or less likely to happen usefully if someone pointed out that not getting a dpkg-supported /usr-merge facility into bookworm means delaying what Guillem *actually* wants (only /usr in the data.tar.*) for *another* release cycle
18:29:36 <helmut> smcv: there is no question that we won't get those fixes into bookworm
18:29:39 <spwhitton> smcv: toolchain freeze has all but started.
18:29:47 <helmut> smcv: we're discussing trixie since a while
18:29:50 <smcv> no point in stirring that fire then
18:30:33 <spwhitton> helmut: I see that he did reply to your message that is in the minutes fro mour last meeting
18:31:07 <helmut> yes, that was vaguely helpful, but on that reply nothing else came back and on Simon Richter's thread neither
18:31:43 <smcv> from a quick glance, Simon Richter's plan seemed viable, although I don't know why he's talking about systemd
18:32:21 <helmut> I have mentally adapted his plan to not do that and then it made a lot more sense. I reviewed that mental adaption instead of what he wrote and concur that it makes sense
18:33:09 <smcv> I have a nasty suspicion that there's an ulterior motive about making sysv-rc imply staying non-merged-/usr, which is exactly what we don't want
18:33:24 <helmut> unlike uau's approach, simon richter's approach has a chance of not breaking mmdebstrap
18:34:00 <smcv> but if we substitute base-files or something else actually Essential as the package that provides the "please merge /usr" instruction, then that does make sense
18:34:12 <Myon> smcv: that sounds indeed like a connection many people might want
18:34:35 <helmut> either way, would someone other than me actually follow up on debian-dpkg@l.d.o with some kind of review?
18:34:38 <Myon> (but we shouldn't go there)
18:35:02 <spwhitton> smcv: since you've already read the proposal carefully, would you have time to do that?
18:35:41 <helmut> https://lists.debian.org/debian-dpkg/2022/12/msg00023.html and https://lists.debian.org/debian-dpkg/2022/11/msg00007.html
18:35:58 <smcv> I wouldn't say I've read it carefully, and tbh I don't really want to get Guillem thinking that I am "the merged-/usr person"
18:36:03 <helmut> 5 mails thus far
18:36:39 <spwhitton> I don't have time for something like that this month unfortunately.  Does someone else?
18:36:53 <helmut> smcv: I think he can understand that if you state it explicitly. My impression is that he does understand that I'm not enthusiastic about it
18:39:39 <spwhitton> ISTM that reviewing, refining these proposals is a worthwhile investment even if Guillem doesn't reply.  Because we know dpkg is going to be fixed, even if it's against Guillem's will.
18:40:02 <spwhitton> Now that merged-/usr is actually happening in bookworm, I mean.
18:40:38 <helmut> at present we're in kind of a chicken&egg problem. we have some proof-of-concept things, but none of them is ready for merging and we cannot get any of them polished until there is kind of a "this is the properties a solution must satisfy" / requirements
18:41:36 <helmut> getting all of them reviewed narrows down the solution space and lets us focus on the one that is most favourably reviewed
18:41:46 <spwhitton> helmut: fair, tho I was thinking that discussion might end up answering that last question without guillem's input.
18:42:21 <helmut> I guess it will
18:42:38 <helmut> the best we can do here is many eye balls
18:43:06 <spwhitton> like, there is guillem's conception of the requirements, and sure he knows dpkg best, but he also has a strong bias.  the rest of us are still capable of coming to conclusions about what's required.
18:43:14 <helmut> anyway, we can probably close this as a topicu and hope for someone to reply ;)
18:43:17 <smcv> I'll try to take a look in more detail, but I'm not really qualified to review dpkg (never patched it before, that I can remember)
18:43:29 <spwhitton> okay.
18:43:54 <spwhitton> let's just continue to keep an eye, and thank you again to people who have been doing that carefully.
18:43:55 <spwhitton> #endmeeting