18:09:54 <spwhitton> #startmeeting
18:09:54 <MeetBot> Meeting started Tue Sep 13 18:09:54 2022 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:09:54 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:10:03 <spwhitton> Sorry.  My clock in kitchen is slow, it turns out.
18:10:07 <spwhitton> #topic Roll Call
18:10:08 <spwhitton> Sean Whitton
18:10:26 <Emperor> Matthew Vernon
18:10:29 <gwolf> Gunnar Wolf
18:10:30 <smcv> Simon McVittie
18:10:41 <spwhitton> apparently I am banned from #debian-ctte-private
18:13:43 <ntyni> Niko Tyni
18:14:13 <spwhitton> #topic Review of previous meeting AIs
18:14:18 <spwhitton> Emperor: so, any movement with you?
18:14:27 <gwolf> As to reviewing our AIs -- As I said on the List that shall Never be Publicly Quoted, I was unavailable for work issues (conference)... And I managed to completely forget about my AI :-(
18:14:57 <Emperor> I've heard nothing back; I think the right answer is NMU, and I'm happy to do this when I'm back from work travel (so early October).
18:15:00 <spwhitton> gwolf: that's okay, do you think you can do it between now and our next meeting?
18:15:09 <gwolf> Yes, I'll re-take the AI.
18:15:42 <spwhitton> okay.  are we all happy with Emperor nmu'ing then?
18:15:46 <spwhitton> thakn you for volunteering both.
18:16:13 <Emperor> I'll do a delayed one as is usual practice, and provide a salsa MR
18:16:47 <spwhitton> right
18:17:08 <ntyni> sounds good to me
18:17:09 <gwolf> Emperor: Thanks! I agree it's the right(est?) course of acion.
18:17:12 <gwolf> acTion.
18:17:20 <spwhitton> other AI is from Myon, and he's not here, so I'm inclined to re-action him with a note saying it's carried over.
18:17:26 <Emperor> +1
18:17:27 <spwhitton> like gwolf's, it's not urgent
18:17:45 <spwhitton> #action Emperor to NMU util-linux, using DELAYED, and with an MR on salsa, early October
18:17:55 <spwhitton> #action gwolf to record in procedures/: send every decision to d-d-a or d-d, defaulting to the former, latter if niche
18:18:04 <spwhitton> #action [carried over] Myon to have a look at web page of old decisions and think about keeping it up-to-date
18:18:19 <spwhitton> #topic Bug#1019409: decide whether pam should support DPKG_ROOT
18:18:37 <spwhitton> it seems like it would be good to sort this out before the freeze.
18:18:37 <Emperor> my feeling is that the "this is worth a discussion on d-devel" argument is quite sound
18:19:13 <gwolf> Yes, I am somewhat sympathetic with vorlon's argument, that this kind of issues should be more widely discussed
18:19:27 <gwolf> even if it touches few packages... it should help raise awareness and get more eyeballs on
18:19:35 <spwhitton> we should keep in mind how vorlon didn't express this (reaonsable) opinion until a TC bug was filed.
18:20:06 <spwhitton> but given that the -devel thread is now in progress, it does seem like we are not in a TC-as-last-resort position anymore
18:20:09 <gwolf> Right, I understand the issue was neglected for over what should be a reasonable time
18:20:22 <gwolf> spwhitton: +1
18:20:48 <spwhitton> but perhaps we could discuss a bit anyway, how we might deal with it depending on what happens with that thread
18:20:53 <Emperor> Can we plausibly say we'll try and come to a view at our next meeting, say? That gives -devel time to talk round the subject without punting it into the long grass indefinitely (which isn't fair on the people trying to do the work)
18:21:02 <spwhitton> Emperor: as individuals, you mean?
18:21:47 <spwhitton> it seems that if -devel is inconclusive, and doesn't result in any patches being applied to PAM, then we are being asked to make the patch application decision on behalf of the PAM maintainres, and they are okay with us doing that.
18:22:04 <spwhitton> so I guess the opinion we need to come to is whether the patch should be applied?
18:22:19 <Emperor> I must admit I've not yet reviewed the d-d thread
18:22:30 <ntyni> yeah https://lists.debian.org/debian-devel/2022/09/msg00099.html seems to be the start of the thread fwiw
18:22:50 <gwolf> I have to get up to speed again. Yes, I'm repeatedly blaming my conference for my lack of attention :-)
18:23:36 <spwhitton> well, if we could go into next meeting knowing exactly what the parameters of the decision are, assuming -devel hasn't meant our bug gets closed, tha would be excellent
18:23:45 <Emperor> Mmm
18:24:02 <spwhitton> my belief is that all we have to deal with is the purely technical question of whether it's a reasonable patch to apply, almost as tho PAM maint were delegating to us.  but icbw.
18:24:09 <Emperor> so action everyone to review the thread before the next meeting, and aim to make a decision (iff necessary) then.
18:24:23 <Emperor> spwhitton: that's my understanding - the PAM maintainers haven't given us a counter-argument AFAICT
18:24:38 <gwolf> spwhitton: Maybe we (c|sh)ould voice our opinions in the d-d thread "as a TC member"?
18:24:57 <spwhitton> gwolf: yes, we should all do that if we think we have things to say
18:24:57 <gwolf> (this is, to make the project aware it is under our radar, and to lower the wait time for a TC sentiment for before next meeting)
18:25:09 <spwhitton> if no-one thinks I've missed anything, we can take that as read and set the explicit goal of reviewing the patch, if necessary, next meeting.
18:25:44 <smcv> all sounds good to me
18:25:53 <ntyni> sure
18:25:58 <spwhitton> okay let me do a few #info/#agreed etc., sec.
18:26:21 <spwhitton> #agreed Either -devel means our bug gets closed, or we are tasked with deciding whether the patch to PAM is to be applied.
18:26:45 <spwhitton> #agreed Next meeting either the bug is closed or we will have the goal of reviewing the patch and deciding whether to apply.
18:27:12 <spwhitton> #action ideally everyone would aim to be ready with opinions on whether to apply the patch, so we can discuss and establish consensus.
18:27:17 <spwhitton> okay then.
18:27:34 <spwhitton> we actually have plenty of time for recruitment, but with two people missing I'm not sure it's a great idea.  any thoughts?
18:27:41 <spwhitton> and gwolf leaving in 10.
18:27:53 <Emperor> I think punt it to next time
18:28:17 <Emperor> (all other things being equal, I'm a bit wary of bringing forward things we said we'd do next time when some people aren't here)
18:28:19 <gwolf> right, next time is still quite timely
18:28:24 <spwhitton> Emperor: yup.
18:28:36 <spwhitton> #topic Any Other Business
18:28:47 <spwhitton> I agree, just thought I would float it briefly.
18:28:52 <spwhitton> has anything come up?
18:29:02 <ntyni> merged-usr seems to be advancing
18:29:18 <spwhitton> looks like merged-/usr (partial) implementation is going okay, and not too much acrimony atm, tho I'm sure we're all watching the threads
18:29:31 <smcv> yeah, the weekend's point release was the blocker for the next step, so that can now proceed
18:30:19 <ntyni> not sure if debian-ctte@ldo is the right place for implementation wth messages but oh well
18:30:29 <Emperor> Mmm
18:31:05 <smcv> well indeed, but having status updates go there seems valuable, given how many ctte decisions it has taken
18:31:19 <gwolf> Right, and given the amount of tension it has created
18:31:23 <ntyni> yes
18:31:33 <smcv> and if the price we pay for that is having people complain about implementation details on -ctte, well, it's not *that* much noise
18:31:42 <gwolf> I hope we are not deceiving ourselves when saying it seems to go well... :-|
18:32:05 <spwhitton> gwolf: I know right.
18:32:46 <smcv> in other "distro changes" news: the gnome and utopia teams are currently discussing whether gnome should install pipewire (with pulseaudio compatibility) rather than pulseaudio, as the preferred/default/whatever audio mixing service
18:33:23 <smcv> which is mostly between the gnome team and the utopia team, but since gnome is our default desktop environment, I thought I should mention it
18:33:28 <spwhitton> it would be cool for that to be in bookworm not trixie if it's def. gonna happen in one of them
18:33:36 <spwhitton> debian not so slow for this one!
18:34:07 <smcv> the thought that seems to be winning at the moment is: we should do it sooner rather than later, so that if there are problems, we have plenty of time to either fix or revert before the freeze
18:34:07 <spwhitton> thank you Simon.  well, I'll close the meeting here
18:34:15 <spwhitton> smcv: right.
18:34:19 <spwhitton> #endmeeting