18:04:18 <spwhitton> #startmeeting
18:04:18 <MeetBot> Meeting started Fri Jan 14 18:04:18 2022 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:18 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:04:21 <spwhitton> #topic Roll call
18:04:23 <spwhitton> Sean Whitton
18:04:27 <Myon> Christoph Berg
18:04:27 <ntyni> Niko Tyni
18:04:42 <ehashman> Elana Hashman
18:05:59 <ehashman> spwhitton: I have to drop at 30 past
18:06:17 <spwhitton> https://jitsi.debian.social/TechnicalCommittee
18:06:20 <spwhitton> (ctte membres only plz)
18:06:55 <spwhitton> Apologies received from Gunnar
18:08:05 <spwhitton> #action spwhitton to start two votes on candidates
18:08:36 <spwhitton> #action spwhitton to write to other candidates
18:10:08 <spwhitton> #action spwhitton update appointment_of_the_chair.md with the "other" convention about not resinging right before new appointments
18:12:13 <spwhitton> #topic Bug#1003653 Revision of removal of rename.ul from package util-linux
18:13:36 <spwhitton> [switching to IRC]
18:14:11 <ntyni> so about rename.ul and alternatives
18:14:15 <Myon> there is: rename - Perl extension for renaming multiple files
18:14:45 <ntyni> right, the Perl one was the first to grab /usr/bin/rename back in 1999 or something like that
18:15:03 <ntyni> then other distributions picked up the util-linux version which is mostly incompatible
18:15:32 <Myon> dropping a utility like that was certainly not expected, but otoh, what is a rename utility doing in util-linux which is supposed to contain things like "mount"?
18:15:34 <ntyni> in ca. 2004 there was a request to switch and a brief setup with update-alternatives which was reverted quite quickly because of the incompatibility
18:15:56 <ntyni> and the alternatives system was pretty much obsoleted after that but remained in place
18:16:25 <ntyni> later in 2015 or something like that we transitioned the Perl rename thing to src:rename and used the existing alternatives system for that
18:16:43 <ntyni> I can dig up bug numbers later but that's pretty much how I recall things
18:17:00 <Myon> so util-linux's binary was always called "rename.ul" only?
18:17:02 <ntyni> of course all that history does not matter very much for the actual issue we're asked to rule on
18:17:04 <spwhitton> Myon: i guess if you wrote a script for another distro and then wanted to use it on Debian, it would be nice to have it there, even if under a diff name
18:17:15 <Myon> spwhitton: ack
18:17:25 <ntyni> yeah I think it's always been rename.ul in Debian except for a brief period with it registering an alternative
18:18:02 <Myon> the perl rename still has 49k installations: https://qa.debian.org/popcon.php?package=rename
18:18:39 <spwhitton> hmm.  I am not sure that the util-linux maintainer has even been asked to reconsider the removal.
18:18:54 <Myon> on a green field, the ideal solution would be to have util-linux ship the binary as "rename" to be compatible with the rest of the world
18:19:08 <ntyni> #966468
18:19:09 <Myon> but in reality, we break the perl-rename users
18:19:23 <spwhitton> ah thanks
18:19:33 <Myon> from what I saw, the maintainer was changing
18:19:35 <spwhitton> oh, right, that was in the tech-ctte bug, I recall now.
18:19:38 <ntyni> sure, ideally util-linux would get /usr/bin/rename but nobody wanted to break existing usage
18:19:55 <Myon> ah was removing rename.ul, but the "wontfix" is from zeha
18:20:38 <ntyni> #304705 has most of the history fwiw
18:20:40 <Myon> so I think the "wontfix" is just there because the new maintainer didn't want to concern themselves with whatever the previous maintainer did (enotime, they don't know, or something)
18:21:08 <Myon> we should probably start by asking zeha about that
18:21:13 <spwhitton> okay.  so we should probably just ask the maintainer, as the ctte, what their reasons were, and whether they would reconsider in light of the various points that have been raised.
18:21:22 <spwhitton> they might just say "okay I'll put it back".
18:21:30 <ehashman> +1
18:21:33 <ntyni> yes
18:21:35 <Myon> right, but that won't fix bullseye
18:21:59 <Myon> the complaint is coming very late
18:22:20 <spwhitton> yeah.  but the release team would be more likely to consider a fix in bullseye if we get it reverted in stable, I would guess (not to say a revert in unstable is a prerequisite to them doing that)
18:22:26 <spwhitton> in unstable*
18:22:40 <spwhitton> do we have a volunteer to write to the maintainer, CCing our bug?
18:22:46 <Myon> I can do that
18:22:51 <spwhitton> great, ty
18:23:07 <spwhitton> #action Myon to write to util-linux new maintainer based on meeting discussion, CCing the TC bug
18:23:16 <ntyni> (while I'm digging, #439935 is about the incompatibility with the alternatives system)
18:23:26 <Myon> do we have any ideas of other solutions besides "put it back and be done"?
18:23:49 <Myon> like actually improving the mismatch with other util-linux users?
18:24:20 <Myon> (but I guess we are mostly stuck with the historical names)
18:24:27 <ntyni> yeah I suspected the wontfix might have been because of a long-standing annoyance with the name clash
18:24:35 <ntyni> but if there's been a maintainer change recently then maybe not
18:24:35 <spwhitton> I mean, someone could try to make an argument that the interface isn't as incompatible as has been thought
18:24:47 <spwhitton> and someone might ask the TC to assess that, if agreement was not forthcoming.
18:25:03 <Myon> ntyni: do you have experience with that?
18:25:35 <Myon> do other distros ship the perl rename?
18:25:35 <ntyni> the util-linux version uses something like shell wildcards to determine the name transformations while the Perl one is more like regexps
18:25:51 <ntyni> I think they are pretty much incompatible for anything nontrivial unfortunately
18:25:56 <Myon> ok
18:26:28 <Myon> ok maybe just putting it back under the .ul name is just fine then
18:26:37 <spwhitton> yeah, it does seem that way.
18:26:44 <spwhitton> alright, as ehashman has to leave, can we do any other business?
18:26:49 <ntyni> yeah it's worked for 20+ years
18:27:07 <Myon> ack
18:27:19 <ntyni> no other business from me
18:27:22 <spwhitton> #topic Any Other Business
18:27:37 <spwhitton> I've set a reminder to resign as chair and to send a poll for february's meeting time; both are dependent on the DPL
18:28:11 <ntyni> and us voting first I guess?
18:28:14 <spwhitton> right yeah
18:28:50 <Myon> nothing from me
18:28:58 <spwhitton> ehashman: anything from you?
18:30:19 <spwhitton> well, her other thing has started now, I guess, so thanks everyone!
18:30:21 <spwhitton> #endmeeting