18:00:04 <spwhitton> #startmeeting
18:00:04 <MeetBot> Meeting started Wed Jun  9 18:00:04 2021 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:04 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:23 <spwhitton> #topic Roll Call
18:00:24 <spwhitton> Sean Whitton
18:00:29 <marga> Margarita Manterola
18:00:30 <bremner> David Bremner
18:01:07 <ntyni> Niko Tyni (but a bit distracted)
18:01:51 <ehashman> Elana Hashman
18:03:13 <spwhitton> gwolf: here?
18:03:14 <spwhitton> smcv: here?
18:03:17 <spwhitton> Myon: here?
18:03:39 <gwolf> Gunnar Wolf
18:04:59 <spwhitton> #topic Review of previous meeting AIs
18:05:04 <spwhitton> good morning everyone :)
18:05:32 <spwhitton> smcv did his AI -- thank you.  I did not do mine *and* failed to include myself in the list of people with AIs, wow
18:05:32 <marga> I failed at my thing :(
18:05:38 <ehashman> I also failed
18:05:41 <spwhitton> #action     spwhitton to submit webmaster team bug/patch to clarify the status of the lists of old decisions
18:05:58 <ehashman> but at least, we failed together
18:06:02 <marga> :)
18:06:30 <spwhitton> shall we reaction, or rethink?  we may just not have the appetite to be working on those issues atm, and that's okay.
18:06:52 <gwolf> The initiative to rethink the TC was _very_ good, I think...
18:06:55 <ehashman> for me it's just been failure to prioritize
18:07:16 <bremner> maybe debconf gives us a timeframe to make some progress?
18:07:19 <ehashman> I only remember the week of the meeting and then get too busy ^_^;
18:07:22 <gwolf> ...but actually getting it moving has proven to be difficult :-(
18:07:29 <ehashman> yeah, conference-driven development
18:07:29 <marga> I'm very de-motivated in general, not specific to the TC thing
18:07:36 <spwhitton> bremner: I was thinking something like that too
18:07:45 <marga> Yes, next DebConf might be the motivation I need.
18:07:46 <gwolf> yup, that could work as motivation
18:07:57 <spwhitton> so shall we consider whether and what to re-#action after we've talked about debconf later in the meeting?
18:08:08 <bremner> sounds reasonable
18:08:30 <marga> Agreed
18:08:36 <ehashman> ++
18:08:41 <spwhitton> #topic Submitting this year's "Meet the Technical Committee"
18:08:43 <gwolf> smcv is not around, but FTR, he had an AI
18:08:48 <gwolf> (and acted)
18:09:02 <spwhitton> gwolf: yup noted above :)
18:09:06 <gwolf> oh, sorry!
18:09:11 <spwhitton> np
18:09:19 <spwhitton> we probably want to do the usual summary of the year, I think
18:09:41 <ehashman> "we had a lot of bugs. some of them were controversial"
18:09:42 <ehashman> done
18:09:48 <spwhitton> we could then follow it up with presentations on the two reimagining the TC tasks we've chosen to focus on, and invite discussion?
18:09:49 <marga> Last year we did "Bits from the TC" by mail and it was very well received
18:09:59 <spwhitton> oh right yes
18:10:06 <bremner> maybe a bit of discussion about how useful / satisfactory we thought the bug resolutions were?
18:10:13 <spwhitton> we did that because we wanted to spend the whole talk on reimagining, right:
18:10:18 <ehashman> yeah
18:10:38 <gwolf> right... we have had a full year to reimagine,and not much imagination to speak of :-(
18:11:00 <bremner> I was just thinking a bit of introspection about the current functioning might help the re-imagining discussion
18:11:14 <spwhitton> so as bremner suggests, some sort of hybrid of an e-mail and a brief intro might be good
18:11:31 <spwhitton> followed by handing over for defined periods to someone leading each of the two topics
18:11:35 <marga> +1
18:11:57 <spwhitton> does anyone know the session length off the top of their head?
18:12:17 <bremner> I vaguely remember 45 minutes, but I'm not 100% sure
18:12:18 <gwolf> usually 40min
18:12:21 <gwolf> or 45, yes
18:12:33 * spwhitton takes a look
18:12:41 <gwolf> we try to do full hour slots, with 15min between sessions for breathing time
18:12:43 <spwhitton> it's 45
18:12:59 <spwhitton> so, I could talk about the year for 10 minutes, then we have 15 and 10 for each of the two topics
18:13:03 <bremner> correct and useless answer from the math guy
18:14:20 <ehashman> and I think we need some time for Q&A
18:14:24 <bremner> maybe 10 x 4 + 5 minute Q&A?
18:14:37 <spwhitton> I was imagining q&a built into the two topic bits
18:14:48 <gwolf> 5min is too little
18:14:51 <bremner> but maybe Q&A on other topics?
18:15:00 <spwhitton> ah totally general q&a
18:15:00 <gwolf> I'd try to do 10min Q&A
18:15:21 <bremner> before or after "presentations"?
18:15:22 <marga> heh, rather than bikeshed time splits shouldn't we concentrate on the content?
18:15:24 <ehashman> ++ gwolf
18:15:46 <bremner> marga: but timesplits are easy, content is hard
18:15:54 <ehashman> do we need more than 5m for the overview of the year? we can still keep 10x4 + 5
18:16:07 <spwhitton> yeah I can probably do it in 5 if there is an accompanying e-mail.
18:16:39 <spwhitton> okay, can someone volunteer to do the cfp submission, and I'll action myself to come up with a draft of the bits mail?
18:16:55 <gwolf> I can do it
18:17:00 <marga> Well, but what will we talk about?
18:17:18 <gwolf> Well, a small roundup of the bugs we covered this year...
18:17:30 <spwhitton> right, plus introducing Myon
18:17:52 <gwolf> ...and the ideas we have discussed (and by then, hopefully hashed more) on how to move the TC forward
18:17:57 <spwhitton> but I don't think we need to talk about the year round up tbh, as it's short and simple.  we should talk about the reimagining.
18:18:04 <spwhitton> I'll go ahead and set up those actions and change the topic
18:18:15 <spwhitton> #action gwolf to submit to debconf CfP
18:18:22 <spwhitton> #action spwhitton to prepare draft of bits mail
18:18:26 <spwhitton> #topic Moving forward with our reimagining the TC tasks
18:18:27 <gwolf> spwhitton: right, and thanking fil for being the oldest of us ;-)
18:19:56 <ehashman> so really, my task (re: privately engaging the TC) is to write down how we're operating right now, and what we can/cannot do (e.g. we can't make decisions based on a private email/information)
18:20:17 <ehashman> I just keep getting distracted from writing it because low priority :)
18:20:18 <spwhitton> alright, I think we still have a consensus to focus on the two topics that were previously assigned to marga and ehashman.  so one option is that we try to come up with a more concrete change proposal for each which we then discuss during the session and see what feedback we get.
18:20:23 <bremner> ehashman: maybe with wild speculation about how this might effect recent things we did?
18:20:47 <bremner> I tend to like the "what problem are we solving" emphasis, if possible
18:21:07 <ehashman> yeah, I can go from that angle
18:21:14 <spwhitton> yeah, especially since we had a bunch of private comms during the systemd bug
18:21:36 <bremner> which people had Opinions about
18:21:41 <gwolf> right. We tried to sum up and open up everything, but we did have private information flow.
18:21:44 <spwhitton> "we felt constrained in these ways and we think most everyone would agree with us that it made things worse, so we'd like to write down that we're going to do this in the future"
18:21:48 <gwolf> And I think it was important to handle it...
18:22:14 <ehashman> *nod*
18:22:24 <marga> It was indeed useful, but some people felt hurt, so we need to learn how to do it better
18:22:54 <bremner> marga: yep, both aspects are important
18:23:14 <spwhitton> marga: that's a good way to put it.
18:23:25 <gwolf> marga: Yes. Although I think people would have got _worse_ hurt if we had not actively tried to help communications between them
18:23:31 <gwolf> but... yes, it's a complex issue
18:23:49 <spwhitton> as we don't have many bugs, it's going to take us some time to develop a conception of how to do it well in a way that doesn't hurt people.
18:24:05 <spwhitton> so my sense is that we want to write down somewhere something which gives us permission to develop that conception in good faith.
18:24:18 <bremner> perhaps people just not being surprised will help
18:24:44 <spwhitton> indeed
18:25:15 <spwhitton> do others have thoughts on what we would actually change w.r.t. this proposal, other than writing down some initial conception of the sort of private communication we are going to go ahead and do?
18:25:32 <spwhitton> do we do a constitutional amendment?
18:25:42 <ehashman> bremner: yeah, I think additional transparency will be useful
18:26:10 <marga> I don't think an amendment is necessary as long all decision-making actions are in the open.
18:26:11 <gwolf> spwhitton: I guess a constitutional amendment will be determined when we have a concrete proposal to push
18:26:15 <ehashman> spwhitton: I do not think we should do a constitutional amendment. I have no desire to add additional capabilities of private comms above and beyond what the constitution allows for
18:26:18 <bremner> /mode + brainstorm: maybe commit the TC to timely public summaries of discussions?
18:26:37 <ehashman> an SLA?
18:26:44 <bremner> heh. trust the SRE
18:26:58 <spwhitton> okay cool, I didn't think we needed a constitutional amendment either, but wanted to know we were on the same page on that
18:27:08 <gwolf> FWIW we have already established in the project that any group of developers can hold private communications. So, even if we are a defined body with defined powers, we can talk privately amongst ourselves or with people involved in issues
18:27:15 <bremner> just that discussions should not be secret forever
18:27:24 <spwhitton> #agreed We don't think that a constitutional amendment is required to implement this part of our plans to reimagine the TC.
18:27:33 <gwolf> ...we even have the private alias where people can write to us ...
18:27:52 <bremner> like if our decisions are based in part on private discussions, the _existence_ of those discussions (and probably the participants) should be public
18:28:17 <spwhitton> bremner: so in the bug closure mails we'd at least state briefly that such and such communication happened?
18:28:30 <bremner> sure. as an easy bar.
18:28:33 <gwolf> bremner: right, but not the contents
18:28:46 <bremner> gwolf: right, because that would not be very private :P
18:28:48 <ehashman> I think the contents _should_ be disclosed if we're making a decision on it
18:28:50 <gwolf> the existence of private communications should be disclosed
18:28:52 <ehashman> just not like, word for word
18:28:53 <marga> well, not the literal contents, but the summarized contents
18:29:00 <ehashman> see, what I did on the systemd bug
18:29:07 <bremner> yeah, fair point on the summary.
18:29:10 <gwolf> bremner: I thought you were to push something like the privacy expiry of debian-private we had for a decade
18:29:25 <gwolf> I'm happy you are not
18:29:26 <bremner> gwolf: no, I am not crazy in that specific way
18:29:32 <spwhitton> ehashman: what you did there was very useful but quite labour-intensive.  in discussions involving more people we wouldn't be able to do that.
18:29:33 <ehashman> like, basically my goal with private communications would be to ensure that people have the opportunity to cool flamewars, *and* for them to access the experience of the TC
18:29:34 <gwolf> (-:
18:29:59 <ehashman> so that someone on the TC can try to help summarize and provide the most compelling version of their argument, if they are not particularly comfortable at doing that
18:30:08 <gwolf> heh, "the TC experience" sounds like an attraction in an amusement park
18:30:14 <gwolf> ...an attraction with very long queues...
18:30:42 <ehashman> spwhitton: eh, it wasn't that bad. I'd _prefer_ we not have to do that. but it is sort of the point of having a TC
18:30:44 <Myon> sorry, forgot the timing
18:30:44 <spwhitton> we could commit ourselves to summarising all private discussion to the extent to which doing so does not significantly delay resolving bugs.
18:30:47 <Myon> here now
18:30:55 <ehashman> spwhitton: sounds good :)
18:31:34 <ehashman> an annoyance I have is that people will escalate things to the TC and then proceed to argue about straw men
18:31:44 <spwhitton> I guess also we would want to restrict it to discussion is that we think actually contributed to our decision?
18:32:05 <spwhitton> in the same way we do not take into account every single public mail in our summaries.
18:32:16 <ehashman> so, I see one of our responsibilities as ensuring we toss out the strawmen and only discuss the strongest versions of arguments rather than weak hypotheticals
18:32:28 <ehashman> spwhitton: yeah
18:33:18 <gwolf> ehashman: Well, we have to be open to at least receive and evaluate anything DDs throw at us. I'd be happy if more people involved the TC in their decisions
18:33:30 <gwolf> even if that meant more work, it would mean the project considers the TC as more useful
18:33:41 <ehashman> yeah. I would like us to be useful!
18:34:26 <ehashman> and we've signed up to take the brunt of public arguments and anger, whereas a random developer who has something filed against them escalated to the TC might not :)
18:34:39 <spwhitton> so I guess there are two sides: we want to encourage private discussion where it means we can be more useful, and we want to commit to particular things we will do to avoid those who are not in the private discussion feeling mistreated.
18:35:05 <ehashman> yes, and that private discussions are as transparent as feasibly possible
18:35:38 <Myon> nod
18:35:58 <gwolf> ...I guess one of the points to being more useful is having lower turnaround
18:36:14 <gwolf> ...and delaying most things to our monthly meeting is not exactly making things fast
18:36:22 <Myon> right
18:36:22 <spwhitton> ehashman: do you think you could make these various points more concrete by our next meeting?  then we can think about how to use however much of the debconf talk we dedicate to this.
18:36:40 <ehashman> spwhitton: yes, I'd like to get my proposal written up
18:36:42 <gwolf> so we'd probably have to decide more without the need for a meeting -- at least, deciding on i.e. whether a bug is pertinent for us or not
18:37:08 <spwhitton> #action ehashman to write up these ideas for discussion by our next TC meeting
18:37:50 <ehashman> I have put some time on my calendar to actually get this done so I stop forgetting :)
18:38:25 <spwhitton> it would be great if we could all have a read through of what you think before next time; you clearly have some specific and useful thoughts
18:38:50 <gwolf> ehashman: Do you think it could be useful (to you, but to all of us) if we had i.e. weekly remainders of the pending AIs and open bugs?
18:38:58 <gwolf> I think a small script could help us with that
18:39:26 <gwolf> (or a small script could be replaced by a full-blown DD, going against well-established popular knowledge ;-) )
18:40:20 <ehashman> gwolf: I would have no objection to a script that pesters in IRC
18:40:21 <spwhitton> me plus Emacs can do such reminders if wanted, but I would want to know people actually want them!
18:40:58 <ehashman> mostly it's just an issue of prioritization :) since this is the lowest priority on my list and anything that will be blocking comes first
18:40:58 <spwhitton> but if someone wants to write a script that is cool too.
18:41:04 <ehashman> e.g. Clojure Team has a GSOC student :D
18:41:37 <spwhitton> sounds like this month you are confident you can do it, so maybe we can just leave it at that.
18:42:30 <spwhitton> okay how about we discuss the other proposal for a bit, and then we can wrap up
18:42:39 <spwhitton> this is the mediation body proposal
18:42:53 <spwhitton> does anyone have a sense of project consensus on the various options presented in marga's original text?
18:43:00 <spwhitton> (I'm jsut re-reading, it's very thoughtful)
18:43:23 <marga> Yeah, I was also re-reading
18:43:52 <marga> Last year I was very convinced that this was needed, but this year it kinda feels like it's not
18:44:03 <marga> (this = some explicitly delegated mediation body)
18:44:05 <spwhitton> interesting.
18:44:44 <marga> If we do the other two things (early invocation + private discussions) and just clarify the situations where the TC can help, that might be enough.
18:45:06 <Myon> +1 on simple solutions
18:45:29 <spwhitton> there are some notes by fil in rethinking-the-tc/earlyinvocation.org
18:45:45 <marga> Yes, those are quite good
18:47:18 <spwhitton> is there someone interested in working those up into some options to present the project with at debconf?
18:47:32 <gwolf> right. Although early invocation depends on others, not on ourselves
18:47:48 <gwolf> I would like to part of the presenters
18:48:00 <spwhitton> gwolf: ?
18:48:30 <gwolf> yes -- I mean, I will go over them and try to make some points and think more about them
18:48:43 <gwolf> ...and I'd like to take presenting in the conference
18:48:44 <ehashman> [time check: it is :48, I'm not sure what else we have on the agenda]
18:48:54 <spwhitton> gwolf: ah okay cool.  it would be great if we had a few options under that heading to discuss next time.
18:48:59 <gwolf> I cannot yet assure which one I'd be most interested in taking
18:49:01 <gwolf> right
18:49:15 <spwhitton> marga: since you were previously driving this, are you on board with this way forward?
18:49:35 <marga> Yes
18:49:50 <spwhitton> okay great!
18:50:07 <spwhitton> #action gwolf to take up fil's notes on early invocation and come up with some concrete proposals
18:50:27 <spwhitton> #topic Any Other Business
18:50:38 <spwhitton> is there anything else anyone would like to raise?
18:51:52 <marga> Nothing from my side
18:52:21 <bremner> same
18:52:22 <spwhitton> marga: I'd like to hear more from you about your change in view about mediation sometime
18:52:29 * gwolf is silent
18:53:02 <spwhitton> perhaps when we can have in person debconf again.
18:53:43 <marga> Well, who knows, maybe I can prepare something for next time :)
18:53:57 * gwolf sighs and hopes for a real DebConf
18:54:02 <spwhitton> that would be cool too!
18:54:05 <spwhitton> I'll go ahead and close
18:54:06 <spwhitton> #endmeeting