17:57:46 <spwhitton> #startmeeting
17:57:46 <MeetBot> Meeting started Wed Apr 14 17:57:46 2021 UTC.  The chair is spwhitton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:57:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:57:50 <spwhitton> #topic Roll Call
17:57:53 <spwhitton> Sean Whitton
17:57:56 <marga> Margarita Manterola
17:57:57 <spwhitton> apologies received from ehashman and ntyni
17:58:01 <gwolf> Gunnar Wolf
17:58:13 <Myon> Christoph Berg
17:58:36 <bremner> David Bremner
17:59:25 <spwhitton> smcv: around?
18:01:00 <gwolf> spwhitton: Maybe we can start the meeting, allow him to join if he can?
18:01:13 <spwhitton> let's wait until 5 past
18:01:21 <spwhitton> since there are already only a few of us
18:01:29 <gwolf> OK
18:01:44 <spwhitton> meetbot's clock seems to have drifted a fair bit
18:02:23 <Myon> TIL openexchange can actually schedule recurring meetings in UTC and seems to get DST changes right
18:02:52 <spwhitton> #topic Review of previous meeting AIs
18:03:13 <spwhitton> I'm going to go ahead and re-action ehashman
18:03:22 <spwhitton> #action ehashman to work on proposal #1 some more and report back to next meeting
18:03:44 <marga> I also didn't do my thing
18:03:53 <spwhitton> okay, are you willing to just be reactioned?
18:03:58 <marga> Yup
18:04:02 <spwhitton> #action marga to work on proposal #3 and share some ideas next meeting
18:04:12 <spwhitton> Simon didn't circulate a draft anywhere I missed, did he?
18:04:56 <gwolf> I don't recall seeing anything like that :-(
18:05:13 <spwhitton> okay then, given that the bug is not urgent, let's just reaction him for now
18:05:21 <spwhitton> #action smcv to draft statement closing #976462
18:05:25 <spwhitton> alright
18:05:42 <spwhitton> #topic #976462 - Should dbgsym files be compressed via objcopy --compress-debug-section or not?
18:05:57 <spwhitton> there have been some additional mails; is our consensus unchanged?
18:06:31 <bremner> remind me, is the concensus "not convinced to change the status quo" ?
18:06:36 <spwhitton> yeah
18:06:44 * gwolf recalls that as being consensus as well
18:06:58 <marga> Yeah, and there was only one mail from a user? Or were there more mails somewhere else?
18:07:08 <Myon> the new info is about new WIP software that just needs to adopt to symbols being compressed
18:07:39 <marga> Indeed
18:07:41 <gwolf> spwhitton: I see only one mail past our previous meeting on the bug (yours, at 09:36-0700, was before the meeting)
18:07:42 <spwhitton> yeah.  it was a useful contribution because the author is actually involved in writing tools tha thandle debug symbols
18:08:09 <spwhitton> gwolf: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=976462#98
18:08:24 <smcv> sorry, I am here now
18:08:52 <spwhitton> hello!  have you got started on the draft to close this one?
18:09:02 <gwolf> Right. There are reasons to have the symbols uncompressed... But AIUI, they can be uncompressed on demand by the user when needed, even if it's not as convenient...
18:09:06 <smcv> and yes, I didn't want to go closing #976462 having got new info that might change our consensus
18:09:06 <gwolf> spwhitton:precisely
18:09:14 <bremner> I think by itself a tool that might be useful in Debian in the future is not enough to change things now.
18:09:26 <spwhitton> bremner: yes that's what I thought
18:09:40 * gwolf +1's bremner wise words
18:09:47 <spwhitton> smcv: has your own view chnaged?
18:09:49 <marga> +1 as well
18:10:49 <smcv> ok, it is sounding as though despite the new contribution from Mark Wielaard, we still think we should keep compressing the -dbgsym to reduce the Installed-Size impact of debugging e.g. big C++ packages like KDE
18:11:01 <Myon> ack
18:11:13 <spwhitton> yeah
18:11:24 <spwhitton> are you still okay to draft the closing smcv?
18:11:28 <smcv> yeah will do
18:11:33 <spwhitton> okay great, then let's move on
18:11:53 <spwhitton> #topic Moving forward with our reimagining the TC tasks
18:12:00 <gwolf> thanks smcv
18:12:10 <spwhitton> We've postponed marga and ehashman's work on this to next time, but does anyone have anything to report?
18:14:18 <smcv> looks like no we don't?
18:14:33 <spwhitton> seems so!
18:14:40 <spwhitton> okay then
18:14:44 <spwhitton> #topic Any other business
18:14:49 <gwolf> Maybe we want to release a Bullseye soon? :-)
18:15:04 <spwhitton> alas we can't overrule delegates
18:15:07 <spwhitton> ;)
18:15:16 <bremner> we could each make a GR
18:15:22 <Myon> the constitution doesn't say we can't reaffirm them ;)
18:15:50 <spwhitton> doesn't sound like anyone has anything to raise?
18:15:52 <bremner> feels strange to have no big bugs
18:15:58 <marga> Nothing from my side
18:16:11 <gwolf> We can always suggest to switch the init system...
18:16:20 <smcv> hopefully nobody will decide that now is a good time to make their pet bug RC
18:16:52 <spwhitton> #endmeeting