18:58:52 <marga> #startmeeting
18:58:52 <MeetBot> Meeting started Wed Jul 15 18:58:52 2020 UTC.  The chair is marga. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:58:52 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:58:59 <marga> #topic Roll Call
18:59:02 <marga> Anybody out there?
18:59:07 <marga> Margarita Manterola
18:59:11 <ehashman> Elana Hashman
19:00:19 <bremner> David Bremner
19:01:29 <marga> Ok. I think it's just us, because I failed at sending the reminder.
19:01:38 <marga> #topic New chair election
19:02:18 <marga> I've just sent the email for my resignation + call for votes (probably still in greylisting), but I think I did it wrong, because it should be a bug, not an email to the tech-ctte list, right? I'll resend it as a bug.
19:02:43 <ehashman> I haven't seen it yet but my email is slow
19:03:05 <marga> There's a bunch of greylisting, it usually takes 10 minutes or so for emails to the list to come through.
19:04:13 <marga> Alright, re-sent as a bug.  It should come through within a few minutes.
19:05:13 <spwhitton> Sean Whitton is here too, apologies
19:05:26 <marga> #topic #963112 - Request for advice on katex rejected by ftp masters
19:05:31 <marga> We have an issue to discuss!
19:06:28 <marga> A rehash of an old issue, unfortunately.
19:06:38 <bremner> I had the impression that spwhitton did a little mediation?
19:06:51 <marga> The bug is still open
19:06:55 <ehashman> from my reading of this issue, they're still waiting on FTP feedback, no?
19:07:16 <ehashman> or do they want ctte feedback
19:07:59 <spwhitton> they didn't explicitly withdraw their request for ctte feedback, but indeed they are waiting for ftp feedback, but from a particular ftp member, who is not especially active in FTP stuff atm
19:08:33 <marga> The goal of the request was to "have a second opinion" to decide whether or not to raise a GR or not.
19:08:59 <bremner> I don't much like that idea, as I think I expressed
19:09:02 <spwhitton> marga: maybe we should discuss that idea in general.  I was thinking that it seems weird to get the ctte on one side of an issue or the other before having a GR
19:09:14 <spwhitton> especially when they've already said something on the topic
19:09:42 <spwhitton> but perhaps that is not a fair interpretation of what was requested
19:09:55 <bremner> fair or not, it matches my impression
19:09:57 <ehashman> I might not be familiar with all the context but I personally view a GR as ... disproportionate?
19:10:08 <marga> It is, yes
19:10:10 <hartmans> spwhitton:  I think it would be fair to ask for help and to ask for options other than GR.
19:10:23 <marga> But it is also the only recourse that a developer has if they disagree with a delegate
19:10:34 <bremner> the only _formal_ recourse
19:10:37 <hartmans> And if the answer you get back is "your position seems reasonable" and "we can't think of any alternatives," well, that's something it would be reasonable for the TC to say sometimes.
19:10:38 <marga> Oh, hey Sam :)
19:10:45 <ehashman> so if the request is for advise re: whether to run a GR, I would not advise for that
19:10:55 <spwhitton> ehashman: I don't think that was the request, fortunately for us.
19:11:00 <ehashman> it seems that there is just slow/lack of communication from the FTP team
19:11:08 <ehashman> but I am not sure how we can assist with that
19:11:40 <ehashman> as someone who's been on the receiving end of slow/lack of communication from the FTP team... ^_^;
19:11:41 <bremner> we could reassign the bug to ftp-master
19:11:46 <marga> Indeed. And as I mentioned, this is a new instance of a previous similar issue. So, there's a lot of baggage.
19:12:59 <marga> spwhitton, why is everyone blocked on waiting to the specific person that rejected the package? Given the additional information that was provided through the bug / mailing list, can't someone else in the ftp-team comment on it?
19:13:39 <spwhitton> marga: yes.  however, the only people processing NEW regularly are Thorsten and me, and I'm very new to the team, so am concerned about stepping on waldi's toes.
19:14:19 <spwhitton> (I mean that I consider myself inexperienced, not that I think waldi would react badly, if you see what I mean)
19:14:53 <marga> Sure, yes. I understand.
19:15:09 <spwhitton> I think we're agreed that the most we could possibly do is say whether or not the situation fits with the previous ctte statement, and that it would be within ctte remit to do that, but we may still not want to do it?
19:15:45 <bremner> sounds about right.
19:16:01 <bremner> I think us "deciding" for individual packaging scenarios is not useful
19:16:07 <bremner> and possibly harmful
19:16:11 <marga> Agreed
19:16:27 <spwhitton> I am inclined to agree too.
19:16:45 <spwhitton> Though I do wish there were some way we could unblock the situation.
19:17:31 <bremner> any developer could try to mediate further with Waldi and Pirate
19:18:23 <bremner> 2 weeks is a bit soon to start complaining, in most debian processes
19:18:55 <spwhitton> yes, though I thought it had been longer than that.
19:19:17 <spwhitton> do we have to vote on not saying anything, then?  or do we just close the bug?
19:19:51 <bremner> or reassign it. Since there is clearly still a problem.
19:19:57 <marga> We don't usually vote for things like that.
19:20:20 <ehashman> I think either closing or reassigning it seems sensible
19:20:30 <spwhitton> ftp doesn't use bugs for NEW, so I suggest just closing.
19:20:54 <marga> Yeah, I think closing is sensible.
19:20:55 <bremner> ok. Someone (TM) should write up our concensus.
19:21:01 <spwhitton> probably shouldn't be me
19:21:05 <bremner> ack
19:21:30 <marga> Is the actual rejection email the one included in the first message to us? It seems like something is missing
19:22:03 <bremner> also true
19:22:27 <spwhitton> want me to dig it out?  It's available to all DDs but I probably have a copy right here.
19:22:46 <ehashman> please do
19:22:58 <marga> I'm trying to find it in the archives of the list. Google didn't find it for some reason...
19:23:20 <marga> https://alioth-lists.debian.net/pipermail/pkg-javascript-devel/2020-June/043518.html
19:23:20 <spwhitton> it is in the archive for pkg-javascript-devel@lists.alioth.debian.org and I am going to forward to ctte-private
19:23:22 <marga> I think that's it.
19:23:23 <spwhitton> oh, okay
19:23:29 <spwhitton> yes that's it
19:24:48 <hartmans> That's a little short on detail.
19:24:55 <bremner> It could be more verbose, but I don't think that changes anything for us.
19:25:08 <marga> No, it doesn't. I just wanted to understand the whole thing.
19:26:18 <marga> I feel like there's clearly a broken relationship between ftp-team and javascript package maintainers, but A) I have no idea how to fix it B) We aren't even the right body to fix it.
19:26:47 <marga> But regarding this specific issue, I think we should close it saying that they just need to keep talking to each other?
19:26:54 <bremner> I can write the bug closing mail, although my initial reaction to the bug was to be annoyed, so if someone else with more even feelings about wants to write it, I don't mind.
19:27:21 <hartmans> Sorry, didn't mean to distract.  I missed the single line of explanation on first reading and thought it was a rejection with no explanation at all.  Even if true, agree it need not be the TC's concern.
19:28:29 <spwhitton> bremner: I don't think you need to rule yourself out, so since no other volunteers, shall we action you?
19:28:36 <ehashman> yeah, I think the issue at this point is that a response has been written to the rejection but FTP team hasn't had a chance to respond/reconsider
19:28:48 <marga> I'll do it.
19:28:56 <marga> And I'll do it tonight, otherwise I won't do it.
19:29:06 <bremner> marga: OK, feel free to punt to me if needed
19:29:07 <spwhitton> #action marga will write response to node-katex bug
19:29:08 <ehashman> thanks marga !
19:29:25 <marga> #topic DebConf BOF
19:30:14 <marga> So, on this matter, Sean sent a draft (THANKS SEAN). And I failed again at writing my thing. I'm a constant disappointment to myself.
19:30:52 <ehashman> sounds like you are busy, don't beat yourself up about it. it's a hard topic
19:31:00 <marga> I'm deadline driven
19:31:11 <marga> I need deadlines that matter, and DebConf is a deadline that matters
19:31:13 <ehashman> highvoltage also messaged me about a "DebConf leadership BoF" or something similar
19:31:16 <spwhitton> That's okay.  I think that we should fix a timeline for BoF stuff today -- specifically, when to request questions, when to stop waiting and curate questions.
19:31:23 <ehashman> spwhitton: ++
19:31:30 <marga> So, if we say, marga needs to write this stuff before X day so that it works, then I'll do it.
19:31:44 <spwhitton> the first of those two things would be that day
19:32:12 <spwhitton> If debconf is at the end of august, and we allow ourselves two weeks to curate questions, and two weeks for people to submit them?
19:32:19 <spwhitton> then marga has a little less than two weeks to write up
19:32:40 <marga> I'd say less than that, because I want TC's input before opening for questions.
19:33:00 <spwhitton> we could reduce time to curate questions to one week, since our talk might not be on the first day of debconf
19:33:01 <marga> So, I think it needs to be done by next Sunday so that there's a week of everyone's input and then we can ask for questions?
19:33:09 <ehashman> that sounds good to me
19:33:31 <spwhitton> marga: could you say which day you mean?  "next"/"this" Sunday is trecherous
19:33:46 <marga> Sorry, I mean this Sunday, July 19th.
19:34:05 <marga> I have zero obligations this weekend, so it's actually doable.
19:34:06 <spwhitton> Okay, then one week later we send it out?  is that long enough for ctte?
19:34:17 <spwhitton> it's short in debian terms
19:34:20 <marga> It is.
19:34:27 <bremner> we can do it.
19:34:29 <marga> If there's debate, we can wait a bit more.
19:34:33 <bremner> worst case, we smile and nod
19:34:38 <spwhitton> marga: I think we ought to set the firm dates today actually
19:34:45 <marga> Ok, as you say, then.
19:35:02 <bremner> it doesn't have to be prefect, it's just a bof
19:35:15 <spwhitton> okay so we send 26th July, and curate from 9th August ?
19:35:40 <bremner> ij
19:35:42 <marga> Sounds good to me.
19:35:46 <ehashman> ++
19:35:58 <spwhitton> I guess we can just use a shared doc for the curation process
19:36:36 <marga> Sure
19:36:57 <marga> #action marga to send draft by next Sunday, July 19th.
19:37:02 <spwhitton> okay, then I think this is probably enough for us to have a BoF together
19:37:11 <marga> #info CTTE to discuss proposal after that
19:37:33 <spwhitton> we probably also want the brief spiel at start of bof, which requires slides
19:37:36 <bremner> assuming the debconf team accepts our placeholder bof application
19:37:38 <marga> #action spwhitton to send a call for questions with the debated draft on Sunday, July 26th
19:37:39 <spwhitton> maybe we should assign someone to that now too
19:37:54 <ehashman> that = ?
19:38:00 <ehashman> oh, slides?
19:38:04 <spwhitton> ehashman: slides summarising the past year for the TC
19:38:21 <spwhitton> maybe this just falls to whoever the chair will be by then
19:38:22 <ehashman> ha, I'd offer, but I wasn't around for the past year, so I have no idea.
19:38:34 <ehashman> let's hope that they don't elect me chair, then :)
19:38:37 <marga> haha
19:39:15 <marga> We are lacking half the group today.
19:39:28 <marga> I think Gunnar should do the slides, as he's the one that submitted the talk :)
19:39:48 <bremner> actually I submitted it originally
19:40:13 <marga> Ok, so you'll do the slides? ;)
19:41:08 <bremner> Uh. OK, when is my deadline?
19:41:33 <ehashman> August 16, to provide one week for review?
19:41:33 <marga> Whenever the talk starts?
19:41:38 <marga> :)
19:41:45 <marga> I think Elana's is better.
19:41:46 <ehashman> alternatively, what marga said
19:41:52 <spwhitton> bremner: which do you prefer
19:42:09 <bremner> Let's go with August 16, to prepare ehashman for being chair
19:42:13 <bremner> ;)
19:42:37 <marga> #action bremner to prepare the slides for the talk before August 16th.
19:42:49 <marga> Ok, I think we're done with this topic?
19:43:22 <spwhitton> I think so yes
19:43:29 <bremner> yes
19:43:40 <ehashman> ayee
19:43:45 <ehashman> yeah sgtm
19:43:45 <marga> #topic Any other business?
19:44:03 <ehashman> are we rescheduling? I know gwolf is not here to discuss results of the dudle
19:44:35 <marga> Ah, yes, that's true.
19:44:37 <bremner> are the results clear?
19:44:42 <marga> smcv didn't get to vote.
19:44:44 <ehashman> I haven't looked
19:44:52 <ehashman> does someone have the link handy?
19:45:02 <marga> https://dudle.inf.tu-dresden.de/deb-tech-ctte/
19:45:09 <marga> There's only one option with 7 yes
19:45:24 <marga> Which is Wednesday 17:00 (i.e. two hours earlier than today)
19:45:48 <spwhitton> in that case we are surely going to pick that regardless of whta smcv says?
19:45:58 <ehashman> there are also some with yes + maybe
19:46:07 <spwhitton> ah
19:46:14 <ehashman> so I'm not sure
19:46:18 <spwhitton> seems we should wait then
19:46:25 <marga> Right, other options could be picked if smcv said no to 17:00
19:46:40 <ehashman> so I guess we await smcv's response
19:46:48 <bremner> did we ask them?
19:46:57 <marga> Yeah, I think that's fair
19:47:04 <spwhitton> shall I send a ping
19:47:12 <bremner> please.
19:47:12 <marga> Sure, that would be nice.
19:47:48 <spwhitton> done
19:48:06 <marga> Thanks
19:48:13 <marga> Ok. Anything else that we should discuss?
19:48:42 <spwhitton> not from me
19:48:56 <ehashman> nor I
19:49:17 <bremner> I hope did not mess up timezones. I might be busy until 17:30.
19:49:34 <ehashman> https://www.worldtimebuddy.com/
19:49:44 <spwhitton> or emacs-world-time-mode ;)
19:49:57 <ehashman> not all of us use emacs, spwhitton :P
19:50:12 <spwhitton> pretty sure bremner does however
19:50:15 <ehashman> (although sometimes I feel like the only lisp hacker who doesn't)
19:50:22 <bremner> spwhitton and I are emacs co-conspirators
19:50:46 <marga> bremner, do you need to change your answer?
19:51:05 <bremner> marga: give me a few minutes to be sure
19:51:09 <marga> ok
19:51:13 <gwolf> Aw crap
19:51:20 <ehashman> hi gwolf
19:51:29 <marga> In any case, we'll wait until Simon's answer is in to make a decision.
19:51:31 <gwolf> Did not realize it was meeting day
19:51:47 <spwhitton> gwolf has already changed the meeting day without telling us ;)
19:52:10 <gwolf> Maybe that was It :-)
19:53:25 <gwolf> Am on the phone. Not the best way to read backlog and be useful... So, I will read later today
19:53:56 <ehashman> gwolf: there was nothing on the agenda today that was particularly spicy
19:54:13 <gwolf> ehashman: no jalapeƱo? Boring...
19:54:37 <bremner> marga: yes, I am busy from 16:30 to 17:30 on Wednesday. I better do the whole thing again just to be sure.
19:54:38 <ehashman> need habaneros for the DC BoF
19:55:08 <bremner> unfortunately all of my meetings are on the half-hour, which does not mesh well with the choices.
19:55:18 <gwolf> FWIW, I suggested my times around my _regular_ (non-COVID) schedule... Silly me?
19:55:59 <gwolf> bremner: we can do a half-assed dudle
19:56:43 <ehashman> is there a follow-up action?
19:56:54 <marga> Alright, everyone please review your answers and make sure they are correct timezone wise and covid-schedule wise.
19:57:22 <marga> gwolf, can I action you to announce the result once smcv's vote is in?
19:57:31 <gwolf> bremner: do you want a new doodle on the :00, :30? Could make sense...
19:57:53 <bremner> gwolf: I don't know, it's a hassle for everyone else.
19:57:57 <gwolf> marga: can be, if it Is OK with all
19:58:09 <gwolf> bremner: typical you... ;-)
19:58:41 <bremner> let's see if we have a time in this dudle that works, and retry on fail
19:58:54 <marga> Sounds good
19:59:01 <gwolf> Ok
19:59:32 <marga> #action gwolf to send the results of the dudle if there's a time that works for everybody (yes or maybe). Or re-send it with half hour splits if there's none.
19:59:39 <marga> And with that....
19:59:41 <marga> #endmeeting