18:59:24 <marga> #startmeeting
18:59:24 <MeetBot> Meeting started Wed Jan 15 18:59:24 2020 UTC.  The chair is marga. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:24 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:59:30 <marga> #topic Roll Call
18:59:39 <marga> Anybody out there?
19:00:04 <ntyni> Niko Tyni
19:00:16 <smcv> Simon McVittie
19:00:23 <marga> Margarita Manterola
19:00:24 <gwolf> Gunnar Wolf
19:02:16 <marga> #topic Review of previous meeting AIs
19:02:46 <marga> So, Simon had to send the closing of the nodejs+ruby bug and that was done. Yay for Simon :)
19:03:18 <marga> Pirate then sent a couple of replies, which I think nobody answered... I'm not sure if we should or not.
19:04:58 <smcv> I feel as though I've already been as clear as I was able to be
19:05:19 <marga> Agreed
19:05:22 <ntyni> they are mostly comments on consequences of the decision afaics, no open questions
19:06:05 <gwolf> Right, he's asking for this to be documented more formally...
19:06:18 <gwolf> is not questioning or the like
19:07:23 <marga> Right, but I don't think this is up to us. Maintainers are still in power of deciding whether they want to split a package or not, depending on a number of factors. There's no way we can make a "ruling" that covers everything
19:07:36 <marga> But it looked to me that Pirate was looking for something like that from us
19:07:42 <gwolf> I think he left Cc: to the bug when writing to debian-ruby for context
19:07:56 <smcv> I suppose someone could carve up the mail I sent into a whole bunch of policy and/or devref MRs...
19:09:21 <ScottK> Seems to me the idea of being able to skip obvious dependencies because devs should know better is a complete departure from the way we've done things in the past.
19:09:42 <smcv> we didn't recommend that?
19:10:15 <ScottK> That's a more general statement of what I thought you all recommended on library dependencies.
19:10:17 <smcv> the closest thing was to recommend libraries not explicitly depending on their interpreter, unless there is some other reason why it's needed
19:10:32 <ScottK> Precisely.
19:11:02 <smcv> on the basis that anything that needs that library is going to need a dependency on its own interpreter regardless
19:12:21 <marga> exactly, the library itself doesn't need the interpreter so it doesn't need to declare that dependency.  Binaries that use the interpreter do. It's not a question of "devs should know better" but of avoiding dependencies that aren't really needed and thus allowing more flexibility with regards to what is required.
19:12:24 <ScottK> It seems a really odd exception to me since the library needs the interpreter to work, but what's done is done.
19:12:51 <ScottK> So the library works without the interpreter?
19:13:02 <smcv> well, yes
19:13:09 <ScottK> Maybe because I use python mostly, I find that surprising.
19:13:12 <smcv> lua and tcl libraries work like this already
19:13:28 <smcv> *some (most?) tcl libraries
19:13:44 <ScottK> OK.
19:13:52 * ScottK will go back to watching.
19:13:58 <smcv> if you have a vim with embedded lua or tcl, you can use those libraries in it, regardless of whether you have #!/usr/bin/lua or whatever it is
19:14:19 <smcv> Python is an exception because byte-compilation needs the matching interpreter frontend
19:14:51 <smcv> and Perl is an exception because its actual interpreter is Essential, and we use the package name 'perl' as a stand-in for "a fully-featured Perl standard library" afaics
19:14:54 <ScottK> OK.  So it's not that you don't need an interpreter for the library, it's that there are choices and it's non-trivial to document them all?
19:15:04 <fil> Hi -- sorry I'm late
19:16:18 <marga> Sure, the problem is nuanced. You could have different interpreters for the same language. The libraries are useful in themselves, regardless of which interpreter you're using.
19:16:39 <marga> So, if you aren't shipping any binaries that require a specific interpreter, there's no reason to declare a dependency.
19:16:50 <smcv> it depends what you see the meaning of the package as
19:17:08 <marga> As Simon mentions, Python requires the interpreters for byte-compiling, so it's a in a different situation as things like javascript, lua, tcl, etc.
19:17:11 <gwolf> Yes, I see it as a departure from how we used to deeal with this some years ago
19:17:42 <smcv> if you see the meaning of ruby-foobar as "in whatever ruby interpreter(s?) you happen to have installed, you can load and use the foobar library" then that's trivially true if the set of ruby interpreters you have installed is empty?
19:17:50 <gwolf> but it makes sense, also due to the languages' landscape moving (i.e. with language-specific packaging and all that ugly stuff...)
19:20:02 <smcv> on the other hand, if you want ruby-foobar not mean "you can *run ruby and* load and use the foobar library", then it would be helpful to be more open to packages like the one we were asked about being split along language lines
19:20:10 <smcv> *want ruby-foobar to mean
19:21:54 <marga> In any case, the reply was just guidance around the discussion we had and the opinions gathered from debian-devel. It was not a full TC ruling, so it has no actual force. If you disagree, you can still declare dependencies on interpreters as you see fit.  The ruby team said that they were fine not declaring it.
19:22:08 <marga> Alright, I think we're ready to move on.
19:22:25 <marga> #topic Recruiting efforts
19:22:45 <marga> We're two people down and unfortunately we haven't received any nominations
19:23:43 <gwolf> how many people were spammed (and probably turned down the offer)?
19:23:49 <ntyni> unfortunate indeed
19:23:55 <marga> I got one personal question regarding the times of this specific meeting, bu that was it.
19:24:06 <marga> I don't know. fil, how many people did you email?
19:24:30 <fil> Hmm, 20 I think -- just sent another 20
19:24:36 <gwolf> uff :-|
19:25:31 <marga> Ok, thanks for that
19:25:36 <fil> well I definitely did 10, and think I did a second batch
19:25:38 <marga> Do we want to do more than that?
19:26:42 <fil> I think sending them to everyone is a bit much, but I can trivially do more
19:27:22 <gwolf> FWIW we are not *desperate* - If we cannot recruit, we can keep the TC being 6 or even 4
19:27:33 <gwolf> But, of course, it's better to have people for the long run
19:28:31 <ntyni> 20 per month seems to me like an ok (if arbitrary) rate for now
19:28:48 <marga> I was wondering whether we want to tackle the "role of the TC" question before we start aggressively recruiting
19:29:08 <gwolf> marga: Due to the low answering turnover... I think we should
19:29:20 <gwolf> At least that will allow us to better "market" the position
19:29:25 <marga> Ok
19:29:40 <marga> This has been a pending AI for me since DebConf, I guess I should get to it.
19:30:03 <marga> #info Fil has sent a batch of recruiting emails. We'll stick to 20 per month for now.
19:30:25 <marga> #action Marga to work on "The role of the TC" question. We might be able to recruit better once we solve that
19:30:35 <marga> Anything else on this subject?
19:30:42 <gwolf> marga: Maybe we should not try to do at the meetings, as it's little time...
19:31:52 <marga> Sorry, what do you mean?
19:32:39 <fil> I think he's suggesting that working out why we're here may take more than an hour ;-)
19:32:40 <gwolf> ...that we should probably start working via mail / etherpad / whatever
19:33:01 <gwolf> ... maybe start defining what you (as the main driver of the point) understand, and discuss around it...
19:33:12 <gwolf> I think it could be as a meta-bug on our meta-package :-]
19:34:08 <marga> Ah, yes, yes. I meant to work on it outside of this meeting and send emails to discuss
19:34:48 <marga> Alright, let's move on
19:34:53 <marga> #topic Any other business?
19:36:54 <marga> Is there anything else anybody would like to discuss?
19:38:24 <gwolf> Seems like not
19:38:26 <ntyni> looks like https://www.debian.org/intro/organization need an update, I'll try to handle that
19:38:34 <ntyni> *needs*
19:38:34 <gwolf> So i'll go pick up my kids :-]
19:39:02 <marga> ntyni, thanks!
19:39:08 <fil> gwolf: have fun :-) (mine both safely tucked up in bed)
19:39:25 <marga> #action ntyni will take care of getting https://www.debian.org/intro/organization updated
19:39:30 <marga> #endmeeting