18:00:35 <marga> #startmeeting
18:00:35 <MeetBot> Meeting started Thu Sep 29 18:00:35 2016 UTC.  The chair is marga. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:58 <marga> #topic roll call
18:01:02 <hartmans> Sam Hartman
18:01:06 <fil> Philip Hands
18:01:06 <marga> Margarita Manterola
18:01:10 <keithp> Keith Packard
18:01:19 <Mithrandir> Tollef Fog Heen
18:02:05 <marga> #topic Next Meeting
18:02:24 <marga> #info October meeting is confirmed to be  date -d 'Thu Oct 27 18:00:00 UTC 2016'
18:02:49 <marga> #info November meeting is still open to votes, currently looking like it will bedate -d 'Thu Nov 24 18:00:00 UTC 2016'
18:03:41 <marga> I want to state that I missed the previous meeting because I had looked at the "Thu" part and assumed it was on the last Thursday of the month, but turned out it was actually on a Tuesday (which the number correctly indicated, but I missed)
18:04:20 <marga> #topic Review of previous meetings' TODOs
18:04:21 <keithp> sorry for the confusion
18:04:45 <marga> So, from the previous meeting, we had 2 action items:
18:04:47 <marga> OdyX to start something on systemd in policy, counting on TC members' constructive support.
18:04:53 <marga> dondelelcaro To send emails starting our membership process.
18:05:46 <marga> Mails about the membership process have been sent, by fil and hartmans. Don also filed the bug.
18:05:47 <fil> [14:40] < OdyX> ... I haven't made progress on any front since last time, unfortunately, ...
18:06:07 <hartmans> And Don; he sent mail to d-d-a
18:06:16 <marga> Ah, yes, that too.
18:06:47 <fil> regarding my mails, I sent 21 in total, and the good news is that nobody complained so far ;-)
18:07:03 <marga> We also didn't get many nominees, did we
18:07:05 <marga> ?
18:08:13 <Mithrandir> we're still looking for more, at least.  I don't think we've historically disclosed numbers, and I don't think we should either.
18:08:25 <marga> ok, sorry
18:08:34 <hartmans> I think it's fair to say the size of the candidate pool is very concerning.
18:08:40 <marga> I didn't mean to disclose numbers. I meant that we still need more nominees.
18:09:05 <hartmans> Mithrandir:  I think it might be very close to time to disclose numbers.
18:09:30 <fil> I had a couple of tentative responses, one including some suggestions about who they might nominate if they were moved to do so, but AFAIK all names we've seen before in that case
18:10:01 <marga> #info New member process mail was sent to d-d-a. Also a bug was filed to track this.
18:10:10 <hartmans> So, one of the mails I sent caused a set of potential names to appear that hasn't been processed to ask people if they would accept yet.
18:10:19 <hartmans> Could someone do that? It'll be a couple of days before I can.
18:10:30 <marga> #info Fil has been sending mails to individual developers asking for nominations. Nobody complained so far. Some names have been put forward.
18:10:56 <marga> #info We have some developers that still need to get contacted regarding accepting or not their nomination
18:11:28 <marga> I guess I could do this, it's just sending the email to the person asking if they accept the nomination, right?
18:11:54 <Mithrandir> yes
18:12:05 <Mithrandir> that's what I've done at least
18:12:18 <marga> Sure, yeah, I can do it.
18:12:31 <marga> Do we have a list of people that have said yes/no/maybe/later?
18:12:41 <fil> BTW I don't think that the mails I sent is a terrible aproach -- I would welcome opinions about whether I should be explicit about the fact that the recipient being selected at random, or other improvement suggestions
18:13:05 <Mithrandir> fil: I think it's fine to continue as you've done.
18:13:10 * marga nods
18:13:47 <fil> the reason not to say that its random is that I think I'd simply bin such a mail ;-)
18:14:15 <Mithrandir> I don't think I'd do it, but EPID
18:14:19 <hartmans> fil:  I think your mails are great
18:14:33 <marga> Alright.
18:14:51 <marga> #action Marga to follow up with potential nominees that have not yet been followed up with
18:15:03 <marga> #action Fil to continue sending emails soliciting nominations
18:15:43 <marga> I guess all of this should have been under a separate topic, sorry about that :-/
18:16:05 <marga> Anyway, let's do another #topic for the non-acted upon #action.  Anything else about the new member process?
18:16:50 <marga> I'll take that as a no.
18:16:54 <fil> BTW do we have any feel for how many of those I should send?  I think small batches are quite a good idea, so I  could do 5 every other day until it provokes a positive/negative response
18:17:44 <marga> Sounds good. I was a little afraid of getting too many replies that we can't handle, but that doesn't seem to be happening, right?
18:18:20 <Mithrandir> marga: indeed
18:18:32 <fil> I've had 2 mails and an IRC chat IIRC -- I think I'll survive :-)
18:18:34 <Mithrandir> fil: no idea.  Pick a number, really.
18:19:39 <marga> Alright, next topic then.
18:19:50 <marga> #topic init system policy
18:20:15 <marga> So, OdyX had to "start something on systemd in policy", but this didn't happen
18:20:34 <marga> And worse, he can't be here today...
18:20:53 <marga> What do we want to do? Shall we wait a little bit longer for him to handle it, or does someone else volunteer to do it?
18:21:11 <hartmans> I think waiting is reasonable for another month.
18:23:11 <marga> Alright, any other opinions on this matter? I guess this isn't urgent anymore, given that the flames have mostly died?
18:23:14 <fil> How about nudging OdyX on the mailing list, at which point he can tell us about the chances of something happening in the month, and we can come up with a plan B as necessary?
18:23:30 <marga> ok
18:23:53 <marga> We still need a volunteer for that :)
18:24:05 <keithp> sounds fine to me
18:24:06 <fil> sounds like me
18:24:24 <marga> #action fil to poke OdyX on the mailing list to make sure that this doesn't stall.
18:25:09 <marga> Alright, that's it for that topic.  Next on the agenda we have:
18:25:10 <marga> #topic #741573 Menu System Policy
18:25:26 <marga> This is sort of surprising to me, as this is an old closed bug
18:25:53 <hartmans> I put this back on the agenda last meeting.
18:26:03 <hartmans> The issue is that our decision still has not been reflected in policy.
18:26:14 <marga> #info The issue is that our decision still has not been reflected in policy
18:26:28 <hartmans> The decision from last meeting was to work on this but that the init system issue was a higher priority
18:26:39 <marga> Ok.
18:26:39 <hartmans> So, sholud we open a new bug or reopen the old one?
18:26:48 <marga> The agenda came with 2 pre-written actions:
18:26:55 <marga> #action OdyX to figure out the state of the patch proposing to implement the rest of the TC decision.
18:27:02 <marga> #action OdyX and aba to find way forward within policy process reflecting input from debconf policy bof
18:27:14 <hartmans> right.
18:27:23 <hartmans> But those haven't happened and neither odyx nor aba are here.
18:27:24 <marga> It's a bit weird to actionify someone that's not here, but I'm assuming OdyX wrote those :)
18:27:37 <marga> I would say open a new bug.
18:27:39 <hartmans> So, we probably want to trick it somehow.  I guess we can track on our agenda instead of as a bug.
18:27:45 <hartmans> rather track it somehow
18:27:59 <marga> The old one has been closed for a long time and it's confusing to re-open now
18:28:07 <marga> No, I think having a bug for tracking makes sense.
18:28:33 <Mithrandir> so, the underlying problem here is that policy is a bit stuck in the water and this + the systemd bug is about changing that
18:29:07 <marga> So are they actually the same "bug" (i.e. update policy)?
18:29:24 <hartmans> Do you want  to action me to open a new bug?
18:29:45 <marga> That probably makes sense, yes.
18:30:07 <hartmans> I think of them as separate issues.
18:30:25 <marga> #action hartmans to open a new bug to track integration of the TC decision into policy
18:30:51 <marga> Anything else on this topic?
18:32:13 <marga> Let's move on, then.
18:32:21 <marga> #topic Additional Business
18:32:28 <marga> Anything else?
18:32:47 <hartmans> One item
18:33:33 <hartmans> As a FYI, I'll be attending the cloud sprint in early November.  There are a lot of vaguely overlapping none-quite-good-enough image creation tools for cloud and custom images, and I'm hoping to make progress understanding what our options are.
18:34:00 <marga> Sounds good
18:34:33 <hartmans> I don't think this issue is likely to come to the TC: there seems to be good progress within the community, but I do think it is worth tracking because it's a case where we have a bunch of overlapping solutions where our users would probably be served by fewer more complete options.
18:34:44 <keithp> hartmans: HPE should be open sourcing another image creation tool based on existing debian tools in the next little while
18:34:45 <hartmans> that's it for me.
18:34:58 <marga> keithp, interesting :)
18:35:26 <hartmans> keithp:  sigh
18:36:03 <keithp> hartmans: I'll provide info to you when that has been released; the goal (as always) is not to take over the world, but to just have another sample of how things might work
18:36:28 <keithp> one of those 'the existing tools don't do what we want' problems, but in this case, the actual work involved was quite small
18:36:47 <keithp> in any case, more info later, when we've managed our corporate process
18:37:44 <marga> Alright, anything else?
18:41:08 <Mithrandir> not from me
18:41:25 <marga> Ok, let's close then
18:41:28 <marga> #endmeeting