18:59:46 <dondelelcaro> #startmeeting
18:59:46 <MeetBot> Meeting started Wed Oct 28 18:59:46 2015 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:59:53 <dondelelcaro> #topic Who is here
18:59:55 <dondelelcaro> Don Armstrong
18:59:59 <vorlon> Steve Langasek
19:00:07 <dondelelcaro> (I'm pulling the updated agenda; bear with me a second)
19:00:10 <Mithrandir> Tollef Fog Heen
19:01:12 <hartmans> Sam Hartman
19:01:56 <dondelelcaro> OdyX, aba, bdale, keithp: ping
19:03:00 <dondelelcaro> #topic Next Meeting?
19:03:11 <dondelelcaro> currently, the winner is the same time on november 25th
19:03:43 <dondelelcaro> the 26th is thanksgiving, so that's probably actually a terrible time for some people
19:04:00 <dondelelcaro> so if people could update their availability for november, that would be awesome
19:04:18 <dondelelcaro> (and while they're doing so, I'll update the script for december)
19:04:21 <hartmans> I think I can do that, actually, although I will be unsurprised if others cannot
19:04:30 <vorlon> nov 25 is no problem for me
19:05:01 <dondelelcaro> cool; I think it'll work for me too
19:05:34 <dondelelcaro> #topic #741573 Menu systems - Debian Policy followup
19:06:01 <aba> aargh.
19:06:07 <aba> why are all meetings at the same time
19:06:31 <OdyX> Hi.
19:06:32 <OdyX> Sorry.
19:06:45 <dondelelcaro> OdyX: what were your plans for further action here?
19:06:51 <OdyX> Didier Raboud
19:06:55 <vorlon> aba: so that calendar? ;)
19:07:17 <OdyX> Well. I'm waiting on vorlon to formulate his concerns with my proposal.
19:07:46 <hartmans> Well, the current state is that -policy has not applied our diff, and discussion of how to implement our additional change has died.
19:07:50 <dondelelcaro> aba: please update your vote if a different date/time would be useful in the future; I think it's probably gone stale
19:07:52 <OdyX> I'm frustrated by Bill who exercices his right not to do anything.
19:07:55 <hartmans> i don't think vorlon has expressed that he has concerns.
19:08:11 <hartmans> He expressed a process concern in applying the diff without seconds as I read his message.
19:08:34 <vorlon> no, I did express concerns
19:08:42 <hartmans> O, I missed those; sorry.
19:08:45 <OdyX> hartmans: he wrote "I (…) do not this text to be in a state that's suitable for release"
19:09:14 <dondelelcaro> #action dondelelcaro to announce next meeting time november 16th
19:09:15 <vorlon> the text is a bare-bones application of the TC ruling, with none of the nuance around transition etc. that a good policy doc needs to have
19:09:46 <OdyX> This was 25 days ago, and you haven't expanded on the reasons. It is frustratingly long.
19:09:47 <vorlon> so yes, I know I haven't gotten a mail off to the list; sorry about that - it's in my todo bucket
19:10:42 <OdyX> First we need the patch we voted on to be included in Policy.
19:10:45 <OdyX> And this hasn't happened.
19:10:51 <vorlon> well, I'm not blocking that
19:11:00 <OdyX> Sure.
19:11:42 <OdyX> it seems that none of the Policy Editors have time or intention to do it.
19:11:49 <hartmans> odyx: I do understand your frustration here.
19:12:21 <OdyX> aba: you are a delegate; could you upload the Policy with the patch (I'm referring to the patch to Policy we explicitely pointed as hash) ?
19:12:27 <hartmans> Obviously, if you get to a point where the policy process seems bolcked to you, you acn ask to bring the issue back here.
19:12:34 <hartmans> rather blocked for you
19:12:52 <dondelelcaro> has the change even been committed?
19:13:20 <hartmans> It was committed and reverted yet again.
19:13:21 <jcristau> OdyX: you could just nmu?
19:13:28 <vorlon> it was committed but then both commits were rolled back
19:13:30 <hartmans> Bill has declined to answer my mail about when he will commit it.
19:13:37 <OdyX> It was commited by Charles, but Bill reset the master branch and didn't cherry-pick it.
19:13:50 <OdyX> I'm considering this on-the-line…
19:14:02 <dondelelcaro> ok, so someone can just commit that patch
19:14:05 <vorlon> not sure I understand what you mean by "on-the-line"
19:14:13 <vorlon> dondelelcaro: only the policy editors have commit access
19:14:17 <Mithrandir> uh, what?  Bill reverted it after our ruling?  Or did I misunderstand what was just said?
19:14:18 <vorlon> no policy editor is committing it
19:14:25 <dondelelcaro> vorlon: ah, got it
19:14:34 <OdyX> I mean that I consider this behaviour to be debatable from a delegated Policy Editor.
19:14:52 <vorlon> Mithrandir: yes, he reverted both the TC-ruled change and OdyX's policy proposal
19:14:54 <hartmans> Note that aba has commit access.
19:15:00 <OdyX> Mithrandir: Bill resetted the master branch to before the cherry-pick by Charles.
19:15:01 <dondelelcaro> well, it should be committed shortly, or one of us will implement it by NMUing policy, I guess
19:15:08 <hartmans> as does Mithrandir
19:15:23 <vorlon> ok
19:15:34 <OdyX> an NMU should only include that change, and none of the changes currently in Git.
19:15:35 <vorlon> seems like a good way forward is for aba or Mithrandir to restore the TC-mandated policy change
19:15:38 <dondelelcaro> Mithrandir, aba: assuming you both have commit access, could you do so?
19:15:50 <vorlon> and then people who care about this can discuss on debian-policy as they should
19:16:01 <Mithrandir> I have commit access to policy?  I didn't know that.  (Apart from using my root powers)
19:16:03 <dondelelcaro> otherwise, if there's no action, I'll NMU policy around November 15th or so.
19:16:23 <hartmans> I'm fairly sure you do. aba has both access and delegated authority
19:16:50 <OdyX> dondelelcaro: can we move faster ? It's been since September 4 that we announced our decision.
19:16:57 <dondelelcaro> Is everyone OK with me waiting a few days for the commit to happen, then announcing my intention to NMU policy
19:17:04 <vorlon> if someone feels an NMU is necessary to unstick things, then that is also an option; I still don't think it's a poor approach to policy, but if neither I nor any of the policy editors have time to drive a discussion then it shouldn't block indefinitely
19:17:19 <vorlon> s/don't think/think/
19:17:32 <hartmans> vorlon: why is an NMU of the non-controversial commit bad?
19:17:33 <dondelelcaro> OdyX: I think that the policy is clear going forward; it's just a case of the actual writing which needs to be cleared up
19:17:40 <Mithrandir> aba: are you willing to do it with your policy hat on?
19:17:42 <hartmans> I agree an NMU of the second part of our ruling would be premature
19:17:52 <OdyX> It certainly is a poor approach to Policy, but if the only currently active Policy Editor doesn't act…
19:18:06 <OdyX> ah yeah, I'm not advocating an NMU of the second part of our ruling.
19:18:12 <dondelelcaro> right; I'm only talking about an NMU for the first part
19:18:21 <vorlon> hartmans: what the TC established was that this commit should be the starting point for further policy discussion; I don't think that means it's "non-controversial"
19:18:46 <dondelelcaro> OdyX: I'll try to get to it faster; I just don't want to promise what I can't do
19:18:48 <OdyX> vorlon: "the TC adopts the changes in $hash".
19:19:10 <hartmans> Ok, noncontraversial was a bad word choice.  But I actually believe we established that that commit is part of Debian's policy, not a starting point for discussion.
19:19:32 <dondelelcaro> #action dondelelcaro to announce intention to NMU policy if the first part of the TC decision is not committed
19:19:40 <OdyX> I think there's a process problem here anyway: there are four delegates, and the only one active has very good reasons to not be active on this very subject
19:19:43 <dondelelcaro> #action aba and/or Mithrandir to commit first part of change if possible
19:20:04 <hartmans> odyx: agreed.
19:20:35 <dondelelcaro> ok; lets move on and circle back if necessary
19:20:36 <OdyX> so even if there were seconds collected, I wouldn't expect Bill to commit and upload Policy with changes "hurting" menu.
19:20:47 <OdyX> (fair enough, I mean, it's probably natural)
19:20:48 <dondelelcaro> #topic #771070 Coordinate plan and requirements for cross toolchain packages in Debian
19:21:05 <vorlon> hartmans: to put it another way, I was ok with the TC resolution that passed because it was my understanding that this was setting the broad technical direction and would be the starting point for the more nuanced policy discussion that needed to happen about how to get there.  If we are going to ram this single policy commit in via NMU, then I agree with Guillem's and Ian's criticisms of this TC
19:22:18 <OdyX> Well. People need to be motivated to actually have the discussion.
19:22:43 <OdyX> And the prerequisite for that is to agree with the general direction. Afaik, neither Bill, Guillem or Ian agrees with the general direction.
19:22:58 <vorlon> Guillem said he did agree with the general direction, fwiw
19:23:19 <OdyX> okay.
19:23:49 <dondelelcaro> frankly, I'd be happier with not NMUing, but things need to keep moving forward
19:24:05 <OdyX> The actual situation is that nothing happens, and a new release will happen before this menu decision takes life in a Policy upload.
19:25:16 <dondelelcaro> with regards to the toolchain issue; my understanding is that OdyX was going to follow up with Vorlon regarding the toolchain discussion
19:25:21 <dondelelcaro> did that happen?
19:25:46 <vorlon> we had a discussion last meeting about closing out this issue, I think?
19:26:28 <OdyX> 2015-10-04 20:38:06     vorlon  OdyX: no, because the meeting seemed wholly uneventful.  What I did mean to do was follow up with helmut by email to confirm whether or not he's satisfied that things have been worked out
19:26:30 <OdyX> 2015-10-04 20:39:24     vorlon  either the sticking points have all been resolved and the TC doesn't have any more work to do here; or the 3-hour BoF didn't get to the heart of the matter; and I'm not sure which it is
19:26:35 <vorlon> because the original petitioner no longer sees any action for the TC, and no one wants to take the time to try to write up a summary of the meeting
19:26:54 <vorlon> right, there were comments further on from helmut
19:26:59 <dondelelcaro> OK, cool; that was outside of the last meeting, so I didn't have it to refer to
19:27:42 <vorlon> 11:34 < dondelelcaro> well, if no one is interested in sumarizing what happened in the meeting, I'm going to propose that we close this bug and move on
19:27:46 <helmut> I can only reiterate that I am out of the contention. There is no point in asking me whether I'm satisfied anymore.
19:27:47 <hartmans> His comments seemed kind of discouraging, but it was not clear that was action.
19:27:56 <hartmans> rather there was action for us.
19:28:37 <dondelelcaro> vorlon: right; I was confused if someone was going to write up something, which is why I haven't closed it
19:28:42 <vorlon> helmut: if you mean that wookey still has some concerns, I would argue the best way to handle those is by wookey opening a separate bug and enumerate those specific concerns
19:29:11 <dondelelcaro> does anyone object to me writing up a short summary of what happened in this bug as a statement, and we can close it?
19:29:19 <OdyX> well. That's probably a good way forward, but this is again a case where the clock just played against considering the problem properly.
19:29:54 <hartmans> Agreed.  I wish without much hope that we could learn from this issue.
19:30:21 <dondelelcaro> #action dondelelcaro to write up a short summary of what happened in #771070 as a statement, and we can close it?
19:30:31 <dondelelcaro> #topic #802159 New OpenSSL upstream version
19:30:35 <OdyX> (Time is often a good way to resolve issues by having all parties put their griefs under the carpet; but that's not what we're constitutionally asked to do)
19:31:18 <Mithrandir> ok, here we have a new bug, so we can try not to let it expire of old age this time around. ;-)
19:31:29 <dondelelcaro> this particular issue is basically a case of a lack of person-hours coupled with a complicated issue, coupled with lack of process
19:31:47 <dondelelcaro> short of designing a process and policy for the SRMs, I'm not sure what to do here
19:32:04 <OdyX> ah. I thought you referred to the multiarch one :-P
19:32:08 <Mithrandir> are we asked to mediate, offer advice or tell the SRMs what to do?
19:32:09 <dondelelcaro> the only other alternative is to have the SRMs punt this issue to us, or for us to somehow override this
19:32:33 <hartmans> or offer advice or mediate
19:32:44 <dondelelcaro> Mithrandir: we're asked to cause a decision to be made
19:32:47 <hartmans> it's not clear to me what the TC is requested to do here and I'd like for us to find that out.
19:32:57 <hartmans> It might be good to get someone to agree to champion this from within the TC.
19:33:04 <hartmans> Now is not a good time for me to volunteer.
19:33:05 <dondelelcaro> hartmans: I've basically already done that
19:33:12 <Mithrandir> dondelelcaro: you talked to adsb (iirc) about this, didn't you?  What was their feedback on it?
19:33:20 <dondelelcaro> Mithrandir: it's quoted in the bug log
19:34:18 <OdyX> he roughly said "lack of time, package is considered risky, so noone touches it even with a remote stick"
19:34:34 <dondelelcaro> right; but no one wants to say no, because it could potentially be a good idea
19:34:40 <hartmans> Unfortunately this is a case where not touching it is very risky.
19:34:44 <dondelelcaro> so it sits without a decision
19:35:38 <OdyX> we can't really force the SRMs to take a decision, or take them in their place, I think.
19:35:54 <dondelelcaro> in any event, unless the SRMs want to delegate this to us, or Kurt wants us to override the SRMs, I think I've done what I can to get an answer
19:36:50 <hartmans> or we want to give advice
19:37:01 <hartmans> It's not clear we can override the srm as a delegate.
19:37:02 <Mithrandir> we could work with the SRMs (and possibly Kurt) to iron out a reasonable policy, but that requires somebody from them having the time to sit down and do it.
19:37:15 <dondelelcaro> Mithrandir: it also requires the SRMs to want a policy
19:37:19 <Mithrandir> yes
19:37:41 <dondelelcaro> I don't think a policy for the SRMs requires the CTTE
19:37:46 <dondelelcaro> anyone can participate in that
19:38:16 <OdyX> The abence of policy/guideline is certainly a concern though.
19:38:35 <dondelelcaro> so going forward: I'm going to ask Kurt specifically what he'd like the CTTE to do, and then proceed further using e-mail
19:38:42 <Mithrandir> it seems like new upstream versions are fine in some situations (linux stable versions, postgres).
19:39:02 <dondelelcaro> #action dondelelcaro to ask Kurt again specifically what he'd like to do regarding #802159
19:39:11 <OdyX> yeah, that's certainly frustrating for maintainers of other packages…
19:39:12 <dondelelcaro> #topic #636783 Constitution: super-majority bug & #795854 Constitutional Amendment: Fix duplicate section numbering (A1)
19:39:16 <Mithrandir> I don't know if those are reviewed for every single changed line or not.  I suspect not.
19:39:47 <dondelelcaro> the revised GR was submitted
19:39:57 <hartmans> hu?
19:40:04 <OdyX> hartmans: you did that :-)
19:40:16 <dondelelcaro> and I believe it has enough seconds already
19:40:23 <OdyX> well. The original GR timed out.
19:40:24 <dondelelcaro> or mabye it needs one more
19:40:37 <hartmans> last I checked we needed one more second.
19:40:43 <dondelelcaro> if someone wants the original ballot, they should submit it
19:41:01 <dondelelcaro> #topic #797533 New CTTE members
19:41:13 <dondelelcaro> I'm going to resend the call for nominations
19:41:28 <dondelelcaro> you all should propose nominees too
19:41:33 <OdyX> yes.
19:42:00 <hartmans> So, odyx, if any of your proposals say yes, someone needs to write up bios/statements
19:42:14 <hartmans> I would not b e able to vote on a name without supporting statements.
19:42:27 <OdyX> Let's wait for answers.
19:42:38 <dondelelcaro> I'm concerned with the lack of nominees so far
19:42:49 <OdyX> Yes.
19:42:50 <hartmans> we currently have 0 accepts, right?
19:42:55 <dondelelcaro> hartmans: yes.
19:43:14 <dondelelcaro> so I'm going to rewrite the call for nominations to be very explicit
19:43:34 <hartmans> In the rewritten call, my recommendation is that you explicitly encourage self-nominations.
19:43:39 <dondelelcaro> hartmans: yes.
19:43:41 <hartmans> I think that works better in our community.
19:43:48 <dondelelcaro> I agree
19:43:53 <hartmans> Obviously nominating others is fine, we just tend to do it infrequently
19:44:10 <dondelelcaro> yep
19:44:28 <dondelelcaro> #action dondelelcaro to call for nominees again while being explicit to self nominate
19:44:35 <dondelelcaro> #topic #795855 Formal cloture vote
19:45:04 <dondelelcaro> this was blocking on bdale
19:45:10 <hartmans> 've been having some interesting discussions with bdale on something like this.
19:45:16 <dondelelcaro> cool
19:45:32 <hartmans> So, here's a brief summary.
19:45:47 <hartmans> We've been focusing on the ballot about binary blobs in the kernel as a discussion point.
19:46:11 <hartmans> In that ballot the community proposed a lot of overlapping options.  He was acting secretary and had to evaluate what the result meant for the project.
19:46:23 <hartmans> He found it challenging.
19:46:56 <hartmans> If we're OK with that kind of ballot, then we're probably OK letting every ballot option someone wants get onto a ballot.
19:47:19 <hartmans> It means that in a situation where there's disagreement about what question to ask, then the question you care about may not get answered by the ballot.
19:47:42 <hartmans> If we're not OK with that sort of situation, then we have to think a lot:-)
19:47:53 <hartmans> that's my summary.
19:48:27 <hartmans> For myself, I actually really liked the power of the binary blob ballot and tend to hold it up as an example of how well our system works.
19:49:29 <hartmans> So my preference would be no action on this bug, but we need to give people who want something else a chance to have that happen.
19:49:52 <dondelelcaro> ok; is there anyone else who would like to take on this issue?
19:50:23 <dondelelcaro> hartmans: could you follow up to the bug with a summary like that, and ask if someone wants to take it on, and close it if no one does within a week?
19:50:26 <OdyX> nope
19:50:30 <Mithrandir> not me.
19:50:40 <hartmans> will do action me please
19:50:56 <dondelelcaro> #action hartmans to  follow up to the bug with a summary like that, and ask if someone wants to take it on, and close it if no one does within a week?
19:51:06 <dondelelcaro> #topic #795857 TC chair appointment
19:51:20 <dondelelcaro> oh, I was supposed to write this up
19:51:22 <dondelelcaro> my bad.
19:51:29 <dondelelcaro> #action dondelelcaro to write up TC chair election process with after new member and/or within 3 months of resignation
19:51:49 <dondelelcaro> let me actually get to that.
19:51:55 <dondelelcaro> #topic #795859 Permit TC to hold private conversations
19:52:03 <OdyX> Same here :-)
19:52:16 <dondelelcaro> #action dondelelcaro to close #795859 but allow any TC member or DD to champion it themselves
19:52:19 <dondelelcaro> yep
19:52:29 <dondelelcaro> #topic Additional Business
19:52:35 <dondelelcaro> anything else?
19:52:41 <hartmans> none here
19:52:54 <Mithrandir> not from me
19:53:17 <OdyX> I think we should have a conversation about how active we expect TC members to be.
19:53:59 <OdyX> I'm frustrated by the whole GR saga.
19:54:14 <OdyX> (I'm not pointing fingers here, there are certainly good reasons for that).
19:54:29 <OdyX> (But maybe this meeting is not the correct time/place/medium to have that discussion)
19:54:56 <Mithrandir> what's the frustration?  Everything taking forever, or something else?
19:55:05 <dondelelcaro> yeah; I'm not sure how to require activity on the CTTE
19:55:08 <OdyX> Yes. Everything taking forever.
19:55:45 <OdyX> dondelelcaro: making it clear that a) the mandate is fixed-length; b) therefore we expect some level of involvment
19:56:01 <dondelelcaro> OdyX: and that people can step down
19:56:22 <hartmans> don: Sometimes it's not about requiring things but about building a culture that encourages them.
19:56:35 <dondelelcaro> OdyX: would you be willing to start a thread on -ctte about that?
19:56:40 <OdyX> can / should if they don't think they can face the reponsibilities anymore.
19:56:43 <OdyX> I can yes.
19:56:44 <dondelelcaro> hartmans: yes... that's partly why we have these meetings
19:56:45 <Mithrandir> yeah, I'm more of the building a culture and setting expectations than anything formal.
19:56:51 <dondelelcaro> OK
19:56:57 <hartmans> For myself, the TC moves so slowly that  I find myself caring less and lowering my standards.
19:57:05 <hartmans> I feel kind of hopeless, so i don't care.
19:57:23 <OdyX> same here.
19:57:35 <hartmans> i consider spending time on TC business or other things and decide that if I work on the TC I'll just get blocked anyway, so it can wait...and wait... and besides it takes so long is it worth the bother.
19:58:12 <OdyX> I'm just not hopeless yet, but rather idealistic, and want to continue making the TC a useful body.
19:58:20 <dondelelcaro> OK
19:58:35 <Mithrandir> so why do we move so slowly?  Is it because we're (overly) cautious, that we try to build consensus and sync up with each other, something else?
19:58:46 <OdyX> Because frankly, if all / most issues only get to timeout because of inactivity, I will become a supporter of just dropping the TC from the constitution.
19:58:52 <hartmans> hopeless is an exageration, or at least not a constant state.  Conversations with odyx, or say the drafting sesnion for resolution text with Keith can easily get me out of that.
19:59:37 <dondelelcaro> I'd love to hear concrete suggestions of things we can do to improve the operation of the CTTE
19:59:52 <hartmans> Mithrandir I think it's because we end up getting stuck waiting for people, and because we're slow to respond to each other.
19:59:59 <OdyX> Mithrandir: the feeling I have (but I don't know how close it is to reality) is that many of us are overwhelmed with ton of other things, and just let the TC issues fall down the priority list.
20:00:17 <Mithrandir> OdyX: they tend not to jump up and down and demand attention, yeah.
20:00:27 <hartmans> When I send mail to the TC with interesting content, the probability that I'll get an interesting reply before the next meeting seems to be about 30%.  The probability that I'll get all the interesting replies I need to move forward is much less than that.
20:00:34 <OdyX> The end-result of that is that any conversation takes _ages_, because people only interact every 2-3 weeks.
20:01:11 <Mithrandir> speaking for myself, I'd be fine with us using this channel more, in particular for coordination when stuff come in, when there's something we want to discuss, etc.  Not sure how well that works for everybody else, though.
20:01:38 <hartmans> I was hoping that if we're explicit that we want people to follow email closely in our nominations, we may get a core group of 3-5 people who are fairly fast to respond after this round.
20:02:27 <dondelelcaro> in the past month, only three CTTE members have e-mailed the mailing list. And only I and OdyX have committed to git.
20:03:32 <OdyX> We maybe need more meetings, but in "spike" terms.
20:04:08 <OdyX> Something like a "fixed timeframe every week" where the TC members tackle the pending mails.
20:04:42 <Mithrandir> I'd be ok with doing that for a bit, seeing how it goes.
20:04:51 <Mithrandir> if it doesn't help, we try something else.
20:05:06 <dondelelcaro> OK
20:05:09 <OdyX> It'd need to be during work-day for me. But we don't need to be in sync though.
20:05:22 <dondelelcaro> I'm going to stop here; I've got to get back to $DAYJOB
20:05:31 <dondelelcaro> thanks, everyone!
20:05:32 <dondelelcaro> #endmeeting