19:03:29 <dondelelcaro> #startmeeting
19:03:29 <MeetBot> Meeting started Wed Jul 29 19:03:29 2015 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:29 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:33 <dondelelcaro> Don Armstrong
19:03:44 <dondelelcaro> (sorry; lagging slightly)
19:03:59 <Mithrandir> hey
19:04:02 <Mithrandir> Tollef Fog Heen
19:04:12 <vorlon> Steve Langasek
19:04:26 <dondelelcaro> #topic Who is here?
19:04:34 <dondelelcaro> (just so everyone is ready)
19:04:43 <dondelelcaro> #topic Next Meeting?
19:05:00 <dondelelcaro> currently the next meeting is scheduled for 2015/08/26 at 19:00 UTC
19:05:09 <aba> that's post debconf?
19:05:18 <hartmans> Sam Hartman
19:05:20 <dondelelcaro> that's squarly in the middle of debconf, so the actual meeting will happen whenever the bof is scheduled
19:05:41 <hartmans> Is there any chance of getting audio in/out of the bof?
19:05:55 * aba seems to have worse problems than usual with the calendar
19:05:55 <vorlon> "squarely in the middle of debconf"?
19:05:58 <aba> hartmans: that's planned
19:06:09 <vorlon> Debconf is Aug 15-22, you cited Aug 26?
19:06:20 <aba> (and tech ctte bof is the last event prior to closing or so)
19:06:22 <hartmans> aba: what technology should I be prepared to use?
19:06:25 <dondelelcaro> vorlon: huh; for some reason I have it in my calendar on the 15-22nd.
19:06:32 <dondelelcaro> err, 24->29
19:06:41 <dondelelcaro> my calendar is probably wrong, then
19:06:58 <Texou> hi
19:06:58 <aba> hartmans: hm, it's just audio out IIRC
19:07:03 <Mithrandir> 26th should wfm.
19:07:12 <dondelelcaro> heh; yeah, my calendar is wrong
19:07:16 <Texou> are meetings public?
19:07:29 <aba> hartmans: and that's via video streaming. however feedback used to work well via irc
19:07:42 <dondelelcaro> Texou: yes, but unless you have something specific which is on topic, generally best not to say too much
19:08:09 <hartmans> aba: I may send mail about  whether we can get some trick for audio in
19:08:24 <hartmans> but will definitely be available via irc
19:08:25 <Texou> dondelelcaro: oh I think I'll stay quite and will read, since I am discovering what is a meeting and what you do
19:09:11 <dondelelcaro> cool; I think we can forgo the meeting on the 26th in favor of the BoF during Debconf; is that OK with everyone?
19:09:39 <Mithrandir> I unfortunately won't be at Debconf, after all.
19:09:50 <dondelelcaro> or rather, does anyone have a problem with skipping the next meeting and having it during the BoF?
19:10:04 <dondelelcaro> Mithrandir: I won't be there either, but I'll participate remotely
19:10:11 <Mithrandir> ok, that wfm, I think.
19:10:15 <Mithrandir> depending on time, etc.
19:10:17 <dondelelcaro> yeah
19:10:41 <hartmans> makes sense
19:10:52 <dondelelcaro> #agreed next meeting during BoF at Debconf, precise time TBA
19:11:06 <dondelelcaro> #action dondelelcaro to announce precise meeting time of next meeting
19:11:44 <dondelelcaro> the meeting after that is scheduled for this time on the 30th of september
19:11:56 <aba> I won't be available there
19:12:21 <dondelelcaro> if there are problems with that, update the appropriate lines in the meeting poll, and I'll make an announcement during our next meeting as to that time
19:12:33 <dondelelcaro> and after that we'll do the DST dance, I think.
19:12:47 <dondelelcaro> #topic #741573 menu systems and mime-support
19:12:59 <hartmans> Almost done!!!
19:13:13 <hartmans> Don, thanks for putting together the ballot.
19:13:21 <dondelelcaro> so I've added the language I wanted to the ballot, and I've added the section that hartmans wanted to option B.
19:13:24 <dondelelcaro> hartmans: no problem
19:13:26 <hartmans> In mail I said that I'd probably vote a=b
19:13:43 <hartmans> however, private mail has suggested that there are some people who care about the distinction
19:13:58 <dondelelcaro> are there any options that people would like to vote for which aren't represented in that ballot?
19:14:00 <hartmans> so I'm probably going to vote b>a because I think b is a true statement.  I think a and b are very similar
19:14:49 <hartmans> vorlon: It sounded in previous discussions like you had objections to Charles's debian-policy proposal.  Now (or before now) would be a good time to concretize them if that's true.
19:15:19 <vorlon> hartmans: if you mean the original proposal that was reverted, yes I do
19:15:34 <vorlon> which keithp had been addressing in his earlier draft
19:15:44 <hartmans> OK, well we're voting on bringing it back next week.
19:16:05 <hartmans> I would really appreciate it if you would write up your concerns.
19:16:40 <vorlon> well, my frustration level is high on this
19:17:10 <vorlon> we had arrived at a rough consensus within the ctte that what had been committed was not good policy
19:17:19 <vorlon> and work was done to get us a good policy
19:17:51 <vorlon> and then we ended up with a reframing of the TC issue in terms of whether the process was followed
19:18:28 <hartmans> I hear your frustration.
19:18:34 <vorlon> now it appears that we're voting on whether we agree with the specific policy language; and keithp's proposal, which was much better, appears to not be in the mix
19:18:58 <vorlon> and I'm not sure I have time to hunt that down before next week
19:19:28 <dondelelcaro> would it be reasonable to also include keithp's proposal as an alternative otion?
19:19:31 <hartmans> I'd also like you to hear my frustration here.
19:19:55 <hartmans> I made it quite clear in my application to be a tc member how I approached process.
19:19:56 * dondelelcaro would like to avoid continuing to drag this issue out further and further
19:20:09 <hartmans> When I was selected, I raised the issue again
19:20:38 <hartmans> Now that I've said basically exactly what I told people I'd do, I'm getting frustration that seems greater than just disagreement.
19:21:20 <hartmans> I understand that we'll disagree with each other from time to time, but it sounds like there's stronger feeling than that going around.  If so, I'd like to explore that.  If not, I regret mishearing.
19:22:11 <dondelelcaro> if I can paraphrase, I think the frustration is that work was spent trying to come up with a good technical policy, and that work hasn't been incorporated into the current ballot
19:22:32 <hartmans> OK.
19:22:48 <hartmans> But if no one wants to drive that work...
19:23:07 <dondelelcaro> well, it was driven for some time, but it hasn't been driven to completion, FWICT.
19:23:09 <hartmans> For example I think that Keith himself (last I saw him present the issue) would rather try and take that forward within debian-policy
19:23:24 <hartmans> rather than here.
19:23:30 <hartmans> Apologies if I'm misunderstanding Keith.
19:23:46 <vorlon> hartmans: my point is that we appear to have come full circle on the question of what the TC should be voting on (setting policy -> determining whether the policy process was followed -> setting policy), and the ballot options we're deciding between (at least A vs. C) are simply choosing between the two bad options that were originally put forward, that the policy process didn't reach agreement on
19:24:10 <hartmans> I agree that if someone on the TC wants to propose that ballot option or propose a delay until we can get that ballot option, they should be able to do that.
19:25:00 <vorlon> right.  so I don't want to delay the vote any further, because I don't think that will result in me finding time to work on it
19:25:11 <vorlon> though if we can get keithp's draft on the ballot I would be happy with that
19:25:16 <dondelelcaro> ok
19:25:19 <vorlon> (requires archaeology to figure out where that landed)
19:25:21 <hartmans> vorlon: I'm really frustrated when I hear you say "The policy process didn't reach agreement on."  I have explained why I believe the policy process did agree to A.  You may disagree with my conclusion, but I'd ask for enough respect to acknowledge that the issue is in dispute.
19:25:27 <Mithrandir> is his draft in a usable state at this point?
19:26:01 <vorlon> otherwise I'm personally inclined to vote FD above all of these ballot options, because I think they all result in bad policy
19:27:05 <vorlon> hartmans: I was trying to avoid the use of the word "consensus" because I don't think we have a consensus about how that word should be used in the policy context (heh).  But whether or not you think there was a consensus, I would have thought it unambiguous that the process did not result in a policy that everyone agreed on
19:27:44 <hartmans> ok, thanks for explaining.  That's not how I read what you were saying, but I do agree that there are people who disagree with that policy.
19:27:51 <hartmans> Your explanation really did help.
19:28:05 <jcristau> it seems unambiguous that there's no policy that everyone will agree on?
19:28:27 <vorlon> jcristau: are you opining or asking clarification of what I meant?
19:29:02 <dondelelcaro> so I think it's up to someone to try to build up a specific patch to policy based on keithp's draft and include it in the ballot options
19:29:34 <dondelelcaro> or alternatively, vote and see what falls out, and work on the changes keithp proposed through the normal policy process
19:29:57 <dondelelcaro> I'm OK with waiting for a while for the first thing to happen, but I'd like to avoid waiting forever
19:29:58 <jcristau> vorlon: asking clarification, because seeing the history i don't think any other process will result in a policy that everyone agrees on
19:30:09 <hartmans> Note that if somenoe proposes such a patch *and* an explanation of the technical objections to the current policy in A, I might well vote for the keith option.
19:30:21 <jcristau> and i'm not sure that should be the expectation, either for the policy process or the tc
19:30:36 <hartmans> But to vote for it i'd need to see a list of objections to A/B in the ballot option/proposed decision.
19:31:58 <dondelelcaro> anyway, I'll summarize this in an e-mail. If someone is making progress on such an option/patch, I'll hold off on voting
19:32:18 <dondelelcaro> #action dondelelcaro to hold off on voting as long as someone is making progress on such an option/patch
19:32:23 <vorlon> jcristau: ok; so as I said, I believed we had arrived at a rough consensus within the TC that the two options - keep or revert - that the policy process arrived at were both not good policy.  It's within the TC's remit to decide technical policy for Debian.  In cases where the policy process doesn't reach a good decision, I think it's appropriate for the TC to vote. I don't know if keithp's draft is something that everyone will agree with, but ...
19:32:29 <vorlon> ... I personally believe it's good policy
19:33:09 <dondelelcaro> #topic #636783 constitution: et al.
19:33:25 <dondelelcaro> just going to mention these for the record; nothing has happened on them, so I'll move on to the next thing
19:33:28 <vorlon> dondelelcaro: as I said, I don't feel I can promise to make progress on this; so if you want to call the vote I don't object to that - I'm just making it known my view on the current ballot options
19:33:32 <dondelelcaro> #topic #771070 Coordinate plan and requirements for cross toolchain packages in Debian
19:33:36 <dondelelcaro> vorlon: yeah, understood
19:33:51 <dondelelcaro> everything being equal, I'd probably prefer to work on it myself, but I'm swamped right now
19:33:54 <dondelelcaro> (grant deadlines)
19:34:30 <hartmans> when does gcc5 transition finalize?
19:34:40 <dondelelcaro> the debconf meeting is still being planed, but parties are busy with gcc5 transition
19:34:45 <jcristau> hartmans: it supposedly starts in 2 days
19:34:54 <dondelelcaro> so hopefully it'll still happen
19:35:09 <dondelelcaro> if it doesn't, I guess our alternatives are to do some kind of phone call or something like that
19:35:10 <hartmans> I propose that if the debconf meeting does not happen we take this up for real as a TC matter and decide policy
19:35:13 <jcristau> and it'll take a while.
19:35:18 <jcristau> vorlon: i don't remember seeing that draft, do you know if it's in the bug log somewhere?
19:35:25 <dondelelcaro> jcristau: there's a draft in git
19:35:30 <hartmans> (or override depending on how we approach)
19:35:40 <jcristau> ok
19:36:08 <vorlon> gcc5 transition is on track to begin on Friday, yes
19:36:25 <dondelelcaro> yeah; I'd like to try one more time for a consensus process, but baring that, we'll have to decide.
19:36:36 <dondelelcaro> it's what we get paid the no bucks for
19:36:54 <vorlon> :-)
19:37:11 <dondelelcaro> #agreed keep trying for consensus; baring that, actually decide the issue
19:37:31 <dondelelcaro> #topic Additional Business
19:37:55 <dondelelcaro> I don't have any additional business; I hope everyone has a great time at Debconf
19:38:27 <Mithrandir> ditto
19:38:29 * aba too
19:38:45 <vorlon> who all is actually making it to DC?
19:38:50 <hartmans> no aob
19:39:03 * aba 
19:39:04 <vorlon> (I am)
19:39:33 <vorlon> I haven't yet looked at schedules though and probably should since I'm leaving early
19:40:34 <dondelelcaro> #endmeeting