17:00:19 <dondelelcaro> #startmeeting
17:00:19 <MeetBot> Meeting started Thu Mar 20 17:00:19 2014 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:19 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:24 <Diziet> Hi.
17:00:25 <dondelelcaro> MeetBot: ping
17:00:25 <MeetBot> pong
17:00:29 <dondelelcaro> MeetBot: ping all
17:00:29 <MeetBot> pong
17:00:32 <dondelelcaro> MeetBot: pingall
17:00:32 <MeetBot> dondelelcaro: You must supply a description with the `pingall` command.  We don't want to go wasting people's times looking for why they are pinged.
17:00:42 <dondelelcaro> MeetBot: pingall Debian CTTE meeting approximately now
17:00:42 <MeetBot> Debian CTTE meeting approximately now
17:00:42 <MeetBot> aba abrotman adsb ansgar bdale buxy carnil chattr cjwatson clopez Diziet dondelelcaro emias Ganneff gregoa jcristau joss keithp KGB-3 KiBi luca lucas Maulkin MeetBot Mithrandir pasky phatmatt prh RichiH slegassick tgies themill tiago tjader weasel xnox
17:00:42 <MeetBot> Debian CTTE meeting approximately now
17:00:56 <dondelelcaro> #topic Who is here?
17:00:59 <dondelelcaro> Don Armstrong
17:01:12 <Diziet> Ian Jackson
17:01:39 <dondelelcaro> I think vorlon had conflicts, but I will ping him just in case
17:02:11 <cjwatson> Colin Watson
17:02:16 <cjwatson> Diziet: Yes
17:02:50 <cjwatson> Diziet: let me clarify that
17:03:34 <KGB-3> 03Colin Watson 05master 70287f1 06debian-ctte 10717076_libjpeg/cjwatson_draft.txt clarify terms
17:05:43 <dondelelcaro> aba, bdale, keithp: ping
17:06:01 <dondelelcaro> vorlon has a conflict, so probably won't be able to participate
17:06:02 <ansgar> cjwatson: Shouldn't it say "IJG libjepg" in 3.?
17:06:10 <KGB-3> 03Colin Watson 05master 71ef4ad 06debian-ctte 10717076_libjpeg/cjwatson_draft.txt clarify naming further
17:06:17 <dondelelcaro> #topic #717076 Decide between libjpeg-turbo and libjpeg8 et al.
17:06:25 <dondelelcaro> lets just jump into this since that's what we're discussing already
17:06:30 <cjwatson> ansgar: hopefully clearer now
17:06:51 <Diziet> I think this resolution is going in the right direction.
17:06:51 <cjwatson> Right, so I'd hoped to send mail out about this draft before this meeting but obviously didn't quite make it
17:07:01 <Diziet> I have wording quibbles which I can do by proposing git changes.
17:07:03 <cjwatson> I have a mail drafted though and will be able to send it right after this meeting
17:07:13 <cjwatson> modulo quibbles of course
17:07:36 <Diziet> But I have another point which is that I don't think this requires 3:1 on the grounds that who owns a Provides is overlapping wossname.
17:07:41 <cjwatson> dondelelcaro: does this meet your transition plan concerns?
17:08:04 <cjwatson> I think some of those were obviated by subsequent bug discussion anyway
17:08:15 <cjwatson> But I was reconstructing this from IRC logs and bug reading months after the fact
17:08:16 <Diziet> I think it should say   "libjpeg-turbo should propose a transition plan, and after a reasonable period for comment, prepare packages ..."
17:08:43 <dondelelcaro> cjwatson: right; I think that's OK. I just wanted to make sure that there were transition plans that were commented on and could be re-raised to the CTTE if necessary
17:08:48 <Diziet> On the majority question we should run it past secretary@
17:09:01 <Diziet> Transition plan should come first, then action, IMO.
17:09:29 <cjwatson> secretary@> OK, seems reasonable, I'll CC them with a request
17:09:56 <cjwatson> On the transition plan: I initially tried to draft this in a way that said "prepare a transition plan, then the TC is minded to resolve that blah blah"
17:10:03 <cjwatson> But it didn't really sound like a resolution
17:10:17 <dondelelcaro> yeah
17:10:32 <Diziet> Hence my suggestion to just tell them to write a transition plan and then implement it.
17:10:44 <Diziet> s/tell/ask
17:10:47 <cjwatson> And when I went back and looked at the bug, they had the most important parts done (test packages etc.) anyway
17:11:22 <Diziet> BTW I need to go in ~35 mins.
17:11:32 <cjwatson> my current mail has:
17:11:33 <cjwatson> It is probably clear from this text how I am inclined to vote; I'm
17:11:33 <cjwatson> afraid I found it quite difficult to put together a clear presentation
17:11:33 <cjwatson> of the IJG libjpeg case based on the bug and mailing list threads I
17:11:33 <cjwatson> worked through.  This is only a draft at this point, and we would invite
17:11:36 <cjwatson> and welcome constructive corrections and clarifications, especially from
17:11:38 <cjwatson> the IJG libjpeg side of this dispute.
17:11:46 <Diziet> Right.
17:12:00 <cjwatson> I might add something about timeline
17:12:46 <Diziet> Do we need more on this at this point ?
17:12:49 <dondelelcaro> #action cjwatson to run libjpeg resolution past secretary@
17:12:51 <Diziet> Thanks to Colin for doing the work.
17:13:03 <dondelelcaro> I think that's good enough for the time being
17:13:14 <dondelelcaro> #topic Next Meeting?
17:13:30 <keithp> sorry, missed the start of the meeting
17:13:33 <Diziet> Hi.
17:14:10 <dondelelcaro> currently this is scheduled for april 24th at 17:00 UTC, iirc.
17:14:21 <dondelelcaro> as we don't have everyone here, I'll run this by the list too
17:14:26 <Diziet> That's awkward for me.
17:14:31 <dondelelcaro> but does anyone here already have conflicts with that date?
17:14:32 <Diziet> I'm likely to be on a train.
17:14:32 <dondelelcaro> ok
17:14:34 <keithp> reading backlog, the libjpeg discussion sound sgood
17:14:50 <dondelelcaro> Diziet: got it; that's after the time change; would moving it around slightly help?
17:14:54 <Diziet> Don't have the train times here right now but I think I'm catching around the 18:00.
17:15:17 <cjwatson> no conflicts on 24 April; specifically can't do the week before (Ubuntu release day) in case anyone was minded to suggest that
17:15:28 <Diziet> Here we go, dep Cambridge station 18:01 BST
17:15:46 <Diziet> Being in the meeting on the train wouldn't work well; the mobile internet's a bit pants.
17:15:55 <keithp> I have no conflict apr 24
17:16:02 <dondelelcaro> would an hour earlier or later be better?
17:16:32 <Diziet> I could be free until 17:30 BST (16:30 UTC) but I guess 15:30 Z is rather early.
17:16:34 <KGB-3> 03Colin Watson 05master 2797d5f 06debian-ctte 10717076_libjpeg/cjwatson_draft.txt transition plan rewording based on Ian's comments
17:16:54 <dondelelcaro> yeah, it's a little bit early. OK. I'll work this out on the mailing list
17:16:57 <Diziet> Ta
17:17:09 <dondelelcaro> #action dondelecaro to figure out when to hold the next set of CTTE meetings on mailing list
17:17:15 <dondelelcaro> #topic #636783 super-majority conflict;
17:17:52 <dondelelcaro> * ACTION: Diziet to move forward with constitutional resolutions on
17:17:52 <dondelelcaro> super-majority conflict eventually  (dondelelcaro, 18:09:50)
17:17:52 <dondelelcaro> * AGREED: constituational ammendments need more work in light of
17:17:52 <dondelelcaro> events  (dondelelcaro, 18:15:04)
17:18:09 <Diziet> So I have two points here that I'd like feedback on.
17:18:13 <dondelelcaro> OK
17:18:22 <Diziet> Firstly, minimum discussion period.  I think there should be one.  72h ?
17:19:02 <Diziet> Secondly, Bdale's point about routine use of the casting vote is a good one.  Possible fixes: no casting vote - deadlocks result in no decision; increase ctte size to 9; give casting vote to dpl.
17:19:15 <Diziet> (I discount "reduce ctte size to 7" on the grounds of doom)
17:19:18 <Diziet> Maulkin: Hi.
17:19:27 <Diziet> Secondly, Bdale's point about routine use of the casting vote is a good one.  Possible fixes: no casting vote - deadlocks result in no decision; increase ctte size to 9; give casting vote to dpl.
17:19:38 <Diziet> ^ repeating myself for Maulkin's benefit, particularly as he's a dpl candidate...
17:19:53 <ansgar> Changing the ctte size doesn't work if not all members vote of a particular question.
17:19:58 <Diziet> ansgar: Yes.
17:20:07 <Diziet> Of these I would prefer to give the casting vote to the dpl.
17:20:24 <cjwatson> three days seems like a perfectly reasonable minimum discussion period
17:20:54 <ansgar> I assume the DPL cannot be a member of the ctte? So all ctte member votes would be equal?
17:21:16 <Diziet> ansgar: The DPL could be but IMO probably shouldn't be.
17:21:34 <cjwatson> casting vote: not sure I have a strong opinion.  giving it to the DPL seems sort of roughly constitutionally appropriate, but I would also be OK with deadlocks meaning that we have to try harder to find something that's a stronger consensus
17:21:45 <ansgar> If he can, we can get back to the same problem.
17:22:06 <Diziet> ansgar: Well except that if the dpl's vote counts double they are at least elected.
17:22:14 <keithp> ansgar: not really, the DPL is elected and thus has a 'larger mandate' to some degree
17:22:33 <cjwatson> Also even if this is a problem it's only for the DPL's term
17:22:49 <Diziet> The only concern I have with giving it to the dpl is that they might not relish being dragged into things.
17:23:24 <cjwatson> I think in this case the DPL would be constitutionally almost-mandated to seek the views of other developers
17:23:32 <cjwatson> sorry, of "the Developers"
17:23:54 <cjwatson> in particular they are instructed to avoid overemphasising their own point of view ...
17:23:57 <Diziet> Indeed.
17:24:18 <Diziet> OK so it sounds like I should carry on with that as the proposal
17:24:24 <cjwatson> (which I think is a good thing for this purpose although it could take a while)
17:24:26 <Diziet> #action Diziet propose 72h min discussion period
17:24:43 <Diziet> #action Diziet propose dpl to have casting vote
17:24:44 <dondelelcaro> the 72 hour bit, I'm concerned about, mainly because it currently means that a ballot will expand to include all options
17:24:53 <dondelelcaro> even irrelevant ones
17:25:08 <Diziet> dondelelcaro: Only options that a tc member thinks should be voted on
17:25:30 <Diziet> On the supermajority bug I think this needs further discussion on -project/-vote.
17:25:46 <dondelelcaro> yeah; we probably should work this out on -project and/or -vote
17:25:58 <cjwatson> dondelelcaro: GRs seem to generally end up with reasonably finite lists of options, though
17:25:59 <ansgar> Diziet: How would a min discussion problem help if the ctte cannot agree on a ballot again?
17:26:12 <cjwatson> and they have a much wider pool of people who can propose options
17:26:28 <ansgar> Include all of A, A+B, A+notB, C, C+B, C+notB, FD?
17:26:29 <dondelelcaro> cjwatson: but they have to be seconded, and the secretary can decide that they are separate
17:26:37 <Diziet> ansgar: The way that committee rules are supposed to work is that people don't have to _agree on the ballot_.  The ballot is constructed by making the union of all the things proposed.
17:27:11 <dondelelcaro> Diziet: the problem with that is the FD issues cause interesting problems when you have multiple items on the ballot
17:27:19 <Diziet> dondelelcaro: If you don't like an option, vote against it.  If your co-tc-members propose dozens of irrelevant options, ask them not to.
17:27:21 <dondelelcaro> but I think this can all be hashed out on the mailing lists
17:27:33 <Diziet> dondelelcaro: Yes, there's the FD bug.  That needs to be fixed.
17:27:51 <dondelelcaro> if not for the FD bug, an over-long ballot wouldn't really matter
17:28:13 <dondelelcaro> anyway, I think this can be discussed on the mailing list; would probably be good to get a draft so we have a basis for discussion
17:28:20 <ansgar> Well, I find it strange if you end with more options than voters ;)
17:29:04 <Diziet> Next topic ?
17:29:07 <cjwatson> I don't find that strange, although I think it will be exceptional.
17:29:16 <cjwatson> Anyway, yes.
17:29:24 <dondelelcaro> #topic #681419 Depends: foo | foo-nonfree
17:29:35 <Diziet> We're still waiting for Steve here, aren't we ?
17:29:41 <dondelelcaro> * ACTION: vorlon to write up response to Diziet about Depends: foo |
17:29:41 <dondelelcaro> foo-nonfree  (dondelelcaro, 18:29:40)
17:29:53 <cjwatson> I think we are
17:29:58 <dondelelcaro> #action vorlon to write up response to Diziet about Depends: foo | foo-nonfree
17:30:02 <keithp> I haven't seen anything...
17:30:03 <dondelelcaro> yeah; I think that's where we are still
17:30:05 <Diziet> Yes.
17:30:15 <dondelelcaro> OK; I'll just leave that there and continue
17:30:21 <dondelelcaro> #topic #733452 init system readiness protocol
17:30:27 <Diziet> This is closed.
17:30:30 <dondelelcaro> I think Diziet just closed this, so we can dispense with it
17:30:31 <Diziet> (by me, who cloned it)
17:30:31 <dondelelcaro> right
17:30:33 <Diziet> Right.
17:30:39 <dondelelcaro> #topic #741573 menu systems and mime-support
17:30:52 <Diziet> I have some things I want to say about this but haven't had time to write them up.
17:31:00 <dondelelcaro> it's unfortunate that rra had a conflict, but I think this still needs some work
17:31:23 <dondelelcaro> I'm also a bit concerned about this, but I think that the policy decision is probably the right way to go, it just needs the rest of the tools to make it work
17:31:25 <Diziet> I am quite unhappy with the content of the alleged consensus draft.
17:31:26 <cjwatson> I haven't yet read the history.
17:31:40 <Diziet> I also think this should have been referred a lot earlier.
17:31:40 <cjwatson> I'll do that but probably tomorrow not today at this point.
17:31:42 <dondelelcaro> but I'm also not up enough on this
17:31:49 <Diziet> I have read the bug, at least.
17:33:18 <Diziet> ISTM that we have the effort available to maintain the Debian menu system menu entries and that what's going on is that some maintainers have been removing them as "obsolete" anyway.
17:33:28 <Diziet> effort available> Even if it is only one person.
17:33:51 <keithp> Diziet: for graphical systems, it has been supplanted by the freedesktop menu system
17:34:10 <keithp> which offers more functionality and a relief from the image format requirements in the debian menu
17:34:22 <Diziet> The two systems seem to be liked by different sets of people.
17:34:26 <Diziet> That's fine, so we can have both.
17:34:46 <Maulkin> ( Diziet: I'm technically on VAC this week, but missed context. Free to chat after this meeting if you want :P )
17:34:51 <Diziet> Maulkin: Sure.
17:34:55 <keithp> Diziet: except that both systems place requirements on a huge number of packages, and so one system is likely to be less well supported across the system
17:35:30 <keithp> and, testing infrastructure for either system is not readily apparent, making the likelihood of broken support quite high
17:35:55 <Diziet> I don't think we should throw something out just because the people contributing it don't think they need a formal testing infrastructure.
17:36:13 <Diziet> The requirement is basically "if someone sends you a menu file, drop it in"
17:36:37 <KiBi> the "consensus" text says menu can stay around.
17:37:03 <Diziet> It leaves it entirely up to a maintainer whether to accept a menu file.
17:37:22 <Diziet> So if a maintainer doesn't like the menu system for whatever reason, they tell the menu file contributor to go away.
17:37:27 <Diziet> This is not hypothetical.
17:37:56 <Diziet> Indeed AIUI this conflict in policy has arisen because the menu contributor appealed to policy to justify their view that the menu entry ought to be included.
17:38:37 <Diziet> But I don't think irc is really the right place to have this substantive conversation.
17:38:55 <keithp> thanks for taking some time to point me towards what issues have been raised though
17:39:33 <Diziet> I have to go RSN (minutes).
17:39:54 <dondelelcaro> cool; let me move on
17:39:55 <dondelelcaro> #topic Additional Business
17:40:00 <dondelelcaro> anything else here?
17:40:23 <Diziet> Nothing from me.
17:41:26 <cjwatson> Nor me
17:41:49 <dondelelcaro> ok; thanks everyone for meeting again
17:42:01 <Diziet> Thank you.
17:42:06 <Diziet> Goodnight all, must go.
17:42:57 <dondelelcaro> #endmeeting