17:58:43 <dondelelcaro> #startmeeting
17:58:43 <MeetBot> Meeting started Thu Feb 27 17:58:43 2014 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:43 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:58:49 <dondelelcaro> #topic Who is here?
17:58:53 <dondelelcaro> Don Armstrong
17:58:55 <bdale> Bdale Garbee
17:59:21 <keithp> Keith Packard
17:59:22 <dondelelcaro> Diziet, vorlon, aba: ping
17:59:32 <rra> Russ Allbery here.
18:00:00 <bdale> vorlon was around earlier, I don't know about Diziet or aba
18:00:24 <dondelelcaro> yeah, not sure either
18:00:45 <vorlon> HI
18:00:51 <vorlon> hi, rather
18:00:55 <vorlon> Steve Langasek
18:01:00 <cjwatson> Colin Watson
18:01:12 <dondelelcaro> cool; just missing Diziet and aba; I'll get started; hopefully they'll be along
18:01:15 <dondelelcaro> #topic Next Meeting?
18:01:17 <dondelelcaro> #topic Next Meeting?
18:01:46 <dondelelcaro> currently the next meeting is scheduled for date -d 'Thu Mar 27 17:00:00 UTC 2014'
18:02:17 <dondelelcaro> (I've moved it back an hour in UTC to account for DST)
18:02:19 <bdale> I think that's an LF event week
18:02:19 <vorlon> I appear to have a work conflict that day/time, fwiw
18:02:49 <dondelelcaro> ok; would the preceeding week work better?
18:02:52 <bdale> yes, that's LF Collab Summit
18:02:59 <vorlon> previous week is better for me, yes
18:03:06 <bdale> yes, me too
18:03:15 <keithp> /aol
18:03:31 <dondelelcaro> OK. I'll tenatively move it one week before (March 20th), and double check on the mailing list
18:03:37 <bdale> good
18:03:48 <dondelelcaro> #agreed tenatively move next meeting to date -d 'Thu Mar 20 17:00:00 UTC 2014'
18:04:06 <cjwatson> I'm fine with either, but that's cool
18:04:09 <dondelelcaro> #action dondelelcaro to check on mailing list if that's OK
18:04:11 <dondelelcaro> topic #717076 Decide between libjpeg-turbo and libjpeg8 et al.
18:04:13 <dondelelcaro> #topic #717076 Decide between libjpeg-turbo and libjpeg8 et al.
18:04:24 <cjwatson> last action on this was
18:04:25 <cjwatson> * ACTION: Diziet to draft resolution asking libjpeg-turbo to make a
18:04:25 <cjwatson> transition plan  (dondelelcaro, 18:05:17)
18:04:38 <cjwatson> I could possibly have a go at that if Diziet is burned out on resolutions
18:04:54 <bdale> he may well be
18:05:01 <dondelelcaro> yeah; probably useful to get that moving forward
18:05:16 <bdale> keithp: did you want to chime in since this was mostly before you joined the ctte?
18:05:16 <dondelelcaro> even if Diziet wants to stab at it, collaborating in git is probably good enough
18:06:12 <cjwatson> yeah, if Diziet doesn't turn up this evening then I'll check with him on it out of band
18:06:14 <keithp> bdale: I read the history and a bunch of external commentary yesterday instead of fixing cmake
18:06:21 <dondelelcaro> #action cjwatson to draft resolution asking libjpeg-turbo to make a transition plan (possibly in collaboration with Diziet)
18:06:45 <cjwatson> links to any useful external commentary welcome
18:07:07 <cjwatson> (I have the bug log and the roughly corresponding Ubuntu history easily enough to hand)
18:07:07 <keithp> from my studies, the resolution I'd love to see is to back out libjpeg8 and offer only libjpeg62 APIs, but that seems unlikely :-)
18:07:37 <keithp> that would allow us to switch from the ijg jpeg library to libjpeg-turbo knowing that we would not impact applications
18:08:08 <dondelelcaro> yeah; I think what we're looking for here is a transition plan which enables that to happen
18:08:29 <keithp> cool
18:08:29 <dondelelcaro> but it's not really the CTTE's place to do the design work for that (though we can collaborate)
18:08:35 <dondelelcaro> ok; moving on
18:08:37 <dondelelcaro> #topic #636783 super-majority conflict;
18:09:00 <cjwatson> * ACTION: Diziet to move forward with constitutional resolutions
18:09:00 <cjwatson> (Diziet, 18:06:33)
18:09:02 <dondelelcaro> this is Diziet again, I believe; this was explicitely put on hold until after the systemd stuff
18:09:05 <dondelelcaro> right
18:09:08 <bdale> right
18:09:11 <cjwatson> indeed so
18:09:22 <bdale> I suspect the resolutions might change given our recent experiences, too
18:09:25 <dondelelcaro> so I'll just put it on him again, and we can ping this once things die down slightly
18:09:28 <dondelelcaro> right
18:09:34 <bdale> yep, happy to leave this pending
18:09:48 <rra> Agreed.
18:09:50 <dondelelcaro> #action Diziet to move forward with constitutional resolutions on super-majority conflict eventually
18:09:53 <keithp> It looked like there were separate resolutions for each of the sub-issues identified; can we work to bring the obvious ones up for a vote and pend the non-obvious?
18:10:15 <cjwatson> we possibly can, although I think Diziet was trying to optimise for not putting the project through umpteen GRs
18:10:21 <rra> IIRC, Diziet had wanted to keep them bundled, yeah.
18:10:23 <keithp> understood
18:10:47 <bdale> right, since any constitutional mods require a GR, doing one for a collected set of agreed-upon changes seems wise
18:10:56 <cjwatson> there may be a middle ground, not sure
18:11:09 <keithp> at some point we should give up and get the 'finished' ones voted though
18:11:12 <rra> There are also new changes that have come up since we last talked through these, like the 2:1 supermajority on the TC override.
18:11:33 <bdale> and the fail later no harm discussion
18:12:10 <dondelelcaro> right
18:12:12 <Diziet> Oh hello.
18:12:15 <Diziet> Sorry I'm late.
18:12:18 <bdale> Diziet: hi!
18:12:18 <dondelelcaro> Diziet: no worries
18:12:20 <keithp> Diziet: welcome!
18:12:59 <fsck_you> Why isn't Tox in the Debian repos yet?
18:13:11 <dondelelcaro> fsck_you: that's not really on topic here.
18:13:28 <rdr> motion to abandon the harmful GNU/systemd/Linux base and rebase Debian on Plan 9 :^)
18:13:46 <fsck_you> rdr: Plan9 is harmful
18:13:50 <bdale> Diziet: did you want to comment on either the current or previous agenda items before we move on?
18:13:57 <dondelelcaro> folks; if you don't have something to say which is on topic, please don't comment.
18:14:07 <Diziet> Just read the scrool.
18:14:11 <Diziet> No, that all sounds good.
18:14:17 <Diziet> cjwatson: Thanks for picking up the libjpeg thing.
18:14:33 <Diziet> And yes, the constitutional things need some more work now in the light of events.
18:14:46 <bdale> ok .. let's pend that then, and move on?
18:14:54 <dondelelcaro> ok; sounds good
18:14:56 <Diziet> Yes.
18:15:04 <dondelelcaro> #agreed constituational ammendments need more work in light of events
18:15:10 <dondelelcaro> #topic #727708 Initsystem coupling
18:15:19 <dondelelcaro> I think this just needs vorlon to vote, and possibly not even that
18:15:27 <Diziet> I see he just has.
18:15:29 <vorlon> I have voted just now
18:15:35 <dondelelcaro> ah; awesome
18:15:41 <Diziet> I haven't tallied the votes.  Anyone done so and calculated what the answer is ?
18:15:59 <rra> IIRC, I think we need a casting vote.
18:16:03 <vorlon> bdale: I've been meaning to ask you to please expand upon your vote; you've voted one of the ballot options below FD, but have not participated in the drafting discussion
18:16:05 <Maulkin> Schwartz = {L,N}
18:16:15 <Diziet> Maulkin: Thank you.
18:16:24 <Diziet> So it's up to Bdale to choose between L and N
18:16:28 <dondelelcaro> right; if vorlon voted L > A, it's L and N
18:16:28 <Maulkin> (unofficial etc, but I'm fairly sure it's right)
18:16:42 <dondelelcaro> (my mail queue hasn't caught up with that yet)
18:16:52 <cjwatson> dondelelcaro: he voted L > A > N > FD, yes
18:16:54 <vorlon> bdale: I think any member of the TC voting an option below FD warrants an explanation (keithp also voted L below FD, but he also gave his own reasoning in the bug)
18:17:01 <Maulkin> dondelelcaro: Correct, it was LANfd
18:17:10 <keithp> vorlon: yes, thanks for remembering
18:17:26 <bdale> vorlon: I thought I was adequately on record as saying that I thought the L option(s) were a bad idea, but I guess I can cough up some text about that if you wish
18:18:14 <cjwatson> bdale: I went through your posts last week before you voted and spectacularly failed to predict your vote, FWIW
18:18:18 <vorlon> bdale: well, earlier iterations of the text were buggier, and the discussion was meant to suss out and fix those bugs
18:18:21 <Diziet> bdale: To me, particularly given the presence of N, FD means "we should discuss this some more and then we can vote on something better"
18:19:24 <bdale> Diziet: right .. if it would make everyone happier, it sounds like I could re-vote putting L ahead of FD .. it won't change the outcome
18:19:28 <vorlon> and particularly considering that rra has said with his policy hat that he thinks this is a policy question he wants to punt to the TC, I think we're not doing our job to decide for "N"
18:19:37 <KGB-3> 03Don Armstrong 05master c517da4 06debian-ctte 10727708_initsystem/coupling_votes.txt add Steve's vote
18:19:54 <bdale> if I'm forced to use a casting vote again, I won't vote for L
18:20:09 <vorlon> right, it seems it doesn't change the outcome since L has already passed quorum, but we want to know your reasoning so we can persuade you it's wrong ;)
18:20:38 <rra> I think I said that more about the original init system discussion, but possibly not.  If I did say that, I think I'm wrong, at least partially -- I feel like we can take at least a good first cut at a Policy draft.
18:20:52 <zzz> OpenRC is the best, and you should choose OpenRC.
18:20:53 <vorlon> (or, alternatively, be persuaded in turn)
18:20:54 <rra> We may have to send it back to the TC again if we can't reach consensus, but at least there's a fair bit of work that can be done before that happens.
18:21:10 <vorlon> heh
18:21:40 <cjwatson> I guess we get to go round this in some other forum, then
18:21:45 <cjwatson> (with different hats on)
18:21:53 <vorlon> rra: ok.  In that case, I'm not particularly happy with an outcome where the TC has refused to give advice, but at least we know the way forward.
18:21:53 <rra> Note that the Policy discussion is different.
18:22:13 <cjwatson> it is, though it will doubtless have a good chunk of common content
18:22:14 <rra> Among other things, Policy doesn't try to predict the future, which changes the shape of some parts of the conversation.
18:22:21 <fsck_you> rra: OpenRC is slow, or if run in parallel, unstable.
18:23:18 <rra> The assumption generally followed in Policy drafting is that Policy says what you should do *right now*, and if what you should do changes, Policy will change then.
18:23:25 * vorlon nods
18:23:31 <rra> That's not 100%, but that's mostly the way Policy reads today.
18:23:52 <rra> So part of what we've been talking about in the TC context would naturally be punted by Policy normally.
18:24:24 <vorlon> well, the two policy changes I see that we could make right now are:
18:24:38 <vorlon> - generalize from sysvinit to "the default init system"
18:25:00 <vorlon> - cover the expectation of compatibility with non-default init systems (which seems like it would become a policy "should")
18:25:18 <Diziet> Can I suggest that this discussion should not be here and not now ?
18:25:21 <vorlon> but probably no need to discuss this in detail here and now; should we move on?
18:25:24 <keithp> vorlon: by 'we', are you talking policy editors or tc?
18:25:24 <Diziet> Thanks.
18:25:37 <rra> Yeah, this is going to be easier to cover in email.
18:25:41 <vorlon> keithp: "we" being those involved in the policy process, not just editors
18:25:44 <dondelelcaro> yeah; I think so
18:25:49 <cjwatson> rra: that's very much along the lines of what I was getting at in e.g. <20140220143106.GM6397@riva.ucam.org> anyway
18:26:05 * cjwatson catches up with Diziet's admonition
18:26:13 <rra> I do need to warn that work is actively on fire, so while I'm going to put a high priority on making time for this, I'm going to struggle with responsiveness.
18:26:19 <dondelelcaro> so we're agreed that we should figure out this issue in the normal policy process; right?
18:26:35 <vorlon> we're agreed that this is the way forward ;)
18:26:42 <bdale> I think I have an action to communicate a casting vote with rationale in email
18:26:49 <Diziet> bdale: Yes.
18:26:59 <rra> I'm hoping that some of the other Policy editors will have time to help with that part of the process.
18:27:01 <dondelelcaro> #action bdale to communicate casting vote with rationale in e-mail to 727708
18:27:06 <bdale> I'm very happy to see "the action" move to the policy process
18:27:08 <rra> Not that I've asked.  :)
18:27:24 <bdale> and I'm actually quite supportive of pro-multi-init-system-support ending up there
18:27:36 <dondelelcaro> #agreed move coupling decision to normal policy process
18:27:52 <dondelelcaro> ok; anything more here?
18:28:05 <dondelelcaro> #topic Additional Business
18:28:39 <keithp> dondelelcaro: did we skip #681419? Or was that part of the GR issues?
18:28:41 <dondelelcaro> I don't personally have anything else
18:28:49 <dondelelcaro> oh, I think we did, actually
18:28:56 <dondelelcaro> #topic #681419 Depends: foo | foo-nonfree
18:28:59 <dondelelcaro> going backwards
18:29:03 <cjwatson> last action on 681419 was
18:29:04 <cjwatson> * ACTION: vorlon to write up response to Diziet about Depends: foo |
18:29:04 <cjwatson> foo-nonfree  (Diziet, 18:07:40)
18:29:08 <vorlon> man
18:29:10 <dondelelcaro> heh
18:29:11 <vorlon> ancient history
18:29:14 <cjwatson> which I think vorlon said at the time was blocked on init system fires
18:29:22 <Diziet> Yes.
18:29:29 <vorlon> yes, I'll make time to get back to that ASAP now
18:29:40 <dondelelcaro> #action vorlon to write up response to Diziet about Depends: foo | foo-nonfree
18:29:48 <keithp> it looked like the TC had reasonable consensus on the correct wording for the change
18:29:55 <vorlon> (where "ASAP" is probably measured in a small number of weeks)
18:30:06 <dondelelcaro> heh
18:30:10 <keithp> vorlon: I'll come extract text from you with beer as needed
18:30:24 <vorlon> keithp: heh, I really just need to write the email
18:30:37 <cjwatson> we were approaching agreement on ballot text I think, but I don't think we had consensus on our preferences
18:30:38 <vorlon> beer is unlikely to help this :)
18:30:51 <cjwatson> but it's been a while
18:31:11 <bdale> it has
18:31:17 <cjwatson> however for some reason ballots without 100% consensus going in no longer seem quite so scary
18:31:32 <keithp> cjwatson: ok, I may have not captured all of the history then, I'll go re-read the threads
18:31:54 <dondelelcaro> ok; anything else here?
18:32:09 <dondelelcaro> #topic Additional Business
18:32:10 <vorlon> right, the options are understood, it was a matter of others wanting me to explain why I disagreed with the option they had been persuaded to go with
18:32:15 <bdale> cjwatson: let's just try to avoid even splits, ok?
18:32:16 <Diziet> cjwatson: It would perhaps have been helpful if we had tried out our non-consensus ballot process on something less important and emotionally charged.
18:32:22 <cjwatson> yes quite
18:32:30 <cjwatson> but it's the tc, we don't have a lot of that
18:32:33 <vorlon> bdale: we could've avoided an even split by keeping the ctte at 7 a bit onger ;-)
18:32:48 <keithp> vorlon: and make me miss all of the fun?
18:32:48 <rra> Yeah, amen to that.  We're too good at coming up with consensus and don't stress-test our edge cases much.  :)
18:33:25 <bdale> if I'd been able to predict the future, I might not have pushed to fill the open seat .. but I'm still glad we did it, since I think having the maximum degree of representation of the project on the ctte is important when we're deciding on things
18:33:25 <Diziet> I have just sent an email to #636783 about the remaining constitutional issues.
18:33:29 <dondelelcaro> awesome
18:34:05 <Diziet> Perhaps we should also suggest changing the max size to 9.
18:34:27 <Diziet> Although even 8 felt like it was getting trickily large.
18:34:29 <bdale> an odd number seems preferable to routine exercise of a casting vote
18:34:38 <Diziet> Anyway, anyone who feels it would help, take it to email.
18:34:48 <rra> On the FD majority thing, we should (and by we, I mean the project, not just the TC) probably take a look at the voting proposals on debian-vote; one of those tweaks may work better than changing > to >=.  I'm not sure.
18:35:58 <dondelelcaro> do we have anything else before I stop?
18:36:02 <bdale> no here
18:36:05 <Diziet> I don't think so.
18:36:06 <keithp> nothing here
18:36:08 * rra has nothing else.
18:36:15 <cjwatson> not I
18:36:44 <vorlon> nope
18:36:48 <dondelelcaro> #endmeeting