16:59:15 <dondelelcaro> #startmeeting
16:59:15 <MeetBot> Meeting started Thu Aug 22 16:59:15 2013 UTC.  The chair is dondelelcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:15 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:44 <dondelelcaro> #topic Who is here?
16:59:55 <dondelelcaro> Don Armstrong
17:00:09 <vorlon> Steve Langasek
17:00:20 <dondelelcaro> bdale, aba, Diziet: ping
17:00:58 * weasel is lurking
17:01:01 <dondelelcaro> I didn't do a very good job advertising, and I suspect people are still traveling for debconf
17:01:25 <Diziet> Hi.
17:01:27 <Diziet> Ian Jackson
17:01:47 <bdale> pong
17:01:53 <bdale> Bdale Garbe
17:01:55 <bdale> e
17:01:56 <bdale> meh
17:01:59 <bdale> Bdale Garbee
17:02:10 <dondelelcaro> awesome; I guess we have enough people to get started then
17:02:15 <dondelelcaro> #topic Next Meeting?
17:02:45 <dondelelcaro> The next meeting is currently scheduled for the same time on Thursday the 29th of September
17:02:55 <dondelelcaro> does that cause a problem for anyone?
17:03:02 <dondelelcaro> err, 26th of september
17:03:08 <Diziet> I'm away then but it's not likely to be any different any other time.
17:03:13 <dondelelcaro> ok
17:03:22 <bdale> 26th is fine with me
17:03:24 <vorlon> seems to be ok for me
17:03:26 <dondelelcaro> ok
17:03:39 <dondelelcaro> #agreed next meeting 26th of september, same time
17:03:46 <dondelelcaro> #topic #717076 Decide between libjpeg-turbo and libjpeg8 et al.
17:04:30 <dondelelcaro> I believe last time we decided that someone should draft an opinion giving libjpeg-turbo the go-ahead to generate a transition plan, etc.
17:04:51 <dondelelcaro> and I think Diziet was going to do that
17:05:12 <Diziet> Was I ?  Oh, sorry, I had completely forgotten.
17:05:16 <dondelelcaro> no worries
17:05:25 <vorlon> I'm curious to know if there has been any more input from the libjpeg8 maintainer
17:05:28 <Diziet> #action Diziet To draft resolution asking libjpeg-turbo to make a transition plan
17:05:53 <dondelelcaro> vorlon: I haven't heard more about it
17:06:06 <dondelelcaro> vorlon: at least, nothing privately that wasn't already on the mailing list
17:06:07 <vorlon> he seemed quite convinced that libjpeg-turbo was the wrong answer, but AFAIK hasn't offered any explanations that might convince the rest of us - which is unfortunate
17:06:24 <dondelelcaro> right
17:06:27 <bdale> right, my sense is that turbo is the right answer unless we get more credible input
17:06:34 <Diziet> What bdale said.
17:06:45 <vorlon> so in the absence of that input, no objection to the stated action
17:07:04 <dondelelcaro> yeah, that's kind of where I'm at too
17:07:30 <dondelelcaro> #agreed proceeding with drafting resolution in the absence of input as to why turbo should not be chosen
17:07:53 <dondelelcaro> #topic #685795 New ctte member
17:08:09 <dondelelcaro> did all of the pinging for this happen?
17:08:19 <dondelelcaro> (this being the new CTTE member)
17:08:34 <bdale> right, let me type for a min on this
17:08:56 <bdale> those of us who were present at Debconf talked about the pool of candidates in various groupings
17:09:03 <bdale> I also had a conversation with Lucas
17:09:29 <bdale> of the original pool, I think we are down to picking one of 3
17:10:05 <bdale> there were a couple additional names thrown out at Debconf for different reasons, after further discussion and reflection it's not clear that either would/should be chosen over anyone in the original pool
17:10:28 <dondelelcaro> okay
17:10:29 <vorlon> apparently I arrived too late at DebConf to be part of those discussions ;)
17:10:46 <bdale> so, I think the next step is probably for me to forward the candidate list with a variation on these comments with some supporting text to the rest of you in a non-public way, and we can proceed to pick someone
17:11:02 <vorlon> agreed
17:11:03 <bdale> vorlon: sorry, I thought you'd been in the loop for one of the chats, but perhaps not
17:11:39 <vorlon> bdale: nah, apparently you thought I'd already laid my opinions out in enough detail that there was no need for further consultation :D
17:12:17 <bdale> there's no particular reason to "rush" on this, but on the other hand, I and others I spoke with agree that having a full TC slate before we might be asked to decide on something like an init system choice would be a good idea
17:12:36 <dondelelcaro> right
17:12:56 <bdale> I'm pretty whacked until the start of Sept, but I'll try to make time to at least send the aforementioned email today or tomorrow my time
17:13:03 <dondelelcaro> #action bdale to forward the candidate list with a variation on these comments with some supporting text to the rest of you in a non-public way
17:13:17 <dondelelcaro> awesome
17:13:32 <dondelelcaro> #topic #636783 super-majority conflict;
17:13:54 <dondelelcaro> I think these just need discussion on the mailing list or an ack from everyone that they are ok; is that correct?
17:14:09 <vorlon> fwiw I'm happy with all the drafts
17:14:19 <Diziet> Bdale had some comment on the advisory overruling one.
17:14:21 <vorlon> I don't recall Diziet saying he was looking for an explicit ack, so I didn't
17:14:34 <Diziet> We spoke at DC and he said he was going to put it in writing.
17:14:37 <dondelelcaro> ah, ok
17:15:02 <bdale> thanks for reminding me, I forgot
17:15:33 * bdale adds notes to his to-do list
17:15:34 <dondelelcaro> #action bdale to comment on advisory overruling constitutional amendment
17:16:03 <dondelelcaro> so for the others, is everyone ok with them? what's the next step?
17:16:08 <bdale> for the rest of you...
17:16:27 <bdale> the basic concern I had was that perhaps that should be raised as a GR by Ian personally, not from the TC
17:16:52 <bdale> my reasoning is that the current wording implies an agreement among TC members about why we have been reluctant to do something that I don't agree with
17:17:03 <Diziet> bdale: You also said that you weren't convinced it would have changed your mind for eg the recent business with network-manager.
17:17:23 <Diziet> And yes if that isn't an accurate statement of the TC's views it needs to be fixed.
17:17:33 <bdale> yes, and we had a long conversation over a meal that I'm going to try to re-think as I write out comments in email
17:18:03 <bdale> the other GR texts all looked fine to me
17:18:25 <vorlon> ah, right; if there's something in the text of the GR that all members of the TC almost, but don't quite, agree with, it's probably easier to just push the GR the more traditional route
17:18:27 <Diziet> I think if we can do that overruling one as a TC thing, and with the others, it would be best.
17:19:17 <Diziet> I'm happy to take wording amendments.  But this is only worth doing if, should it passing, it would have made TC members more willing to overrule in the recent cases where we haven't had enough consensus for that.
17:19:23 <Diziet> s/it passing/it pass/
17:19:27 <Diziet> IYSWIM
17:19:36 <bdale> ok, in that case I'll promise to think harder about what I actually think the GR should ask developers so that we get a result that's meaningful without tripping over the consensus bit that tripped me up
17:19:49 <Diziet> Thanks.
17:20:23 <dondelelcaro> cool; for the others, should we ack them and then proceed to voting?
17:21:04 <dondelelcaro> or just ask for objections if there are any, and then vote?
17:21:10 <Diziet> I would prefer to run all of them concurrently so if we can fix the overruling advice one, I'd like to wait.
17:21:30 <dondelelcaro> ok
17:21:31 <Diziet> But if you all think we should put that one aside, then I see nothing that needs doing to the others.
17:21:44 <dondelelcaro> I'm ok with either way, since I don't see a need to rush
17:22:08 <Diziet> OK, thanks.
17:23:05 <dondelelcaro> #agreed wait on amendments to fix overruling advice, then proceed
17:23:15 <dondelelcaro> #topic #681419 Depends: foo | foo-nonfree
17:23:26 <vorlon> possibly still blocked on me
17:23:27 <vorlon> sorry
17:23:28 <dondelelcaro> I think this one was just waiting on vorlon to write up a response
17:23:31 <dondelelcaro> cool
17:23:36 <vorlon> will get that done this month
17:24:00 <dondelelcaro> #action vorlon to write up response to Diziet about Depends: foo | foo-nonfree
17:24:07 <dondelelcaro> #topic Additional Business
17:24:17 <dondelelcaro> anything else?
17:24:20 <Diziet> Not from me.
17:24:37 <bdale> one note for those not at Debconf
17:25:03 <bdale> it's abundantly clear to me that the TC will be asked, soon, to make decisions on the choice of default next-generation init system
17:25:22 <dondelelcaro> yeah; I'm almost surprised that that hasn't happened yet
17:25:51 <bdale> a chat with Lucas made it clear that he'd prefer we were able to bring this to conclusion in something like 6 months max so that all relevant changes for jessie can happen without time stress
17:25:59 <vorlon> still straightening the bows on the package before I drop it in your lap
17:26:16 <Diziet> The presentations at DC were helpful but mostly in the sense that they provided a concrete grounding for things I had osmosed.
17:26:27 <bdale> obviously, until a question is posed, there's no action for us to take as a TC... but I'd strongly like to suggest that everyone pay as much or more attention than usual to the systemd and upstart discussions since I think a TC question is inevitable
17:26:59 <dondelelcaro> yeah; this is partly why I started wading in with https://wiki.debian.org/Debate/initsystem
17:27:17 <vorlon> well, I don't know that I would advise paying attention to discussions on the mailing list, which tend to be quite repetitive ;)
17:27:30 <bdale> thanks for the pointer .. I'm not doing a good job following my own advice right now due to time constraints ...
17:27:54 <dondelelcaro> yeah
17:28:38 <vorlon> dondelelcaro: right, someone dove straight into https://wiki.debian.org/Debate/initsystem and started filling the "upstart" page with their own list of "cons"; I don't think that's a useful way to structure the discussion (I think the different camps should be allowed to elaborate their own positions, not have opponents editing the page out from under them), so I haven't bothered using that structure
17:28:57 <dondelelcaro> vorlon: right, I agree.
17:29:10 <Diziet> vorlon: I think that's not how it was supposed to be used.
17:29:30 <Diziet> dondelelcaro: Can you please slap that down ?
17:29:50 <vorlon> so, I could scrub that and start drafting an upstart position on that page; but I'll only do that if the TC thinks that's useful generally
17:30:06 <vorlon> otherwise I'd just go straight to presenting on the list as a usual TC question
17:30:35 <dondelelcaro> either way works for me; I'd probably distill things out of the discussion and shove them into the main page
17:30:40 <Diziet> I don't have much of an opinion.  Perhaps we should try the Debate thing on something where, err, people are less likely to transgress.
17:31:14 <bdale> pushing the existing con list down to a "comments from others" section or something could work in the short term?
17:31:22 <dondelelcaro> yeah; I can just do that
17:32:16 <Diziet> I think that the people pushing the upstart pov should be entitled to just delete adverse comments.
17:32:32 <Diziet> If this is supposed to be a debate, each side must be allowed to put their own pov.
17:32:47 <bdale> hrm, I don't actually see the comments in question.
17:33:13 <bdale> vorlon: looks like you edited already?
17:33:25 <Diziet> There's a Pro/Contra thing there.
17:33:32 <dondelelcaro> yeah; I just edited that
17:33:41 <vorlon> bdale: https://wiki.debian.org/Debate/initsystem/upstart, "Comments from Others" said "Disadvantages" until someone edited it just now
17:33:54 <dondelelcaro> yeah; it said Contra. I edited it. ;-)
17:34:17 <Diziet> I don't have time now but you can't really have Pro/Contra on these pages.  That just encourages the wrong kind of behaviour.
17:34:26 <Diziet> Perhaps doing this on a wiki is too different from usual wiki use.
17:34:29 <dondelelcaro> yeah
17:34:39 <bdale> ok .. the presence of one line of text with two links doesn't wind me up, particularly
17:35:00 <Diziet> bdale: Yeah, but it means that opposing partisans have a nice heading to fill up with their ideas.
17:35:03 <vorlon> so it seems there's a general sense that the TC would like this kind of presentation; so I'll flesh it out
17:35:04 <bdale> given there's zero systemd content so far, it's not exactly a balanced view yet
17:35:21 <Diziet> bdale: Oh yes.
17:35:24 <Diziet> I hadn't spotted that.
17:35:53 <bdale> I'm not sure I care what format it's in, but if we're to decide something, somehow we need to have a clear presentation of the pros and cons of each system that we can warp into something we can actually compare and contrast
17:36:15 <dondelelcaro> yeah; since I don't personally have an opinion, I haven't wandered into the sub-options
17:36:16 <Diziet> Yes.  I would be happy to have that as a presentation from each camp.
17:36:29 <dondelelcaro> I just put a bunch of questions into the main page, and set up the framework
17:36:32 <bdale> whether each party populates the 'con' part of the other page or lists a "why not other choices" section on their own page seems purely a structural distinction to me
17:36:49 <Diziet> But we're going to have to ask questions and refine it so either they need to maintain a "position statement" which they update and repost, or we have to do this kind of wiki thing.
17:37:00 <bdale> right
17:37:00 <Diziet> Otherwise we'll have just a big thread and no structure.
17:37:13 <bdale> wiki hosting of the position statements seems useful
17:38:38 <dondelelcaro> cool; I think we can at least try out the wiki with position statements, and see where that gets us
17:38:43 <dondelelcaro> anything else?
17:38:53 <bdale> not here
17:39:04 <Diziet> bdale: However we do it, we should have clear rules which are stated and enforced.
17:39:35 <dondelelcaro> https://wiki.debian.org/Debate <-- this actually has the rules for the debate
17:39:37 <Diziet> I think a rubric at the top of each page, perhaps.
17:39:53 <bdale> dondelelcaro: maybe link back to that from each page?
17:39:58 <dondelelcaro> so I think actually that whoever took the upstart side could just delete everything else
17:40:06 <dondelelcaro> yeah, I should do that
17:40:40 <Diziet> When you say "Please don't edit the main text of other people's position documents" it's not clear whether you mean the main body text, or the whole actual page rather than the wiki comment page.
17:40:50 <Diziet> I think you should mean the latter.
17:41:35 <bdale> makes sense to me
17:42:05 <bdale> however, rather than just deleting other contributions, if we're going to clarify the rules, I'd like to see the contributions moved to whatever is the right place instead of just deleted
17:42:28 <dondelelcaro> got it
17:42:33 <bdale> my reasoning is that just deleting contributions made before we solidify the rules seems prone to irritating someone and discourages contribution
17:43:21 <dondelelcaro> yeah
17:43:32 <bdale> if, in the end, the rules say the proponent can just delete such feedback if they don't agree, that's fine as the ultimate outcome
17:43:59 <bdale> I would certainly rather see the various proponents spend more time telling us "why" their system than trying to tell us "why not" other choices
17:44:25 <Diziet> Indeed.  But if they really want to criticise the other choices they can do that in a section on their own page.
17:44:25 <dondelelcaro> yeah
17:44:31 <bdale> suitably clever wording in the form of "why" arguments will make the rest clear enough anyway
17:44:38 <bdale> sure
17:44:43 <Diziet> Right.
17:44:46 <Diziet> I think we all agree.
17:44:51 <bdale> as I mentioned earlier, a "why we're better than them" section is fine with me
17:45:00 <bdale> yep, agreement
17:45:30 <bdale> so, should we explicitly poke the systemd and openrc proponents, or just let it lie?
17:45:57 <vorlon> I have the impression that openrc may have withdrawn
17:46:27 <vorlon> at least, after the last discussion on -devel, zigo seemed to get why openrc doesn't actually offer comparable features to systemd/upstart
17:46:32 <bdale> ok
17:46:45 <vorlon> but perhaps someone wants to check with him anyway rather than taking my word for it ;)
17:47:22 <bdale> part of me is happy to wait for the question to be put to the TC
17:47:47 <Diziet> It's worth prodding them.
17:48:55 <dondelelcaro> ok
17:49:08 <dondelelcaro> any last minute bits?
17:49:27 <bdale> nope.  thanks again for hosting these, dondelelcaro
17:49:32 <dondelelcaro> bdale: no problem
17:49:33 <dondelelcaro> #endmeeting