18:59:42 <rvandegrift> #startmeeting
18:59:42 <MeetBot> Meeting started Thu Jun 11 18:59:42 2020 UTC.  The chair is rvandegrift. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:42 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:59:48 <noahm> hi all
18:59:51 <chillysurfer> hello!
19:00:47 <rvandegrift> first item on the agenda: stretch and lts.  Noah is planning to keep building ec2 images, what do others think?
19:02:05 <waldi> azure will go on as well
19:02:42 <noahm> At least based on the marketplace listings, stretch still seems more popular than buster on ec2.
19:03:17 <noahm> But those metrics don't reflect usage of the AMIs listed on the wiki
19:04:34 <rvandegrift> zigo's list message made it sounded positive for the openstack images too
19:04:46 <kuLa> hi all
19:04:46 <waldi> for azure we don't have any numbers. i could check the mirrors
19:04:57 <chillysurfer> i could also do some digging on the azure side
19:05:08 <chillysurfer> i should be able to pull those numbers for stretch
19:05:39 <rvandegrift> any of the gce folks around?  if not, I can follow up to ask them
19:06:13 <noahm> I doubt there's anything really meaningful in these metrics, I just find it curious that stretch is still so popular.
19:06:24 <noahm> ...And people complain that debian stable is so "stale"
19:07:19 <chillysurfer> would be interesting stats for sure
19:07:55 <rvandegrift> #action rvandegrift follows up with gce folks to find out their position on lts for stretch
19:08:05 <waldi> noahm: don't ask. 5 years of support are clearly not enough
19:08:21 <kuLa> GCP is not using yet what we produce and default img is buster already
19:08:35 <kuLa> by what we produce I mean FAI
19:10:11 <rvandegrift> kuLa: I think they are - a buster vm I just started yesterday has fai logs
19:10:51 <waldi> kuLa: they do, but they don't use our toolset around it
19:10:57 <kuLa> oooh that would be interesting that I missed it somehow but it's a good news
19:11:15 <kuLa> thx for the info guys
19:11:19 <rvandegrift> so if everyone agrees that they'll do stretch lts images, do we need to announce anything?  or just keep publishing
19:11:23 <noahm> either way, they are producing the images, not us. So they can keep doing what they're doing regardless of our decisions.
19:11:32 <kuLa> true
19:12:28 <noahm> rvandegrift: probably no need for an announcement, but I may update the Marketplace listing in EC2 once LTS support starts.
19:12:30 <waldi> rvandegrift: just keep publishing. and maybe add the end-of-support date to the description
19:13:36 <rvandegrift> sounds good.  any other lts issues?
19:14:38 <noahm> well, there's still jessie. not sure what to do there.
19:14:47 <noahm> It hasn't been updated in ... ages.   At least on ec2.
19:15:05 <noahm> But, we can ignore that for a little longer.  No need to discuss here.
19:15:50 <rvandegrift> okay, sounds good
19:16:51 <rvandegrift> next agenda item: cloud-init updates for stable
19:18:13 <rvandegrift> noahm's email reports that release managers are onboard, but want some additional testing - what platforms have been tested and which remain?
19:18:28 <chillysurfer> i've been doing extensive testing on azure
19:18:49 <noahm> chillysurfer: do you have a specific test suite, or are you doing ad-hoc testing?
19:18:54 <chillysurfer> i've ported the cloud-init upstream sru testing to debian with good success
19:19:05 <chillysurfer> noahm: mostly adhoc testing, but i've adopted upstream's sru testing
19:19:23 <chillysurfer> so in other words, upstream signs off based on those tests, they're good enough for me
19:19:26 <chillysurfer> (at the moment)
19:19:35 <chillysurfer> ... signs off based on those tests on ubuntu, that is..
19:19:42 <noahm> I've done a little testing on ec2.  Nothing comprehensive, but I can prioritize that and get to it in the next week or so.
19:19:55 <noahm> We need thorough testing on openstack.
19:20:00 <rvandegrift> #info azure test results at https://salsa.debian.org/trstringer/azure-debian/-/tree/master/
19:20:42 <chillysurfer> it would be nice to standardize this though so we don't have different clouds having different levels of testing
19:21:09 <noahm> yup
19:21:20 <chillysurfer> unfortunately my scripts as of right now have a lot of azure-isms in it
19:22:39 <noahm> these scripts? https://salsa.debian.org/trstringer/azure-debian/-/blob/master/buster/sru_validate_debian_debian-10_10_0.20200511.260_with_cloud-init_20.2-2_bp.sh
19:23:11 <chillysurfer> noahm: yeah exactly. sru_*.sh are the ones i ported from upstream
19:23:47 <noahm> ok. mostly looks like the az* calls handle launching and sshing to the instance, right?  Should be easy enough to port.
19:24:02 <noahm> But that looks like a good start for something cross-cloud.
19:24:41 <chillysurfer> yeah all of those az_* are wrappers. i think az_vm_ssh is mostly what i used, which was just a wrapper around me doing an ssh proxy jump to destination vms
19:25:22 <chillysurfer> but those could be replaced with ssh calls
19:26:10 <rvandegrift> #info chillysurfer's cloud-init test script: https://salsa.debian.org/trstringer/azure-debian/-/blob/master/buster/sru_validate_debian_debian-10_10_0.20200511.260_with_cloud-init_20.2-2_bp.sh
19:26:48 <noahm> I will post details of EC2 testing to the mailing list within the next week.
19:26:51 <noahm> Who can test openstack?
19:27:59 <rvandegrift> I think zigo mention some tests, but I can't find it on the list.  I'll send him a note to find out
19:28:14 <rvandegrift> #action rvandegrift follow up on cloud-init update testing on openstack
19:28:39 <noahm> rvandegrift: thanks
19:28:40 <rvandegrift> any other items related to cloud-init stable update?
19:32:09 <rvandegrift> next item: we had some discussion about delegations.  we can talk about that here.  but I propose to wait until we have a (probably online) sprint
19:32:30 <rvandegrift> imo, it isn't pressing - but if folks disagree, that's okay too
19:32:52 <chillysurfer> has there been any planning on the next sprint?
19:33:31 <rvandegrift> nothing formal - I've been thinking about ways we might do it without travel, assuming that still looks bad in the fall
19:34:01 <noahm> I don't have anything to contribute to the delegates discussion beyond what's been on the mailing list.
19:34:55 <noahm> we can try jitsi.debian.social for a remote sprint.
19:36:08 <rvandegrift> no one is rushing to object, so we'll skip further delegation discussions for now
19:37:02 <rvandegrift> that's the end of my agenda - does anyone have other items to discuss?
19:38:23 <waldi> zigo wnted to have something
19:38:43 <kuLa> yeah but I don't think he managed to join
19:38:55 <noahm> I still want to come up with a real plan for keeping the buster (stable) FAI configuration isolated from the unstable/testing configuration, but I'm not prepared to talk about it right now.
19:40:23 <rvandegrift> ah yes - zigo wanted to talk about rescue images, but it seems like an initial agreement was reached.  we can wait for him to follow up since he didn't make it
19:41:35 <rvandegrift> I think we're done for today, thanks everyone.  next meeting will be July 7 at the same time
19:41:55 <rvandegrift> #endmeeting