18:59:57 <serpent> #startmeeting
18:59:57 <MeetBot> Meeting started Wed Nov 20 18:59:57 2019 UTC.  The chair is serpent. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:57 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:00 * rvandegrift is here
19:00:21 <serpent> So - first meeting after sprint
19:00:48 <serpent> Any proposal for agenda?
19:00:59 <serpent> I guess we'll need to discuss Image Finder
19:01:23 <serpent> and maybe touch topic of mirrors in cloud providers
19:01:28 <serpent> anything else?
19:01:43 <noahm> The SPI legal approval for the AWS marketplace seller agreement.
19:01:56 <noahm> Not sure that we have the right people here for that, though.
19:02:14 <serpent> Probably not, it's hanging on SPI.
19:02:24 <noahm> yep. but I at least want to grumble about the process in public. ;)
19:02:31 <serpent> But we could ping them to ask what's happening, why it's stuck
19:02:43 <noahm> I've twice sent them email.
19:03:01 <serpent> And - did you get any response?
19:03:08 <noahm> No response at all.
19:03:09 <noahm> Two SPI board meetings have happened since we requested their signoff.
19:03:13 <noahm> :(
19:03:14 <serpent> #topic - SPI
19:03:42 <serpent> Can you forward me emails you sent?
19:03:57 <noahm> sure
19:04:04 <serpent> I'll ask them with delegate hat on (probably putting leader into CC)
19:04:41 <waldi> there are tickets open in the spi rt. i asked zobel to take care of them during the f2f spi does this week
19:05:05 <serpent> waldi - thanks
19:05:06 <noahm> waldi: thank you.
19:05:33 <serpent> should we keep such discussion more in the public?
19:05:38 <waldi> maybe
19:05:39 <noahm> let's wait for that meeting to happen before pushing harder.
19:06:06 <waldi> not only the aws stuff is stuck, also all the gdpr stuff for the europeans
19:06:07 <serpent> OK, waldi - please send me more info about this meeting (when it'll finish)
19:06:32 <serpent> If we don't get feedback week after that, we'll need to push a bit more
19:06:43 <waldi> yep
19:07:15 <serpent> #info We wait for SPI meeting to see what they do regarding AWS marketplace agreement
19:07:49 <serpent> Any more legal/organizational problems or issues?
19:08:22 <noahm> still also waiting on SPI for AWS GovCloud legal signoff, I believe.
19:09:01 <serpent> #info We also need gov cloud agreement signed by SPI
19:10:11 <noahm> nothing else on this topic from me.
19:10:22 <serpent> Good.
19:10:36 <serpent> Do we have any news about Image Finder?
19:10:54 <serpent> #topic Image Finder
19:11:09 <serpent> Is it deployed on some VM so we can play with it?
19:11:22 <serpent> I remember that plan after Sprint was to deploy it
19:11:28 <noahm> It's been on http://image-finder.debian.net/ for some time.
19:12:12 <noahm> But it's serving stale data and no https.
19:12:26 <noahm> No news at all since the sprint, really. :/
19:12:37 <serpent> So it's deployed, but not getting data from Salsa CI?
19:13:11 <noahm> It's deployed in a "proof-of-concept" mode. Nothing about that installation was intended to be permanent, IIRC.
19:13:24 <serpent> Yes, I know.
19:13:57 <serpent> But idea was that we shold have it integrated with CI so we can see how it behaves when we get more and more images
19:14:12 <serpent> Before we move it to something permanent
19:14:39 <noahm> There was a good amount of discussion about how we were going to push data to it, but I don't remember what the conclusion was.
19:14:50 <noahm> In any case, without the authors here, I'm not sure it's worth further discussion.
19:15:09 <serpent> #action I'll then ask Arthur about it
19:15:39 <serpent> To see what's the plans and timeline - and whether he needs some help
19:15:54 <noahm> sounds good.
19:15:56 <noahm> thank you
19:16:11 <serpent> #topic A bit orga
19:16:34 <serpent> As you probably noticed, I sent summary of previous meeting, and also some info about IRC
19:16:50 <serpent> I still need to send:
19:16:57 <serpent> 1. summary of BoF from DebConf
19:17:02 <serpent> 2. Summary of sprint
19:17:51 <serpent> 3. work on Salsa membership process (add info to Salsa description, sent official email about it to mailing list, as agreed during sprint
19:18:01 <Mrfai> Is 1. needed?
19:18:20 <serpent> 4. sent email to leader proposing Russ and Thomas as new delegates
19:18:37 <serpent> So - any preferences as for order of those?
19:18:55 <serpent> Mrfai - not sure, that's why I'm asking here
19:19:16 <serpent> Maybe I'll just send short info with link to Gobby
19:19:37 <noahm> I wasn't at DebConf. If the BoF discussion was interesting, I'd love a summary, but if there wasn't really anything new, then I don't need it.
19:20:06 <serpent> Then I'll go through it, and see if it makes sense.
19:20:29 <serpent> But from what I remember, we were mostly discussing about Image Finder, Salsa process, and few smaller topics
19:20:42 <serpent> Basically what we dig deeper into at sprint
19:20:59 <noahm> yeah, the sprint notes might be sufficient.
19:21:11 <Mrfai> yep. so skip the Bof summary, just add a link to the gobby document in the Sprint summary
19:21:17 <rvandegrift> agreed - I'd appreciate it, but not necessary if nothing new came up.  And I'd be happy to read the notes if sufficient
19:21:41 <serpent> OK, then I'll just sent link and few sentences during weekend
19:22:02 <serpent> As for points 2, 3, 4 - what's the most urgent from those?
19:22:25 <noahm> 4 should be quick, might as well get it done so we're back up to the full compliment of delegates.
19:22:36 <rvandegrift> agreed
19:22:45 <serpent> I'm tempted to focus on 3 and 4 (official, delegate stuff) before end of month
19:23:04 <Mrfai> agreed
19:23:05 <serpent> I'm a bit busy at work with Black Friday preparation :-)
19:23:19 <serpent> OK, then 4 goes to beginning of queue
19:24:02 <serpent> Any more issues as for group and orga issues?
19:24:34 <Mrfai> no
19:24:39 <noahm> nothing from me.
19:24:42 <rvandegrift> nope
19:25:01 <serpent> OK.
19:25:29 <serpent> Do we have more topics? Do we have people for talking about debian mirrors?
19:25:44 <serpent> I don't remember detailed status of this
19:25:54 <serpent> But it was something we wanted to touch
19:26:19 <noahm> It's somewhat orphaned. I think we probably need to engage mirror admins and/or DSA to coordinate plans, goals, etc.
19:26:49 <noahm> I'm happy contact them, and to work on it, but I haven't had time recently to think much about it.
19:27:08 <noahm> So if anybody beats me to it, that's great.
19:27:19 <serpent> I remember looking at the code, but we'll have to dig into it to set it up.
19:27:34 <serpent> And maybe work on some solution to be multi-cloud.
19:27:43 <noahm> well, I'm not sure we necessarily want to re-use any of the existing code.
19:27:50 <serpent> I guess first would be to document how it's solved currently
19:27:58 <noahm> (at least if you mean the stuff that sets up the AWS CloudFront mirror in the old account)
19:28:37 <serpent> Yes, I was talking about that code
19:29:09 <serpent> I guess you're right - we should first think about how we want to solve it before going into old code
19:29:14 <noahm> There are some reasons why it'd be preferable to use full mirrors in each cloud region and not bother with a CDN frontend.
19:29:42 <noahm> So we should understand the goals of the project and come up with a preferred approach.
19:29:56 <serpent> Totally agree
19:30:55 <noahm> Engaging with the mirror admins about this will help; IIRC the idea is to have Debian (DSA?) managed mirrors in as many geographic areas as possible so we can build something more reliable than the loose network of independently operated mostly .edu hosts.
19:31:42 <serpent> So it's a bigger project, and we'd need full Delegate team for it :-)
19:32:17 <waldi> i tried that already. i don't see how DSA could manage something like that
19:33:00 <waldi> for information, read #7104
19:33:09 <noahm> in rt?
19:33:14 <waldi> yes
19:33:21 * noahm will check that out.
19:33:22 <serpent> waldi: you mean from cloud-proficiency perspective or something other?
19:34:25 <waldi> serpent: from the perspective of their existing automation
19:34:39 <serpent> OK, I understand
19:35:42 <noahm> interesting. At the 2018 sprint, Luca indicated a desire for something like this, from DSAs perspective. But I'll have to read more on the ticket to see what others are thinking.
19:35:58 <noahm> Anyway, probably not a lot to discuss here right now.
19:36:11 <serpent> Yes, agreed
19:36:20 <waldi> yeah
19:37:17 <serpent> Any more topics beside decidine next meeting date (Christmas period, after re:Invent tiredness, etc.)?
19:37:40 <noahm> FWIW, I've found the availability of daily sid AMIs on EC2 to be super useful for packing, testing, etc.
19:38:15 <serpent> You mean the one we're building on Salsa and putting on AWS?
19:38:20 <noahm> yes
19:38:51 <serpent> Cool - thanks for feedback
19:39:15 <noahm> Making it easy for the general DD community to use them would be neat.
19:40:01 <Mrfai> maybe add a link in the wiki to the images
19:40:36 <noahm> that works for people who have their own clouds/accounts (AWS or openstack or Azure)
19:40:41 <noahm> But not everybody does.
19:40:43 <serpent> noahm: I guess, especially for testing some more unusual packages, like GPU-related, etc.
19:41:25 <serpent> But I guess for that we'd need to get linked DD and cloud user accounts
19:41:47 <serpent> Again - we discussed about that with Luca in 2018, but nothing moved after that
19:41:52 <noahm> yep
19:42:23 <waldi> we can get msdn or what it is called today accounts with azure credit for DD if we ask
19:43:18 <waldi> they would be complete separate from our stuff
19:45:28 <serpent> Should we start thinking about process for that?
19:47:03 <noahm> In the short-term, I am planning on a blog post (maybe micro-news post) mentioning the availability of the images for people who already have the requisite access.
19:47:21 <serpent> That'd be perfect first step
19:47:25 <Mrfai> very good idea
19:47:29 <waldi> bits.d.o always works
19:47:51 <noahm> waldi: +1
19:48:22 <rvandegrift> I think Steve Zarkos mentioned the Azure credit - I'll dig through email and update https://wiki.debian.org/MemberBenefits if I can find info on the process
19:48:55 <waldi> i can ask him during our call next week
19:49:00 <waldi> or send him an email
19:49:16 <rvandegrift> perfect thanks waldi
19:52:10 <waldi> #action noahm to start a blog post about daily images
19:52:29 <waldi> #action waldi to talk to microsoft about azure credit for DD
19:53:46 <serpent> Let's slowly wrap up and discuss date of next meeting
19:53:51 <serpent> any limitations?
19:54:21 <serpent> We have 18th and 11th of December which match
19:54:27 <serpent> both are Wednesdays
19:54:41 <noahm> I think either of those will work for me.
19:54:45 <waldi> no limitations
19:54:52 <Mrfai> both are fine
19:55:00 <rvandegrift> both are fine for me too
19:55:13 <serpent> Then I propose 11th - it's further away for Christmas
19:55:32 <serpent> Any objections?
19:56:10 <Mrfai> no
19:56:13 <noahm> no objections
19:56:25 <serpent> #agreed: next meeting, 2019-12-11
19:56:50 <serpent> 19:00UTC is still OK? It's one hour earlier than previously, because of winter time
19:57:03 <serpent> Or should we move it to 20:00UTC for winter?
19:57:36 <noahm> 1900 is better for me, but 2000 will work.
19:57:50 <serpent> Then 19:00 can stay
19:58:21 <serpent> So - should we finish?
19:59:45 <serpent> Thanks for discussion, see you around :-)
19:59:49 <serpent> #endmeetin
19:59:50 <serpent> #endmeeting