19:58:19 <elmig> #startmeeting
19:58:19 <MeetBot> Meeting started Wed Nov  3 19:58:19 2010 UTC.  The chair is elmig. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:58:19 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:58:19 <elmig> i don't know who else is around, but thanks all for your time and attending
19:58:19 <dba> .oO(is passively here too)
19:58:19 <elmig> i wll start with a short followup from last meeting
19:58:19 <elmig> Current isues:
19:58:19 <elmig> ==============
19:58:19 <elmig> Known blockers:
19:58:19 <elmig> 1 - zipl installation problem that makes s390 uninstalable with separate /boot #519254
19:58:19 <elmig> 2 - data corruption due to os-prober #599203 what if partitions are mounted rw?
19:58:19 <elmig> 3 - problems with yaboot for powerpc with added controller #589701
19:58:19 <elmig> 4 - apt problem due to empty indexes #600852
19:58:19 <elmig> any developments known on these issues?
19:58:19 <otavio> item 4 is fixed
19:58:19 <elmig> ok, i will update list
19:58:19 <otavio> item 1 might have been fixed ... waldi were looking at it
19:58:19 <otavio> item 2 needs discussion with cjwatson ...
19:58:19 <otavio> cjwatson: there?
19:58:19 <elmig> #agreed apt problem due to empty indexes #600852 fixed
19:58:19 <otavio> item 3 ... no idea
19:58:19 <elmig> #zipl installation problem that makes s390 uninstalable with separate /boot #519254
19:58:19 <waldi> otavio: i did? when?
19:58:19 <elmig> #info zipl installation problem that makes s390 uninstalable with separate /boot #519254 - waldi working on this
19:58:19 <elmig> ...or not :)
19:58:19 <elmig> #action - data corruption due to os-prober #599203 - needs discussion with cjwatson
19:58:19 <otavio> waldi: you were still on VAC and said you were building s390-tools
19:58:19 <otavio> waldi: do you remember it?
19:58:19 <otavio> waldi: phil were going to push an NMU and you said to wait
19:58:19 <otavio> elmig: separated /boot ... no. it was a problem with initramfs-tools
19:58:19 <otavio> elmig: sorry .. this is a new issue
19:58:19 <otavio> waldi: sorry
19:58:19 <elmig> #info s390 issue .  separated /boot ... no. it was a problem with initramfs-tools
19:58:19 <elmig> 2 issues on s390?
19:58:19 <waldi> different problem
19:58:19 <otavio> waldi: yes; exactly
19:58:19 <otavio> waldi: i saw it later
19:58:19 <elmig> #info 2 issues with s390
19:58:19 <otavio> waldi: can you take a look on that?
19:58:19 <elmig> you guys noticed my stupid comment regarding os-prober issue? what if partitions are mounted as rw?
19:58:19 <elmig> ok, moving on...
19:58:19 <elmig> - partman-zfs and partman-ufs are missing l10n integration.
19:58:19 <elmig> anyone knows the status on this?
19:58:19 <otavio> elmig: rw or ro?
19:58:19 <elmig> rw
19:58:19 <bubulle> elmig: about the os-prober issue, a last option is to have grub2 relax dependency on os-prober and *not* have os-prober installed when grub2 is
19:58:19 <elmig> currently is ro afaik
19:58:19 <otavio> elmig: didn't ge t it then
19:58:19 <bubulle> elmig: arg, partman-ufz and partman-zfs were completely forgotten by /me
20:12:03 <elmig> otavio: partition is already mounted in another host as rw, when is mounted as ro things go wrong
20:12:03 <elmig> (or i maybe wrong)
20:12:03 <otavio> elmig: i guess it is still mounting it as rw now
20:12:03 <elmig> bubulle: will look into that later?
20:12:03 <otavio> elmig: but the point is that mounting it in any way can cause problems
20:12:03 <bubulle> if I don't forget..:-(
20:12:03 <waldi> and you can't mount many filesystems unclean
20:12:03 <otavio> elmig: because of journaling or some
20:12:03 <elmig> #action bubulle will loon into localization of partman-{ufs,zfs}
20:12:03 <bubulle> elmig: the problem is that I need to hack something to avoid fuzzies to pop up
20:12:03 <elmig> bubulle: RFH on -i18n?
20:12:03 <dileks> whats RFH? RequestForHelp?
20:12:03 <elmig> y
20:12:03 <CIA-3> debian-installer: 03bubulle * r65299 10packages/po/packages_list: Now count statistics for partman-ufs as we're after beta1
20:12:03 <bubulle> elmig: no, should be OK
20:12:03 <bubulle> I think I'll work on partman-zfs tonight, to be sure..:-)
20:12:03 <bubulle> partman-ufs is OK, indeed. It was already i18n'ed but not counted in stats
20:12:03 <otavio> good
20:12:03 <elmig> regarding the remaining blockers, let's follow that on -boot?
20:12:03 <elmig> (s390, os-prober)
20:12:03 <otavio> waldi: are you able to look at this zipl issue?
20:12:03 <otavio> elmig: I will talk to cjwatson about os-prober
20:12:03 <elmig> #action otavio will talk to cjwatson about os-prober
20:12:03 <elmig> - speakup status? bubulle already uploaded rootskek to fix speakup issues. Iw will not be included in beta1. Needs to be documented in the errata.Beta2?
20:12:03 <elmig> (it's rootskel)
20:12:03 <otavio> elmig: no; beta2 will have it
20:12:03 <elmig> #actian beta2 will have speakup issues fixed
20:12:03 <elmig> - Support for usb3 for squeeze - bug against kernel-wedge - #601249
20:12:03 <elmig> and this will go to beta2?
20:12:03 <elmig> otavio?
20:12:03 <elmig> moving on...
20:12:03 <elmig> - It was proposed to integrate installation manual with already working l10n stats bot. There is already stats! What needs to be done?
20:12:03 <elmig> bubulle: can you sched light on this?
20:12:03 <bubulle> oopqs
20:22:47 <bubulle> I'm still unsure whether these stats are really calculated
20:22:47 <otavio> elmig: usb3 will be I guess
20:22:47 <bubulle> I need online time to work on this and am unsure when to have it
20:22:47 <otavio> elmig: I need to get into it
20:22:47 <bubulle> elmig: so, ATM, lower priority for me
20:22:47 <elmig> #action usb3 will be included on beta2 (low priority)
20:22:47 <elmig> bubulle: later can you point the source of those scripts?
20:22:47 <elmig> maybe there's someone who can work on that
20:22:47 <bubulle> elmig: manual l10n stats scripts are in manual/scripts
20:22:47 <elmig> #info integrating l10n stats scrips - low priority ATM
20:22:47 <elmig> ok
20:22:47 <elmig> i am working on errata as you know, i will update it again as soon as i sort out one issue with wml
20:22:47 <elmig> #info elmig woring on errata (wml issue - pass3)
20:22:47 <elmig> - Octavio updated the website regarding next release.
20:22:47 <elmig> i guess this is done
20:22:47 <elmig> - samuel updated figures in the installation guide and lowmem package (probably needs to be done again, because as bloats are being worked on)
20:22:47 <elmig> #info work on figures, probably needs to be done again
20:22:47 <elmig> ...and Beta1 was released \o/
20:22:47 <otavio> The most important thing is check if we identify blockers that can be fixed soon
20:22:47 <elmig> #info end of followup - moving on to current issues
20:22:47 <otavio> I have a fix for the resume (when using swap on lvm) in my local tree
20:22:47 <elmig> #info - #568877 - lvm2: Hibernation with swap in LVM (but not root partition) fail
20:22:47 <otavio> I need to test it and push
20:22:47 <bubulle> elmig: for the install manual, samuel mentioned that things need to be checked in the kfreebsd manual
20:22:47 <elmig> bubulle: just a minute
20:22:47 <bubulle> probably many things don't apply to kFreeBSD
20:22:47 <elmig> otavio: i can help testing that patch, i need help with base-installer as you know
20:22:47 <otavio> elmig: OK
20:22:47 <otavio> elmig: we do it after meeting
20:22:47 <elmig> #info lvm patch needs to be tested
20:22:47 <elmig> - samuel did some refactoring work for installation manual - but kbsd install guide needs to be checked also for what doesn't belong there (PXE booting, how?, lvm available? how is SMP/UP choice handled?)
20:22:47 <elmig> bubulle: the manual issues reported by samuel
20:22:47 <elmig> #info - samuel did some refactoring work for installation manual - but kbsd install guide needs to be checked also for what doesn't belong there (PXE booting, how?, lvm available? how is SMP/UP choice handled?)
20:22:47 <elmig> who can help with kfreebsd?
20:22:47 <bubulle> hard to say. mail the porters list?
20:22:47 <elmig> good idea
20:22:47 <elmig> #action mail the porters list regarding kfreebsd
20:22:47 <elmig> anyone willing to follow this?
20:22:47 <elmig> #info - kernel for archs: according to: installer/doc/devel/kerntabl alpha (2.6.30), sh4 (2.6.32-?), m68k (2.6.26) ?
20:22:47 <elmig> these kernels can be updated to current .32 ?
20:22:47 <elmig> just spotted this in a recent commit
20:22:47 <otavio> personally I am not changing kernels that I am not following
20:22:47 <otavio> m68k, alpha and sh4 are "not official" in squeeze so I won't use time for it now.
20:22:47 <otavio> if porters want to do so, they can do it.
20:22:47 <elmig> #info  m68k, alpha and sh4 are "not official" in squeeze so I won't use time for it now.
20:22:47 <elmig> otavio: who can generate these images to porters to test?
20:22:47 <otavio> elmig: they can do it. We need someone from those arches to join d-b and play with it
20:22:47 <zumbi> m68k looks like dead, sh4 nobuhiro might be interested
20:22:47 <elmig> #info m68k looks like dead, sh4 nobuhiro might be interested
20:22:47 <elmig> #idea ping porters mailing lists
20:22:47 <elmig> next issue:
20:22:47 <elmig> #info - size for / (enough for 2 kernel) ?
20:22:47 <elmig> bubulle: this is closed?
20:22:47 <qq-> zumbi,  there are works on m68k, they have even .32 kernels
20:22:47 <bubulle> elmig: needs partman-auto upload
20:40:01 <otavio> I do it later today or tomorrow
20:40:01 <elmig> #action space on / for 2 kernels needs partman-auto - otavio - will go for beta2
20:40:01 <zumbi> qq-: people might be working on kernel, but debian user land is the blue line at http://buildd.debian-ports.org/stats/
20:40:01 <elmig> zumbi, qq : willing to contact porters on try to get help?
20:40:01 <zumbi> elmig: OK I take it
20:40:01 <elmig> #action zumbi will ping porters on lagging kernels
20:40:01 <elmig> #info - missing installation guide for kFreeBSD
20:40:01 <waldi> m68k is currently being revived
20:40:01 <elmig> the lack of documentation is really a issue, install-reports are starting to appear with kfreebsd installations
20:40:01 <elmig> i confess i cannot help much with that
20:40:01 <elmig> #idea - status of automated builds?
20:40:01 <elmig> there is some discussion on automated builds. i believe some fail
20:40:01 <elmig> otavio: aware of this?
20:46:23 <otavio> elmig: yes
20:46:23 <otavio> elmig: aba was the  one working on them lately
20:46:23 <CIA-3> debian-installer: 03bubulle * r65300 10packages/po/sublevel3/ (79 files): Merge strings for partman-zfs
20:46:23 <bubulle> elmig: gaudenz is working on improving daily builds (log reports)
20:46:23 <otavio> bubulle: exactly
20:46:23 <bubulle> my own daily builds are working properly atm
20:46:23 <otavio> bubulle: he has produced a patch but I couldn't look at it yet
20:46:23 <elmig> bubulle: all arches?
20:46:23 <elmig> #info gaudenz is working on improving daily builds (log reports)
20:46:23 <otavio> elmig: he builds i386 and amd64 locally IIRC
20:46:23 <elmig> #info  aba was the  one working on them lately
20:46:23 <CIA-3> debian-installer: 03bubulle * r65301 10packages/po/packages_list: Add partman-zfs to localized packages
20:46:23 <elmig> someone will follow this or we wait for further developments on mailing list?
20:46:23 <elmig> #idea wait for further developments on the building infrastructure
20:46:23 <elmig> any issues that i have missed?
20:46:23 <otavio> Not that I am aware of
20:46:23 <elmig> :)
20:46:23 <otavio> We should get fixed things in unstable as soon as possible
20:46:23 <otavio> so package that has fixes that should be part of d-i for squeeze needs uploading soon
20:46:23 <otavio> so things does not get stuck for rc1
20:46:23 <elmig> otavio: any canditates?
20:46:23 <otavio> elmig: partman-auto
20:46:23 <elmig> #agreed fixe bugs in unstable: candidate-> partman-auto
20:46:23 <elmig> we do have 1000+ open BRs we need to clean up
20:46:23 <CIA-3> debian-installer: 03bubulle * r65302 10packages/partman/partman-zfs/debian/ (68 files in 2 dirs): Localize debconf templates
20:46:23 <elmig> surely some are fixed
20:46:23 <elmig> and are just laying there
20:46:23 <elmig> we do need more triaging
20:46:23 <elmig> do you guys think a BSP can be useful in next weeks?
20:46:23 <elmig> or other priorities?
20:46:23 <bubulle> elmig: I'm unsure a BSP is really useful atm
20:57:06 <bubulle> after the release, sure (might unveil good issues to work on...to avoid things like this WPA suggestion popping up now)
20:57:06 <elmig> #idea BSP after release
20:57:06 <elmig> so one issue we *never* talked before:
20:57:06 <elmig> ...WPA?
20:57:06 * bubulle made his poiint clear, I think..:-)
20:57:06 <elmig> this as to be raised here, imho
20:57:06 <bubulle> partman-zfs localization is now done, btw
20:57:06 <elmig> just an idea...
20:57:06 <otavio> I agree with bubulle ... it is too late for squeeze
20:57:06 <elmig> the eee guys are using wpa with d-i for a long time...
20:57:06 <otavio> elmig: but not properly integrated ...
20:57:06 <otavio> elmig: it depends on wpa-supplicat new udeb and also heavy changes on netcfg
20:57:06 <otavio> elmig: besides l10n work
20:57:06 <otavio> elmig: so a no go for it
20:57:06 <elmig> i understand you but i surely (and others) lack working wifi with d-i
20:57:06 * zumbi has a topic to raise
20:57:06 <elmig> so not usefull to ping them in this point in time?
20:57:06 <bubulle> then we should add this to the wheezy installer release goals..:-)
20:57:06 <elmig> #action add wpa to wheeze installer goals
20:57:06 <elmig> moving on...
20:57:06 <elmig> next release?
20:57:06 <elmig> goals?
20:57:06 <zumbi> elmig: do you mind me to raise a topic/question?
20:57:06 <elmig> zumbi: sure
20:57:06 <zumbi> could documentation be improved for enabling people use custom kernels (use case arm targets)?
20:57:06 <elmig> as an appendix to the manual? or in the wiki?
20:57:06 <zumbi> either
20:57:06 <dileks> just FYI: I could use the network configuration dialog in g-i when I added wpasupplicant to --packages in live-builder (formerly live-helper) setup. starting the generated ISO in live-mode, configure the WLAN/network and then run the graphical-installer.
20:57:06 <bubulle> zumbi: the wiki seems appropriate, imho
20:57:06 <otavio> elmig: wiki
20:57:06 <elmig> can we agree on wiki and maybe a txt on repo for now, and patches to the manual after release?
20:57:06 <zumbi> elmig: that would be perfect, more than expected
20:57:06 <elmig> #agreed documentation on using custom kernels on wiki and maybe a txt on repo for now, and patches to the manual after release? - zumbi
20:57:06 <elmig> otavio: next release
20:57:06 <elmig> any tentative date?
20:57:06 <otavio> elmig: it depends on things to be fixed.
20:57:06 <otavio> elmig: my idea is to get it soon
20:57:06 <CIA-3> debian-installer: 03bubulle * r65303 10packages/partman/partman-auto/debian/changelog: releasing version 94
20:57:06 <elmig> soon as in a few weeks?
20:57:06 <elmig> or a month?
20:57:06 <bubulle> otavio: partman-auto just upload to fix the / partition size problems
20:57:06 <CIA-3> debian-installer: 03bubulle 07packages * r65304 10/partman/partman-auto/94/: tagging version 94
20:57:06 <otavio> elmig: in one or two weeks
20:57:06 <elmig> #action partman-auto uploaded to fix / size issue
20:57:06 <bubulle> otavio: then an RC? I mean, when should I mass-upload?
20:57:06 <elmig> #agreed beta2 in one or two weeks - main goals: fix things
20:57:06 <otavio> bubulle: yes
20:57:06 <otavio> bubulle: I plan to massupload by the end of this week but not the final one
20:57:06 <otavio> bubulle: so we have refresh work inside of b2
20:57:06 <elmig> my list is done. feel free to talk on other issues that i may have missed
20:57:06 <bubulle> ok, so another massupload for the rc end of november or so?
20:57:06 <otavio> bubulle: specially since we had a lot of work done in l10n and translators deserve it to be included as soon as possible
20:57:06 <otavio> bubulle: yes
20:57:06 <bubulle> otavio: btw, don't forget shaking whoever can do the needed update for pt_BR..:-)
20:57:06 <bubulle> if you don't I'll ask a pt_PT translator..:-)
20:57:06 <elmig> :)
20:57:06 <bubulle> otavio: ah, udpkg
20:57:06 <bubulle> KiBi suggestion to get rid of mistakes when uploading
20:57:06 <elmig> #agreed massupload
20:57:06 <elmig> #idea udpkg: KiBi suggestion to get rid of mistakes when uploading
20:57:06 <CIA-3> debian-installer: 03bubulle * r65305 10packages/partman/partman-zfs/debian/changelog: releasing version 2
20:57:06 <bubulle> and partman-zfs is now localized
21:14:24 <elmig> #action partman-zfs is now localized - bubulle
21:14:24 <CIA-3> debian-installer: 03bubulle 07packages * r65306 10/partman/partman-zfs/2/: tagging version 2
21:14:24 <bubulle> without breaking l10n stats (just copied translations from paretman-ufs and s/ufs/zfs)
21:14:24 <bubulle> paretman, aha
21:14:24 <elmig> any more topics?
21:14:24 <bubulle> none for me
21:14:24 <otavio> neither for me too
21:14:24 <elmig> i like to thank all for your time
21:14:24 <elmig> sorry for my long list with me doing lot's of talking
21:14:24 <otavio> sure; no problem
21:14:24 <elmig> feel free to make observations so i can improve the agenda
21:14:24 <zumbi> elmig: thanks for doing the work
21:14:24 <otavio> I guess it was quite good.
21:14:24 <elmig> :)
21:14:24 <elmig> ladies and gentlemen....
21:14:24 <elmig> #endmeeting