17:59:52 <pollo> #startmeeting
17:59:52 <MeetBot> Meeting started Thu Aug 19 17:59:52 2021 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:52 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:58 <pollo> #topic Roll Call
17:59:59 <highvoltage> hello if you are here for the meeting
18:00:00 <pollo> hi!
18:00:03 <bittin> hello
18:00:11 <highvoltage> wouter sends apologies
18:00:13 <pollo> proposed agenda: https://deb.li/oNCD
18:00:21 <highvoltage> he'll likely still be able to drop in later during the meeting
18:00:53 * nattie waves
18:01:06 <nattie> just here to keep half an eye on you lot
18:01:18 <highvoltage> where's the other 1.5 eyes looking at?
18:01:33 <nattie> highvoltage: that's private!
18:01:42 <pollo> I moved the review system topic to the end
18:03:52 <pollo> #topic Q&A webapp
18:04:08 <pollo> DebConf starts very soon and I don't think the app will be ready
18:04:11 <paddatrapper> Sorry I'm late
18:04:22 <pollo> it's sad, but I think we should just use the pad for DC21
18:04:44 <paddatrapper> Can test run it with a miniconf at some point in the future
18:04:47 <highvoltage> at least there's something. and besides, new things are probably better to try out during a mini-dc anyway
18:05:08 <highvoltage> (snap)
18:05:09 <bittin> so starting the etherpad server? :p
18:05:16 <pollo> well, fixing it yes
18:05:26 <paddatrapper> Do we know what the issue is there
18:05:29 <paddatrapper> ?
18:05:36 <pollo> new npm version behaves differently
18:05:55 <pollo> we should fix it manually and work on ansible later imo
18:06:02 <paddatrapper> +1
18:06:06 <highvoltage> I hate having to depend on anything npm (which I do, but I hate it)
18:06:21 <pollo> so, we agree not to use the Q&A app?
18:06:36 <pollo> #agreed we won't use the Q&A app, as it's not ready
18:06:38 <paddatrapper> Yeah :(
18:06:55 <pollo> anyone wants to volunteer to fix the pad? I _could_ do it, but I'm also kinda swamped with work
18:07:11 <paddatrapper> I'll give it a stab tomorrow
18:07:20 <pollo> #action paddatrapper to try to fix the etherpad
18:07:29 <highvoltage> that escalated quickly
18:07:48 <pollo> anything else for this topic?
18:07:50 <highvoltage> (oh I missed the 'to try' in that action.. d'oh)
18:08:17 <pollo> #topic DC21 infra
18:08:32 <pollo> I skipped the schedule topic, I think we're done with the schedule :)
18:08:40 <highvoltage> Apparenlty VMs sporadically lose networking
18:08:48 <bittin> well its online and terceiro has sent it out too
18:08:51 <bittin> (schedule that is)
18:09:05 <pollo> it's pretty worrying
18:09:30 <highvoltage> (as in, their interfaces dissappear and then when you reboot them, there's a 5 minute wait for the interface to appear but then it just completes with local IPs)
18:09:31 <bittin> cronjob to restart it during breaks (silly idea)
18:09:45 <pollo> could someone open a ticket at infomaniak?
18:10:18 <paddatrapper> highvoltage: the ones I've reset via the openstack console haven't taken 5 minutes to come up, probably only about 1 or 2
18:10:21 <pollo> I know we're not using the IP assignment thingy openstack offers
18:10:52 <highvoltage> pollo: I could, I'm trying to gather more info to help them, zigo seemed to think earlier that this was already revolved, but it doesn't seem that we're affected by the previous issue that there was
18:11:26 <highvoltage> paddatrapper: yeah if I reset via openstack they come back, if I reset from within the VM (using the console), then...
18:11:28 <pollo> #action highvoltage to try to follow up with infomaniak and zigo about network interfaces on the VMs disappearing
18:11:37 <highvoltage> paddatrapper: then I get this: https://jonathancarter.org/files/temp/debconf/gva-network.gif
18:11:38 <pollo> thanks a lot
18:11:48 <paddatrapper> highvoltage: ah I see
18:12:07 <pollo> fwiw, I saw that systemd timer thing when we were blocking the DHCP ports
18:12:13 <highvoltage> I think the qemu machine has to be destroyed and recreated for the ethernet device to re-appear
18:12:35 <pollo> anyway, do we have something else to discuss about the infra?
18:12:46 <highvoltage> Is there a local login for all these VMs?
18:12:55 <olasd> pollo: is there a specific topic for etherpad?
18:12:57 <highvoltage> Does the videoteam use have a password available somewhere?
18:13:03 <pollo> olasd: do we need one?
18:13:04 <wouter> o/
18:13:11 <highvoltage> I wanted to check more on that VM this morning but didn't have a local login
18:13:13 <pollo> highvoltage: in ansible yes
18:13:17 <olasd> pollo: who is going to fix etherpad?
18:13:25 <paddatrapper> olasd: me
18:13:31 <olasd> ok
18:13:33 <pollo> see the Q&A topic :)
18:13:33 <paddatrapper> Try at least
18:13:34 <highvoltage> pollo: ok I couldn't find it this morning so if you could guide me to that it would be great.
18:13:41 <olasd> ah, yeah, sorry :P
18:13:50 <pollo> #action pollo to provide highvoltage with all the passwords
18:13:54 <pollo> ALL OF THEM
18:13:59 <highvoltage> I guess I have nothing else on infra from me
18:14:21 <olasd> have we had the load spikes since the machines have been respun on the other load profile?
18:14:26 <pollo> I think the only part of the infra that's not been tested is the sreview bits, but we have a topic for that
18:14:33 <olasd> (I guess that'd be a question for zigo)
18:14:35 <pollo> olasd: I haven't checked
18:14:53 <pollo> even if we did, I don't think we could do much more? we're using the best volume storage they offer now
18:14:58 <olasd> *nod*
18:15:14 <pollo> if someone has time to investigate that, I can action :)
18:15:37 <olasd> just something to keep in mind, but nothing very actionable IMO
18:15:50 <pollo> #topic DC21 volunteers
18:15:58 <pollo> I kinda dropped the ball on this, sorry
18:16:09 <pollo> I wanted to send the volunteer message on tuesday, but forgot
18:16:29 <pollo> I haven't been able to get help from tumbleweed to fix the website to enable the volunteer module either
18:16:29 <bittin> might be able to try to help out with something
18:16:43 <pollo> bittin: do you know django :) ?
18:16:59 <bittin> nope i can't code have been trying to learn 14-15 times but given up so can't help there sorry
18:17:07 <bittin> but its not really my thing
18:17:29 <pollo> I'll send the "we need volunteers" email today
18:17:32 <olasd> pollo: I can look at that tonight
18:17:36 <pollo> olasd: thanks a lot
18:17:39 <olasd> that = the website
18:17:50 <olasd> what's the plan B ?
18:17:52 <pollo> #action olasd to have a look at enabling/fixing the volunteer module on the website
18:17:54 <pollo> a wiki page
18:18:02 <pollo> like we do for miniconfs
18:18:10 <olasd> we do?
18:18:18 <wouter> I think so?
18:18:20 * fil sneaks in late
18:18:21 <paddatrapper> Or ethercalc
18:18:22 <pollo> yup, urbec did a bunch of them
18:18:34 <highvoltage> +1 on ethercalc over wiki
18:18:37 <wouter> well, to be fair, plan C is "urbec does everything"
18:18:39 <highvoltage> (if needs be)
18:18:43 <olasd> bad wouter
18:18:50 <wouter> olasd: she'd be happy too
18:18:52 <bittin> o: never heard about ethercalc until now :)
18:18:55 <bittin> a new tool to know
18:19:02 <pollo> I'll schedule a training session on sat, but if someone else wants to hold one it'd be nice
18:19:04 <highvoltage> urbec is also traveling and busy atm so not a good strategy
18:19:18 <wouter> highvoltage: sure. I wasn't serious, anyway
18:19:18 <paddatrapper> pollo: I've scheduled one for tomorrow too
18:19:35 <pollo> heh, ok, I'll rush the email then :)
18:19:45 <olasd> (is it bad that I don't know when the conf starts? :P)
18:19:53 <pollo> on the 24th?
18:19:59 <paddatrapper> I may need one before I train anyone though :P
18:19:59 <wouter> olasd: RSN(tm)
18:20:00 <olasd> looks that way
18:20:03 <highvoltage> don't rush, drink a nice cup of tea, take a deap breath, and send a zen e-mail
18:20:16 <olasd> (pah, tons of time to fix stuff ;p)
18:20:26 <highvoltage> olasd: it is. but it's on Tuesday btw
18:20:40 <highvoltage> olasd: or switch to alternate infra if needed?
18:20:41 <fil> :-)
18:20:49 <pollo> as I said previously, my first week of class is also next week, and apparently I landed another job somewhere else? Not sure I'll have tons of time during actual DC to take on volunteer slots
18:21:22 <highvoltage> it seems like this whole DebConf would've been better if it was a month later
18:21:23 <pollo> anything else on this topic?
18:21:40 <olasd> do we do on-call shifts again? assuming yes
18:21:44 <pollo> yes
18:21:55 <wouter> do we have a roster?
18:22:17 <pollo> once we have something to manage volunteer schedules, I expect things to get clearer
18:22:27 <wouter> okay
18:22:52 <olasd> I'm done
18:23:03 <bittin> Maybe ethercalc or Google Sheets can be used to build a rooster/schedule?
18:23:16 <highvoltage> pollo: next pls
18:23:16 <pollo> that's a backup solution yes
18:23:31 <pollo> #topic Review system
18:24:00 <wouter> so I didn't have as much time as I hoped to finish things after the test run on Tuesday
18:24:15 <wouter> there was an issue with the database password, but it seems to work now
18:24:25 <pollo> is the issue with slides upload fixed?
18:24:40 <wouter> yes, zigo's upload came through, it's on vittoria
18:24:51 <wouter> and I told terceiro that people who did an upload of their slides will have to redo it
18:25:08 <pollo> I haven't seen KGB announces today though
18:25:15 <wouter> it was a hardcoded something that didn't exist, but the good news is that it processes videos first, so by that time the video had gone through
18:25:20 <wouter> yeah, me either, not sure what's going wrong there
18:25:26 <wouter> I'll check it after the meeting
18:25:42 <wouter> but I suspect I made a mistaken in the configuration for KGB or the kgb-client config or some such
18:25:49 <wouter> because everything else seems to work just fine
18:25:53 <pollo> do you want us to have a video go through the review pipeline after the meeting?
18:26:14 <wouter> no, I would need to change the config on vittoria for that and I don't want to do that while uploads are running
18:26:19 <pollo> I don't think anyone has had a look at the actual video uploaded to QA check them either
18:26:35 <wouter> I can look at that during the weekend
18:26:45 <wouter> #action wouter to do QA on uploaded videos during the weekend
18:26:46 <pollo> ok
18:27:21 <wouter> also, I've let Tammy know about the added sponsors, she's going to update the slides either today or tomorrow
18:27:38 <pollo> we'll likely have to break the sreview conf on vittoria to make changes though
18:27:51 <pollo> and historically, people have a tendency to upload things very late
18:27:58 <wouter> yup, definitely, which is why I don't want to do that just yet
18:28:04 <pollo> so when were you thinking of doing it?
18:28:22 <wouter> suggestions welcome
18:28:25 <pollo> my point being I'm not sure I'll have a effect and we're going to experience upload downtime anyway
18:28:31 <pollo> *it'll
18:29:30 <wouter> I'll create a separate config for the recordings event, then the two can run in parallel
18:29:35 <wouter> will do that on the weekend too
18:29:45 <pollo> thanks
18:29:50 <pollo> anything else for this topic?
18:29:59 <terceiro> wouter: is it normal that uploads stay in state "injecting" for a while?
18:31:16 <terceiro> or, of they are "injecting", can I assume they are fine? or do I need to wait for them to finish to only them look at the final result?
18:33:04 <wouter> terceiro: yes, perfectly normal
18:33:19 <wouter> terceiro: we want the videos to be in a specific codec at a specific bitrate and resolution
18:33:29 <wouter> terceiro: if they're not, then the system will do a transcode. That's the "injecting" state
18:33:46 <wouter> terceiro: if they are in the correct codec, then it will just be a copy from one container to another
18:34:21 <wouter> (sorry, someone was at the door)
18:34:32 <pollo> #topic Any Other Business
18:34:37 <highvoltage> I have a few things
18:34:39 <bittin> not from me
18:34:48 <highvoltage> anyone know what the status is of audio normalization?
18:35:00 <pollo> highvoltage: at what stage?
18:35:10 <highvoltage> pollo: any, really
18:35:14 <wouter> SReview has audio normalization built in, and it is enabled this year
18:35:26 <wouter> it wasn't last year, because the implementation used bs1770gain which is slightly broken
18:35:27 <pollo> I don't think we're doing anything fancy in voctomix directly
18:35:31 <highvoltage> pollo: but in particular, I'm also interested in soemthing after loopy
18:35:45 <wouter> this year that's been replaced by an ffmpeg-based thing
18:35:57 <pollo> highvoltage: I don't understand
18:36:05 <highvoltage> wouter: ok, so if it's just in sreview that just affects recorded talks right?
18:36:26 <wouter> highvoltage: and bofs for postprocessing, yes
18:36:45 <highvoltage> pollo: we have lots of videos in the loop that come in at wildly different audio levels. I try to get them more or less levelled up, but it's hard to get perfect, it would be nice to have some normalization for the loop too
18:36:59 <pollo> doesn't obs offer that?
18:37:18 <wouter> highvoltage: I have a script as part of SReview that can take a video and spit out another video with normalized audio
18:37:22 <bittin> guess people use wildly different mics
18:37:30 <highvoltage> pollo: it can somewhat, then we'd still need to level it out with the talks, which is usually the bigger issue
18:37:32 <wouter> highvoltage: you could throw every submitted video through that before you start doing editing?
18:37:42 <highvoltage> (complaints are usually that the stream is suddenly too loud after a talk)
18:37:45 <wouter> they'll also be normalized at the same level as the talks then
18:38:38 <pollo> well, the recorded talks :)
18:38:40 <highvoltage> wouter: could work, I'll look into that then and be in touch with you. so we'll do it by hand then with probably no live normalization after obs
18:38:54 <highvoltage> ok then on to the loop itself
18:39:01 <wouter> highvoltage: sure
18:39:07 <highvoltage> it's working and pretty much ready for the conference
18:39:11 <wouter> \o/
18:39:18 <bittin> o/
18:39:37 <highvoltage> feel free to take a look at it on-stream at some point and give feedback earlier rather than later, next week is sure to be too busy to make big changes
18:39:50 <highvoltage> it's basically the DC20 recipe + a whole bunch of fixes
18:40:08 <bittin> have been looking good when i looked at it today
18:40:24 <highvoltage> and if there's any other questions feel free to ask any time
18:40:29 <pollo> oh, I see you fixed the vocto ingest!
18:40:49 <pollo> #info obs streaming to vocto has been fixed
18:40:55 <highvoltage> and then my last question, anyone know where tumbleweed is?
18:41:20 <pollo> afaiu, he's in a plane tomorrow
18:41:24 <highvoltage> pollo: yeah highvoltage fixed itâ„¢
18:41:27 <pollo> and then he'll have some time
18:41:39 <highvoltage> ok cool. I don't have much else
18:41:46 <highvoltage> except that I want a 4K screen
18:41:51 <pollo> don't wee all
18:41:58 <bittin> i want another screen :p
18:41:59 <highvoltage> no but unlike Wouter I'm always serious
18:42:00 <olasd> pollo: the volunteers app seems to Just Work
18:42:02 <highvoltage> I want a 4K screen
18:42:11 <pollo> olasd: have you been able to add volunteer slots?
18:42:12 <olasd> from starting the dc21 app and running the right management command
18:42:12 <wouter> highvoltage: I'm also serious, which is why I have a 4K screen
18:42:24 <highvoltage> which is why I'm going to ask if I can use Debian money for it
18:42:26 <wouter> (well, 4K UHD TV, really, with 3D too, even though I've not used that much)
18:42:35 <wouter> </brag>
18:42:48 <pollo> that was the issue I was having, not being able to use https://debconf21.debconf.org/volunteers/admin/video_mass_schedule/
18:43:09 <pollo> anyway, that discussion can happen after the meeting
18:43:12 <pollo> any other AoB ?
18:43:22 <wouter> (any other any other business)
18:43:33 <wouter> not from me, no
18:43:38 <bittin> :D https://debconf21.debconf.org/badges/
18:43:48 <fil> if there are any menial tasks that need doing, feel free to prod me -- I may well have time
18:43:53 <pollo> #endmeeting