18:01:02 <pollo> #startmeeting
18:01:02 <MeetBot> Meeting started Thu Aug  5 18:01:02 2021 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:02 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:09 <pollo> #topic Roll Call
18:01:12 <pollo> hello!
18:01:14 <wouter> hi!
18:01:21 <paddatrapper> o/
18:01:29 <lenharo> hi
18:01:29 <highvoltage> sorry for starting without you
18:01:47 <CarlFK[m]> hello
18:02:17 <pollo> #topic Review system
18:02:37 <wouter> #info pollo and wouter just ran some tests, going well but more work seems necessary
18:03:10 <wouter> just found & fixed a bug in the (new) FFmpeg audio normalizer
18:03:36 <wouter> question for everyone: the upload processing has some new features since last year, where it can decide to skip transcoding if the video looks "good enough"
18:03:45 <wouter> as well as reject an upload if something is problematic with it
18:03:59 <wouter> I've enabled the feature that rejects the upload if the video is longer than the time scheduled for it
18:04:10 <wouter> do we want to reject videos where the audio has a bit rate that is too low or some such?
18:04:20 <wouter> or where the resolution is crappy?
18:04:53 <wouter> (we can also just re-encode them if the bit rate or the resolution are too high, that's not a problem; but obviously SReview can't magically invent data that isn't there)
18:05:02 <pollo> I think it would be nice features, but I think we're cutting it close
18:05:19 <pollo> we should try to get the upload links published asap
18:05:21 <CarlFK[m]> I would issue warnings for all of those - else risk "your video is actuall ok, but the system won;t it be uploaded"
18:05:33 <wouter> you get a proper error message
18:05:38 <wouter> (well, some markup is broken, but meh)
18:05:48 <pollo> iirc the deadline for uploads is august 14th
18:05:57 <wouter> that still leaves ~a week
18:05:59 <highvoltage> oh my
18:06:19 <wouter> configuring those limits is not difficult, I can do that today
18:06:26 <wouter> the question is whether we want it
18:06:32 <pollo> wouter: no, the deadline for people to upload their video is aug 14th
18:06:43 <pollo> preferably, we want the system to be working before that :)
18:06:46 <wouter> pollo: yes, that is ~a week from now?
18:07:06 <wouter> so I mean that if I fix things now, it leaves about a week for people to upload, which I think should be enough?
18:07:12 <pollo> yes
18:07:43 <wouter> configuring these limits is not too complicated, and that bit is well battle-tested (I used it for FOSDEM, with 600+ videos and all kinds of weird files thrown at it)
18:08:12 <pollo> I'd say 320p is too low then
18:08:28 <wouter> wfm
18:08:38 <wouter> should we reject 8kHz audio, too?
18:08:56 <pollo> yup, that's basically bad-phone-bitrate levels
18:09:13 <wouter> it also excludes bluetooth audio headsets for recording though
18:09:35 <wouter> (because BT HSP maxes out at that bitrate)
18:09:43 <pollo> really?
18:09:47 <wouter> (I'm pro, but...)
18:09:50 <wouter> yes, really
18:10:02 <wouter> AASP does not, but is one-way (audio playback only, no recording)
18:10:02 <pollo> let's not check for audio bitrate then
18:10:32 <wouter> okay, I'll only check video resolution then
18:10:47 <wouter> can you tag that as agreed? Need to be a chair for that
18:11:28 <pollo> #agreed we'll be automatically rejecting uploads that are too long or 320p and less
18:12:04 <pollo> #topic Q&A webapp
18:12:09 <wouter> hang on
18:12:13 <pollo> #undi
18:12:15 <pollo> #undo
18:12:15 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x17266d0>
18:12:29 <wouter> as for post-event processing, I've sent a message to dsa to ask for a hole in the firewall
18:12:45 <wouter> I haven't had as much time configuring encoder1 as I'd hoped last weekend
18:13:18 <wouter> but I will work on that this week as much as possible
18:13:21 <wouter> (done, now)
18:13:42 <pollo> #info encoder1 still needs to be configured
18:13:44 <pollo> #topic Q&A webapp
18:13:53 <pollo> no changes, but I'll try to devote some time to it this week
18:14:08 <pollo> fwiw, the grabber works
18:14:14 <wouter> \o/
18:14:25 <pollo> worst case scenario, we can always fallback to using the etherpad
18:14:25 <wouter> what still needs to happen for the Q&A webapp?
18:14:56 <pollo> a bunch of UI things, like being able to delete questions, questions disapearing when they have been answered, etc
18:15:05 <pollo> tumbleweed did a list last meeting
18:15:09 <pollo> or the one before that
18:15:28 <wouter> oh, sorry, forgot to check last week's minutes
18:15:44 <wouter> (I updated the reminder in my phone so I shouldn't forget next week's meeting anymore...)
18:15:53 <pollo> #topic DC21 infra
18:16:14 <pollo> paddatrapper: have you had a chance to work on the VM size list?
18:16:24 <paddatrapper> not yet, hope to get to it tomorrowe
18:16:54 <pollo> everything seems to work, but jibri: https://salsa.debian.org/debconf-video-team/ansible/-/issues/83
18:17:11 <pollo> xorg just eats all the RAM available and then crashes...
18:17:23 <pollo> I've tried a bunch of things, but if someone else could have a look it would be nice
18:17:26 <wouter> don't know if anyone cares, but I noticed earlier today that the Vagrant tests are failing currently
18:17:42 <wouter> something with generating certificates that doesn't have pyopenssl or some such
18:17:46 <pollo> yes, they have been for a while, it's an issue with the CI, not ansible
18:17:57 <paddatrapper> I can look at it tomorrow
18:17:59 <wouter> I fixed the CI issue, I thought?
18:18:09 <paddatrapper> (it being jibri)
18:18:12 <pollo> #action paddatrapper to have a look at https://salsa.debian.org/debconf-video-team/ansible/-/issues/83
18:18:14 <pollo> thanks
18:18:19 <wouter> it's not urgent, but I did want to mention it
18:18:34 <pollo> #info the vagrant ansible CI is currently failing
18:19:12 <pollo> jibri is the last piece missing for us to do an end-to-end test
18:19:35 <pollo> when that's done I'll try to schedule something
18:19:43 <pollo> anything else?
18:20:19 <pollo> #topic DC21 schedule
18:20:35 <wouter> that seems up and running
18:20:45 <pollo> terceiro: can we start building a volunteer schedule, or are things still moving around too much?
18:20:56 <wouter> there were some issues with SReview parsing it (the format had changed slightly since last year), but tumbleweed and I figured that out
18:21:59 <pollo> #action pollo to set up the volunteer bits on the website
18:22:08 <pollo> #topic New Video Archive Mirror
18:22:10 <pollo> no news
18:22:17 <pollo> #topic Any Other Business
18:22:25 <wouter> I think we should boot that from the agenda until after debconf?
18:22:30 <wouter> (archive mirror, that is)
18:22:38 <highvoltage> is someone (like a content team or the video team) reviewing videos for basic quality issues?
18:22:55 <pollo> nattie: ^^ ?
18:22:59 <wouter> well, there's the automated checks, but nothing beyond that currently
18:23:04 <wouter> AFAIK
18:23:47 <pollo> wouter: we can do that in Sreview right?
18:23:58 <wouter> yes, definitely
18:23:59 <pollo> iirc that's what we did last time
18:24:26 <wouter> I'm not sure if that's true, but FOSDEM definitely did
18:24:30 <wouter> so the feature is there
18:24:45 <pollo> wouter: please set it up then :)
18:24:54 <wouter> it already is :)
18:25:18 <pollo> #action pollo to prod valhalla and urbec to see if they can help us with pre-conf video quality checks
18:25:29 <pollo> anything else?
18:26:51 <pollo> #topic Next meeting
18:26:59 <pollo> Debconf start soon!
18:27:01 <wouter> next week still fine I think
18:27:28 <pollo> Next Meeting Thursday August 12th from 18:00 to 19:00 UTC ?
18:27:34 <wouter> wfm
18:27:58 <paddatrapper> sounds good
18:28:11 <pollo> #agreed Next Meeting Thursday August 12th from 18:00 to 19:00 UTC
18:28:14 <pollo> #endmeeting