17:58:44 <pollo> #startmeeting
17:58:44 <MeetBot> Meeting started Tue Nov 10 17:58:44 2020 UTC.  The chair is pollo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:44 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:58:49 <pollo> #topic Roll Call
17:58:52 <tumbleweed> o/
17:59:00 <pollo> please say hello if you are here for the meeting!
17:59:13 <pollo> #link agenda: http://deb.li/oNCD
18:00:05 <tumbleweed> is it just the two of us?
18:00:42 <pollo> let's wait a little
18:00:44 <pollo> but that would be sad
18:01:15 <tumbleweed> and/or fast
18:01:45 <CarlFK> im reading
18:02:54 <pollo> #topic Miniconfs - Infra State
18:03:06 <pollo> tumbleweed: can you summarise the changes to the OBS VM?
18:03:09 <pollo> not sure I followed
18:03:26 <tumbleweed> so, from my understanding
18:03:44 <tumbleweed> highvoltage bumped the size (can't recall whether that is above the planned size or not)
18:04:20 <tumbleweed> it was still struggling, so he pre-rendered a bunch of scenes, which helped
18:04:32 <highvoltage> I bumped it to one larger than planned, but I also converted some scenes to pre-rendered ones that we would do live otherwise
18:04:42 <highvoltage> so back to the original size *might* be fine now
18:04:50 <tumbleweed> those pre-renderings do contain some artifacts (I think)
18:05:20 <pollo> #action highvoltage to investigate the OBS VM sizing
18:05:24 <highvoltage> yeah due to some earlier experiments they rendered as flv, I'll re-render those as mp4 then they should be better
18:05:39 <highvoltage> (colour is off too and I think that's also an flv fault)
18:05:53 <tumbleweed> flv is just a container. But I presume it implies a preset in your editor
18:06:12 <highvoltage> yeah
18:06:14 <tumbleweed> I'd suggest using the same h.264 settings (or roughly similar) as we use for our recordings
18:06:51 <pollo> I don't there is much to add to this topic
18:06:54 <pollo> the rest is more setup
18:07:02 <tumbleweed> highvoltage: I assume it's the main area that's pre-rendered and the bar at the bottom is still composited on it?
18:07:06 <highvoltage> tumbleweed: it already looks a lot better after that vbr change (can't remember what the newer technique is called off-hand right now)
18:07:29 <tumbleweed> I switched it to crf, which is constant-quality at an unlimited bitrate
18:07:51 <highvoltage> tumbleweed: yeah, for the most part. the "you're watching" scenes is compositing a little but it seems fine on the cpu in that case
18:08:05 <highvoltage> ah yes, crf. yeah that seemed to have helped
18:08:43 <pollo> #topic Miniconfs - Setup
18:08:55 <pollo> I ansibled all the VMs last week
18:09:04 <pollo> we since fixed a buch of issues
18:09:10 <pollo> #link setup status: https://pad.online.debconf.org/p/mcdo2_setup_status
18:09:12 <tumbleweed> I did one of my two actions: better VU meters in vogol
18:09:27 <pollo> #info the VU meter in vogol has been improved
18:09:31 <tumbleweed> still want to improve etherpad auth (which means switching to a new auth plugin, now that somebody has forked mine and taken over maintainance)
18:09:42 <tumbleweed> the nodejs world is quite forky
18:09:56 <pollo> lol, they forked your stuff since dc20
18:10:23 <pollo> I think all's left is grafana?
18:10:43 <pollo> and OBS, but we've talked about this already
18:11:12 <tumbleweed> grafana is up
18:11:20 <tumbleweed> but will probably see some more tweaking
18:11:27 <pollo> but the dashboards aren't configured yet
18:11:27 <highvoltage> I'm focussed on content related stuff because that's the most critical
18:11:34 <tumbleweed> pollo: they are
18:11:42 <highvoltage> but I'll get OBS essentials in ansible if no one beats me to it
18:12:18 <pollo> tumbleweed: I don,t see them then
18:12:32 <highvoltage> OBS is going to be a bit of a snowflake for these minidebconfs. ideally I'd like to rip out the current scene sequencer completely, hopefull we can use something completely different / NIH'y in the future
18:13:07 <highvoltage> (or perhaps get upstream Advanced Scene Switcher to add some more features, either way not going to happen this month)
18:13:16 <pollo> ah, I do see the dashboard, they're just hidden
18:13:27 <pollo> anyway, I think we're in a good spot
18:13:41 <tumbleweed> pollo: I think you need to configure our own home screen
18:13:48 <tumbleweed> *your*
18:13:54 <pollo> #action pollo to configure the default home screen
18:14:06 <pollo> do we know if SReview is up?
18:14:11 <phls> I'm following
18:14:13 <tumbleweed> I'd assume not
18:14:39 <tumbleweed> we can try to copy & tweak dc20 config
18:15:01 <pollo> I think wouter was waiting on the schedule
18:15:06 <pollo> highvoltage: how final is the one published?
18:15:37 <highvoltage> I know one talk is pending confirmation, and I know one was going to be moved (might be already, checking...)
18:15:54 <tumbleweed> that sounds final enough to not wait
18:15:57 <pollo> +1
18:16:13 <pollo> tumbleweed: want to chat with wouter and see if we can get Sreview up before the weekend?
18:16:14 <highvoltage> yeah it's pretty much there
18:17:04 <highvoltage> I see the jitsi links are there too, so thanks
18:17:28 <tumbleweed> pollo: sure
18:17:47 <pollo> #action tumbleweed to follow with wouter and try to get Sreview working before the weekend
18:17:54 <pollo> I think that's all for setup?
18:18:18 <highvoltage> I'm going ahead and creating all the html templates for the jitsi rooms too. jitsi from obs really works just fine so I'll keep that as a back-up in case jibri misbehaves at any point.
18:18:32 <tumbleweed> sreview also needs title screen SVGs
18:18:36 <tumbleweed> I think highvoltage is on that?
18:18:44 <highvoltage> yep
18:19:08 <pollo> #action highvoltage to finish the sreview title cards
18:19:16 <highvoltage> even to start.
18:19:24 <pollo> we wanted to get a video through the entire pipeline
18:19:35 <tumbleweed> yeah, I'd like us to do a dry-run on this stack
18:19:50 <pollo> we can try something before the training session, friday?
18:20:00 <tumbleweed> yep
18:20:10 <tumbleweed> if sreview isn't ready yet, we'll still have a recording that we can put through it later
18:20:31 <highvoltage> can someone send me the link to the DC20 SVG? just so that I know what the variables in there should be called and so on
18:20:31 <pollo> I'm free the entire day, any preference?
18:20:39 <pollo> if not we can do 18:00 UTC
18:20:44 <tumbleweed> highvoltage: it's in the dc20-online repo
18:21:19 <tumbleweed> https://salsa.debian.org/debconf-team/public/data/dc20-online/-/tree/master/artwork/video
18:21:32 <highvoltage> found it, thanks
18:21:37 <tumbleweed> pollo: yeah 16:00 onwards works for me
18:22:05 <pollo> #agreed Stack Test Run on Friday Nov 13th @ 18:00 UTC
18:22:20 <pollo> #topic Miniconfs - Training
18:22:26 <pollo> I'm brewing beer on sunday
18:22:44 <pollo> but I can schedule something on sat
18:23:47 <tumbleweed> do we have volunteers yet? do we need to do outreach?
18:24:10 <pollo> if we agree on training this weekend, I can take care of that
18:24:24 <pollo> I could do a session on sat and ask paddatrapper if he can do one on sun
18:24:26 <highvoltage> yeah we need to do ourreach, I'm planning to at least reach out to the .br and malayalam organisers to send their video volunteers for that
18:24:45 <tumbleweed> I'm happy to help out this weekend
18:24:52 <tumbleweed> but again, can only do 16:00 onwards
18:24:53 <phls> from br is me and @lenharo
18:24:58 <pollo> #agreed we'll have training session this weekend
18:25:13 <highvoltage> later than 16:00 will probably be better for brazilians anyway
18:25:27 <phls> on weekends it's ok after 13h UTC
18:25:31 <pollo> #action pollo to setup the wiki pages for training and check with paddatrapper and tumbleweed for training sessions
18:25:51 <pollo> phls: we're on a similar timezone, so it should be ok :)
18:25:57 <phls> but after 16h UTC is better indeed
18:26:04 <phls> ah, yes :-)
18:26:18 <pollo> anything else on training?
18:26:24 <phls> yes
18:26:44 <phls> is this training for operate the room? or something deeper?
18:26:54 <tumbleweed> just operations
18:26:58 <phls> ok
18:26:59 <tumbleweed> the deeper stuff is all already done
18:27:12 <pollo> (mostly) :)
18:27:58 <pollo> #topic Miniconfs - MDCO Brazil
18:28:14 <tumbleweed> I don't know what would be useful there? but happy to walk you through the stack if it helps?
18:28:18 <pollo> do you want to chat now or should we setup a meeting later?
18:28:24 <pollo> phls: ^^
18:28:41 <phls> well, I have a general question
18:29:11 <phls> MDCO Brazil will be 12h to 23h UTC. How deep we (br-team) will need to setup things?
18:29:28 <phls> or there will be always from you with us?
18:29:40 <pollo> you need to give us a schedule, preferably in the "pentabarf" format
18:29:51 <tumbleweed> pollo: they have a wafer instance, so that's easy
18:29:55 <pollo> ah great
18:30:18 <highvoltage> phls: have you seen the current loop? we'll have to set up at least a basic scene collection if you want a loopy for the weekend
18:30:21 <pollo> phls: we'll try to have someone from the core videoteam at all times
18:30:35 <pollo> but atm we can't guarantee anything
18:30:39 <highvoltage> so basically we need a logo for the bottom (I didn't see one on the website so I could make something up too)
18:30:51 <tumbleweed> highvoltage: which reminds me. Do we want a non-OBS static loop for mdco2? (or static image)
18:30:55 <tumbleweed> also bgloop
18:30:57 <highvoltage> and if you have any specific music that you want to play or want to find then that's also a todo
18:31:06 <tumbleweed> (and again, these would apply to mdco.br too)
18:31:16 <pollo> it was useful for dc20
18:31:22 <pollo> I think we should, as a backup
18:31:27 <highvoltage> tumbleweed: I was thinking that we'd have a standby loop like the backup sponsors list we had during dc20?
18:31:29 <phls> ah, we will need to add 2 logos from sponsors on this loopy
18:31:38 <tumbleweed> highvoltage: ack. Can we action you to create those?
18:31:43 <highvoltage> yeah
18:31:59 <pollo> #action highvoltage to generate statics loops
18:32:03 <tumbleweed> maybe a bgloop won't be necessary
18:32:08 <tumbleweed> we only have recordings and jitsi
18:32:09 <tumbleweed> so side-by
18:32:11 <highvoltage> what's the bgloop?
18:32:13 <tumbleweed> -side won't happen
18:32:24 <tumbleweed> bgloop is shown behind the voctomix layouts that don't fill the screen
18:32:33 <pollo> phls: if you have specific questions, I think writing on the mailing list would be simpler?
18:32:45 <tumbleweed> https://debconf-video-team.pages.debian.net/docs/loops.html#safe-zones-for-the-background-loop
18:32:45 <phls> pollo, yes, its ok to me
18:33:16 <tumbleweed> but, with this simplified voctomix setup, I guess we don't need a bgloop
18:33:27 <highvoltage> phls: can you (or someone from mdcobr) put together a slide with the sponsors that we can use?
18:33:47 <highvoltage> phls: and also a logo that fits in the bar? I guess the debian brazil logo with minidebconf online or similar next to it would work
18:34:39 <phls> highvoltage, ok, I will ask details to you latter
18:34:44 <highvoltage> great
18:34:54 <phls> thanks
18:34:57 <pollo> #action phls (or someone from mcdobr) to provide a slide with sponsor logos + a general logo for the conf
18:35:00 <pollo> anything else?
18:35:05 <phls> no
18:35:17 <pollo> #topic Video archive documentation
18:35:24 <pollo> I haven,t touched that
18:35:42 <pollo> #topic Any other business
18:36:02 <highvoltage> yeah
18:36:25 <highvoltage> tumbleweed: I'm not sure how video.js is usually embedded on the site
18:36:39 <highvoltage> could it be added to the home page?
18:36:45 <tumbleweed> highvoltage: yeah... it's a little messy
18:36:47 <tumbleweed> it totally could be
18:37:03 <tumbleweed> let's start by looking at what terceiro has done in the wafer-debconf branch you're using
18:37:07 <tumbleweed> it may be there already
18:37:21 <highvoltage> ok
18:38:06 <highvoltage> we have received two pre-recorded talks so far
18:38:20 <highvoltage> thursday is the deadline so we should have quite a few by the weekend for testing
18:38:37 <pollo> #info thursday is the deadlin for pre-recordings
18:38:48 <highvoltage> I'm uploading them all the obs1 machine too as a backup and they should rsync really quick from there to their final destination
18:39:00 <tumbleweed> I assume they're being reviewed for quality?
18:39:00 <pollo> highvoltage: we're not likely to use them from training though
18:39:09 <highvoltage> of course
18:40:17 <tumbleweed> highvoltage: you want to copy them to voctomix1:/home/videoteam/recorded-talks/
18:40:45 <highvoltage> thanks
18:41:14 <highvoltage> nothing else from me
18:41:25 <pollo> #topic Next Meeting
18:41:43 <pollo> Tue Nov 17th @ 18:00 UTC ?
18:41:47 <tumbleweed> +1
18:42:13 <pollo> we'll have had a dry run + training, so it'll be a good moment to assess what remains to be done
18:42:41 <pollo> #agreed Next Meeting: 17 Nov @ 18:00 UTC
18:42:44 <pollo> #endmeeting