18:00:12 <tumbleweed> #startmeeting
18:00:12 <MeetBot> Meeting started Sat Aug 22 18:00:12 2020 UTC.  The chair is tumbleweed. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:12 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:12 <paddatrapper> All guests should now be reporters
18:00:18 <paddatrapper> ginggs: you should be able to see it now
18:00:19 <tumbleweed> #link http://deb.li/oNCD Agenda
18:00:30 <tumbleweed> hi
18:00:33 <pollo> 0/
18:00:36 <tumbleweed> say hi if you're here for the meeting
18:00:41 <paddatrapper> \o
18:00:45 <olasd> hi if you're here for the meeting
18:00:52 <sahilister[m]> hi o/
18:00:53 <olasd> (yeah it's been a while :P)
18:00:59 <tumbleweed> :)
18:01:03 <wouter> o/
18:01:27 <cate> hello
18:01:54 <tumbleweed> #topic Video Stack - Jitsi
18:02:16 <wouter> seems to work?
18:02:16 <tumbleweed> So, since the last meetnig there were some reports that jitsi was not showing everybody's video
18:02:20 <tumbleweed> I think that's normal behavior
18:02:31 <tumbleweed> although apparently meet.jit.si doesn't seem to be as sensitive to it
18:03:04 <pollo> what do you mean by "not showing everybody's video" ?
18:03:05 <wouter> are there any details on what exactly is going wrong with it?
18:03:08 <olasd> yeah, same question
18:03:09 <wouter> yeah, that
18:03:12 <wouter> :)
18:03:27 <tumbleweed> 18:04 < tumbleweed> I did some hacking on skinning the jitsi last nigth
18:03:27 <tumbleweed> 18:04 < tumbleweed> there's probably more we can do
18:03:27 <tumbleweed> 18:04 < tumbleweed> I think jiust the house logo would probably work better than the current logo
18:03:53 * nattie waves belatedly
18:03:54 <tumbleweed> yeah, there was even a recording
18:04:00 <tumbleweed> see #debian-social from a few days ago
18:04:03 <tumbleweed> I can dig out logs
18:04:55 <tumbleweed> http://fam-tille.de/tmp/barbara_andreas_jitsi/frames_06_00_video_stopped.tgz was the recording
18:05:08 <wouter> is it something we can fix before the conference, and/or is it a major issue that would result in problems? If not I'd think we can just ignore it...
18:05:14 <paddatrapper> there may be a config switch in meet that sets the threshold for low bandwidth mode - where inactive participants have their video turned off for a local user
18:05:16 <tumbleweed> yeah, let's ignore and move on
18:05:33 <paddatrapper> It only affects the local user and not the stream (from what I understand)
18:05:42 <tumbleweed> I'm sure we'll get all sorts of werid bug reports in the next days
18:05:45 <wouter> paddatrapper: yes, if you can find that and tune it a bit that might make sense, but other than that...
18:06:01 <wouter> tumbleweed: or the past few ones, too ;)
18:06:12 <tumbleweed> #topic Video Stack - Voctoweb
18:06:25 <tumbleweed> olasd: my changes to the fullscreen button may have negated some of the need for presets
18:06:34 <olasd> tumbleweed: cool
18:06:42 <tumbleweed> although they could be useful for PinP
18:07:04 <tumbleweed> auth is done, and seems people aren't complaining
18:07:05 <paddatrapper> The only trick people need to be aware of is setting grabber full screen using the Fullscreen Solo will mute Jitsi
18:07:27 <tumbleweed> paddatrapper: would you like a Fullscreen button too
18:07:31 <tumbleweed> and then Fullscreen Solo can be red
18:07:47 <wouter> the way paddatrapper explained it during training was pretty okay I'd say
18:07:52 <paddatrapper> tumbleweed: maybe, using the A button also works, but not as intuitive
18:08:15 <wouter> paddatrapper: otoh, having two "fullscreen" buttons might be even less intuitive
18:08:19 <pollo> +1
18:08:27 <tumbleweed> could rename the second one to just Solo
18:08:39 <tumbleweed> But that probably makes more sense to somebody who knows an audio desk
18:08:43 <tumbleweed> than a random video volunteer
18:08:47 <urbec> or add a "changes audio!"
18:08:53 <wouter> tumbleweed: since we've been training people on the current interface though, I'd be wary of changing it too radically at this point
18:09:02 <paddatrapper> Maybe change the colour of the current and leave it as is?
18:09:08 <tumbleweed> wouter: yeah, that's why I pushed those throguh last night
18:09:13 <pollo> hmm, so there's no sound when using the "loop" button ?
18:09:16 <paddatrapper> Generally people know red = dangerous
18:09:22 <tumbleweed> pollo: yeah
18:09:26 <olasd> but it isn't dangerous
18:09:33 <wouter> paddatrapper: except in China, where green = dangerous...
18:09:34 <tumbleweed> Red is also the color of B source, though
18:09:39 <urbec> would have associated red with off here
18:09:49 <tumbleweed> I used blue because A source
18:09:54 <paddatrapper> true. Then leave it to be consistent with training
18:10:14 <cate> red is "record"
18:10:23 <olasd> if source == 'grabber': disable_audio_switching() :P
18:10:41 <tumbleweed> I've tried to avoid source-specific hacks like that, but we totally can
18:11:01 <tumbleweed> anyway, let's keep moving
18:11:06 <wouter> tumbleweed: yeah, but I think it wouldn't help
18:11:10 <tumbleweed> #topic Vide Stack - Playback
18:11:23 <wouter> +o
18:11:25 <tumbleweed> Haven't poked at seeking any more
18:11:31 <tumbleweed> or wouter's API yet
18:11:49 <tumbleweed> if that doesn't happen, we'll just manually copy over the day's videos
18:11:50 <pollo> we now have a script for playback fallback though
18:11:51 <wouter> tumbleweed: I don't think seeking is critical, it shouldn't change anyway?
18:11:53 <tumbleweed> that was always the fallback plan
18:12:15 <olasd> so are tomorrow's videos ready?
18:12:21 <pollo> videoteam@voctomix1:~$ videoteam-recordings-playback -h
18:12:31 <wouter> yes, all videos have been successfully transcoded now
18:12:44 <olasd> so are tomorrow's videos ready to be played back on voctomix1?
18:12:48 <wouter> I just went over all 42 submitted videos and hit the "play" button in the SReview interface
18:12:51 <olasd> ok
18:12:52 <wouter> they all work
18:12:53 <olasd> cool
18:13:00 <tumbleweed> so, we need to copy them over
18:13:06 <tumbleweed> I'll talk to wouter about that after the meeting
18:13:10 <wouter> sure
18:13:18 <tumbleweed> #topic Video Stack - Loop Generation
18:13:30 <tumbleweed> The loop is currently bouncing through the streaming backend to voctomix
18:13:32 <tumbleweed> and it's a bit dodgy
18:13:34 <tumbleweed> e.g. right now
18:13:51 * tumbleweed restarts it
18:14:05 <olasd> when reading it through rtmp it's just fine, so clearly an ingest issue
18:14:16 <tumbleweed> yeah
18:15:11 <tumbleweed> that's videoteam-ingest-0.service if anyone wants to hack o nit
18:15:23 <olasd> cron a restart of ingest in the middle of each talk? :P
18:15:30 * olasd hides
18:15:39 <wouter> olasd: it's actually not too terrible an idea
18:16:13 <wouter> maybe have voctoweb do it when you switch away from the loop ;)
18:16:53 <tumbleweed> and yes, the backup loop has no audio
18:17:03 <tumbleweed> I haven't investigated whether this is by design or I screwed up
18:17:36 <tumbleweed> #topic Video Stack - Grabber
18:17:40 <tumbleweed> probably nothing to say here, as usual?
18:17:46 <wouter> highvoltage isn't here though, right?
18:17:54 <tumbleweed> doesn't seem to be
18:18:11 <paddatrapper> he's out having supper I believe
18:18:12 <tumbleweed> #topic Video Stack - SReview
18:18:34 <wouter> yeah, there were more bugs than I'd hoped for, but things seem to be worked out now
18:18:48 <wouter> videos are already stored in per-day directories
18:19:07 <tumbleweed> We still don't have title screens for recordings
18:19:16 <wouter> so you just need to copy over the right directory; if all you need from the metadata is the date, then you don't need the metadata
18:19:21 <wouter> yeah, I was about to say that
18:19:43 <tumbleweed> cool, yeah, that was always the easy way to get pre-recorded talks
18:19:47 <wouter> it's not crucial just yet, and worst case I'm married to a graphic designer, but she's already said she doesn't have time
18:20:09 <tumbleweed> so, for an online conference, I think getting talks out ASAP is important
18:20:15 <tumbleweed> we should try to get something done today
18:20:23 <tumbleweed> so they can start releasing tomorrow
18:20:28 <wouter> I also have a script that syncs the states of the three talks, and it seems to work for Q&A
18:20:34 <wouter> er, three events I mean
18:20:55 <wouter> if you go to the overview page and you go to the "Q&A" event, you'll see that the talks that don't have any recording are marked as "ignored" there
18:21:07 <wouter> the idea being that for a live talk you must review through the "normal" event
18:21:16 <wouter> and for a prerecorded talk you need to only review the Q&A event
18:21:21 <tumbleweed> and for others you'll combine the pre-recording with the Q&A?
18:21:32 <wouter> SReview will, yes
18:21:45 <wouter> the review would just review the recording to get out the Q&A
18:22:05 <wouter> and then the prerecording and the Q&A will be injected into the "main" event and be chucked out as a single video
18:22:47 <wouter> I haven't yet had time to test that out in detail, I intend to do that by manually running the transcode job for the first prerecorded event...
18:23:01 <wouter> we'll see whether it has any issues (I sure hope not)
18:23:15 <wouter> other than that I'm ready
18:23:18 <tumbleweed> OK
18:23:28 <tumbleweed> Anyone want to take an action to hack together some title screens?
18:23:55 <wouter> I'll do it tomorrow if nobody else pitches up anything by then
18:24:03 <tumbleweed> I assume if someone creates an ugly draft, other people will suggest improvements :P
18:24:07 <wouter> (but I wouldn't complain if someone does...)
18:24:09 <wouter> heh, true :)
18:24:11 <paddatrapper> I'll see if my brother is able to tonight
18:24:46 <tumbleweed> FWIW: https://salsa.debian.org/debconf-team/public/data/dc20-online/-/issues/11
18:25:26 <tumbleweed> #info wouter will create a title screen tomorrow if nobody else has yet
18:25:34 <tumbleweed> #info paddatrapper will ask his brother if he can do a title screen
18:25:41 <tumbleweed> #topic Video Stack - Streaming
18:26:17 <olasd> so, the yt fallback has been implemented
18:26:21 <tumbleweed> yeah
18:26:24 <tumbleweed> so, on that
18:26:47 <tumbleweed> if nginx goes down for too long (like this morning when I was making the dump directory bigger)
18:26:50 <tumbleweed> it'll stop
18:26:59 <pollo> Are we streaming to yt by default or just falling back to it in case of trouble?
18:27:04 <tumbleweed> and it won't create a new stream unless you have streaming control panel open when nginx starts
18:27:20 <tumbleweed> so... it may break and require a nginx restart to fix
18:27:39 <wouter> tumbleweed: IIRC, youtube assumes that once the stream stops that's the end of it and you need to create a new live stream, right?
18:27:43 <tumbleweed> pollo: we're pushing to it so that we have it as an option
18:28:03 <tumbleweed> wouter: yes. And I can't seem to do that if the video is already being sent
18:28:10 <tumbleweed> thus the nginx restart
18:28:22 <wouter> at OSW.co.za I did live streams to youtube straight from vocto
18:28:29 <wouter> wouldn't that be an option?
18:29:03 <tumbleweed> yes it would
18:29:14 <tumbleweed> but also unnecessary?
18:29:48 <wouter> sure; I'm just thinking it cuts out moving parts between vocto and youtube so there's less space for something to go wrong
18:29:50 <olasd> tumbleweed: if we need to publish the yt stream url something is on fire and there will be a video team member around, so I don't think having to do an nginx restart is much of a problem
18:29:55 <pollo> Have we load tested yet? If not I can ping #debian-devel after the meeting
18:30:02 <tumbleweed> olasd: right
18:30:10 <tumbleweed> paddatrapper: you had an action to test?
18:30:20 <wouter> who has access to the youtube control panel beyond tumbleweed though?
18:30:24 <olasd> I do
18:30:36 <wouter> okay, good
18:30:54 <tumbleweed> wouter: I think it'll survive short outages (i.e. restarts) just not long ones
18:31:12 <tumbleweed> pollo: So, then, yes there is the question
18:31:13 <paddatrapper> tumbleweed: hasn't happened yet
18:31:17 <paddatrapper> The week ran away with me
18:31:22 <tumbleweed> should we make the YT stream public?
18:31:34 <tumbleweed> It seems reasonable to me - if it's useful to our audience
18:31:38 <nattie> what problem would that solve?
18:31:38 <tumbleweed> and it probably brings an audience
18:31:55 <wouter> tumbleweed: sure -- I was just thinking that if you have things go through nginx, then nginx becomes a SPOF, which would be nice to avoid, but it's not critical and if you think it would not improve matters then I'm that's fine
18:32:04 <tumbleweed> the downside is that it's not being looked after as carefully as anything else
18:32:28 <pollo> I think it's dangerous, as people will expect it to work
18:32:30 <olasd> tumbleweed: meh
18:32:34 <wouter> also the youtube interface doesn't have any of the interaction options
18:32:35 <pollo> And most of us don't have access to it
18:32:46 <olasd> that can be fixed
18:33:00 <tumbleweed> wouter: neither does mpv
18:33:09 <wouter> I'm okay with it being a backup option, but I'd suggest not publishing it except in case of real problems
18:33:12 <pollo> I don't have a google account :)
18:33:24 <olasd> that can be fixed (:P)
18:33:25 <pollo> And I can't create one since my phone is voip
18:34:15 <wouter> can't you bypass giving them a phone number? I've always been able to...
18:34:31 <pollo> Nope
18:34:33 <wouter> not that you must have a google account though (in fact...)
18:34:36 <olasd> anyway; I think the answer is "no" on making the stream public
18:34:38 <tumbleweed> can we step back from pollo's anti-googleness and talk about the question at hand
18:34:42 <tumbleweed> yeah, seems the consensus is no
18:34:43 <wouter> sorry
18:34:44 <olasd> for now at least?
18:35:19 <tumbleweed> #topic Video Stack - Etherpad
18:35:26 <tumbleweed> nobody seems to be complaning atm, so I guess it works
18:35:31 <wouter> heh :)
18:35:38 <tumbleweed> it does mean people need salsa accounts, though
18:35:40 <wouter> yeah, it seemed to work during paddatrapper's training
18:36:21 <tumbleweed> I guess nobody has actually tested it in the grabber yet
18:36:29 <tumbleweed> because I haven't heard complaints about needing to be logged into salsa from the grabber
18:36:39 <tumbleweed> the trick there is to use the public URL for the pad which doesn't require auth
18:36:54 <paddatrapper> Yeah I don't think anyone has tried changing the grabber pad yet
18:37:31 <tumbleweed> or we should log into salsa from a test user
18:37:33 <wouter> I guess there's no way to avoid the auth altogether?
18:37:53 <pollo> +1 for test user
18:37:54 <tumbleweed> we decided to have auth to be able to deal with abuse
18:38:01 * tumbleweed has a test user we can use
18:38:20 <wouter> fair enough
18:38:27 <olasd> or we could make a dedicated user and have its credentials on the readme
18:38:28 <tumbleweed> I'm just a little worried that there are other flows that are
18:38:35 <tumbleweed> going to come up in every event and nobody has tested
18:38:37 <olasd> (the rabber readme)
18:38:40 <olasd> grabber*
18:39:13 <wouter> I think a test user is probably a good idea, yes
18:39:20 <tumbleweed> I have one, I'll log it in
18:39:25 <wouter> keep it logged in, and add the credentials to the readme just in case
18:39:38 <tumbleweed> #topic Video Stack - Embed in the Website
18:39:39 <olasd> .oO(doesn't pollito have a salsa account?)
18:39:57 <tumbleweed> So, highvoltage was reporting some HLS issues this morning
18:40:19 <tumbleweed> looks like if the stream glitches (eg nginx restart) we get 503 / 404s that don't have CORS headers
18:40:28 <tumbleweed> and the browser caches this fact for the lifetime of the page
18:40:39 <tumbleweed> so, we should fix that
18:41:08 <tumbleweed> There's also things video.js does to try to avoid reusing those bad streams (see the discussion before the meeting)
18:41:17 <tumbleweed> didn't seem like there was anything we need to tweak there, though
18:41:28 <olasd> tumbleweed: the trick seems to add "always" at the end of the add_header directive in the nginx config
18:41:37 <olasd> according to stackoverflow :P
18:41:45 <tumbleweed> olasd: can I action you?
18:41:54 <olasd> yeah
18:42:04 <tumbleweed> #action olasd to add CORS headers to streaming frontend errors
18:42:23 <tumbleweed> #topic Advice/training for directors talkmeisters
18:42:27 <tumbleweed> We had training today \o/
18:42:34 <nattie> so many training
18:42:36 <paddatrapper> The two sessions went well
18:42:37 <wouter> yeah, and it seemed to go well
18:42:41 <paddatrapper> One more to go
18:42:43 <tumbleweed> and aside from auth, nobody seems to be complaining about anything
18:42:53 <paddatrapper> Yeah
18:42:58 <olasd> I should have attended, seeing how I'm pretty much the lone volunteer for tomorrow morning ;p
18:43:04 <paddatrapper> We should probably hold training during the conf too
18:43:10 <olasd> paddatrapper: definitely
18:43:13 <tumbleweed> yeah, I was wondering about that
18:43:15 <olasd> we need more volunteers
18:43:39 <tumbleweed> has anyone sent a "videoteam needs you" video to loopy?
18:44:04 <wouter> I'll probably be around tomorrow morning too, in case you need me
18:44:22 <pollo> tumbleweed: action md
18:44:24 <pollo> Me
18:44:38 <tumbleweed> #action pollo to send a "videoteam needs you" video to loopy
18:44:51 <tumbleweed> #topic Advice/training for presenters
18:45:00 <nattie> speaker test calls are happening
18:45:01 <tumbleweed> I see this has been happening
18:45:07 <tumbleweed> any jitsi issues?
18:45:28 <nattie> there was the occasional thing where people would say they were joined but we couldn't see them
18:45:34 <nattie> but that would sort itself out when they reloaded
18:46:01 <tumbleweed> so... arrive early for your talk so issues can be resolved
18:46:41 <tumbleweed> I guess that's that
18:46:52 <tumbleweed> #topic Actions from last meeting
18:46:57 <tumbleweed> pollo wrote the playback fallback
18:47:00 <wouter> I think "arrive early" is a good idea regardless
18:47:08 <tumbleweed> indeed
18:47:20 <tumbleweed> #topic AoB
18:47:33 <wouter> how does the playback fallback work?
18:47:45 <tumbleweed> -h apparently
18:48:18 <olasd> we need more volunteers for tomorrow morning; I'm currently alone for the first two talks :P
18:48:29 <wouter> olasd: like I said, I can be around too
18:48:33 <pollo> /usr/local/bin/videoteam-recordings-playback -i path/to/videofile -p HH:MM:SS
18:48:35 <tumbleweed> sorry, can't help there :)
18:48:37 <nattie> olasd: does that include the opening session?
18:48:41 <olasd> nattie: yes
18:48:50 <nattie> well, that doesn't really need a talkmeister as such
18:48:52 <wouter> and it might be a good idea if the first few talks are videoteam members so that we can fix issues if they appear?
18:48:58 <nattie> yeah
18:50:50 <nattie> i can probably also be around and talkmeister if nobody else signs up for those
18:51:09 <pollo> Anything before this Debian med bof is too early for me
18:52:33 <cate> tomorrow I'll be away from computers, but then I could be more active (and better internet for volunteering)
18:52:56 <olasd> I think that's it for AoB?
18:53:20 <tumbleweed> #topic Next Meeting
18:53:47 <wouter> should we do something after the last talk tomorrow evening to evaluate how things are going, or would that be too soon?
18:53:54 <tumbleweed> The DC20 team is going to do potential meetings in the 16:45 break every day
18:54:07 <wouter> we can do ours later than that
18:54:13 <wouter> I think that's a good idea regardless
18:54:24 <olasd> wouter: I'm not sticking around until 1:20 AM for a feedback meeting :P
18:54:47 <olasd> although... maybe
18:54:50 <tumbleweed> that same 16:45 break could be a good time to meet
18:54:56 <tumbleweed> although we'd want to not clash
18:55:10 <wouter> tumbleweed: we could also do the 18:00 UTC one
18:55:11 <nattie> there's enough overlap between videoteam and general orga that clashing should be avoidable
18:55:17 <wouter> er, 18:45 UTC
18:55:17 <tumbleweed> talks start at 18:00
18:55:29 <wouter> ah, damn
18:55:32 <wouter> looking at the wrong times, sorry
18:55:42 <olasd> I suspect the team meeting will be short and we can meet after it?
18:55:47 <tumbleweed> yes, I think so
18:55:52 <tumbleweed> but it's hard to set a specific time
18:55:56 <tumbleweed> maybe 17:00 ?
18:56:01 <wouter> alternatively, the 20:45 UTC slot could work too
18:56:07 <wouter> (for me, at least)
18:56:11 <wouter> bit late, but doale
18:56:14 <wouter> +b
18:56:33 <tumbleweed> Shall we play it by ear tomorrow
18:56:37 <olasd> yes
18:56:39 <tumbleweed> Try for 17:00
18:56:41 <wouter> yeah, think so
18:56:44 <tumbleweed> Reassess if necessary
18:56:49 <wouter> +1
18:56:50 <olasd> I think we might want to discuss feedback from the orga meeting during our meetings anyway
18:56:53 <tumbleweed> #agreed let's attempt to meet at 17:00 UTC daily
18:56:55 <wouter> right
18:56:56 <tumbleweed> yeah
18:56:58 <olasd> so having them close together would be sensible
18:57:14 <tumbleweed> Let's call this done then
18:57:16 <tumbleweed> #endmeeting