18:01:04 <tumbleweed> #startmeeting
18:01:04 <MeetBot> Meeting started Thu Aug 13 18:01:04 2020 UTC.  The chair is tumbleweed. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:04 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:06 <tumbleweed> somebody's got to do it
18:01:20 <tumbleweed> #link http://deb.li/oNCD Agenda
18:01:23 <tumbleweed> #topic roll call
18:01:26 <pollo> 0/
18:01:27 * nattie hollahs
18:01:35 <tumbleweed> hai
18:02:02 <tumbleweed> #topic video stack
18:02:09 <tumbleweed> #topic video stack - jibri
18:02:20 <tumbleweed> Shall we call that done?
18:02:38 <pollo> last meeting we had questions about passwords and jibri?
18:02:44 <tumbleweed> ah, yes
18:03:04 <tumbleweed> I haven't touched that. I've been looking at protecting etherpad, which we'll get to later...
18:03:25 <tumbleweed> I'd say there are 2 questions about passwords and jibri:
18:03:31 <tumbleweed> 1. Do we want to set a streaming password
18:03:36 <paddatrapper> o/
18:03:38 <tumbleweed> 2. Do we want to be able to use password protected rooms
18:03:58 <pollo> I'd say yes if possible for both
18:04:01 <tumbleweed> both seem like nice to have, yes
18:04:06 <paddatrapper> 1. Is possible
18:04:08 <pollo> 2 can be mitigated by random URLs
18:04:10 <paddatrapper> 2. Is not
18:04:18 <paddatrapper> Jibri doesn't support it
18:04:34 <tumbleweed> although, of course it could be made to support it
18:04:38 <tumbleweed> but not sure how hard that would be
18:04:50 <terceiro> let's maybe don't count of patching stuff this late in the game?
18:04:54 <pollo> +1
18:05:00 <tumbleweed> terceiro: that's basically all I'm doing atm :P
18:05:18 <terceiro> :-o
18:05:23 * terceiro shrugs
18:05:31 <paddatrapper> upstream bug report: https://github.com/jitsi/jibri/issues/264
18:05:36 <tumbleweed> but yeah, if we wanted to do that, a few months ago would have been better
18:05:42 <pollo> paddatrapper: what would the streaming password UX look like?
18:05:46 <terceiro> or maybe let's not decide on new things to patch this late ... :)
18:06:12 <paddatrapper> pollo: it would need to be part of the key in the streaming popup
18:06:30 <paddatrapper> Then we use that to determine which vocto instance we are streaming to
18:06:45 <tumbleweed> in practice the vocto instance could be static, in our setup
18:06:49 <pollo> so you'd enter something like asknaksdnuqonkd:voctomix1 and if the password isn't right, it'd fail?
18:07:15 <tumbleweed> pollo: yeah, or just asknaksdnuqonkd if the vocto instance was static
18:07:17 <paddatrapper> pollo: if we make the bash script do that, yes
18:07:40 <tumbleweed> or rewrite it in python, because that's some ugly bash :P
18:07:47 <pollo> I think we should, doesn't sound so hard to do in that patched ffmpeg script anyway
18:07:59 <paddatrapper> tumbleweed: very, but maybe after DC :P
18:08:16 <tumbleweed> which of you will take the action?
18:08:45 <paddatrapper> I'm not going to get a chance this week... I'm swamped as it is
18:08:51 <pollo> I don't have tons of spare time, as the deadline to hand out my master thesis is less than a month away :S
18:09:00 <tumbleweed> or should we suggest rewriting it in perl, to make more people interested
18:09:04 <pollo> lol
18:09:07 <paddatrapper> Though I think I'm less swamped than that!
18:09:13 <paddatrapper> tumbleweed: action me
18:09:27 <tumbleweed> #action paddatrapper to implement a streaming password
18:09:39 <tumbleweed> #topic videoe stack - voctoweb
18:09:46 <tumbleweed> only very minor progress this week
18:09:58 <tumbleweed> I cleaned up some UI clutter, and started a mechanism to see who else is editing your video stream
18:10:08 <tumbleweed> (when you're not in the same room, I'm expecting this to be an issue)
18:10:30 <paddatrapper> yeah it was already slightly confusing during the dry run
18:10:36 <tumbleweed> I still want to do seeking, and presets
18:11:18 <tumbleweed> it doesn't seem to be leaking memory any more (at least, not like before)
18:11:34 <tumbleweed> #topic video stack - loop generation
18:11:45 <tumbleweed> calling highvoltage (or olasd)
18:11:46 <highvoltage> o/
18:12:37 <highvoltage> also made very little progress, but after this weekend (where I'm going to focus on my 3 DebConf session content and get it all sorted out), I should have some decent time available to come up with something nice
18:12:48 <tumbleweed> zigo: it'd still be nice to get a firewall exception on that gpu machine for port 5900, for our VNC over TLS
18:13:06 <pollo> tumbleweed: can't we use another port?
18:13:21 <highvoltage> at least my other debian work is more or less up to date so I actually think the outlook is now good for me to actually get it done by the next meeting
18:13:30 <tumbleweed> pollo: I don't know what's open. Only 22 that I've noticed.
18:13:55 <pollo> what's the name of that machine again?
18:14:01 <tumbleweed> obs1
18:14:11 <highvoltage> although I'm not sure how to get to OBS yet on the obs1 machine, not sure what the best way is to start and access a remote X session there and if I should use the stuff already implemented
18:14:12 <tumbleweed> jeff3rson[m]: Any thoughts on loop design yet?
18:14:24 <tumbleweed> highvoltage: that's all implemented
18:14:43 <tumbleweed> same stuff that we're using for our grabber
18:14:53 <tumbleweed> except for this pesky firewall, that means you need to do some ssh port forwarding
18:15:21 <highvoltage> well, I still don't know how to access it until you tell me which ports to forward and where
18:15:39 <tumbleweed> highvoltage: port 5900 (the usual VNC port) on obs1.online.debconf.org
18:15:51 <tumbleweed> you'll need a VNC client that does tls. Like xtigervncviewer
18:15:58 <tumbleweed> or virt-viewer
18:16:15 <highvoltage> ah just port 5900 listening on localhost at obs1? ok can do
18:16:33 <tumbleweed> shout if you get stuck
18:16:49 <highvoltage> nothing further from me for the topic
18:16:51 <tumbleweed> there should be a normal xfce desktop on there, and OBS installed
18:17:04 <tumbleweed> #topic video stack - sreview
18:17:07 <tumbleweed> wouter: around?
18:17:24 <tumbleweed> terceiro: you need us to look into the uploads failing?
18:17:31 <terceiro> yes please
18:17:33 <terceiro> I am very concerned about it
18:17:54 <tumbleweed> I can look for obvious errors in logs
18:17:58 <nattie> yeah, people are coming to the speaker desk and we can't give them a proper answer
18:18:03 <tumbleweed> but basically this is wouter's baby
18:18:04 <terceiro> not only the uploads failing, but I also need upload urls for a few new talks that were added after wouter generated the first batch
18:18:25 <tumbleweed> no idea how to generate those, we'd have to reverse engineer
18:18:34 <tumbleweed> ivodd has done that occasionally in the past
18:18:46 <terceiro> I think we need to rediscuss the deadline in these conditions
18:18:49 <tumbleweed> (reverse-enginering sreview, I mean)
18:19:05 <terceiro> we are 3 days from the deadline and the upload seems to be broken
18:19:21 <tumbleweed> so, the point of the deadline is:
18:19:31 <pollo> for the new urls, I think what it needs is the new schedule import
18:19:31 <tumbleweed> 1. To give the speaker assistance team time to review videos and give feedback
18:19:47 <tumbleweed> nattie: dunno how long you need for that? What manpower is like, etc.?
18:20:07 <tumbleweed> 2. To give time for everything to be encoded and in the right place before talks start
18:20:16 <tumbleweed> we can throw resources at 2, up to a limit
18:20:20 <nattie> tumbleweed: well, just now, terceiro fielded questions on that from two people
18:20:27 <terceiro> also we already have one "oh I didn't notice the deadline was so close, how late can I be?" request
18:20:57 <nattie> and one "please can i go live, it just doesn't feeeeeeeeeeeeeeeeeeeeeeeel right", but that's beside the point
18:21:00 <highvoltage> oh I sent that message telepathically? I hadn't realised
18:21:30 <pollo> forgot your tin-foil hat
18:21:41 <tumbleweed> So, technically, I'd imagine we can get down to hours before a talk. But it starts to get quite painful then
18:21:51 <tumbleweed> I think we'd want everything encoded at least the day before
18:22:03 * highvoltage uses all his mental energy to resist the instinct to want to write a little flask app to do this
18:22:04 <terceiro> ok
18:22:07 <tumbleweed> nattie: not sure how long you need for review, though?
18:22:14 <CarlFK> there is the option of encoding on the fly
18:22:19 <tumbleweed> CarlFK: no, there isn't
18:22:30 <nattie> i've no idea as yet, but it's not ideal that people can't submit
18:22:36 <terceiro> so we uploads can be a bit late
18:22:43 <terceiro> *the uploads
18:23:10 <paddatrapper> we probably need at least 2 or 3 days after the uploads are fixed
18:23:14 <paddatrapper> for people to upload
18:23:48 <tumbleweed> CarlFK: so, technically, we can throw anything into our playback mechanism, but we'd decided not to do that
18:24:08 <tumbleweed> (there is risk of things not working if we do, and we'd rather catch those sooner)
18:24:45 <tumbleweed> So, should we set a new deadline? or just give the content team leeway to extend a few days?
18:24:54 <pollo> I'd day the later
18:24:56 <pollo> say
18:25:11 <paddatrapper> +1 to the latter
18:25:21 <terceiro> ok for me as well
18:25:22 <pollo> better have people with videos ready to upload and a broken upload system
18:25:31 <tumbleweed> how about: The video team will be happy if all of the videos are uploaded, reviewed, and encoded the day before they are to be presented?
18:25:56 <tumbleweed> and the rest is up to content and speaker assistance teams
18:25:58 <terceiro> I will not announce a new deadline iff sreview is fixed soon(TM), but will handle individual requests assuming there is some leaway
18:26:30 <tumbleweed> my assumption is that if people aren't ready before a deadline, they will just not bother, and go live
18:26:47 <tumbleweed> I always expected half of the speakers to push hard to go live :P
18:27:11 <terceiro> I'm still trying to be a good citizen, but ...:)
18:27:23 <tumbleweed> #agreed On extending deadlines: The video team will be happy if all of the videos are uploaded, reviewed, and encoded the day before they are to be presented? Content & assistance team have descresion to extend deadlines to speakers
18:27:37 <tumbleweed> give or take spelling mistakes
18:27:44 <terceiro> ack
18:27:58 <tumbleweed> and an errant ?
18:28:04 * nattie hands tumbleweed some discretion
18:28:18 <tumbleweed> #topic video-stack - playback
18:28:24 <tumbleweed> covered earlier, I think
18:28:42 <pollo> isn't that playback on the website?
18:29:08 <tumbleweed> no, I think this agenda item dates back to the dark ages
18:29:18 <paddatrapper> yeah
18:29:24 <tumbleweed> wouter is going to produce some metadata that I should also take advantage of in voctweb. I need to do that
18:29:52 <tumbleweed> #topic video-stack grabber
18:30:09 <tumbleweed> grabber-y stuff seems stalled atm (in the sense of nobody is poking at it, but it's good enoughâ„¢)
18:30:47 <tumbleweed> highvoltage's loop work has the potential to provide some of these needs (now/next, etc)
18:30:58 <tumbleweed> #topic video-stack - etherpad
18:31:14 <tumbleweed> All the auth plugins are old and suck
18:31:18 <highvoltage> tumbleweed: kk, I might need some explanation of that post-meeting
18:31:18 <tumbleweed> so I've been writing my own
18:31:23 <tumbleweed> almost done
18:31:30 <terceiro> ugh
18:31:38 <tumbleweed> nothing works, basically
18:31:43 <terceiro> I would suggest we just use pad.riseup.net but :)
18:31:45 <tumbleweed> this is JS. All the APIS change all the time
18:31:49 <paddatrapper> I haven't had a chance today to get ehterpad into ansible
18:31:55 <paddatrapper> Hopefully this weekend
18:31:57 <tumbleweed> the idea was to be able to have something we can moderate
18:32:02 <tumbleweed> and I think I'm there
18:32:06 <terceiro> ok
18:32:19 <tumbleweed> it can have salsa auth, that sets the initial usernames
18:32:21 <terceiro> but how will auth work when embedded in the website?
18:32:26 <tumbleweed> and we can restrict auth to groups if necessary
18:32:37 <tumbleweed> so, we can grant public read only access (busy hacking on that now)
18:32:43 <pollo> and the riseup pad has an annoying downtime period that happens in the EU morning for backups
18:33:09 <tumbleweed> well, we were looking at our own pad for auth (for moderation). No external pad can help there
18:33:21 <terceiro> do you think we need 1 pad per talk? GUADEC used 1 per track/day
18:33:22 <paddatrapper> public read-only kinda defeats the purpose of open questions though
18:33:29 <pollo> sure, I was just saying pad.riseup.net might not be the best fallback
18:33:45 <nattie> i think we're meant to be taking them via irc
18:33:49 <paddatrapper> terceiro: It is nice for archival afterwards
18:34:01 <pollo> and it's nice for people who have questions before the talk
18:34:13 <tumbleweed> so, what I'm imagining is embed public read-only versions in the site
18:34:37 <tumbleweed> with a "edit this pad" button that opens a new tab, where salsa auth happens
18:34:37 <DLange> make be take a look at CodiMD, it has auth and groups out of the box
18:34:41 <paddatrapper> a lot of the SotM feedback was that they liked the open pads as discusson could happen elaborating on a point between attendees
18:34:44 <DLange> much more modern code base
18:34:54 <tumbleweed> DLange: sorry, already sunk a few days into this
18:34:57 <tumbleweed> come back last week
18:35:03 <DLange> hehe
18:35:09 <DLange> will do in a parallel universe :)
18:35:26 <paddatrapper> in at least one universe we are using CodiMD
18:35:41 <highvoltage> tumbleweed's NIH tends to be better than other stuff anyway
18:36:07 <tumbleweed> from the docs, it looks great
18:36:16 <terceiro> tumbleweed: sounds very good
18:36:27 <paddatrapper> +1
18:36:50 <tumbleweed> actually, once the user is authed
18:36:58 <tumbleweed> they could probably use read-write embedded pads too
18:37:20 <tumbleweed> but.... anyway
18:37:34 <terceiro> is it possible at all to reuse the website auth? :)
18:38:17 <pollo> if you are embedding etherpad, note that Chrome 84+ (not in Debian) requires "Set-Cookie: SameSite=None; Secure"
18:38:20 <tumbleweed> sure
18:38:23 <terceiro> FWIW mu current state at the watch page is https://ibb.co/WFfx2Tf
18:38:34 <terceiro> WIP of course
18:39:00 <tumbleweed> terceiro: nice
18:39:06 <paddatrapper> looks good
18:40:01 <terceiro> the current yak being shaved is trying to make oftc webchat look less terrible
18:41:02 <terceiro> I will also need some waty to switch the pad when a new talk starts, if we are going for 1 pad per talk
18:41:20 <terceiro> suggestions welcome
18:42:14 <tumbleweed> yeah, means the view page will need to be watching the schedule
18:42:30 <tumbleweed> can think of some ways to do that
18:42:45 <tumbleweed> using website auth needs more thought too. It's doable, but different
18:42:57 <tumbleweed> let's move on
18:43:02 <tumbleweed> #topic video stack - streaming setup
18:43:05 <tumbleweed> nothing to really say here
18:43:12 <tumbleweed> except that CarlFK is documenting it :)
18:43:42 <tumbleweed> #topic advice/trainig for directors & talkmeisters
18:43:46 <tumbleweed> paddatrapper: you started some docs?
18:44:19 * paddatrapper grabs the link
18:44:43 <paddatrapper> https://storm.debian.net/shared/RzhOvZKXcMXDKC0PzCxY31gbO-5dpmocR-lK9PaeVAH
18:45:25 <tumbleweed> we're going to need to actually do some training at some point
18:45:58 <terceiro> and get volunteers
18:46:05 <tumbleweed> and that
18:46:08 <paddatrapper> yes and people will need to time to play around with it and get comfortable
18:46:09 <tumbleweed> although I hear some people have some
18:48:35 <tumbleweed> next weekend I guess
18:48:48 <tumbleweed> but now's a good time to start recruiting
18:48:52 <paddatrapper> probably a good bet
18:49:17 <tumbleweed> #agreed train with volunteers on the 22nd
18:49:19 <pollo> I added a point to the agenda for that
18:49:21 <terceiro> need a volunteer to get volunteers
18:49:39 <tumbleweed> yeah, I've been trying to get people to take that action :P
18:49:51 <tumbleweed> #topic advice/training for presenters
18:49:58 <tumbleweed> anything more to say here?
18:50:15 <paddatrapper> Have there been any questions from presenters (aside from upload issues)?
18:50:18 <tumbleweed> have we had any presenters test their setups yet?
18:50:50 <terceiro> not yet AFAICT
18:51:09 <terceiro> the first one who joined the # said he would be up for it
18:51:23 <terceiro> but I think we will have to initiate
18:51:39 <tumbleweed> nattie: I believe this is on you?
18:51:42 <nattie> yeah
18:51:57 <nattie> i guess we'll start doing test calls soon
18:52:10 <tumbleweed> please let us know how they go
18:52:14 <nattie> will do
18:52:16 <paddatrapper> Throughout the week?
18:52:32 <tumbleweed> nobody is really mucking with the jitsi instance, atm
18:52:35 <tumbleweed> so any time is good
18:53:37 <tumbleweed> #action speaker assistance team to start test calls
18:53:43 <tumbleweed> #topic call for volunteers
18:53:49 <tumbleweed> we need a volunteer wrangler
18:54:05 <nattie> i can do that at least partly
18:54:12 <nattie> if someone would like to join me
18:54:44 <tumbleweed> I can help, I just don't want to be *it*
18:54:49 <terceiro> I'm swamped so I won't get any more stuff to do
18:55:00 <tumbleweed> we need:
18:55:01 <paddatrapper> I can help from Monday
18:55:04 <tumbleweed> 1. a call for volunteers
18:55:13 <pollo> what's the work needed on the website ?
18:55:22 <pollo> do we have a module ready to be turned on?
18:55:26 * nattie is already in call-for writing mode, so can start on that
18:55:29 <tumbleweed> pollo: we need to define roles
18:55:32 <tumbleweed> 2. that
18:55:53 <tumbleweed> 3. somebody to run training
18:56:17 <tumbleweed> 4. somebody to coordinate during the conference (I guess shifts, due to timezones)
18:57:00 <paddatrapper> I'm happy to do 3 and help with 4
18:57:19 <pollo> for the roles, director, talkmeister?
18:57:33 <tumbleweed> #agreed nattie and tumbleweed to get a call for volunteers
18:57:49 <paddatrapper> pollo: https://salsa.debian.org/debconf-team/public/data/dc20-online/-/issues/8
18:58:09 <pollo> hmm
18:58:31 <tumbleweed> and maybe coordinator shifts? (not tied to individual talks)
18:58:57 <paddatrapper> yeah
18:59:48 <tumbleweed> somebody want to take the action to define these?
19:00:11 <pollo> I can try to work on that issue tonight
19:00:11 <paddatrapper> tumbleweed: define the shifts?
19:00:18 <paddatrapper> or the roles?
19:00:21 <tumbleweed> #agreed paddatrapper to run training sessions
19:00:35 <tumbleweed> #agreed pollo to define volunteer roles
19:00:38 <tumbleweed> paddatrapper: both :)
19:01:26 <tumbleweed> ad-hoc roles like coordinator are defined in `volunteer-tasks.yml` in the root of the site
19:01:41 <tumbleweed> the video tasks are defined in the DB, but if we get a final list on the ticket, we can make them so
19:02:02 <pollo> do we want a video-team member schedule?
19:02:18 <tumbleweed> pollo: expand on that?
19:02:24 <nattie> who's available when, you mean?
19:02:30 <pollo> well, we did say we wanted a video-team member available at all atime
19:02:37 <nattie> oh, the on call schedule
19:02:41 <paddatrapper> people for when SHTF
19:02:46 <pollo> yes
19:02:49 <tumbleweed> pollo: sounds good, yes
19:03:42 <tumbleweed> given the late date, I'd like to avoid separate roles for talks and bofs if possible
19:03:54 <pollo> +1
19:04:17 <tumbleweed> also, I think it's obvious that we need to support live talks
19:04:35 <tumbleweed> which ivodd was refusing to even discuss when we wrote those notes :P
19:04:53 <pollo> I'll take that in account
19:04:57 <paddatrapper> From our PoV a live talk is an extended Q&A
19:05:06 <tumbleweed> pretty much, yes
19:05:50 <tumbleweed> #agreed stick to the same video volunteer roles for every event, if possible, for simplicity
19:06:11 <tumbleweed> #agreed create a "video-team member on call" schedule
19:06:25 <tumbleweed> #topic blocked salsa issues
19:06:26 <tumbleweed> meh
19:06:39 <tumbleweed> #topic actions from last meeting
19:06:48 <tumbleweed> I didn't investigate jibri passwords, as discussed
19:06:51 <tumbleweed> second jibri is alive
19:07:05 <tumbleweed> terceiro has mockups of a video page
19:07:11 <tumbleweed> wouter generated upload URLs, but we need more
19:07:19 <tumbleweed> speakers were emailed
19:07:20 <paddatrapper> #action paddatraper to test if simultaneous jibri streaming is working
19:07:36 <tumbleweed> do I need to repeat that? (I never remember meetbot rules)
19:07:43 <nattie> may as well for good measure
19:07:45 <paddatrapper> tumbleweed:no
19:07:50 <paddatrapper> it should 'just work'
19:08:15 <tumbleweed> OK, and th ecarried over actions are mostly carried over
19:08:28 <tumbleweed> well, I guess normalization was done, wouter wanted to test
19:08:29 <paddatrapper> Jitsi is now 480p across the board
19:08:47 <tumbleweed> #topic any other business
19:08:51 <pollo> hmmm
19:09:11 <pollo> if we have live talks, have we tested if 480p is enough for a screen share?
19:09:35 <pollo> it was fine for faces, but I'm not so sure for text :)
19:09:36 <paddatrapper> We need a way of publishing Jitsi room and Q&A pad links to speakers and video team volunteers
19:09:44 <paddatrapper> pollo: good point. Not sure
19:09:49 <tumbleweed> pollo: I'm not too worried about that
19:10:09 <paddatrapper> well it will be important for the grabber
19:10:11 <tumbleweed> I mean, same rules as: make your slides readable from the back of the room, or over a low bandwidth streabm
19:10:15 <nattie> slides themselves should be available at some point anyway
19:10:20 <tumbleweed> nattie: definitely something to check when you test with speakers
19:10:20 <nattie> if people are really keen to see
19:10:26 <nattie> noted
19:10:32 <tumbleweed> get them to go thorugh their slide deck, as it is
19:10:39 <tumbleweed> and terminals etc
19:10:55 <CarlFK> "Show me a config file"  might be a good generic test  for random text
19:11:00 <pollo> paddatrapper: pad links can be put on each talk page
19:11:39 <tumbleweed> and IRC topics
19:11:45 <pollo> CarlFK: yes, please "cat /etc/shadow"
19:12:44 <terceiro> I still think it would be easier to have 1 pad per day :)
19:13:07 <tumbleweed> that's fine for questions, but not great for BoFs
19:13:15 <tumbleweed> unless the pad links to pads :P
19:14:27 <tumbleweed> #topic upcoming meetings
19:14:30 <tumbleweed> next week, I guess
19:14:37 <nattie> sure, got nothing better on
19:14:46 <paddatrapper> If we don't publish Jitsi rooms, people will start inventing their own
19:14:49 <paddatrapper> sure
19:14:50 <tumbleweed> nothing new to test-run nthis weekend
19:14:59 <CarlFK> is there support or concurrent talks?
19:15:12 <tumbleweed> #agreed meeting next week, as usual
19:15:14 <tumbleweed> #endmeeting