18:04:00 <tumbleweed> #startmeeting
18:04:00 <MeetBot> Meeting started Thu Aug  6 18:04:00 2020 UTC.  The chair is tumbleweed. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:00 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:04:05 <tumbleweed> OK, if nobody else will do it
18:04:21 <nattie> *snerk*
18:04:21 <tumbleweed> #link agenda http://deb.li/oNCD
18:04:24 <nattie> ECONTEXT
18:04:25 <tumbleweed> #topic roll call
18:04:30 <tumbleweed> \o
18:04:44 <nattie> yeah guess i'm here
18:04:48 <pollo> 0/
18:04:54 <pollo> MeetBot: pingall meeting!
18:04:54 <MeetBot> meeting!
18:04:54 <MeetBot> akhvar anupaannjoseph[m] CarlFK CarlFK[m] cate christoph daven_ DLange dustinm`` dwfreed esh_ fil foka FrdricLehobeyProxience[m] Ganneff ginggs gio gwolf hacksk[m] highvoltage indiebio ivodd jathan jcristau Jeffity jon_d jon_d___ jrtc27 kanashiro Kannan[m]
18:04:54 <MeetBot> KGB-0 KGB-1 KGB-2 larjona lenharo MadameZou marga mdrights[m] MeetBot mithro msantana mujeebcpy[m] nattie nattiemh[m] nicoo noahfx olasd p2-mate paddatrapper phls phls[m] pollo Q_ Ranjithsiji[m] RattusRattus seaLne[m] sgk[m] silver siqueira taffit taowa terceiro
18:04:54 <MeetBot> tobi tumbleweed tumblingweed tvincent tzafrir urbec valessio[m] valhalla videoteam wouter zigo zumbi
18:04:54 <MeetBot> meeting!
18:05:59 <tumbleweed> #topic Video Stack
18:06:05 <tumbleweed> #topic Video Stack - Jibri
18:06:14 <tumbleweed> So, jibri is running on the jitsi machine
18:06:21 <tumbleweed> but you were saying that we're going to have problems with new deployments
18:08:45 <tumbleweed> pollo?
18:08:52 <pollo> oh me?
18:08:59 <tumbleweed> I guess we should start testing this out with a new jitsi instance
18:09:03 <pollo> ahhh, yes
18:09:21 <pollo> hmm, maybe? I'm using the xmpp API to connect to prosody, but I don't think we are
18:09:32 <tumbleweed> OK, maybe we're fine then
18:09:35 <pollo> but if we have a working version, I think it would be good to note it down and stick to that
18:09:50 <tumbleweed> I haven't tested password protected rooms. I assume jibri doesn't support them yet?
18:09:55 <pollo> as I've complained previously, the jitsi packaging is prone to breakage.
18:10:16 * pollo has never touched jibri
18:10:40 <tumbleweed> no time like the present
18:10:42 * tumbleweed tests
18:11:27 <tumbleweed> doesn't seem to be starting
18:11:57 <wouter> o/
18:12:00 <wouter> sorry I'm late
18:12:11 <tumbleweed> #action tumbleweed to investigate jibri password protection options
18:12:23 <tumbleweed> without paddatrapper, let's move on
18:12:29 <pollo> worst case we can use randomly generated strings for roomnames
18:12:47 <tumbleweed> yeah, that's not the end of the world
18:12:49 <tumbleweed> #action tumbleweed to spin up a second jitsi
18:13:01 <tumbleweed> #topic Video Stack - Voctoweb
18:13:09 <tumbleweed> Still haven't got around to renaming
18:13:16 <tumbleweed> couldn't decide between voctovue and vogol
18:13:23 <nattie> we could have a poll!
18:13:43 <wouter> I think my vote would be clear :)
18:13:47 <tumbleweed> Search Results
18:13:47 <tumbleweed> Web results
18:13:54 <tumbleweed> gr @ paste
18:14:21 <tumbleweed> also, still no seeking. I must look at that, because I suspect it'll be non-trivial
18:14:52 <tumbleweed> However, I think we've got something quite useable and stable. From here on, it's basically defining the UX we want
18:15:23 <tumbleweed> #topic Video Stack - loop generation
18:15:33 <tumbleweed> highvoltage: any progress with OBS?
18:16:26 <highvoltage> tumbleweed: not any since the last meeting unfortunately. oh except that I trired out that external html thingy
18:16:29 <highvoltage> and it works
18:16:49 <tumbleweed> wouter: any progress on loop design?
18:17:14 <highvoltage> if I don't end up getting to that, is everyone fine with the usual sponsors loop as a backup?
18:17:21 <tumbleweed> of course
18:17:24 <highvoltage> having said that, I think I *will* have something ready for DebConf
18:17:32 <wouter> tumbleweed: haven't had time yet, and Tammy said she can't really do much with the logo we have
18:17:40 <tumbleweed> the usual sponsors loop is just fine. But I wouldn't be suprised if it gets replaced with something fancier during debconf
18:17:41 <highvoltage> it probably just won't covery 100% of the nice things I'd have hoped to get in
18:17:47 <wouter> I'll try to come up with something next weekend or so
18:18:02 <tumbleweed> wouter: should we reach out to the logo & shirt designers?
18:18:15 <wouter> can't hurt if someone has time
18:18:25 <wouter> my plate is pretty full around getting SReview changes in
18:18:36 <tumbleweed> anyone want to take the action?
18:18:49 <highvoltage> tumbleweed: also from what you said the VM gpu thing didn't work out, so for now I'm just going to plan to run it on a laptop at my place? I have reliable fibre and ups/generator.
18:19:03 <tumbleweed> highvoltage: no, it worked
18:19:21 <tumbleweed> but it couldn't run the thing olasd wanted to try
18:19:26 <highvoltage> ok, then I'll ask you to remind me of the login details after the meeting then
18:19:54 <tumbleweed> so, if he's abandoned that then we ne need to get OBS up on it again
18:20:20 <tumbleweed> highvoltage: OBS on your laptop isn't an option. You need 300mbps to voctomix
18:20:39 <tumbleweed> (or stream to something closer to voctomix that feeds into voctomix)
18:21:24 <highvoltage> sure if the hosted instance works then no problem
18:22:34 <tumbleweed> #topic Video Stack - SReview
18:22:43 <tumbleweed> wouter: I'll look at your MRs today
18:22:49 <tumbleweed> but I see you got it up
18:22:58 <wouter> tumbleweed: yeah, 99% there
18:23:20 <wouter> the gridengine refactor is still in need of minor fixups, but current workaround is "run ansible twice"
18:23:23 <wouter> which I think is fine
18:23:37 <wouter> there's some issue with UTF-8 which means the overview page is empty currently
18:23:54 <wouter> not sure whether it's a problem in my import script or in the wafer data, need to investigate that
18:24:06 <pollo> what does the UX to upload pre-recorded videos?
18:24:10 <wouter> has to do with some indian script that mojo doesn't like
18:24:27 <wouter> pollo: eh, clarify please?
18:24:59 <pollo> will speakers get unique URLs to upload their videos? Is it a page where you select your talk and then upload?
18:25:12 <wouter> pollo: yeah, they'll get unique URLs
18:25:26 <wouter> the URL will be the same as the review URL, except it'll be /i/ in front rather than /r/
18:25:39 <wouter> I haven't made an overview page for that or anything, but that should be fairly simple to make
18:25:43 <pollo> good, I was worried about attacks if the interface was open to everyone
18:26:12 <wouter> yeah, that's why I didn't make an overview page :)
18:26:17 <tumbleweed> #info sreview is 99% there
18:27:29 <wouter> haven't got any issues beyond that, so unless anyone has questions, we can move on?
18:27:39 <wouter> oh, right
18:27:51 <wouter> also still have to write a script to sync data between multiple SReview instances
18:28:12 <wouter> my hacky idea to make multiple recordings be cut together is to have the output from one SReview instance be the input of the other
18:28:25 <wouter> won't get anything else ready in time, and this would look reasonably OK
18:28:35 <pollo> huh, I guess that would work
18:29:01 <wouter> the upload form will then say something like "Deliver your files to DebConf20 prerecordings" or some such
18:29:15 <tumbleweed> #topic Video Stack - Playback
18:29:18 <tumbleweed> I guess this is already covered
18:29:39 <tumbleweed> #topic Video Stack - Grabber
18:29:52 <tumbleweed> Not a whole lot to say here, either
18:29:58 <tumbleweed> it exists
18:30:01 <pollo> haven,t had time to work on audio
18:30:05 <pollo> I don't think I will
18:30:13 <tumbleweed> I'm not convinced that we'll be relying on it
18:30:28 <tumbleweed> it'll be more of an emergency tool if we can't get something into the stream for some reason
18:30:33 <pollo> I think it would be a good backup option to have audio, but not critical
18:30:56 <tumbleweed> yeah
18:31:10 <tumbleweed> #topic Video Stack - Streaming
18:31:14 <tumbleweed> No news here either
18:31:29 <tumbleweed> We should probably start thinking abuot end-user UI
18:31:39 <wouter> tumbleweed: in what way?
18:31:46 <tumbleweed> i.e. the embed in the conference site, probably together with IRC. Maybe etherpads for BoFs?
18:31:51 <wouter> just going to be a plain video stream?
18:31:52 <wouter> oh, right
18:32:14 <pollo> tumbleweed: do you really think we'll get something with IRC embedded before the conf?
18:32:31 <tumbleweed> pollo: well, we usually embed the video
18:32:46 <tumbleweed> it's not like a whole lot more work to embed an IRC widget
18:32:59 <pollo> for that we can just reuse what we have on video.debconf.org no?
18:33:14 <wouter> yeah, we should probably look at exsisting chat widgets and plonk that on a video page or something
18:33:19 <tumbleweed> pollo: we usually have it on debconf20.debcon.org
18:33:25 <tumbleweed> the venue page shows the live video stream
18:33:30 <tumbleweed> and we link to that from the front page
18:33:34 <pollo> yes, but the code can be reused
18:33:39 <tumbleweed> yes
18:33:57 <tumbleweed> terceiro: put any thought into this yet?
18:34:09 <terceiro> hi
18:35:01 <terceiro> not really. am embedded IRC thing like in previous years should work I guess
18:35:17 <terceiro> for questions, in GUADEC they even used etherpad, and seemed to work ok
18:35:33 <wouter> did we have that? must've missed that.
18:35:45 <pollo> yeah, that's what we were planning to use
18:35:48 <pollo> that or gobby
18:35:56 <tumbleweed> did we do embedded IRC before? I can't recall it from recent years
18:35:56 <wouter> (but, yeah, cool if it's been done)
18:35:57 <terceiro> gobby is a PITA for non-insiders
18:36:13 <tumbleweed> but yes, embedding is trivial
18:36:13 <pollo> but we don't have a debian etherpad instance
18:36:26 <pollo> so we'd have to rely on some public instance
18:36:27 <highvoltage> storm.debian.net does etherpad
18:36:28 <wouter> is that hard to set up?
18:36:35 <wouter> (honest question, no clue at all)
18:36:39 <tumbleweed> Building a nice page that shows you video, IRC, and gobby, at reasonable sizes and layout is slightly less trivial. Needs somebody to put some time and thoguht into it
18:36:43 <terceiro> yeah I was going to mention storm.d.n
18:36:45 <pollo> wouter: prone to breakage from my experience
18:37:12 <tumbleweed> eh? been pretty solid in my experience
18:37:16 <wouter> would it make sense to ask for volunteers in the larger community?
18:37:17 <tumbleweed> just the sharing mechanism sort of sucks
18:37:28 <pollo> no, I meant etherpad, not storm
18:37:44 <pollo> is storm powerful enough to handle 100s of people on a pad?
18:37:57 <wouter> storm.d.n seems a bit slow, not sure about that
18:38:06 <wouter> (dunno whether that's storm in general or this instance)
18:38:10 <highvoltage> it has been a bit slow in my experience
18:38:24 <terceiro> slow for me as well, but only to load the first time
18:38:27 <highvoltage> paddatrapper is going to move it to a bigger instance soon
18:38:27 <terceiro> after that, just works
18:38:43 <highvoltage> (not sure if that will be before DebConf, I'm working on some nice server space asap for it)
18:38:49 <terceiro> I can try working on such page
18:38:56 <terceiro> since the harder part of content is almos done
18:39:23 <tumbleweed> #action terceiro to attempt a video streaming + irc & etherpad page
18:39:33 <highvoltage> looking at the date I thin it's likely that storm.debian.net will be on a bigger server before DebConf
18:39:48 <tumbleweed> I imagine we could temporarily host an etherpad lite or something like that for debconf
18:40:32 <terceiro> is there an existing repo I should work against?
18:40:35 <highvoltage> *nod*
18:40:52 <tumbleweed> terceiro: I imagine it'd be on the dc20 site
18:41:02 <terceiro> ack
18:41:03 <tumbleweed> and you can copy from dc19
18:41:24 <tumbleweed> although the stream redirect mechanism has changed a little, but I think it stayed API compatible. I'll check
18:41:48 <terceiro> well, on the site side I will only need an URL for the <video>, so I can test with something else
18:41:57 <terceiro> for now
18:42:04 <tumbleweed> we have a stream running
18:42:21 <tumbleweed> https://backend.live.debconf.org/redir/live/main.m3u8
18:42:43 <tumbleweed> err, did I screw tha tup
18:43:11 <tumbleweed> https://onsite.live.debconf.org/redir/live/main.m3u8
18:43:30 <tumbleweed> that's more like it
18:43:41 <terceiro> k
18:44:17 <wouter> terceiro: fyi, you'll need some js code to load that kind of stream, can't "just" do it on html5
18:44:37 <terceiro> wouter: ok I will copy from dc19
18:44:40 <wouter> (assuming you do know, but better safe than sorry)
18:44:47 <tumbleweed> https://salsa.debian.org/debconf-team/public/websites/dc19/-/blob/master/templates/wafer.schedule/venue.html
18:45:35 <tumbleweed> you can probably replace that mirror finding code, because the redir does a http redirect now
18:45:54 <tumbleweed> anyway
18:45:56 <tumbleweed> moving on
18:46:18 <tumbleweed> #topic advice training for directors / talkmeisters
18:46:30 <tumbleweed> Still not there, I think we need to dry-run this whole stack ourselves, first
18:46:54 <nattie> i'm always up for testing stuff
18:46:54 <tumbleweed> We've been postponing that
18:47:02 <tumbleweed> Should we try to do that this weekend?
18:47:10 <tumbleweed> I don't think there's anything critical missing
18:47:30 <wouter> sounds like a plan, though I'm not sure I'll be able to help out much
18:47:31 <nattie> sure
18:47:37 <pollo> I can spare a few hours to test yes
18:47:42 <highvoltage> +1, also a long weekend locally, which helps a big
18:47:58 <highvoltage> *bit (sorry fingers don't want to fing anymore)
18:48:01 <tumbleweed> ah, you have monday off
18:48:05 <wouter> oh right
18:48:05 <terceiro> I can help as well
18:48:09 <tumbleweed> Shall we around this time on Saturday?
18:48:09 <highvoltage> wouter me and paddatrapper!
18:48:25 <pollo> tumbleweed: I don't think it's a good idea to do it all at the same time?
18:48:31 <pollo> we only have 1 instance
18:48:33 <wouter> highvoltage: you're assuming I don't follow Belgian public holidays
18:48:44 <wouter> (it happens to be a fair assumption, but I do work for a Belgian company...)
18:48:46 <pollo> we'll be stepping on each other's feet
18:48:46 <highvoltage> wouter: true, but I'm assuming correctly
18:49:02 <wouter> yup :)
18:49:32 <highvoltage> it's ok we've all got big strong feet
18:49:38 <tumbleweed> pollo: I was thinking more of a mock event
18:49:47 <pollo> ah
18:49:47 <tumbleweed> but you should absolutely play on your own, too
18:49:50 <highvoltage> yeah a rehearsal of sorts
18:50:05 <nattie> ...did someone say "rehearsal"?!
18:50:09 <wouter> perhaps start with an upload?
18:50:13 <pollo> mi-mi-mi-miiii
18:50:41 <pollo> sat at the usual meeting time wfm
18:50:57 <wouter> that's a bit late, is 20:00 local time for me
18:51:08 <wouter> can't we do a bit earlier, or is that too difficult for you guys?
18:51:17 <nattie> some people have timezones
18:51:18 <pollo> that's ok with me too
18:51:23 <nattie> i can do earlier though
18:51:24 <tumbleweed> I can do up to about 5 hours earlier
18:51:38 <wouter> I'm mostly concerned about not losing too much of the afternoon, fwiw
18:51:39 <tumbleweed> s/5/4/
18:52:02 <wouter> so, let's say 14:30 UTC then?
18:52:13 <wouter> (don't want to push getting people out of bed too early either...)
18:53:10 <tumbleweed> WFM
18:53:15 <pollo> +1
18:53:34 <nattie> +1
18:53:39 <highvoltage> +
18:53:40 <tumbleweed> #agreed trial conference run on 2020-08-08 14:30 UTC
18:53:53 <wouter> now I have to make sure not to make a complete fool of myself and forget about it ;)
18:53:57 <tumbleweed> who will be the speaker? :)
18:54:07 <pollo> an old video?
18:54:08 <tumbleweed> I guess we should try a talk and a bof, at least
18:54:15 <pollo> we can share the jitsi room
18:54:17 <wouter> yeah, makes sense
18:54:22 * nattie will happily take part in the pseudo-bof
18:54:47 <tumbleweed> OK
18:55:05 <wouter> we might make that pseudo-bof another meeting, if we play our cards well ;-)
18:55:18 <wouter> s/well/right
18:55:29 <tumbleweed> :)
18:55:32 <tumbleweed> #topic Advice/training for Speakers
18:55:42 <wouter> probably after the trial run too?
18:55:58 <tumbleweed> nattie: You wanted to mail speakers
18:56:32 <tumbleweed> terceiro: you've already pointed them at the instructions IIRC
18:56:40 <tumbleweed> so the next step will be to give them upload URLs
18:56:52 <wouter> I'm going to focus on that now
18:56:56 <tumbleweed> wouter: can we generate these from wafer talk IDs? Or will you need to provide a mapping?
18:57:06 <terceiro> yes, they were pointed to the instrucitons
18:57:09 <wouter> I will have to provide a mapping, due to how they're done
18:57:12 <terceiro> we can always point them again just to be sure
18:57:20 <wouter> actually I can already run an SQL query now
18:57:22 <nattie> tumbleweed: i'm writing on the badger
18:57:36 <terceiro> I would like to point speakers wrt the schedule being up ASAP
18:57:43 <terceiro> s/point/ping/
18:57:54 <tumbleweed> so, we have a standard badger that tells people that their talk has been scheduled at X slot
18:58:14 <wouter> terceiro: I could give you the URLs right now, except that the import script seems broken and that might mean I have to start over
18:58:29 <wouter> to avoid any issues there, I'd like to fix that issue first before I give that to you
18:58:30 <terceiro> wouter: the upload URL ca be given later
18:58:38 <wouter> I'll try to get that sorted ASAP
18:58:55 <tumbleweed> OK, let's record some actions
18:59:00 <tumbleweed> #action wouter to generate upload URLs
18:59:09 <tumbleweed> #action nattie to write an email to speakers
18:59:32 <tumbleweed> #action terceiro to mail speakers pointing at the schedule (and upload URL, if available)
18:59:58 <tumbleweed> terceiro: https://salsa.debian.org/debconf-team/public/websites/wafer-debconf/-/blob/master/examples/badger_speakers_scheduled.py is the standard one I was thiking of
19:00:01 <tumbleweed> needs updating...
19:00:08 <terceiro> ok
19:00:18 <tumbleweed> IIRC the way we used that before was to run it daily
19:00:29 <tumbleweed> so people get notified about changes too
19:00:39 <paddatrapper> Damn, I forgot about the meeting again...
19:01:04 <nattie> well, we seem to be still going
19:01:05 <terceiro> ok, maybe I'll setup a cron job in debussy
19:01:10 <wouter> paddatrapper: no worries, you're not the first (aka, I know the feeling ;-) )
19:01:16 <tumbleweed> paddatrapper: should we go back to jibri?
19:01:50 <tumbleweed> wouter: if the schedule changed, wolud the upload URL change?
19:01:59 <tumbleweed> if so, maybe you should be providing an API rather than  dump
19:02:21 <wouter> tumbleweed: the upload script tries to retain the upload URL
19:02:33 <wouter> tumbleweed: if the wafer URL doesn't change, then neither will the upload URL
19:02:34 <tumbleweed> great
19:02:47 <wouter> but having said that, there *is* an API :-)
19:02:50 <tumbleweed> IIRC in the wafer URL, the ID at the beginning is stable
19:02:57 <tumbleweed> but the rest of it can change
19:03:10 <highvoltage> c c/win 73
19:03:26 <wouter> I'm not sure if it chops off the latter part, but it does use that
19:03:34 <wouter> highvoltage: leaving us already? ;-P
19:03:43 <tumbleweed> highvoltage: btw, on embedding IRC. It seems matrix can probably be embedded...
19:03:48 <wouter> (I'll check and fix if necessary)
19:03:59 <highvoltage> tumbleweed: so you're saying I should get a move on on the bridge :)
19:04:02 <nattie> there's also the OFTC web interface, no idea if that's embeddable though
19:04:07 <tumbleweed> highvoltage: I mean, if we had a bridge, it'd be an option
19:04:11 <tumbleweed> nattie: IIRC it's embeddable
19:04:33 <highvoltage> tumbleweed: I can spend a few minutes on it tonight. who knows maybe we're lucky and it turns out to be easy
19:05:08 <tumbleweed> #topic Blocked Salsa Issues
19:05:19 <tumbleweed> #link https://salsa.debian.org/debconf-team/public/data/dc20-online/-/issues
19:05:21 <wouter> are we actually using those?
19:05:34 <tumbleweed> doesn't seem like it :P
19:05:41 <tumbleweed> there is discussion of team roles happening in that issue
19:05:44 <wouter> heh :)
19:05:50 <tumbleweed> some of the rest are stale, though
19:06:02 <tumbleweed> so... moving on
19:06:05 <tumbleweed> #topic Carried over actions
19:06:15 <tumbleweed> wouter: you were going to look at normalizing audio?
19:06:26 <tumbleweed> paddatrapper: you were going to look at jitsi resolution switching
19:06:30 <wouter> the upload was supposed to do that, yes
19:06:41 <wouter> need to double-check whether it actually does :)
19:06:47 <wouter> fairly easy to add if it doesn't though
19:07:08 <wouter> it currently forces a resolution already on the uploaded video, so there's that
19:07:11 <tumbleweed> paddatrapper: you were going to start writing up the overall architecture
19:07:20 <tumbleweed> and I won't even bother repeating olasd's items - not here
19:07:23 <paddatrapper> tumbleweed: yeah, though I think the only way to do it is to have two instances
19:07:35 <tumbleweed> two instances certainly works
19:07:41 <tumbleweed> although probably confusing
19:07:58 <pollo> well, one can be bof.online.debconf.org
19:08:05 <pollo> and the other jitsi.online.debconf.org
19:08:20 <tumbleweed> we still don't know if we need this, of course
19:08:27 <paddatrapper> Notes started here: mainly SotM at the moment, but I'm adding DebConf stuff and splitting out for a MR https://storm.debian.net/shared/RHoWWYZ6f63XS8KW0vmEg24tiHQic3lx9_vKenoIyBn
19:09:13 <tumbleweed> the voip jitsi integration is more tricky if there are multiple instances. Currently not supported unless we had separate phone numbers
19:09:29 <tumbleweed> although we could do fancier switching from a single asterisk
19:10:13 <tumbleweed> and moving on
19:10:19 <tumbleweed> #topic Any Other Business
19:11:12 <tumbleweed> I'll take that as a no
19:11:16 <tumbleweed> #topic Upcoming Meetings
19:11:22 <tumbleweed> I guess Saturday
19:11:38 <tumbleweed> we should probably be running these like debconf BoFs... :P
19:11:46 <highvoltage> I'll be on irc as usual until then
19:12:08 <tumbleweed> next IRC meeting 2020-08-13 18:00 UTC?
19:12:16 <wouter> wfm
19:12:23 <pollo> +1
19:12:26 <tumbleweed> #agreed next IRC meeting 2020-08-13 18:00 UTC
19:12:31 <wouter> how many days until debconf by now?
19:12:44 <wouter> 22, do I see that right?
19:12:53 <tumbleweed> 17 from now
19:12:53 <nattie> bit fewer than that
19:12:56 <nattie> right
19:13:23 <wouter> time sure flies
19:13:29 <tumbleweed> with the recorded talk deadline in 10 days
19:13:56 <tumbleweed> #endmeeting