18:01:32 <ivodd> #startmeeting
18:01:32 <MeetBot> Meeting started Thu Jul 30 18:01:32 2020 UTC.  The chair is ivodd. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:32 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:36 <ivodd> #chair pollo
18:01:36 <MeetBot> Current chairs: ivodd pollo
18:01:39 <pollo> lol
18:01:39 <nattie> wow
18:01:46 <nattie> ivodd: no, you have to do it now
18:01:47 <ivodd> #topic who's here
18:01:49 <wouter> o/
18:01:51 <pollo> 0/
18:01:57 <tobi> \o
18:01:57 <nattie> i'm here!
18:02:11 <tumbleweed> \o
18:02:21 <ivodd> #topic video stack - jibri
18:02:34 <ivodd> there was quite some work on jibri, but I don't know the current status
18:03:27 <pollo> the MR is still a WIP, afaiu, paddatrapper needs to change a few things
18:03:33 <pollo> but 75% of the work is done?
18:03:37 <tumbleweed> the MR is 90% there
18:03:44 <tumbleweed> it's been all details recently
18:03:51 <ivodd> do we have a jibri running somewhere already?
18:04:01 <tumbleweed> it should be on the jitsi VM right now
18:04:08 <tumbleweed> I'd like to see us get one up on another machine
18:04:21 <ivodd> #info jibri is mostly running, the MR to get it into ansible is 90% there
18:04:34 <ivodd> tumbleweed: does it feed into vocto?
18:04:44 <ivodd> (I haven't checked voctoweb in the last few days)
18:04:53 <tumbleweed> ivodd: I haven't seen it do that, yet
18:05:01 <tumbleweed> but I know it's ansibled onto that box
18:05:37 <ivodd> anything else about jibri?
18:06:08 <ivodd> #topic video stack - voctoweb
18:06:26 <ivodd> tumbleweed continues to have fun with this :)
18:06:33 <wouter> that seems to be working now?
18:06:47 <highvoltage> as long as tumbleweed is having fun, it's good for everyone
18:06:52 <tumbleweed> it has been working since the beginning
18:07:00 <wouter> that goes for a great many things, actually, not just voctoweb
18:07:05 <tumbleweed> although I guess it was a bit crashiy while it was constantly poking at voctocore
18:07:42 <ivodd> tumbleweed: is there anything specific we need to get into (except playback, which is later on the agenda)?
18:08:12 <tumbleweed> so, it's probably approaching the point where it's useful to work out what controls we want to offer
18:08:17 <tumbleweed> and what automation we'd like
18:08:36 <pollo> tumbleweed: by controls you mean presets?
18:08:37 <tumbleweed> (I'm imagining it'd be nice to be able to queue up another video for after the current playback, or a switch to a different source, for example)
18:08:47 <ivodd> pollo: yes
18:08:56 <tumbleweed> yeah, what UI buttons, what should they do
18:09:05 <pollo> tumbleweed: I don't think queing is very important
18:09:06 <ivodd> I suggest we make an issue for that, to avoid spending an hour on that now
18:09:12 <pollo> +1
18:09:14 <ivodd> pollo: queing is very important :)
18:09:30 <wouter> ivodd: yeah, I would tend to agree
18:09:31 <tumbleweed> I don't think it's MVP critical - I think we could run the conference with it as is
18:09:38 <tumbleweed> but it's certainly nice to have
18:09:44 <tumbleweed> for crisp transitions
18:10:08 <tumbleweed> +1 to moving this discussion out into issues
18:10:08 <ivodd> tumbleweed: without 'easy' interface, I think it will be hard to train volunteers, but I think we agree on this and we can discuss this outside the meeting
18:10:15 <ivodd> #topic video stack - loop generation
18:10:44 <pollo> the idea being we'd like to be able to modify the sponsor loop live%
18:10:46 <tumbleweed> so, I've been meaning to play with things like https://stackoverflow.com/a/54065773/8629
18:10:47 <ivodd> there have been some suggestions to replace the 'static' loop with something more dynamic, but AFAIK, nothing has happened on this
18:10:51 <tumbleweed> but I can't do everything :P
18:11:07 <highvoltage> ivodd: I've been working on it
18:11:14 <ivodd> tumbleweed: did you get something like that working?
18:11:27 <tumbleweed> olasd was planning to look at casparcg
18:11:32 <highvoltage> ivodd: it's not finished yet. there's also some feature creep from following HOPE (they have some great ideas)
18:11:35 <tumbleweed> but I think he got stalled on GPU support in the VM
18:11:37 <pollo> highvoltage: with OBS?
18:11:41 <highvoltage> pollo: yes
18:11:45 <tumbleweed> ivodd: no, I haven't tried yet
18:12:20 <ivodd> highvoltage: what are you planning to use?
18:12:26 <highvoltage> ivodd: obs in a VM
18:12:37 <pollo> personal opinion, but I feel adding OBS on top of our already very heavy stack is too much if it's just for the loop
18:13:04 <tumbleweed> highvoltage: we have an OBS VM you can play on
18:13:09 <highvoltage> it doesn't complicate much, it can stream to jitsi so, it's just showing a jitsi stream really
18:13:21 <ivodd> my feeling is that worst case, we can use the 'static' loop, and if something better shows up, we can use it
18:13:23 <tumbleweed> pollo: it's easy enough to have the other loop fill in if the obs loop dies
18:13:41 <pollo> yes, but OBS can't really be automated, can it?
18:13:43 <ivodd> also, if it just runs by itself, volunteers don't need to know the detals (which is important)
18:13:51 <ivodd> pollo: it can (but that requires addons)
18:13:53 <pollo> someone will have to clikedy click that too
18:13:53 <highvoltage> well I know how to use OBS so it's more a case of setting up the scenes and sequences, that's going to be better to set up locally, export, and then add to the vm
18:14:12 <tumbleweed> sounds good
18:14:16 <ivodd> #info highvoltage is trying to set up something based on OBS
18:14:17 <highvoltage> ivodd: yes, of course, static loop is the good fallback option here
18:14:19 <tumbleweed> pollo: it can be automated
18:14:36 <ivodd> #info olasd is planning to look at casparcg
18:14:42 <highvoltage> and if it doesn't work out, we also have mdco#2 in november as another shot to try that out again
18:15:17 <ivodd> about the gstreamer stuff: I did some basic tests a few weeks ago, which worked locally, but as soon as you pipe it into vocto, I get issues with time
18:15:18 <highvoltage> ivodd: yeah that loop will run by itself until we want to change something, but volunteers wouldn't need to touch it
18:15:20 <ivodd> so I gave up on it
18:15:49 <ivodd> #info we can use the static loop, but if something nicers is ready in time, we can switch to that
18:16:11 <pollo> anyone volunteers for design?
18:16:22 <wouter> for the loop?
18:16:25 <pollo> yes
18:16:26 <wouter> I can look at it, or have Tammy do so
18:16:36 <wouter> I'll see if she's interested later
18:16:41 <highvoltage> I'll need a sponsors loop anyway so maybe that's a good place to start?
18:16:53 <pollo> wouter: imo the "easiest" way to produce the loop is to use the ffmpeg commands in our doc
18:16:56 <pollo> via a bunch of pngs
18:16:56 <wouter> we'll need sponsor logos if we're going to do that
18:17:20 <highvoltage> if only they were already scattered all over the website
18:17:22 <wouter> pollo: er, we need some animation software
18:17:23 <pollo> wouter: DLange did say the sponsors on the website were pretty final
18:17:26 <wouter> the rest is just output
18:17:33 <wouter> cool
18:17:45 <ivodd> anything more on this?
18:17:51 <pollo> sure, just saying the file format needs to be specific
18:17:57 <pollo> or else we can't loop it :)
18:18:04 <wouter> just saying it doesn't matter for me :)
18:18:04 <tumbleweed> right, but that can be fixed later
18:18:33 <DLange> beautiful loop <- +1 (and many +1 from fundraising team, I'm sure)
18:19:01 <DLange> (we get two more sponsors as it currently looks, should know within a week)
18:19:07 <wouter> #action wouter to look at generating sponsor loop design
18:19:13 <ivodd> #action wouter to look at generating sponsor loop design
18:19:24 <ivodd> #chair wouter
18:19:24 <MeetBot> Current chairs: ivodd pollo wouter
18:19:39 <wouter> ivodd: er, you don't need to be a chair to #action yourself, but thanks anyway ;)
18:19:50 <ivodd> wouter: oh - TIL
18:20:08 <ivodd> #topic video stack - sreview
18:20:09 <highvoltage> what colours should the sponsor loop background be? *ducks*
18:20:35 <wouter> so I did some work on that, and the basic infra to inject videos and transcode them to a particular profile is ready
18:20:44 <wouter> people can upload video recordings and slides etc
18:21:01 <wouter> these get stored on the SReview host (currently vittoria), and then transcoded to the profile
18:21:05 <wouter> we keep both the source and the transcode
18:21:20 <wouter> unfortunately, the current profile still crashes vocto, so I need to fiddle with it a bit more
18:21:25 <ivodd> #info sreview is ready, people can upload video recordings and slides etc
18:21:46 <wouter> but it would probably help if we could figure out *why* that broken video crashes vocto, excactly, so I can create the right profile that avoids that issue
18:22:00 <wouter> other than that, we're good
18:22:02 <tumbleweed> at least, with broken inputs it does
18:22:07 <wouter> well, yes
18:22:14 <nattie> highvoltage: same colour as the bike shed, obvs
18:22:15 <tumbleweed> there are presumably things that go through it and don't break vocto
18:22:36 <wouter> sure, but the whole point of this exercise was so that we come up with video files that don't break vocto
18:22:47 <wouter> if we go through this and it still happens, that's kindof missing the point :)
18:23:50 <wouter> anyway, if it's unlikely that this will happen with actual videos that people upload, I'm not bothered, but we don't know why vocto crashes, so I don't want to say that it's not going to be a problem
18:24:28 <ivodd> so to be safe we should feed all videos into vocto before we play them...
18:24:35 <wouter> maybe rather than try converting videos we should talk to vocto upstream instead and have the bug fixed? I'm starting to feel more & more that I'm doing things for no particularly good reason
18:24:41 <wouter> that too, I guess
18:25:01 <wouter> if there's a way to automatically test whether vocto would crash, I can run that script on the output of SReview, too
18:25:10 <wouter> (automatically)
18:25:44 <pollo> I still think it's a good idea to re-encode
18:25:48 <highvoltage> sorry that I'm a bit behind on what's going on, but what does that mean, would users upload their videos through some frontend to sreview and then after some processing it gets streamed from there during DebConf?
18:26:01 <pollo> we'll figure out why vocto crashes on that profile for sure
18:26:02 <wouter> well, I'm not going to throw away the work I just did :)
18:26:08 <ivodd> wouter: automatic tests seems like a good idea
18:26:21 <wouter> highvoltage: something along those lines, yes. I've modified SReview a bit so people can use it to upload recordings
18:26:41 <wouter> highvoltage: we then run it through ffmpeg using SReview's infrastructure for that, so that all our files are encoded the same way
18:27:07 <wouter> SReview just dumps the re-encoded files in a directory somewhere, we stream files in that directory to vocto during the conference
18:28:49 <ivodd> which brings us to...
18:28:55 <ivodd> #topic video stack - playback
18:29:10 <ivodd> playing files works from voctoweb (just tried it :)
18:29:10 <wouter> nice transition :)
18:29:30 <ivodd> obviously if the encoding issues can be solved, but we already talked about that
18:29:39 <wouter> yes
18:29:52 <ivodd> I don't know if we need to say a lot more about this
18:29:53 <ivodd> tumbleweed: ^
18:30:10 <tumbleweed> yeah, it seems to be working fine
18:30:17 <tumbleweed> obviously some big missing features, like seeking
18:30:35 <ivodd> #info basic playback in voctoweb works
18:30:41 <tumbleweed> and no real organisation of the files, yet
18:30:59 <tumbleweed> but that could be as simple as just copying the right files for the day into the directory at the start of the day
18:31:13 <ivodd> well, this is related to the point about voctoweb above, so I guess we can talk about that later
18:31:13 <pollo> if something happens in the middle of the video and we need to restart it in the middle, it's going to be hard without seeking :s
18:31:36 <ivodd> pollo: yes
18:31:54 <pollo> we can always use the grabber input + vlc as a hotfix
18:32:01 <pollo> but that machine would need access to the files
18:32:05 <ivodd> pollo: does that work with audio?
18:32:15 <pollo> ah
18:32:16 <ivodd> also, that makes thing very complicated for volunteers
18:32:23 <pollo> it could :)
18:32:30 <ivodd> anyway, another good transition:
18:32:36 <ivodd> #topic video stack - grabber
18:32:43 <pollo> you can grab the default pulseaudio with x11grab, but we aren't doing that atm
18:33:04 <pollo> we now have a grabber1.online.debconf.org machine
18:33:10 <pollo> accessible via vnc
18:33:23 <wouter> jitsi does grab audio from the video stream (and in fact mutes the microphone) if you switch to playing a youtube video
18:33:28 <wouter> so I think it should not be an issue
18:33:42 <tumbleweed> we'll have seeking, don't worry
18:34:01 <ivodd> the grabber is available as a source in voctoweb
18:34:16 <ivodd> so it can be used to show basically anything
18:34:36 <pollo> but as I said, currently it doesn't grab sound
18:34:39 <pollo> should I add that?
18:34:47 <wouter> sorry, what exactly is the grabber supposed to do?
18:34:52 <wouter> I think I'm missing something
18:34:59 <pollo> wouter: it's for questions on etherpad / gobby
18:35:12 <pollo> it's a voctomix source
18:35:30 <wouter> oh, we're not using jitsi for that anymore then? Or am I missing something?
18:35:40 <ivodd> wouter: it can potentially also used for things like a 'now/next' page (if someone makes one), or a note that the talk is delayed/cancelled
18:35:46 <wouter> oh, that bit
18:35:49 <wouter> okay, right
18:36:04 <pollo> wouter: we don't plan to have attendees log to jitsi to ask questions no
18:36:30 <ivodd> wouter: having a design for such a webpage would also be nice :)
18:36:33 <pollo> questions will go through pad / gobby and the talkmeister will as them
18:36:40 <wouter> ivodd: heh :)
18:36:53 <wouter> okay, clear. Thanks.
18:37:12 <ivodd> I think that's everything for the video stack
18:37:26 <ivodd> #topic streaming setup
18:37:34 <tumbleweed> no news here
18:37:40 <tumbleweed> it's ticking along happily
18:37:40 <ivodd> I don't think olasd is around, and everything was already working fine last week, so I suggest we move on
18:37:49 <ivodd> #topic Advice/training for directors (/talkmeisters)
18:38:04 <ivodd> as long as we don't have a working setup, I don't think we can do much here as well
18:38:18 <wouter> yeah, things might change too much still
18:38:28 <ivodd> #topic Advice/training for presenters
18:38:29 <wouter> although we could start an outline and general overview kind of thing?
18:38:54 <wouter> that was finished already, I thought?
18:39:01 <ivodd> advice was done
18:39:20 <pollo> highvoltage did say he wanted to add stuff ?
18:40:11 <highvoltage> pollo: yeah it's just a few stuff I'll merge back to videoteam docs no big deal
18:40:17 <ivodd> ok, moving on
18:40:27 <ivodd> #topic Blocked salsa issues
18:40:36 <ivodd> I think all of them have been discussed already, so moving on
18:40:43 <ivodd> #topic Actions from last meeting
18:40:45 <wouter> still have my gridengine MR
18:40:53 <wouter> but that is not my highest priority
18:41:22 <wouter> (as in, working on it, but prioritizing SReview)
18:42:12 <ivodd> wouter: anything we need to discuss about that right now?
18:42:20 <wouter> three action items fro olasd (who's not here), and two for tumbleweed
18:42:28 <wouter> ivodd: nope, just wanted to mention it so it ends up in the notes
18:42:34 <ivodd> wouter: ok, good :)
18:42:51 <ivodd> the action items for the people who are around are all discussed already, I'll copy the others to the agenda for next time
18:42:59 <ivodd> #topic any other business
18:42:59 <wouter> yeah, was about to say the same :)
18:43:03 <ivodd> anyone?
18:43:21 <pollo> do we have a schedule for when we want things to work?
18:43:32 <wouter> not that I know of, but good idea
18:43:43 <ivodd> pollo: I was going to ask under 'test runs', but we can talk about it now
18:43:53 <ivodd> at least it would be good to have a semi-working setup
18:44:00 <ivodd> so that means feeding jibri into vocto
18:44:26 <pollo> feels like we should be able to test things soonish
18:44:30 <ivodd> if we have that, we have all the sources in vocto, and can try a pre-run
18:45:04 <ivodd> does anyone have a suggestion for a timeline?
18:45:35 <wouter> "be ready two days before debconf starts?"
18:45:36 <pollo> what do we mean exactly by "test run"
18:46:09 <wouter> (which means work our way back from then, figure out how much time everything needs (broadly) and set deadlines based on that)
18:46:30 <ivodd> pollo: ideally, it would be doing a test with volunteers to see if everything works
18:46:50 <pollo> volunteers not being use core members who hacked on the system
18:46:52 <wouter> pollo: I think we have people (preferably people who did not write the code in question) go through the motions of uploading, playing, etc stuff?
18:46:56 <pollo> s/use/us/
18:47:05 <ivodd> pollo: yes
18:47:18 <ivodd> so a pre-test run would be a test by us (who know details of the setup)
18:47:23 <wouter> maybe we can ask urbec to do these things?
18:47:28 <pollo> then we'll need 1 week to make a call for volunteers?
18:47:50 <ivodd> I think if we ask, we'll get some people quickly, but the issue is that we aren't ready for that yet
18:47:54 <wouter> actually, no, she might know too much for that to be a useful test
18:48:16 <wouter> is that true though?
18:48:23 <wouter> voctoweb is mostly there
18:48:27 <wouter> SReview is mostly there
18:48:35 <ivodd> we don't have a jitsi feed into vocto yet
18:48:45 <ivodd> we're probably close
18:48:49 <wouter> is that a lot of work to finish?
18:49:00 <wouter> I think if we ask volunteers now, that gives us a bit of a deadline, which might help
18:49:01 <pollo> if paddatrapper can land the jibri MR, we can pre-test this weekend
18:49:13 <pollo> and have volunteers test next week
18:49:21 <wouter> right, that's what I was thinking
18:49:32 <ivodd> I think that's a good idea too
18:49:33 <wouter> and then we can ask for volunteers once the jibri MR lands
18:49:55 <ivodd> I think we had a number of people who said the were happy to help testing a month ago
18:50:15 <ivodd> so I'll add the info later (under the right topic)
18:50:21 <ivodd> any other 'other business'?
18:50:26 <wouter> good to know -- we should probably ask them then
18:50:40 <wouter> maybe we should #agree something first?
18:50:58 <highvoltage> #agree the jitsi bridge should be blue
18:51:02 <tumbleweed> sorry, been on the phone to family
18:51:19 <wouter> #agreed ask for volunteers to test things after jibri MR lands (hopefully this weekend)
18:51:48 <wouter> does that make sense?
18:51:55 <pollo> +1
18:52:16 <ivodd> ok
18:52:25 <ivodd> #topic upcoming meetings - next irc meeting
18:52:37 <wouter> same time same place next week?
18:52:38 <ivodd> next Thursday I guess
18:52:46 <wouter> we seem to have a good rhythm going, would like to keep it
18:52:51 <ivodd> ok
18:53:01 <ivodd> #topic upcoming meetings - pre-test runs by video team
18:53:01 <wouter> (even if thursdays are not ideal for me)
18:53:24 <ivodd> #agreed pre-test run by video team this weekend
18:53:27 <ivodd> (see above)
18:53:43 <ivodd> #topic upcoming meetings - test runs with volunteers
18:53:56 <ivodd> #info hopefully the weekend after next
18:54:11 <wouter> also see above :)
18:54:16 <ivodd> right :)
18:54:19 <ivodd> anything else?
18:54:35 <ivodd> #endmeeting