20:00:54 <marga> #startmeeting
20:00:54 <MeetBot> Meeting started Mon Jan  5 20:00:54 2015 UTC.  The chair is marga. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:54 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:00:57 <RichiH> .
20:01:08 <marga> #topic Roll call
20:01:18 * madduck 
20:01:20 <marga> As usual, please say hello to know who's around
20:01:20 <bremner> here.
20:01:23 <nattie> hola
20:01:29 <Aakash> hello
20:01:34 <cate> ciao
20:01:35 <rmayorga> I'm lurking around
20:01:47 * highvoltage lurking too
20:01:47 <tumbleweed> hi
20:01:54 <hvhaugwitz> Hallo
20:01:57 <_rene_> hallo
20:02:02 <jathan> Hallo
20:02:18 <marga> #topic Next steps for DC15
20:02:24 <marga> We've been kind of inactive in the past meetings and now need to shake the drowsiness away, we have 8 months till the beginning of the conference and lots of things still need to get done.
20:02:25 <and1bm> Hello!
20:02:32 <marga> I've JUST started a wiki page for this, but it's pretty empty so please let's try to think of what needs to get done and add it there, with an owner.
20:02:42 <marga> https://wiki.debconf.org/wiki/DebConf15/TODOs
20:03:45 <RichiH> marga: timelined todo is a good idea
20:03:51 <marga> Since everyone editing at the same time is probably not going to work, if you have suggestions please state them here
20:04:03 <marga> RichiH, yeah, although some TODOs are harder to timeline than others
20:04:16 <marga> But I think we need a timeline now, to be able to prioritiz
20:04:31 <tassia> hi all
20:05:34 <marga> For example, we need to figure out childcare, but I'm not sure where that fits
20:05:53 <nattie> hi tassia
20:06:48 <tassia> marga, are you talking about whcich team should handle childcare?
20:06:59 <RichiH> i think she was referring to what needs to be done when
20:07:04 <marga> Right
20:07:13 <tassia> it was part of participant assistance
20:07:14 <RichiH> what /me still does not know is if there's consensus on _what_ child care is, really
20:07:44 <nattie> i guess childcare is one of mine
20:07:57 <tassia> right
20:08:06 <marga> tassia, sure, but it has a very strong component of local people as we need to figure out what the possibilities are both regarding legal and money constraints
20:08:06 <RichiH> nattie: loni can/wants to help in that regard as well
20:08:15 <nattie> or rather, under my umbrella - it will be mostly-autonomous, with me just trying to keep track of what's going on
20:08:23 * marga nods
20:08:28 <nattie> RichiH: *nods*
20:08:50 <RichiH> nattie: the main question as i see it is "paid professionals" vs "volunteer" and the whole insurance and "what happens if one child has fewer arms than before" thing
20:08:57 <edrz> .
20:09:11 <tassia> RichiH, ;-)
20:09:30 <nattie> RichiH: shall i talk to loni sometime soon, perhaps?
20:09:44 <tassia> the legal constraint comes first I think
20:09:51 <nattie> absolutely
20:10:03 <RichiH> nattie: see /query
20:10:12 <nattie> *someone* has been meaning to write a minors policy for about 3 years, which ties in with the childcare thing, i guess
20:10:15 <RichiH> also, we will be at fosdem
20:10:18 <RichiH> just fyi
20:10:37 <tassia> how is childcare at fosdem?
20:10:52 <RichiH> none
20:11:07 <madduck> i think we could seriously consider making it a debconf standard
20:11:10 <RichiH> you take care of your own
20:11:12 <RichiH> madduck: agreed
20:11:15 <madduck> of course i say this out of own interest too, but I am not alone
20:11:18 <nattie> there's a partners' programme, but no kids' programme
20:11:20 <RichiH> we are all aging
20:11:41 <bremner> there is a partner's programme?
20:11:44 <RichiH> yes
20:11:47 <marga> bremner, FOSDEM
20:11:48 <nattie> bremner: at fosdem, yes
20:11:51 <bremner> oh, sorry.
20:11:52 <RichiH> spouse tour, at fosdem
20:12:04 <marga> we are going a bit off-topic
20:12:05 <nattie> at debconf, partners are expected to bloody well take part ;)
20:12:06 <madduck> anyway, this is probably stuff for another meeting another time
20:12:07 <n0rman_> spuse tour? really? funny...
20:12:18 <n0rman_> :)
20:12:18 <tassia> funny
20:12:21 <marga> I've added childcare as an item without a date, as I don't know where it should be
20:12:26 <madduck> nattie: could you and loni sync up, also formorer was interested
20:12:31 <madduck> and propose a plan
20:12:32 <nattie> madduck: sure
20:12:37 <madduck> I stand by for budget questions
20:12:46 <marga> What other things do we need to add?
20:13:02 <madduck> there'll be a lot more added as we get closer
20:13:04 <marga> I'm sure there are plenty, so let's try to think them up and get owners for each
20:13:12 <madduck> but for now, I think you have the big things for the first quarter
20:13:17 <madduck> apart from fundraising ;)
20:13:33 <marga> But that one is always ongoing...
20:13:35 <_rene_> venue - getting to (more important near the sponsorhip stuff to make travel plans etc)
20:13:56 <madduck> marga: sending out "welcome PDFs", which is maybe a newish idea, but would be really useful this year
20:14:08 * _rene_ can do that (and actually already has - bad, though - photos for hbf -> jugendherberge)
20:14:14 <madduck> explaining how to get to the venue, what to do there, what has to be paid and how
20:14:29 <madduck> _rene_: deadline july?
20:14:30 <nattie> so the sort of thing that would normally be in the welcome bag, but as a pdf in advance?
20:14:46 <_rene_> nattie: well, getting to the venue in the welcome bag is too late ;)
20:14:53 <madduck> nattie: yeah, with personalised information, possibly a QR code from the hostel
20:15:05 <madduck> and statements about how much to pay so people remember to possibly go by a money machine
20:15:06 <MeanderingCode> hello
20:15:09 <nattie> _rene_: getting to the venue in the welcome bag is also a matter of size!
20:15:20 <madduck> nattie: oh, MeanderingCode is also very interested in childcard. GET HIM! ;)
20:15:31 <MeanderingCode> already /query'd :)
20:15:50 <nattie> :)
20:15:58 <_rene_> madduck: sounds plenty of time to finish it, yeah, but I would probably aim for it earlier
20:16:36 <marga> Well, it needs to be sent out in July, I think
20:16:45 <marga> But it can start getting prepared earlier
20:17:40 <marga> I've marked it as starting the work in May and sending it out in July
20:17:51 <marga> _rene_, are you owning that?
20:18:11 <_rene_> jup
20:18:36 <madduck> there is also https://github.com/PyCon/2015/wiki/PyCon-2015-Checklist which we could cross-check, without losing ourselves in details btw
20:19:14 <marga> oh wow
20:19:37 <marga> it's kinda long and very thorough
20:19:51 <madduck> yeah, great resource
20:20:03 <madduck> but one where you can lose a lot of time ;)
20:20:19 <madduck> that should be our long-term goal though, to have something like that.
20:21:47 <marga> Ok, if anybody else wants to add more tasks, please do so. I'll keep working on this list
20:22:15 <marga> #topic Dates for Call for papers and Opening of Registration
20:22:23 <marga> This is the big thing that is coming up
20:22:37 <marga> Our intention had been to do the CfP in January and open registration at the same time
20:22:57 <marga> It looks, though, like summit is probably not going to be ready to do both at the same time.
20:23:03 <marga> We can:
20:23:11 <RichiH> just to make sure: we are still planning to have staged CfP and bursary decisions, correct?
20:23:22 <marga> 1 - Wait until summit is ready for the CfP (Feb, maybe)
20:23:29 <madduck> not staged cfp, but maybe staged acceptance.
20:23:31 <madduck> RichiH: ^
20:23:35 <marga> 2 - Make a CfP where people just send the proposals to content@
20:23:56 <madduck> 3 - fix summit ASAP ;)
20:24:01 <RichiH> madduck: i am painfully aware; i now have proper internets again
20:24:04 <marga> RichiH, what do you mean by staged?
20:24:13 <RichiH> marga: have several rounds
20:24:20 <rmayorga> as part of content@, I'll choose option 1
20:24:22 <marga> I think that for CfP, yes
20:24:49 <marga> For attendees registering, I think only one round and for handing out money maybe two rounds (i.e. some people might be waitlisted in the first round)
20:24:54 <madduck> of course we'll renew the CfP (other conferences "extend the deadline") to get back into the newsstream
20:25:19 <RichiH> vorlon: you said you should have time in early 2015, is that the case?
20:25:22 <jathan> I was thinking in the talks
20:25:37 <madduck> the "staged" idea I think was about accepting a few talks (e.g. 30%) early, accepting the bulk (50%) in June/July, and saving the rest for short-term decisions.
20:25:52 <jathan> about the time for send purposes
20:26:00 <madduck> so let's not confuse cfp with talk acceptance.
20:26:00 <marga> Yeah, that sounds sensible and about what we had discussed
20:26:09 <jathan> ok
20:26:51 <madduck> marga: but this is content team domain, really. Given that we have RichiH here right now, I think we need to consider a third option for Summit and I think it could be done
20:27:21 <marga> I know it's content team, but I want to know what is the general feeling of what would be better
20:27:44 <marga> madduck, what would be the third option?
20:27:45 <n0rman_> madduck: RichiH and rmayorga
20:27:53 <madduck> and the third option is to get it up and running ASAP and start accepting events without requiring registration, allowing events to be associated later
20:28:00 <madduck> or creating accounts as they are submitted.
20:28:02 <RichiH> n0rman_: ?
20:29:12 <jathan> In Content Team we have been doing some tasks related to write some guidelines about inviting speakers
20:29:52 <jathan> Debconf Schedule scheme for the week
20:30:00 <tassia> regarding the staged idea, I remember there were concerns about that
20:30:11 <tassia> but I can't remember the details right now
20:30:45 <marga> That's fine, we are just talking about the opening of cfp and registration, not the closing right now.
20:31:08 <jathan> Tassia: I can send you the email with all the initial tasks details if you want.
20:31:18 <marga> RichiH, when do you think would be the earliest possible to have summit ready to receive registrations?
20:31:22 <n0rman_> is there a problem on how is talking team working previously_? is it realy neccessary to change times?
20:31:27 <Tincho> sorry, I was away in another meeting
20:31:44 <madduck> cate, edrz: do you know if what I am proposing is easy to do? Accept submissions without requiring logins?
20:31:47 <jathan> Because for the moment they are not in the wiki of Content Team
20:31:48 <n0rman_> talks*
20:31:48 <marga> n0rman_, your question is unclear.
20:31:51 <madduck> or auto-creating accounts that can later be merged?
20:31:52 <tassia> jathan, thanks! but I also got that email ;-)
20:31:56 <madduck> i.e. within the next two weeks?
20:31:57 <jathan> ok
20:32:20 <Tincho> madduck: what would be the benefit of submitting events without an account?
20:32:23 <n0rman_> madduck: sorry, I mean, with CfP procedure previously, creating events only for people registered in summit
20:32:28 <RichiH> marga: late january is the earliest i see as realistic
20:32:42 <rmayorga> for CfP, as I said it is better if we have summit ready
20:32:45 <madduck> Tincho: make it easier for people; get started earlier.
20:32:50 <marga> n0rman_, the problem is that summit is not ready
20:33:07 <n0rman_> marga: so summit needs to be ready
20:33:08 <cate> madduck: people need to edit own submission, but if it is ok to have it public and editable for all, I don't think there is a problem
20:33:08 <Tincho> madduck: I just find it weird to submit an event without an account...
20:33:13 <Tincho> seems like a lot of fuss
20:33:21 <marga> Personally, I think that waiting for it to be ready, if it's ready in February, is better
20:33:24 <cate> django, not summit, but I think it is ok, because we don't link users
20:33:38 <marga> But we can't postpone it more than that if we want to close sponsored reg. in March 31st
20:33:53 <n0rman_> normally CfP is in april/may, isn't? looks like there is time to have summit ready
20:34:09 <madduck> cate: so ack the submission with a link allowing one to set a password to the account that was created in postgresql
20:34:28 <marga> Postponing the deadline for sponsored registration makes it harder for people that need the sponsoring to plan ahead and buy cheaper tickets, as has been discussed several times
20:34:29 <n0rman_> cate: public and editable for all? so we can use wiki.debconf.org to make our schedule :)
20:34:37 <bremner> the road to hell is paved with ad-hoc webdev
20:34:49 <madduck> cfp in feb is also fine IMHO, it does not have to be Jan, but I think we need to start working on it ASAP
20:35:14 <rmayorga> madduck: working on it is just to draft the emails and so on
20:35:15 <madduck> bremner: "… hell is … webdev"
20:35:16 <cate> n0rman_: it is more difficult to enforce structure, rating, and importing things in db later
20:35:23 <marga> Can we aim to do CFP & opening of registration on Feb 1st, and do our best to make it?
20:35:25 <rmayorga> most of the jobs is done by the speakers
20:35:27 <n0rman_> cate: was a joke , sorry
20:35:37 <rmayorga> when summit is ready
20:35:39 <n0rman_> who is summit-devs?
20:35:53 <n0rman_> can they confirm if summit will be ready?
20:35:53 <Tincho> I am not seeing clearly what are we trying to achieve here
20:36:03 <madduck> RichiH: when can we count on there being a dc15-ready summit instance?
20:36:21 <marga> Tincho, figure out what we want to do regarding these 2 topics that are closely related and are currently the most urgent
20:36:59 <RichiH> madduck: "count on" implies being sure, so that only moves the date backwards
20:36:59 <cate> it was one of my tasks for this holidays. I finished the django docs, but than flu blocked me to start summit hacking
20:37:00 <Tincho> cfp does not seem to be too urgent, is it?
20:37:25 <n0rman_> IMHO, what we need first is to confirm summit is ready for events/users
20:37:34 <cate> [the feasibility, and what to change, not to put all summit ready]
20:37:56 <madduck> Tincho: we are trying to work towards http://lists.debconf.org/lurker/message/20141204.100511.e4bada48.en.html
20:38:03 <marga> Tincho, not for old-timers that already know how DC works but for new speakers it generally helps to plan early and get their talks accepted
20:38:55 <madduck> Tincho: and it also helps a lot of people to know at least a little bit about what debconf will offer when they are ready to convince their bosses/families before registering.
20:39:37 <Tincho> marga, madduck: I think the thing to do here then is to agree with content on that, and asking them to make it happen
20:39:46 <madduck> it's also how most every other conference does it: create a programme and then invite people to register (and pay). We don't require people to pay, so we don't have to wave carrots as much, but it still makes sense.
20:40:10 <madduck> Tincho: discussions with content team are ongoing. We are now talking about the technical side of things.
20:40:21 <madduck> i.e. summit, with RichiH as lead of the infra team
20:40:38 <madduck> because it's the next step no matter when we publish a cfp or open registrations.
20:40:46 <Tincho> aye
20:41:30 <bremner> well, RichiH already said late January at the earliest, I think. So asked and answered?
20:41:36 <marga> RichiH, so, do you think it's sensible to aim at setting Feb 1st as the date for having summit ready for registration+cfp?
20:41:47 <marga> bremner, he said it was a stretch
20:41:55 <bremner> "at the earliest"
20:41:58 <marga> I'd rather agree on something sensible than set a not-feasible goal
20:42:51 <Tincho> one thing I would like to see is that content (and assistance) get the responsibility for sending the cfp, and opening registration, and that they see that it happens in time
20:42:55 <RichiH> i think we should be done "within" february; but i am not as far as i wanted to be with getting people on board
20:43:11 <RichiH> that's largely due to /me falling off the internets for some time
20:43:27 <marga> RichiH, do you mean within january hopefully?
20:43:34 <RichiH> on the plus side, i also have one external guy who speaks django who may be interested
20:44:00 <marga> Tincho, of course, the CFP is going to be sent by content.
20:44:37 <madduck> Tincho: we'll gladly hand over to content and assistance as soon as they are ready to take over; for the moment, this is critical stuff to dc15 and so we are trying to nudge things rather than waiting longer. Hope that's okay.
20:44:43 <RichiH> marga: if asked for something _confirmed_, i am basically just adding time at the end - i suspect it will be done more quickly
20:45:26 <Tincho> marga: what I mean is that once a date is agreed, I would like to see *them* asking infra for the needed tools. I am not saying this will happen overnight, but we should try to get to that kind of dynamic, imho
20:45:29 <madduck> RichiH: agile development. start by getting a Git repo and a working django with some responsive people able to control it by next week! ;)
20:46:12 <RichiH> madduck: i know the basics, yah ;)
20:46:39 <marga> RichiH, ok, I'm hoping I'm understanding you correctly and that aiming to Feb 1st makes sense
20:46:50 <madduck> RichiH: sorry; but then let's agree on that… a basic, non-public summit for dc15 up and running and ready to be hacked on by the next meeting?
20:47:25 <RichiH> as we are on bi-weekly, that's very realistic
20:47:31 <marga> #agreed We need to get summit ready to start registrations + talk submissions by Feb 1st.
20:47:35 <Tincho> madduck: yes, I understand that.
20:47:50 <marga> #action RichiH will work on getting an internal version ready by January 19th
20:48:06 <n0rman_> sorry to ask this, will we use another summit instance, different from dc14?
20:48:17 <Tincho> marga: can we also #agree to ask content and assistance to commit for dates and hand over responsibility?
20:48:28 <rmayorga> it suppose to have multi-conferecnce support n0rman_
20:48:56 <Tincho> rmayorga: ohai, I did not notice you were there :)
20:49:10 <rmayorga> Tincho: :)
20:49:24 <madduck> n0rman_: ideally multi-conference, i.e. one instance for the future
20:49:25 <marga> Tincho, he was and we were taking his "content team" feedback into account
20:49:39 <madduck> but it's not entirely certain whether this is a good idea regarding schema changes
20:49:50 <tumbleweed> archiving off old conferences is probably ideal
20:49:51 <madduck> otoh there is apparently a tool to archive django sites into static sites
20:49:56 <cate> the sytem is multiconference. schedule_summit table define the conference
20:50:02 <RichiH> madduck: "wget"
20:50:03 <RichiH> ;)
20:50:06 <madduck> try it!
20:50:09 <marga> #agreed We need to confirm with content and assistance team that they agree with this dates and then make it happen.
20:50:10 <RichiH> but yah, i know there is a tool
20:50:33 <madduck> so then multiconference, but archiving every year and pointing dcX.dc.o to that archive once the conf is over
20:51:09 <Tincho> so, next topic?
20:51:21 <madduck> n0rman_: for dc15, *maybe* it's best to reuse dc14 summit, but maybe it's best to start a new one and archive dc14
20:51:21 <marga> It's not like there's an agenda...
20:51:39 <cate> note: summit != dcX websites
20:51:48 <marga> What's the next most urgent thing that we need to work on?
20:51:53 <madduck> cate: unfortunately, yes.
20:52:05 <madduck> Tincho: marga led this meeting mostly with https://wiki.debconf.org/wiki/DebConf15/TODOs and we've been going off on tangents since the start.
20:52:25 <madduck> marga: summit. budget. fundraising.
20:52:44 <madduck> cate: https://wiki.debconf.org/wiki/Summit/WebsiteIntegration
20:52:45 <Tincho> madduck: I missed that link, thanks
20:52:47 <marga> Anything to discuss about budget or fundraising?
20:53:01 <madduck> i set myself up for that, didn't I? ;)
20:53:09 <Tincho> madduck: I would try to get these items distributed to the relevant teams
20:53:14 <n0rman_> madduck: when it was decide to use summit, I thought was thinking to become summit a multi-conference system :/ and not just archive
20:53:18 <n0rman_> I mean, like penta
20:53:21 <madduck> Tincho: yes, marga is doing that.
20:53:32 <marga> Tincho, I was first trying to create the timeline, then looking for owners within the teams
20:53:44 <madduck> n0rman_: the problem is a bit that if the schema changes, then what does it mean to old sites?
20:54:02 <Tincho> marga: cool
20:54:13 <n0rman_> madduck: penta didn't have that problem, right?
20:54:22 <madduck> marga: I'll work on budget and aim to get the budget approved by Feb 28; anyone who wants to seriously help should let me know and is welcome
20:54:39 <marga> n0rman_, it did, by the end it was a very ugly mess of different options colliding with each other
20:54:46 <madduck> n0rman_: all database-apps have this problem, it's just a question of how youj solve this.
20:55:15 <madduck> the big question is: do we need dc14@summit ever again, or wouldn't it be much more sensible to have a "hard-copy" i.e. archive
20:55:23 <madduck> the data are still in the database
20:55:30 <madduck> but the website is no longer generated dynamically
20:55:31 <n0rman_> madduck: and where are you planning to archive?
20:55:38 <madduck> n0rman_: dcX.dc.o
20:55:39 <Tincho> let's move that discussion to infra, no point in having us all on that
20:55:47 <madduck> Tincho++
20:55:50 <marga> Yeah, I agree.
20:55:56 <madduck> but this is sort of an all-purpose meeting today, Tincho.
20:56:01 <n0rman_> madduck: as cate said, dcX.dc.o != summit
20:56:02 <marga> We are basically out of time by now.
20:56:02 <madduck> to get us started. but you are right.
20:56:09 <madduck> n0rman_: and maybe it should be. ;)
20:56:12 <n0rman_> madduck: why?
20:56:15 <marga> #topic Any Other Business?
20:56:22 <madduck> n0rman_: let's talk after meeting
20:56:27 <marga> Anything else not summit related that we want to discuss?
20:56:40 <bremner> Yeah, I need to know if bursaries should meet at 2100 CET on thursday or friday
20:56:57 <madduck> we ended 2014 with about 70k € of approved sponsorship and that's cool, but not enough.
20:57:10 <marga> bremner, that's a strange question :)
20:57:16 <madduck> so keep sending in leads of possible sponsors
20:57:20 <madduck> and look for them.
20:57:32 <cate> https://summit.debconf.org/debconf15/
20:57:33 <bremner> marga: It's not about summit.
20:57:40 <marga> bremner, right :)
20:57:51 <madduck> cate++ \o/
20:58:01 <bremner> so basically last chance to pipe up before I flip a coine
20:58:06 <madduck> is that mountain in heidelberg, cate? ;)
20:58:07 * madduck hides
20:58:08 <marga> Personally, I'd think Thu is better than Fri, as people usually want to go out on Fri. But if you are the coordinator for bursaries, it's your call.
20:58:21 <cate> madduck: I don't make templaces, CSS and such things ;-)
20:58:31 <Tincho> bremner: I vote for not friday, but I will not be a bursary, so feel free to ignore me :)
20:59:00 <madduck> cate, n0rman_, rmayorga, RichiH: if you have time after the meeting, I'd love to talk a little more about dcX.dc.o and summit.
20:59:39 <Tincho> I have one thing:
21:00:16 <Tincho> I feel that if we get more organised into teams, the -team meetings should disappear and be replaced by coord meetings
21:00:33 <marga> ...
21:00:53 <RichiH> madduck: only very little; i have guests over and am stretching things with this meeting already
21:00:54 <madduck> Tincho: they sort of are. marga is holding this bunch together ;)
21:00:56 <marga> I don't.
21:01:10 <n0rman_> Tincho: hmmmm, don't think so, we always need -team meetings
21:01:17 <madduck> maybe less frequently, but we need to have dc-team meetings.
21:01:30 <marga> I think they are a separate thing
21:01:33 <madduck> they should be what the subteams work towards.
21:01:53 <madduck> e.g. infra team agreed to have a hackable summit instance by the next dc-team meeting
21:01:58 <Tincho> but in that case, the coord meeting should be internal to the team, not what has been unti now
21:02:13 <madduck> on #debconf-coord?
21:02:20 <marga> no more channels...
21:02:29 <RichiH> #debconf-nomorechannels ?
21:02:38 <Tincho> I don't care about the channel, just that I don't care about internal workings of coord, but I care about inter-team coordination
21:02:51 <Tincho> and the meetings so far have been more or less the same as this
21:03:21 <marga> So, my opinion is this: in the DC15 meeting we talk about specific local things, the timeline for the conf, etc.  Whereas the coord team meeting is more about following up on what each team is doing
21:03:35 <n0rman_> #debconf-meetings
21:03:37 <n0rman_> :)
21:04:34 <marga> I really don't think it's useful to make this meeting longer to discuss this...
21:04:40 <bremner> did we endmeeting yet?
21:04:46 <marga> Nope, here it comes
21:04:49 <marga> #endmeeting