17:06:21 <MoC> #startmeeting
17:06:21 <MeetBot> Meeting started Sun Mar  1 17:06:21 2015 UTC.  The chair is MoC. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:21 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:06:28 <MoC> #chair intrigeri
17:06:28 <MeetBot> Current chairs: MoC intrigeri
17:06:32 <MoC> #chair h01ger
17:06:32 <MeetBot> Current chairs: MoC h01ger intrigeri
17:07:11 <MoC> topics: mail for maintainers, mail for debian-devel-announce, udd script, next steps
17:07:16 <MoC> intrigeri: any other topic?
17:07:41 <intrigeri> nope (since I had not time to catch up on Debian#702030 yet)
17:07:54 <MoC> ok, me neither
17:08:11 <MoC> #topic mail to maintainers of apparmor profiles
17:08:17 <intrigeri> updating the maintainers list.
17:08:22 <MoC> intrigeri: thanks for the nitpicking i just saw
17:08:29 <MoC> intrigeri: the one i made?
17:09:01 <intrigeri> yep, dropping MIA former maintainers, using @debian.org email addresses.
17:09:08 <intrigeri> done.
17:09:24 <MoC> MIA ?
17:09:27 <intrigeri> I'm only *slightly* wondering about the timing and possible duplication
17:09:30 <intrigeri> (missing in action)
17:09:57 <MoC> oh ok
17:10:08 <intrigeri> that is, assuming these maintainers read d-d-a@, there's quite some duplication between both draft messages, and very little on the email to maintainers that's not in the d-d-a  one, right?
17:10:16 <MoC> true
17:10:35 <intrigeri> OTOH a more "personal" (well, sent through pkg-$PACKAGE@ lists) note is nice.
17:10:56 <intrigeri> anyway. works this way, good enough, not worth rethinking all that IMO.
17:11:19 <intrigeri> maybe just email the maintainers first, wait a week, and then email d-d-a?
17:11:25 <MoC> yes
17:11:29 <intrigeri> s/a week/4-7 days/
17:11:31 <MoC> ack
17:11:35 <intrigeri> yay
17:11:49 <MoC> #agreed mail maintainers with the current draft of the maintainer email
17:12:09 <MoC> #agreed mail d-d-a in 4-7 days with the dda email draft
17:12:14 <intrigeri> and then email leader@ so that he tells HR to get more people on that. ah no, doesn't work this way :]
17:12:21 <MoC> and i wanted to put the text on the blog too
17:12:30 <MoC> hehe
17:12:36 <MoC> #save
17:12:58 <intrigeri> perfetto
17:13:08 <MoC> intrigeri: and i can email from my account and sign like i did in the draft?
17:13:54 <intrigeri> let me double-check, but I think so, yes.
17:14:07 <MoC> ok
17:14:13 <intrigeri> hmm, almost
17:14:26 <intrigeri> s/Debian AppArmor Packaging Team/Debian AppArmor Team/
17:14:32 <intrigeri> (in both emails I guess)
17:14:44 <MoC> oki
17:14:51 <intrigeri> next topic then?
17:14:56 <MoC> let me correct that quickly
17:15:04 <intrigeri> not sure who's authorized to post to d-d-a@
17:15:07 <intrigeri> we'll see.
17:15:07 <MoC> ok
17:15:16 <MoC> ok
17:15:19 <MoC> #action check who is authorized to post to d-d-a
17:15:25 <intrigeri> if you're forbidden too, your NM process should take max 3 months anyway, depending on how the AM is reactive.
17:15:26 <MoC> #topic udd script
17:15:34 <intrigeri> s/too/to/
17:15:49 <MoC> intrigeri: the AM?
17:15:52 <intrigeri> so, the UDD script. I did a little bit of Python again last week, hence my last batch of suggestions
17:16:04 <MoC> great stuff, thanks
17:16:12 <intrigeri> "new maintainer" process, "application maintainer" is the DD who checks your skills and says yes in the end.
17:16:17 <MoC> i'll implement that
17:16:17 <MoC> oh ok
17:16:33 <intrigeri> worst case we'll wait for you to be a DD before you can send this email :P
17:16:46 <MoC> intrigeri: so you were silently suggesting that i should enter the NM process now?
17:16:47 <MoC> :)
17:16:50 <MoC> krkkrkr.
17:17:12 <MoC> worst case, you'll send it i guess?
17:17:16 <intrigeri> silently? really? OK, let me make it clearer: please do enter the NM process as soon as you have a little bit of time on your hands.
17:17:22 <intrigeri> yes, I can do that, sure.
17:17:26 <MoC> :))))))
17:17:54 <intrigeri> so, about the UDD script: last version is running in production, right?
17:17:55 <MoC> so, what i did not get is your comment about the comments
17:18:00 <MoC> yes
17:18:03 <MoC> it is
17:18:08 <intrigeri> comment about the comments?
17:18:10 <intrigeri> ah
17:18:11 <intrigeri> OK
17:18:21 <intrigeri> e.g. """Send the message"""
17:18:34 <MoC> ah
17:18:36 <intrigeri> it seems that you're using the docstring (or whatever it's called in Python) syntax for all comments.
17:18:39 <MoC> "It's now unhappy with using strings as comments outside of a function's docstring."
17:18:49 <intrigeri> apparently pylint doesn't think it's the best way to do it.
17:18:51 <MoC> no, only for those which are documenting a function
17:18:58 <intrigeri> it may be that Python actually *evaluates* such string statements.
17:19:35 <intrigeri> well, I see a lot of such strings used as comments everywhere in the body of functions, outside of the docstring that immediately follows its name and args.
17:19:35 <MoC> hm, i need to check but i followed the guidelines
17:20:00 <intrigeri> I'd be happy to learn that pylint is wrong -> please point me the guidelines post-meeting :)
17:20:17 <MoC> right
17:20:41 <intrigeri> also the config vars should be proper (full-caps) constants imo. but pylint will tell you all that better than me.
17:20:47 <intrigeri> anyway
17:20:48 <MoC> you're correct, i also used them outside of functions
17:20:49 <MoC> whenever i wanted to describe and not comment code
17:20:53 <MoC> and that would be wrong probably
17:20:58 <MoC> ok
17:21:01 <MoC> i will check that
17:21:08 <MoC> #action check udd script with pylint
17:21:17 <MoC> i wanted to do that but i did not...
17:21:19 <MoC> #save
17:21:26 <MoC> everything else: ack
17:21:30 <intrigeri> is the current state of the production setup good enough? as in, should we move the cronjob to some place where all of us can edit/disable it if needed, or?
17:21:51 <intrigeri> no idea how one usually does that on alioth. I could ask other teams I'm part of.
17:21:56 <MoC> hm, let me edit the comment part and then we can move it somewhere else
17:22:02 <intrigeri> sure.
17:22:19 <MoC> on alioth, i only know how one user can add/edit a crontab
17:22:45 <MoC> if there is a common place to put the files it might work
17:22:48 <intrigeri> I'm not aware of per-Unix-group crontabs, indeed.
17:23:20 <intrigeri> let's keep the cronjob as-is, then. but perhaps it wuold be good if the script was stored in some group-specific place where we all have write access.
17:23:40 <intrigeri> iirc any Alioth team gets a group and then possibly a group "home" dir.
17:23:44 <MoC> indeed
17:23:44 <MoC> intrigeri: shall i research this?
17:23:46 <MoC> ok
17:24:10 <MoC> #agreed research if ther eis some group-specific place where we all have write access on alioth to store the udd script
17:24:14 <MoC> #save
17:24:20 <intrigeri> perhaps we can just postpone until you're fed up of being the only maintainer of this script + cronjob setup.
17:24:25 <MoC> hehe
17:24:28 <MoC> yep
17:24:45 <MoC> #info  iirc any Alioth team gets a group and then possibly a group "home" dir.
17:24:47 <MoC> next topic?
17:24:48 <MoC> todo?
17:24:54 <intrigeri> also, putting the Git repo on Alioth, owned by the team (as opposed to GitHub) would probably make sense at some point.
17:25:01 <MoC> that is true
17:25:04 <intrigeri> that's all I had to say about the udd thing, iirc.
17:25:35 <MoC> #agreed try to put the git repo for the script on alioth, owned by the team, as opposed to github
17:25:38 <intrigeri> so next topic, yay.
17:25:43 <MoC> #topic todo
17:26:07 <MoC> so, for #702030, i have not researched anything yet
17:26:24 <MoC> do you think it's useful to see how ubuntu does it?
17:26:28 <intrigeri> I don't have the problem space in mind anymore :/
17:26:47 <intrigeri> iirc Ubuntu enables AA by default via a kernel patch. but this might have changed, or I may be confused.
17:26:55 <intrigeri> so likely it won't cut it for us.
17:26:56 <MoC> ok, so the idea was to activate apparmor automatically when one installs apparmor
17:27:00 <MoC> yep
17:27:28 <MoC> and i proposed to use a postinst script in all the LSM packages which would check if an LSM is already active
17:27:36 <MoC> and propose to use only one of them via debconf
17:27:38 <intrigeri> sbeattie, jjohansen, sarnold: can you confirm that Ubuntu enables AA by default with a kernel patch?
17:28:09 <intrigeri> seems to make sense but I don't feel I can authoritatively comment on it right now. I should re-read that thread.
17:28:14 <MoC> ok
17:28:25 <MoC> then let's postpone this discussion
17:28:30 <MoC> do it via email?
17:28:43 <intrigeri> looks like the DM selection mechanism to me, that's been revamped in sid or experimental by didrocks and mpitt etc.
17:29:03 <intrigeri> well, we still have some time, I could quickly re-read the thread now perhaps.
17:29:18 <MoC> intrigeri: ok go ahead!
17:29:19 <intrigeri> so that I can comment on the bug ASAP and not block you.
17:29:34 <intrigeri> but perhaps when I'm done reading it's time for me to leave, so don't wait for me.
17:30:18 <MoC> intrigeri: so, before you read, lets quickly see what else is left on the todo list?
17:30:27 <intrigeri> sure.
17:30:28 <MoC> there is the migrate profile documentation
17:30:49 <MoC> you said last time that this can be done after the internship time, and we might work on it together
17:30:56 <MoC> maybe ask the irssi maintainer
17:30:56 <intrigeri> I see send a couple email, migration doc, and a small aa-p-e update.
17:31:12 <intrigeri> I didn't change my mind
17:31:14 <MoC> the emails: i will take care of it.
17:31:25 <MoC> aa-p-e update: i'll do it this week
17:31:42 <MoC> and for the migration doc, we can simply schedule some date if you want to ?
17:31:43 <intrigeri> only one week left. time to write a final report, perhaps?
17:31:48 <intrigeri> MoC: yep, cool.
17:32:05 <intrigeri> MoC: regarding the scheduling thing, I'd rather switch to PM, though.
17:32:32 * cboltz searches for his abbr. dict.
17:32:53 <MoC> intrigeri: regarding scheduling: ok
17:33:12 <MoC> #agreed work on the migration doc together with intrigeri, finding a schedule privately
17:33:23 <MoC> #action MoC should write a final report
17:33:36 <MoC> cboltz: yeah, with intrigeri that's needed :p
17:34:12 <intrigeri> well, AFAIK IIRC I usually DTRT wrt. abbrvs
17:34:16 <cboltz> you'll probably get a similar result in an openSUSE meeting ;-)
17:34:36 <cboltz> but the difference is that I know the abbr.s there
17:34:36 <MoC> intrigeri: ::::DDD
17:34:36 <intrigeri> OTOH less abbrvs sometimes is more KISS
17:41:09 <MoC> ok.
17:41:12 <MoC> found a schedule.
17:41:38 <MoC> then the only thing left is to get some pointers for #702030
17:41:41 <MoC> #save
17:41:58 <intrigeri> MoC: if you give more details wrt. what pointers you need, that may help.
17:42:12 <intrigeri> MoC: general maintainer scripts doc? something more specific?
17:42:29 <MoC> intrigeri: the maintainer doc - i think i can read that
17:43:01 <MoC> intrigeri: simply if the process which i proposed is worth being done that way
17:43:05 <MoC> i think you eventually already said yes to me
17:43:11 <MoC> but i was not so sure anymore
17:43:41 <MoC> my question is probably: would it work?
17:44:00 <intrigeri> not sure anymore either.
17:46:44 <MoC> intrigeri:  i let you re-read the thread?
17:46:46 <intrigeri> I can spend 15 minutes re-reading the thread, but not sure I'll reach a conclusion without thinking of it a bit more.
17:46:49 <intrigeri> yes, please.
17:47:14 <intrigeri> so meeting done, and intrigeri does his homework, right?
17:47:23 <MoC> ok no problem
17:47:33 <MoC> #action intrigeri should comment on MoCs proposal on #702030
17:47:58 <intrigeri> s/should/MUST/
17:48:00 <intrigeri> :)
17:48:24 <MoC> #action intrigeri MUST comment on MoCs proposal on #702030
17:48:41 <MoC> oh, and last but not least: next/last meeting=
17:48:41 <MoC> ?
17:49:12 <intrigeri> I say we don't need it for the internship (since it'll be over)
17:49:22 <intrigeri> but we may want to keep having regular team meeting on IRC, perhaps
17:49:23 <MoC> ok
17:49:43 <MoC> intrigeri: sure
17:49:45 <intrigeri> I think it would help me allocate some time to AA/Debian on a regular basis.
17:49:52 <MoC> ack
17:49:56 <intrigeri> e.g. monthly <1h meeting
17:50:00 <MoC> indeed
17:50:03 <MoC> sounds good
17:50:15 <intrigeri> every 3rd of the month, 5pm CET?
17:50:30 <intrigeri> MoC: (leaves a couple hours before jumping to some other meeting of ours ;)
17:50:37 <MoC> hehe
17:50:37 <intrigeri> (would be easy for me to remember)
17:50:40 <cboltz> do you want your own meeting, or would integrating it with the upstream meating make sense?
17:50:45 <MoC> indeed so
17:50:53 <intrigeri> cboltz:  very good question!
17:50:54 <cboltz> (probably depends on the topics to discuss...)
17:50:57 <MoC> i'll let intrigeri answer this
17:51:15 <MoC> <1h meeting sounds good
17:51:16 <intrigeri> I'm not sure. I say we could try and add our bits to the upstream meeting a couple times and see?
17:51:28 <MoC> cboltz: when it that generally?
17:51:57 <cboltz> usually 2nd tuesday of the month 20:00 UTC
17:52:05 <cboltz> the next one is March 10
17:52:09 <cboltz> http://wiki.apparmor.net/index.php/MeetingAgenda
17:54:48 <MoC> i think it might be a good idea to join meetings but then again i fear that we won't focus on aa in Debian in particular
17:54:58 <MoC> intrigeri: and you?
17:55:37 <intrigeri> well, sometimes these upstream meetings are focussed on stuff that happens in/via/thanks to Ubuntu, so perhaps it wouldn't be crazy to add our bits
17:55:42 <intrigeri> i'm all for trying, I think
17:55:47 <intrigeri> doesn't hurt :)
17:55:54 <MoC> ok then let's try like that on march 10th
17:56:40 <MoC> #agreed the debian apparmor team should continue to have regular meetings after the internship ends. so, we should participate in the monthly upstream meeting. http://wiki.apparmor.net/index.php/MeetingAgenda
17:56:44 <MoC> intrigeri: ack?
17:56:50 <MoC> intrigeri: then i think we're done.
17:57:16 <intrigeri> yay
17:57:17 <intrigeri> \o/
17:57:26 <MoC> cool, thanks!
17:57:34 <intrigeri> I should be able to make it on March 10. we'll see.
17:57:51 <MoC> cboltz: thanks for your input again!
17:58:00 <MoC> #endmeeting