16:04:46 <h01ger> #startmeeting
16:04:46 <MeetBot> Meeting started Wed Feb  4 16:04:46 2015 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:05:11 <h01ger> #chairs MoC intrigeri
16:05:14 <h01ger> #chair MoC intrigeri
16:05:14 <MeetBot> Current chairs: MoC h01ger intrigeri
16:05:15 <intrigeri> ready too.
16:05:21 <h01ger> #topic agenda
16:05:29 <h01ger> so what topics do we have to discuss?
16:05:43 * h01ger is happy to chair but equally happy if someone else does...
16:06:35 <intrigeri> I don't think I have much to put on the agenda. Except maybe:
16:06:54 <intrigeri> next steps for the navigation reorg and then re-evaluating it.
16:07:24 <h01ger> MoC: ?
16:07:33 <intrigeri> reading the plans for the next 2 weeks.
16:08:03 <MoC> oh
16:08:12 <MoC> i am here.
16:08:39 <h01ger> so what shall we discuss?
16:08:43 <intrigeri> agenda++ plans for next weeks
16:08:44 <MoC> i have some questions regarding the navigation
16:08:51 <intrigeri> yay
16:09:04 <h01ger> so "wiki / navigation" is one topic..
16:09:13 <h01ger> anything else? sounds like a short meeting
16:09:18 <MoC> and about my quick triggered new profile bug mails
16:09:35 <MoC> and next 2 weeks
16:10:04 <MoC> shall we start with the navigation?
16:10:46 <intrigeri> yep
16:10:52 <MoC> #topic wiki navigation based on user stories
16:11:08 <MoC> ok, so, intrigeri, thanks for your initial review, first of all
16:11:22 <intrigeri> I can redo it whenever we feel it's the right time.
16:11:35 <MoC> yes
16:11:46 <MoC> you suggested that we delete the page PackageMaintainers
16:12:21 <MoC> i have then indeed split up this page into MergeFromUpstream and ImportProfileFromExtra
16:12:44 <MoC> but then I realized that i still have the Packaging with dh_apparmor part to put somewhere
16:12:53 <intrigeri> replied over email already :)
16:13:00 <intrigeri> (10 minutes ago, sorry)
16:13:14 <MoC> oh let me read this quickly then
16:14:00 <MoC> oh ok
16:14:01 * h01ger vaguely plans to test the pages to/when fixing tbl for wheezy-bpo but then i dont see me doing this anytime really soon
16:14:21 <MoC> intrigeri: so, indeed we need to have a page for an initial packaging
16:14:34 <MoC> how should i call that page?
16:14:39 <h01ger> seems useful indeed
16:14:46 <intrigeri> I think that's the "Ship an existing AppArmor profile confining software S in the Debian package that ships S" user story
16:15:00 <MoC> exactly
16:15:24 <MoC> intrigeri: and right now i do not have a dedicated page for that one
16:15:27 <intrigeri> Contribute/InitialProfileImport? Contribute/ImportExistingProfile?
16:16:45 <MoC> I have Contribute/PackageMaintainers (which should be renamed i guess). what about Contribute/FirstTimeProfileImport or  Contribute/FirstTimeProfilePackaging?
16:17:06 <MoC> Contribute/ImportExistingProfile seems a bit too generic, i dunno
16:17:07 <intrigeri> ACK Contribute/FirstTimeProfileImport
16:17:13 <MoC> ok
16:17:52 * intrigeri has 11 wiki pages open. wow. hopefully I'm not missing some more.
16:17:59 <MoC> arf :))))
16:18:32 <MoC> so, we would habe Contribute/FirstTimeProfileImport and a page called Contribute/ShipProfile?
16:18:37 <MoC> or not?
16:18:50 <intrigeri> what would the latter say?
16:18:51 <MoC> not necessary maybe.. i can link to everything from Contribute
16:19:04 <intrigeri> not sure what user story ShipProfile would be about.
16:19:21 <MoC> ok, yes, i am simply confused about this part, nevermind
16:19:39 <MoC> then, you answered my question about this part
16:19:42 <intrigeri> cool
16:19:45 <MoC> next thing: https://wiki.debian.org/AppArmor/Contribute/ImportProfileFromExtra
16:19:55 <MoC> what is the strategy to adopt here?
16:20:03 <intrigeri> I say postpone that to the latest weeks.
16:20:10 <MoC> #agreed move PackageMaintainers to Contribute/FirstTimeProfileImport
16:20:12 <intrigeri> and, there's good doc about this on the Ubuntu wiki iirc.
16:20:34 <intrigeri> maybe we can simply point to it.
16:20:54 <MoC> intrigeri: i thought that this page is about taking a profile from the Debian package apparmor-profiles-extra to my own package?
16:21:05 <intrigeri> yes.
16:21:06 <MoC> or should this be coordinated with Ubuntu then?
16:21:12 * h01ger really prefers to have consistent documentation in one place then pointing elsewhere. obviously this has limits, but as a general rule...
16:21:22 <intrigeri> hmmm. well, Ubuntu has no -extra package.
16:21:29 <MoC> correct
16:21:29 <h01ger> ubuntu also might ship a new version tomorrow
16:21:46 <h01ger> s/then/than/
16:22:07 <MoC> intrigeri: i'll try to read the Ubuntu documentation then and we can postpone this discussion
16:22:12 <intrigeri> OK. at least it'll be a good source of inspiration, it deals with conffiles moving around and all.
16:22:22 <h01ger> agreed
16:22:26 <MoC> #agreed postpone content discussion of  https://wiki.debian.org/AppArmor/Contribute/ImportProfileFromExtra
16:22:29 <MoC> #save
16:22:41 <MoC> next topic then?
16:22:53 <intrigeri> yep.
16:22:54 <MoC> #topic follow-up on new-profile tagged bugs
16:23:02 <MoC> so, i've now seen that you answered my email
16:23:03 <intrigeri> congrats for following-up
16:23:08 <MoC> thanks :)
16:23:08 * h01ger nods intrigeri
16:23:12 <h01ger> :)
16:23:21 <MoC> but i should have made you read the follow up first i think
16:23:30 <h01ger> there are always some people who prefer unusual things
16:23:33 <intrigeri> well, no big deal.
16:23:34 <intrigeri> that's fine.
16:23:52 <MoC> ok
16:24:04 <intrigeri> MoC: I'm actually glad that you felt at ease doing it without asking us first.
16:24:13 <intrigeri> MoC: IMO that's part of the "moving from mentoring to team work" process.
16:24:18 <MoC> hehe :)
16:24:19 <intrigeri> yay
16:24:23 <MoC> intrigeri: great
16:24:29 <h01ger> true indeed
16:24:36 <MoC> but i think i should resend it to -submitter@b.d.o
16:24:41 <MoC> at least once
16:24:46 <h01ger> bounce?
16:24:49 <intrigeri> +1
16:24:54 <MoC> h01ger: what does that mean?
16:25:21 <MoC> #agreed MoC should resend the new-profile follow up email to the actualy bug submitter
16:25:21 <h01ger> re-sending the mail but bcc:ing the new addressant
16:25:34 <h01ger> instead of changing to:+cc: headers
16:26:16 <h01ger> something i've only learned to do after almost 20y of using email
16:26:19 <MoC> well, i wont resend it to the bts again anyway, right?
16:26:37 <MoC> bounce = only bcc?
16:26:40 <MoC> :)
16:26:42 <h01ger> the replies will go to the bug, if the person just presses reply
16:26:47 <MoC> oh
16:26:50 <h01ger> no need to change headers
16:27:08 <MoC> i should read the doc about this or ask you again later then
16:27:40 <h01ger> in my MUA its a special way for forwarding... feel free to ask later :)
16:27:43 <intrigeri> more to say on this topic?
16:27:48 <MoC> shall i'll send you the email over the mailing list first before sending it?
16:28:01 <h01ger> sure, why not
16:28:05 <MoC> over the ml?
16:28:42 <MoC> #agreed MoC should ask h01ger later about email bounces so the submitters reply will still go the the BTS
16:29:04 <MoC> then we can rediscuss the contents of the email i guess
16:29:09 <h01ger> sure, why not. i'd also trust you to send good mails without though..
16:29:27 <h01ger> but i'm happy to review if you prefer thi
16:29:28 <h01ger> s
16:29:40 <MoC> well, i should have explained better why / who i am to send this email and things like this
16:29:43 <MoC> which i did not
16:29:56 <MoC> but, thanks btw for your encouragements about making mistakes :)
16:30:04 <MoC> next topic ?
16:30:11 <intrigeri> not needed imo
16:30:11 <intrigeri> especially given my current latency..
16:30:16 <MoC> intrigeri: ok
16:30:21 <h01ger> MoC: please make more new mistakes! :-)
16:30:25 <MoC> :)
16:30:42 <MoC> intrigeri: i can check that with h01ger, too
16:30:47 <intrigeri> hmm
16:30:50 <intrigeri> wrt. the navigation thing
16:30:53 <MoC> yes?
16:31:05 <intrigeri> I'd like to know if/when I should schedule time for re-doing a full pass on the user stories / navigation
16:31:11 <intrigeri> during the next two weeks, or later?
16:31:18 <MoC> intrigeri: in about a week
16:31:20 <h01ger> #topic next two weeks
16:31:25 <intrigeri> OK
16:31:28 <MoC> :D
16:31:42 <MoC> ok, so i already updated the todo list a bit earlier
16:32:01 <MoC> i will finish the navigation, ask you for review again, then move to the udd query
16:32:02 <h01ger> what else for the next two weeks? (besides next meeting, which shall be the final topic :)
16:32:18 <h01ger> #info < MoC> i will finish the navigation, ask you for review again, then move to the udd query
16:33:18 <MoC> then i have import my upstream bugfixes on  pidgin-prefs to the apparmor-profiles-extra package through Git
16:33:18 <intrigeri> scheduled that navigation pass.
16:33:38 <intrigeri> good priorities order imo.
16:33:59 * h01ger nods
16:33:59 <intrigeri> imo top prios indeed are navigation and usertags notifications.
16:34:10 <h01ger> #info < MoC> then i have import my upstream bugfixes on  pidgin-prefs to the apparmor-profiles-extra package through Git
16:34:11 <intrigeri> the pidgin profile thing can wait
16:34:18 <intrigeri> the migrate profile doc too
16:34:27 <intrigeri> the bzr branch thing can wait too
16:34:30 <MoC> i rescheduled the migrate profile doc
16:34:43 <MoC> and will reschedule the 2 other things too then
16:34:57 <intrigeri> cool
16:35:20 * h01ger things thats nothing for # info but YMMV
16:35:26 <h01ger> thinks..
16:35:37 <intrigeri> I've nothing to add on this topic.
16:35:39 <MoC> i'll ask questions about the navigation in the wiki when i'm done with the pages
16:35:46 <MoC> and nothing to add to the topic either
16:36:03 <intrigeri> next topic = next meeting?
16:36:10 <h01ger> yup
16:36:15 <MoC> ok
16:36:17 <h01ger> #topic any other business
16:36:22 <h01ger> or that :)
16:36:27 <intrigeri> OK
16:36:30 <h01ger> but if we have nothing...
16:36:31 <intrigeri> I've none.
16:36:42 <MoC> none
16:36:45 <h01ger> #topic next meeting
16:37:20 <MoC> what about the 15th,17th, 18th for the next meeting?
16:37:22 <intrigeri> Feb 17-19 work for me.
16:37:23 <h01ger> today in two weeks is suboptimal, but absolutly doable. tuesday would be a tiny bit better, so is thursday
16:37:40 <MoC> i have a preference for after the 17th
16:37:47 <intrigeri> go for the 17th
16:37:57 <h01ger> wednesday the 19th then?
16:38:14 <MoC> i was about to suggest the 18th :p
16:38:19 <MoC> haha.
16:38:32 <MoC> can we roll a dice?
16:38:33 <h01ger> works for me
16:38:45 <intrigeri> 17, 18, 19 work for me.
16:38:47 <h01ger> 18th, 18oo CET?
16:38:55 <MoC> 18th, 18h CET is good
16:39:12 <intrigeri> 17CET?
16:39:17 <MoC> ok
16:39:20 <intrigeri> 18 is fine, 17 is better for me.
16:39:42 <intrigeri> I mean 17cet is better for me.
16:39:47 <MoC> oh ok :D
16:39:56 <MoC> h01ger: what about you?
16:39:58 <intrigeri> h01ger: ok?
16:40:05 <h01ger> #agreed next meeting 18th february, 1600 UTC
16:40:11 <h01ger> #save
16:40:16 <intrigeri> yay
16:40:19 <MoC> cool
16:40:23 <h01ger> cheers!
16:40:26 <MoC> then we're done?
16:40:27 <intrigeri> that's all, right?
16:40:30 <MoC> that was quick! thanks!
16:40:33 <h01ger> +take care! :)
16:40:34 <MoC> #endmeeting