17:12:50 <h01ger> #startmeeting
17:12:50 <MeetBot> Meeting started Thu Jan 22 17:12:50 2015 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:12:50 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:13:24 <MeetBot> h01ger: Error: "is" is not a valid command.
17:13:52 <h01ger> #chair Moc intrigeri
17:13:52 <MeetBot> Current chairs: Moc h01ger intrigeri
17:15:09 <MoC> re
17:15:32 <h01ger> #chairs Moc
17:15:37 <intrigeri> agenda++: is "Follow-up on new-profile tagged bugs" about pointing the patch submitters to our shiny new doc?
17:15:45 <h01ger> #chair Moc
17:15:45 <MeetBot> Current chairs: Moc h01ger intrigeri
17:15:52 <MoC> i have quite a shitty connection.
17:16:22 <h01ger> ok
17:16:22 <h01ger> #topic collect agenda items
17:16:23 <MoC> User stories
17:16:23 <MoC> User tags
17:16:23 <intrigeri> MoC: not sure you've seen "MoC: how about moving not done stuff from Week5 & 6 to Week 7&8?"
17:16:23 <MoC> and follow-up on new profile tagged bugs
17:16:23 <MoC> intrigeri: most of it was moved already
17:16:23 <MoC> moving the last 2 items
17:16:23 <intrigeri> MoC: great.
17:16:23 <h01ger> so stories, tags and new profile bugs?
17:16:23 <h01ger> +status + next meeting
17:17:20 <MoC> https://wiki.debian.org/AppArmor/Progress#TODO
17:17:41 <intrigeri> OK, I'll stop multitasking.
17:17:56 <h01ger> #topic status update
17:18:08 <h01ger> there was this nice mail yesterday
17:18:52 <h01ger> http://lists.alioth.debian.org/pipermail/pkg-apparmor-team/2015-January/000362.html
17:18:54 <MoC> there are about 6 weeks left, so if there is anything you want to put on my agenda, you should
17:18:55 <h01ger> #save
17:19:00 <intrigeri> I'm very happy with the progress that's being made. Not only MoC does amazing work, but it motivates me to spend >=1h a week on this topic.
17:19:33 <intrigeri> MoC: are you OK with the current (doc / more technical stuff) ratio?
17:19:39 <MoC> sure!
17:19:47 * h01ger is with intri except i dont manage to get work done on this topic
17:19:56 <MoC> but i would like to work soonish on #702030
17:20:16 <intrigeri> MoC: I mean, if you prefer it would be fine IMO that you now focus e.g. on Debian#702030 and/or usertag notifications,
17:20:25 <intrigeri> MoC: and leave the doc / navigation part to others or to later.
17:20:36 <MoC> i would still want to spend ~ 3 days on doc
17:20:37 <h01ger> #702030 is "Please automatically enable AppArmor when the userspace tools are installed"
17:20:52 <MoC> or 1 week
17:21:03 * h01ger likes MoCs plan
17:21:06 <MoC> and then start with the more technical stuff and usertag notifications
17:21:10 <MoC> h01ger: :)
17:21:17 <intrigeri> e.g. on the navigation topic, I could do a first pass for each user story, and make it clear what's the current expected navigation path.
17:21:20 <h01ger> shifting focus to action while keeping doing documentation sounds great
17:21:37 <MoC> intrigeri: ok
17:21:59 <MoC> so, just fyi, based on the status update from yesterday: since then i wrote https://wiki.debian.org/AppArmor/Contribute/Import
17:22:17 <MoC> and i agree that we should move Debugging AppArmor to a dedicated page
17:22:20 <MoC> i just wonder where
17:22:30 <h01ger> Contribute/Debug ?
17:22:34 <h01ger> or just /Debug?
17:22:39 <intrigeri> MoC: org-mode++'ed (DEADLINE: <2015-01-29 Thu> SCHEDULED: <2015-01-24 Sat>)
17:23:07 <MoC> intrigeri: are you talking emacs to me?
17:23:12 <h01ger> should we move to the next topic, user stories
17:23:15 <intrigeri> I'd say /Debug, since it'll be meant for all kinds of public, even those who don't identify themselves as contributors (although they are)
17:23:22 <MoC> ok for /Debug
17:23:35 <h01ger> #agreed on a new page, /Debug
17:23:39 <MoC> ok
17:23:45 <MoC> then next topic sounds good
17:24:08 <h01ger> #topic user stories
17:24:18 <MoC> #agreed spend one more week on documentation until 29th january 2015
17:24:23 <MoC> sorry..
17:24:25 <intrigeri> (OT: broken link at the bottom of https://wiki.debian.org/AppArmor/Contribute/Import)
17:24:26 <h01ger> p
17:24:31 <h01ger> np even
17:24:32 <h01ger> #save
17:24:34 <MoC> intrigeri: i just corrrected that
17:24:41 <MoC> 10 minutes ago
17:24:52 <intrigeri> I see "simply ?submit a patch"
17:25:04 <intrigeri> the link works but its linktext is "?"
17:25:09 <intrigeri> sorry, I'm OT again.
17:25:12 <MoC> correct
17:25:15 <intrigeri> so, user stories.
17:25:31 <h01ger> #save
17:25:45 <h01ger> whats the status? all have been written,or?, so whats next?
17:25:49 <intrigeri> as said via email, I think they're very good now and should be "implemented"
17:26:08 <intrigeri> that is, adjust the doc and tools to match these stories and identified solutions.
17:26:23 <intrigeri> the "needfinding" phase is over IMO, as they say.
17:26:28 <MoC> ack
17:26:30 * h01ger agrees
17:26:33 <h01ger> #agreed spend one more week on documentation until 29th january 2015
17:26:56 <intrigeri> hence what I wrote above:
17:26:57 <h01ger> #agreed user stories are very good now and should be "implemented": adjust the doc and tools to match these stories and identified solutions
17:26:58 <intrigeri> todo++?: move userstories to dedicated page, and 'implement' each solution on the corresponding wiki page
17:27:06 <h01ger> #save
17:27:14 <h01ger> (sorry for meetbot noise)
17:27:22 <intrigeri> should this be made part of TODO somehow?
17:27:26 <MoC> intrigeri: AppArmor/Progress/UserStories ?
17:27:27 * h01ger thinks so
17:28:00 <MoC> ok
17:28:03 <intrigeri> well, now that they're done it has little to do with tracking progress, but is more like internal team doc
17:28:16 <intrigeri> AppArmor/Team/UserStories?
17:28:27 <h01ger> (me agreed with "should this be made part of TODO somehow")
17:28:28 <intrigeri> or simply AppArmor/UserStories
17:28:42 * h01ger thinks the 2nd is better
17:28:49 <intrigeri> and link from the Tools section on AA/Contribute
17:28:56 <intrigeri> since that's indeed a tool.
17:29:10 * h01ger nods some more
17:29:15 <MoC> ok
17:29:34 <MoC> #todo move user stories to dedicated page AppArmor/UserStories
17:29:50 <h01ger> #save
17:29:51 <MoC> #todo link User stories from the Tools section on AA/Contribute
17:29:56 <intrigeri> should we wait for my action item above (1st navigation pass) before we move the userstories-derived solutions to the corresponding pages?
17:30:14 <MoC> intrigeri: i think that would spare me a lot of time yes
17:30:18 <h01ger> #action < MoC> #todo move user stories to dedicated page AppArmor/UserStories
17:30:19 <intrigeri> Good.
17:30:25 <h01ger> #action < MoC> #todo link User stories from the Tools section on AA/Contribute
17:30:35 <MoC> #action intrigeri  1st navigation pass through UserStories
17:30:38 <h01ger> #save
17:30:57 <MoC> Usertags?
17:31:10 <intrigeri> so let's add "'implement' each userstories-derived solution on the corresponding wiki page" to weeks 9&10?
17:31:17 <MoC> ok
17:31:20 <intrigeri> and then yay, next topic.
17:31:21 <h01ger> (OT: so it seems #action works for #moc but #info not. strange. as she's a chair...)
17:31:32 <h01ger> #action add "'implement' each userstories-derived solution on the corresponding wiki page" to weeks 9&10?
17:31:49 <h01ger> #topic usertags
17:31:53 <intrigeri> (meta: slowly transitioning from mentoring to more equalitarian team-work, as that's our future, I hope :)
17:32:03 <h01ger> :)))
17:32:05 <intrigeri> (hence I'm going to take a few action items.)
17:32:15 <intrigeri> (not too many, though. crazy busy.)
17:32:32 <MoC> hehehe
17:32:32 <intrigeri> so, usertags.
17:32:53 <MoC> intrigeri: i read your review and i ack the new usertags : merge-to-upstream and merge-from-upstream
17:33:05 <MoC> i wrote them into the doc already
17:33:06 <intrigeri> cool.
17:33:16 <intrigeri> I think we have a good usertags set now.
17:33:21 <MoC> cool
17:33:22 * h01ger agrees
17:33:26 <intrigeri> shall we discuss a bit the plan wrt. notifications?
17:33:31 <MoC> yep
17:33:46 <intrigeri> there are notes on https://wiki.debian.org/AppArmor/Progress#Notes
17:34:07 <MoC> ok
17:34:16 <intrigeri> I guess 1st step is wishlist bug against bugs.d.o, since really, that would be the most consistent solution.
17:34:18 <MoC> so.. i'd go for the UDD request
17:34:24 <MoC> intrigeri: true
17:34:50 <MoC> adding it to the todo list
17:35:00 <MoC> but.. i dont think this will work anytime soon
17:35:01 <intrigeri> and indeed we shall not expect debbugs to implement that extremely fast, likely (I hope I'm wrong), so I'm OK with focussing on other solutions,
17:35:10 <MoC> ack
17:35:16 <intrigeri> except maybe other solutions take as much time to implement as the proper one in debbugs
17:35:20 <h01ger> #agreed go for a wishlist bug against the bts for (better) notification support for usertags
17:35:25 <h01ger> https://wiki.debian.org/AppArmor/Progress#Notes
17:35:36 <intrigeri> maybe worth spending 2h looking at how hard it would be to patch debbugs to extend its existing notifications system to usertags?
17:35:47 <intrigeri> before taking a different implementation path?
17:35:58 <h01ger> dondelcarlo would probably love that, but its perl ;)
17:36:09 <intrigeri> last time I've seen a talk by Don about debbugs, he was very eager to get contributions.
17:36:28 <h01ger> indeed. i would love that too
17:36:29 <intrigeri> hmmm. maybe *I* should look into it, then.
17:36:36 <MoC> hm
17:36:40 <h01ger> intrigeri: :-))
17:37:12 <MoC> intrigeri: if you can have a quick look and advise me or think i can do it.. that would be nice
17:37:31 <MoC> i mean advise me after your findings
17:37:35 <MoC> :)
17:37:42 <h01ger> anything else about usertags? anything else to #info or #agree?
17:37:45 <h01ger> or next topic=
17:37:46 <intrigeri> trying to find the Git repo.
17:37:46 <h01ger> ?
17:37:54 <h01ger> linked under every bug, i think
17:38:24 <intrigeri> #action <intrigeri> evaluate how hard it would be to add usertags +/- notifications to debbugs
17:38:31 <intrigeri> (no idea if that works)
17:38:34 <h01ger> #save
17:38:45 <h01ger> seems it worked
17:38:47 <h01ger> next topic?
17:39:31 <MoC> ok
17:39:44 <h01ger> intrigeri: ?
17:39:47 <intrigeri> hmm
17:40:01 <intrigeri> I don't have the problem space in mind, so I'll trust MoC's judgement regarding SOAP vs. UDD.
17:40:42 <MoC> intrigeri: well both would work but it seems the UDD version is quicker to implement
17:40:47 <MoC> both would be reusable
17:40:58 <intrigeri> cool. next topic then.
17:41:05 * h01ger thinks "whatever works"
17:41:06 <h01ger> #topic new profile bugs
17:41:38 <MoC> ok, so i thought that i should ping the person who reported new-profile tagged bugs to point them to our documentation
17:41:47 <MoC> and tell them that we might be able to help
17:41:54 * h01ger thinks thats an excellent idea
17:41:57 <MoC> we basically already did that per email
17:41:59 <intrigeri> +1
17:42:04 <MoC> but there has been no follow up
17:42:11 <intrigeri> yay, let's crash test our doc.
17:42:22 <MoC> and people who see these bugs do not have our email answers
17:42:25 <MoC> ok :)
17:42:38 <MoC> intrigeri: one single little problem is thebranch name
17:42:44 <intrigeri> and then, we'll have to face the "some people are fine with sending patches to Debian, but not with going the full upstream first way" reality.
17:42:45 <MoC> i basically pretty much did what you said..
17:42:52 <MoC> i will retry a 3rd time though
17:42:57 <MoC> yes
17:43:07 <intrigeri> MoC: sounds like I should retry myself, then.
17:43:08 <MoC> intrigeri: and in that case, shall i try to implement their patches?
17:43:19 <MoC> and propose them?
17:43:39 <MoC> i mean, that would be a sucky solution, but it could be a possibility
17:43:40 <intrigeri> #action <intrigeri> find out what bzr command works for pushing branches to LP under the apparmor-dev project
17:43:46 <MoC> :)
17:43:57 <MoC> intrigeri: i can also retry
17:44:12 <intrigeri> regarding forwarding new profiles upstream and polishing them as needed:
17:44:24 <intrigeri> I don't think it's part of our mission to do that (for *new* profiles)
17:44:33 <MoC> ok
17:44:47 <intrigeri> I'm happy if some of us do it sometimes, for some reason
17:44:50 <MoC> intrigeri: shall we point the apparmor devel list to them ?
17:44:55 <intrigeri> e.g. they want this profile themselves.
17:44:55 <MoC> intrigeri: ack
17:45:13 <intrigeri> note that in this case, one becomes the de-facto primary maintainer of this profile (even if this concept doesn't exist formally)
17:45:21 <intrigeri> so it's not really a one-shot job.
17:45:24 <MoC> ouh.
17:45:31 <MoC> yeah, not my job then :)
17:45:56 <intrigeri> well, I mean, once we've done everything so that e.g. Debian ships a profile for less(1), it's our duty to make sure it keeps working.
17:46:05 <MoC> i understand
17:46:06 <intrigeri> would be sad to see less(1) broken.
17:46:19 <intrigeri> looking at the current new-profiles tagged bugs.
17:47:33 <intrigeri> from a team's (collective) perspective, we could use the same priorities as the security team has chosen for build-time hardening.
17:47:56 <intrigeri> (that is focussing on stuff that has had DSA in the past, stuff that listens on the network, iirc)
17:48:45 <MoC> sounds interesting
17:48:50 <intrigeri> frankly, getting more profiles in isn't my priority, before we have good cross-distro profile maintenance workflow and infra.
17:48:59 <MoC> intrigeri: ack
17:49:33 * h01ger agrees with that too
17:49:34 <MoC> so, i'll just do the doc crash test on them
17:49:41 <intrigeri> yay
17:49:57 <intrigeri> done with this topic?
17:50:04 <MoC> #action MoC follow up on new-profile tagged bugs
17:50:06 <MoC> yes
17:50:07 <MoC> #save
17:50:10 <h01ger> #agreed MoC will crash test new docs using doc submitters as testers
17:50:16 <MoC> somehting else?
17:50:27 <intrigeri> was that the last topic?
17:50:44 <h01ger> only "next meeting" left. and "any other business"
17:50:51 <h01ger> #topic any other business
17:51:20 <MoC> i dont have any other business i can think of right now
17:51:39 * h01ger neither
17:51:44 <intrigeri> I have one, but maybe too early.
17:51:50 <MoC> ok?
17:52:00 <MoC> intrigeri: tell us
17:52:20 <intrigeri> once we've got all this great stuff done, and once Jessie is out, I'd be up to have an AppArmor sprint.
17:52:31 <intrigeri> e.g. to work on the cross-distro collaboration topic.
17:52:32 <MoC> \o/
17:52:35 * h01ger too
17:52:36 <MoC> sounds good.
17:52:46 <intrigeri> would be especially awesome if we can get some !Debian people in.
17:53:02 <MoC> would that be after 9th of march or before ?
17:53:07 <MoC> just to know
17:53:14 <intrigeri> ENOTIME before March.
17:53:27 <intrigeri> I'm thinking more of May/June TBH.
17:53:36 <MoC> ok
17:53:37 <MoC> sounds good
17:53:46 <intrigeri> food for thought. to be discussed later.
17:53:47 <h01ger> june would only work in the first half of the month for me
17:54:06 <MoC> let's try to organize this somehow
17:54:13 <intrigeri> imo it's critical to have at least one Ubuntu person there, and very important to have cboltz too.
17:54:30 <MoC> indeed
17:54:31 <h01ger> #agreed lets think about an apparmor meeting once jessie is out, to improve cross distro collab and more
17:54:39 <MoC> :)
17:54:45 <MoC> ok next topic ?
17:54:46 <intrigeri> (and hopefully Canonical management and $$$-holders wouldn't disagree)
17:54:49 <h01ger> #agreed < intrigeri> imo it's critical to have at least one Ubuntu person there, and very important to have cboltz too.
17:54:51 <MoC> :D
17:54:58 <h01ger> #next meeting
17:54:59 <h01ger> when?
17:55:00 <MoC> for next meeting i'd suggest february 3rd
17:55:04 <h01ger> #topic next meeting
17:55:27 * h01ger would prefer the 4th
17:55:35 <intrigeri> I can't do the 3rd without entering sacrifice mode (already another meeting that day, + some medical thing, + travelling the day before)
17:55:40 <h01ger> the 3rd is the day directly after fosdme..
17:55:43 <MoC> actually me too :)
17:55:45 <intrigeri> 4th is good to me.
17:55:46 <MoC> 4th is better
17:55:51 <h01ger> time?
17:56:05 <MoC> 18pm CET again ?
17:56:08 <intrigeri> yes.
17:56:12 <MoC> nice.
17:56:16 <MoC> h01ger?
17:56:19 <h01ger> #agreed next meeting: february 4th, 17 UTC / 18 CET, in #apparmor
17:56:20 <intrigeri> a bit earlier would be better but 6pm CET is OK.
17:56:29 <h01ger> like 17 CET?
17:56:30 <MoC> oh otherwise.. 17pm?
17:56:33 <MoC> sounds good too
17:56:42 <intrigeri> yep.
17:56:44 <h01ger> #agreed next meeting: february 4th, 16 UTC / 17 CET, in #apparmor
17:56:51 <intrigeri> awesome.
17:56:56 <h01ger> indeed :)
17:57:01 <intrigeri> woohoo
17:57:02 * h01ger thanks for the nice meeting
17:57:03 <MoC> cool
17:57:07 <MoC> thank you both!
17:57:13 <intrigeri> thank *you*
17:57:15 <MoC> #endmeeting
17:57:16 <h01ger> #endmeeting