15:16:51 <MoC> #startmeeting
15:16:51 <MeetBot> Meeting started Mon Jan  5 15:16:51 2015 UTC.  The chair is MoC. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:16:51 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:17:06 <MoC> #chair MoC
15:17:06 <MeetBot> Current chairs: MoC
15:17:11 <MoC> #chair intrigeri
15:17:11 <MeetBot> Current chairs: MoC intrigeri
15:17:16 <MoC> #chair h01ger
15:17:17 <MeetBot> Current chairs: MoC h01ger intrigeri
15:17:20 <MoC> ok
15:17:27 <intrigeri> let's start!
15:17:55 <intrigeri> agenda.
15:17:56 <MoC> #topic status update
15:18:08 <intrigeri> - prioritize todo's for next weeks
15:18:16 <intrigeri> - anything else?
15:18:26 <MoC> fine with me
15:18:30 <intrigeri> - feedback from MoC regarding how the mentoring goes
15:18:43 <intrigeri> (mentors need feedback, too :)
15:18:50 <MoC> log is here btw: http://meetbot.debian.net/apparmor/2015/
15:18:57 <MoC> intrigeri: :)
15:19:25 <MoC> #topic status update
15:19:27 <intrigeri> yay, public meeting. hi, NSA!
15:19:58 <MoC> intrigeri: krkrk :P
15:19:59 <MoC> thanks for the useful feedback. as i said on the ML i did not have time to do a lot the last 2 weeks
15:20:36 <intrigeri> np. expected. this time of the year.
15:20:46 <MoC> intrigeri: i still have a hard time with these user stories :) but recent bug reports have been opening my eyes on needed documentation a bit more
15:20:58 <intrigeri> good
15:21:39 <intrigeri> what are your top 5 goals for next 2 weeks?
15:21:56 <intrigeri> (/me looking at the TODO to see what *I* would put in there.)
15:22:55 <MoC> intrigeri: so, user stories need to be finished, then usertags defined. I need to document those and then we can start announcing it (planet, d-devel, where else ?)
15:23:05 <MoC> also, we need email notifications
15:23:08 <MoC> for usertags
15:23:13 <MoC> so that is my top 3
15:24:41 <MoC> i would also like a section on how to contribute to upstream (instead of what i previously suggested in my email about a wiki page about new profiles)
15:24:46 <MoC> what do you think?
15:24:49 <intrigeri> my top 5 would be:
15:24:52 <intrigeri> 1. update TODO: strike done things, postpone not done tasks to future weeks
15:24:52 <intrigeri> 2. import doc from the blog into the Debian wiki
15:24:52 <intrigeri> 3. complete first draft of the main 3-5 user stories we need
15:24:52 <intrigeri> 4. from there, propose a set of usertags
15:24:52 <intrigeri> 5. document usertags for various personas who'll need them
15:25:07 <intrigeri> and if time permits, investigate tech solutions further to keep track of usertagged bugs.
15:25:16 <MoC> ack
15:25:23 <intrigeri> that section on how to contribute upstream is my #2, right?
15:25:28 <MoC> yes
15:25:42 <intrigeri> basically, 1-4 are "complete work that's been started already, before diving into new exciting things"
15:25:48 <MoC> indeed
15:25:55 <MoC> let me tell that to our MeetBot log
15:25:58 <intrigeri> yay.
15:26:14 <MoC> #agreed MoC 1. update TODO: strike done things, postpone not done tasks to future weeks
15:26:31 <MoC> oh wait this should maybe be another tag..
15:26:33 <intrigeri> I expect 1-3 take a week, and then we discuss #3 and #4 and you do #5 during the 2nd week.
15:26:40 <MoC> #action MoC 1. update TODO: strike done things, postpone not done tasks to future weeks
15:26:55 <MoC> #action MoC 2. import upstream doc from the blog into the Debian wiki
15:27:05 <MoC> #action MoC 3. complete first draft of the main 3-5 user stories we need
15:27:14 <MoC> #action MoC 4. from there, propose a set of usertags
15:27:21 <MoC> #action MoC 5. document usertags for various personas who'll need them
15:27:26 <intrigeri> (this #1-5 list is the kind of things I'd love to see in the report, as an example for what I suggested earlier today :)
15:27:29 <MoC> #save
15:27:34 <MoC> intrigeri: ok
15:27:59 <intrigeri> the longer the TODO list gets, the more we'll need such processes.
15:28:17 <MoC> i think indeed that we should maybe meet again in roughly 1 week. and until then i can work on 1-3
15:28:53 <intrigeri> actually, #2 should be s/into the Debian wiki/into the upstream doc, and point there from the Debian wiki/
15:28:58 <intrigeri> of course some stuff will be Debian-specific, though.
15:29:04 <intrigeri> so it may need to be more fine-grained.
15:29:41 <intrigeri> MoC: agreed regarding meeting in a week. email may not be fast enough.
15:29:47 <MoC> intrigeri: but.. shall i create a separate page for this "how to contribute to upstream" in your opinion?
15:29:55 <MoC> ack
15:30:34 <intrigeri> hmmm, in a week doesn't work well for me. I can do Sunday 11, or 14th+
15:30:44 <MoC> then 14th+
15:30:49 <MoC> that leaves me a bit more time
15:30:52 <MoC> ok?
15:30:53 <intrigeri> MoC: yes. let's keep our main pages very short.
15:31:24 <MoC> #action MoC 6. create a wiki page on how to contribute to upstream, let's keep our main pages very short
15:31:25 <intrigeri> if 14th+, then maybe send a RFC on the list in a week. so we can start discussing over email.
15:31:30 <MoC> indeed
15:32:01 <MoC> RFC of usertags right?
15:32:02 <intrigeri> #action MoC send a RFC regarding #3 on Monday, Jan 12th
15:32:11 <MoC> #save
15:32:15 <intrigeri> #action MoC propose meeting around the 14th of January
15:32:39 <h01ger> arg. hi
15:32:43 <intrigeri> 14th would work for me.
15:32:46 <intrigeri> h01ger: heya!
15:32:49 <MoC> h01ger: hi!
15:32:52 * h01ger was cleaning up CCH and totally forgot about this meeting
15:32:54 <MoC> intrigeri: sounds good
15:33:01 <MoC> h01ger: oh poor you!
15:33:06 <intrigeri> 14th, 4pm CET?
15:33:07 <MoC> :)
15:33:12 <h01ger> just home since 4h and going through irc highlights.. stil not at the end
15:33:21 <MoC> works for me
15:33:40 <h01ger> i'm not 100% it will work for me. 15th would be better
15:34:02 <MoC> h01ger: i wanted to send SMS and then i remembered that your phone number is stuck in a sleeve with dozens of pgp fingerprints from people... :D
15:34:13 <intrigeri> can't do 15th. 16th?
15:34:33 <MoC> i suspect that i wont be online on 16th
15:34:36 <h01ger> nope
15:34:41 <MoC> :D
15:34:46 <MoC> 14th earlier?
15:35:07 <h01ger> lets try 14th 4pm and i will find out the next days if i can make it
15:35:14 <MoC> ok
15:35:29 <MoC> #agreed next meeting jan 14th 2015, 4p CET
15:35:32 <intrigeri> OK.
15:35:37 <MoC> #agreed next meeting jan 14th 2015, 4pm CET
15:35:56 <intrigeri> MoC: I like how you've reformatted the user stories!
15:36:04 <MoC> intrigeri: :))))))))))
15:36:07 <MoC> thanks!
15:36:20 <intrigeri> MoC: don't necessarily wait 1 week before sending a RFC, if you're happy enough earlier.
15:36:25 <intrigeri> can't wait.
15:36:31 <MoC> ok!
15:36:42 <MoC> i'll think about it a bit more
15:36:59 <MoC> shall we move to the mentoring feeback topic?
15:37:47 <intrigeri> yes.
15:37:54 <MoC> #topic feedback on mentoring
15:38:02 <intrigeri> MoC: the stage is yours.
15:39:28 <MoC> intrigeri: haha, i don't have a lot to say as this week in particular has been otherwise busy. *But* I very much appreciate the details you've sent me regarding the stuff i wrote.
15:39:41 <MoC> i did not have any problems understanding what you've said
15:39:50 <intrigeri> cool.
15:40:24 <MoC> i was happily surprised when i saw that you pointed somebody to the blog posts :)
15:40:37 <intrigeri> did I?
15:40:48 <MoC> yes on the pkg-apparmor ML i believe
15:40:50 <intrigeri> that's the best we have right now. and it's pretty good.
15:40:53 <h01ger> in a bug
15:40:59 <MoC> h01ger: right
15:41:02 <intrigeri> ah, parpes.
15:41:16 <intrigeri> indeed, we see in real-time the need for such doc.
15:41:37 <MoC> i am not sure how well this person understands upstream/debian, that's why i thought, we need more info on this particular issue
15:41:44 <MoC> and i also added a user story for this
15:41:59 <MoC> so, that's good, i feel confident!
15:43:00 <MoC> intrigeri: do you have more pointers for the user stories, btw? I've read up on cucumber and i was wondering if you expect me to dive deeper into the "scenarios"?
15:43:11 <intrigeri> let me check how they look like now.
15:43:24 <MoC> like, have more detailed stories, for particular cases
15:43:57 <h01ger> MoC: tails.git/features is full of them
15:43:58 <intrigeri> the way they are phrased is the right level of abstraction and details, I think.
15:44:07 <MoC> ok
15:44:14 <intrigeri> the Tails ones are often confused. sometimes too low-level, sometimes not.
15:44:21 <MoC> h01ger: i was not aware of that
15:44:22 <MoC> :D
15:44:58 <MoC> anything else?
15:45:08 <intrigeri> MoC: actually, looks like you'll be able so send a RFC for these user stories after 1-2 more hours of polishing max, no?
15:45:17 <MoC> intrigeri: i think so!
15:45:17 <MoC> :D
15:45:24 <intrigeri> yes, something else I want to add.
15:45:41 <MoC> #topic anything else
15:45:43 <MoC> :D
15:45:48 <intrigeri> I've been doing mentoring for years. A couple GSoCs, a NM process, etc. And I have to say that
15:46:03 <intrigeri> it's probably the first time that I have the clear feeling that I'm spending way less time mentoring,
15:46:08 <intrigeri> than I would spent doing the work myself.
15:46:15 <intrigeri> So: congrats, thanks, yay! \o/
15:46:17 <MoC> yaaaaay!!!!! :))))))))
15:46:18 <intrigeri> .
15:46:21 <h01ger> :)))
15:46:24 <MoC> thank *you*!
15:46:35 <intrigeri> (not saying it's not worth spending more time mentoring than doing the work. often it's worth it.)
15:47:03 <intrigeri> any other topic, or are we done?
15:47:14 <MoC> happy to hear this. and it will be carved into silicium forever, as the MeetBot is recording this, hahaha.
15:47:19 <MoC> intrigeri: i'm done
15:47:22 <MoC> h01ger: you?
15:47:42 <intrigeri> glad to see the selinux folks replying on https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773346
15:48:11 * h01ger has nothing to add
15:48:20 <MoC> that bug also needs a usertag!
15:48:41 <h01ger> i'm glad there is so much progress, despite i have little time to contribute atm
15:48:42 <intrigeri> MoC: yay. probably a user story we didn't think of yet.
15:48:55 <intrigeri> not sure it's worth a user story. maybe just a distro-infra usertag and be done with it.
15:48:56 <MoC> the last one :)
15:49:07 <MoC> yep
15:49:55 <intrigeri> (we can easily refine such "internal" usertags later, contrary to the ones we'll be announcing on d-d-a@, that 'd better be well-chosen.)
15:50:01 <MoC> yep
15:50:06 <intrigeri> Cool. Context-switching, then.
15:50:20 <MoC> then we're done?
15:50:21 <MoC> #save
15:50:46 <intrigeri> yay.
15:51:00 <MoC> thanks
15:51:03 <MoC> #endmeeting